## Contents

Welcome.............................................................................................................................................................................................. 15
What’s new in Corel PaintShop Pro 2023....................................................................................................................................... 15
Installing and uninstalling Corel programs....................................................................................................................................16
Starting and exiting the program....................................................................................................................................................... 17
Registering Corel products..................................................................................................................................................................17
Updates and messages.......................................................................................................................................................................17
Corel Support Services......................................................................................................................................................................18
About Corel..........................................................................................................................................................................................18

Learning PaintShop Pro........................................................................................................................................................................19
Documentation conventions................................................................................................................................................................. 19
Using the Help.................................................................................................................................................................................. 20
Corel PaintShop Pro 2023 User Guide PDF.......................................................................................................................................... 21
Using the Learning Center palette...................................................................................................................................................... 21
Learning with video tutorials........................................................................................................................................................... 22
Using Web-based resources................................................................................................................................................................22

Workspace tour................................................................................................................................................................................... 25
Exploring workspace tabs.................................................................................................................................................................. 25
Switching tabs......................................................................................................................................................................................30
Switching workspaces...........................................................................................................................................................................31
About the Photography workspace.........................................................................................................................................................31
Choosing a workspace color...............................................................................................................................................................32
Using palettes.......................................................................................................................................................................................32
Using toolbars...................................................................................................................................................................................... 34
Using tools........................................................................................................................................................................................... 35
Customizing toolbars and palettes..................................................................................................................................................... 39
Using dialog boxes............................................................................................................................................................................ 40
Viewing images.................................................................................................................................................................................. 43
Using shortcut keys............................................................................................................................................................................ 45
Retouching and restoring images.....................................................................................................................................................155

Removing red-eye...............................................................................................................................................................................155
Applying cosmetic changes............................................................................................................................................................... 157
Removing scratches........................................................................................................................................................................ 159
Removing flaws and objects with the Clone Brush or Object Remover............................................................................................161
SmartClone retouching and design..................................................................................................................................................163
Using Magic Fill to erase image areas............................................................................................................................................ 165
Moving selected areas with Magic Move...........................................................................................................................................166
Erasing image areas........................................................................................................................................................................ 167
Placing images in shapes or text with the Frame Tool.................................................................................................................. 169
Cutting out image areas................................................................................................................................................................. 172
Changing portrait backgrounds with AI Background Replacement..................................................................................................173
Retouching image areas by using brushes...................................................................................................................................... 175
Recoloring image areas for a realistic effect...................................................................................................................................... 177
Replacing colors, gradients, or patterns......................................................................................................................................... 178

Removing digital noise.................................................................................................................................................................... 123
Removing chromatic aberrations..................................................................................................................................................... 125
Using Lens Correction to fix distortion, chromatic aberration, and vignetting...........................................................................127
Correcting lens distortions................................................................................................................................................................. 128
Adjusting white balance...................................................................................................................................................................... 129
Adjusting brightness, contrast, and clarity........................................................................................................................................ 131
Adjusting hue and saturation............................................................................................................................................................... 137
Adding or removing noise.................................................................................................................................................................... 139
Applying a depth of field effect with AI Portrait Mode..................................................................................................................... 143
Controlling depth of field................................................................................................................................................................. 144
Blurring images.................................................................................................................................................................................. 146
Sharpening images................................................................................................................................................................................ 148
Softening images................................................................................................................................................................................ 149
Removing haze................................................................................................................................................................................... 150
Resizing images.................................................................................................................................................................................. 150
Enlarging images by using AI-Powered upsampling....................................................................................................................... 153

Adding or removing noise.................................................................
Using layers with illustrations................................................................. 223
Using the Layers palette........................................................................ 223
Creating layers...................................................................................... 226
Promoting the background layer.......................................................... 227
Deleting layers and clearing layer contents......................................... 227
Duplicating and copying layers............................................................. 228
Renaming layers................................................................................... 228
Viewing layers...................................................................................... 229
Finding layers...................................................................................... 229
Organizing layers by color...................................................................... 230
Changing the order of layers in an image.............................................. 230
Moving layers on the canvas................................................................. 231
Grouping layers................................................................................... 231
Linking layers...................................................................................... 232
Blending layers.................................................................................... 233
Setting layer opacity............................................................................ 235
Protecting transparent areas of raster layers....................................... 236
Merging layers..................................................................................... 236
Using adjustment layers...................................................................... 238
Using layer styles................................................................................ 239

Working with masks.............................................................................. 245
Understanding masks........................................................................... 245
Displaying masks................................................................................ 245
Creating masks................................................................................... 246
Deleting masks................................................................................... 249
Editing masks..................................................................................... 249
Loading masks.................................................................................... 250
Saving masks...................................................................................... 251

Working with colors and materials...................................................... 253
Using the Materials palette.................................................................. 253
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choosing colors in the Material Properties dialog box</td>
<td>255</td>
</tr>
<tr>
<td>Choosing colors for paletted images</td>
<td>257</td>
</tr>
<tr>
<td>Choosing colors from an image or the desktop</td>
<td>257</td>
</tr>
<tr>
<td>Using gradients</td>
<td>258</td>
</tr>
<tr>
<td>Editing gradients</td>
<td>261</td>
</tr>
<tr>
<td>Exporting and importing gradients</td>
<td>262</td>
</tr>
<tr>
<td>Applying a color or transparency gradient with the Gradient Fill tool</td>
<td>263</td>
</tr>
<tr>
<td>Using patterns</td>
<td>264</td>
</tr>
<tr>
<td>Using textures</td>
<td>265</td>
</tr>
<tr>
<td>Working with custom color palettes and swatches</td>
<td>267</td>
</tr>
<tr>
<td>Applying effects</td>
<td>271</td>
</tr>
<tr>
<td>Choosing effects</td>
<td>271</td>
</tr>
<tr>
<td>Applying 3D effects</td>
<td>274</td>
</tr>
<tr>
<td>Applying Art Media effects</td>
<td>277</td>
</tr>
<tr>
<td>Applying Artistic effects</td>
<td>279</td>
</tr>
<tr>
<td>Applying environment maps and bump maps</td>
<td>287</td>
</tr>
<tr>
<td>Applying Distortion effects</td>
<td>287</td>
</tr>
<tr>
<td>Using the Displacement Map effect</td>
<td>292</td>
</tr>
<tr>
<td>Applying Edge effects</td>
<td>293</td>
</tr>
<tr>
<td>Applying Geometric effects</td>
<td>295</td>
</tr>
<tr>
<td>Applying Illumination effects</td>
<td>297</td>
</tr>
<tr>
<td>Applying Image effects</td>
<td>298</td>
</tr>
<tr>
<td>Applying Photo effects</td>
<td>299</td>
</tr>
<tr>
<td>Using Retro Lab</td>
<td>303</td>
</tr>
<tr>
<td>Applying a gradient with the Graduated Filter effect</td>
<td>304</td>
</tr>
<tr>
<td>Creating vintage-style photos with the Time Machine</td>
<td>305</td>
</tr>
<tr>
<td>Applying film and filter effects to photos</td>
<td>307</td>
</tr>
<tr>
<td>Applying Reflection effects</td>
<td>310</td>
</tr>
<tr>
<td>Applying Texture effects</td>
<td>311</td>
</tr>
<tr>
<td>Adding picture frames to images</td>
<td>318</td>
</tr>
</tbody>
</table>
Sizing, shaping, and rotating vector objects ................................................................. 352
Aligning, distributing, and arranging vector objects .................................................... 353
Grouping and ungrouping vector objects ..................................................................... 355
Converting objects to paths ....................................................................................... 356
Adding and closing contours ....................................................................................... 356
Editing contours and paths ......................................................................................... 357
Drawing lines ................................................................................................................ 359
Saving custom line styles ............................................................................................ 360
Drawing curves ............................................................................................................. 361
Modifying lines and curves ......................................................................................... 363
Copying and moving vector objects ............................................................................ 364

Working with brushes .................................................................................................. 365
Choosing brushes ........................................................................................................ 365
Choosing brush options ............................................................................................... 366
Using brushes ................................................................................................................ 366
Customizing brush settings ......................................................................................... 367
Creating brush tips and presets ................................................................................... 368
Importing and sharing brush tips ................................................................................ 370

Painting and drawing with the Art Media tools ............................................................ 371
Working with Art Media layers ................................................................................... 371
Working with the Mixer palette ................................................................................... 372
Working with Art Media tools ...................................................................................... 374
Using the Oil Brush tool ............................................................................................... 376
Using the Chalk tool ................................................................................................... 376
Using the Pastel tool ................................................................................................... 377
Using the Crayon tool .................................................................................................. 377
Using the Colored Pencil tool ...................................................................................... 378
Using the Marker tool ................................................................................................. 378
Using the Watercolor Brush tool ................................................................................ 379
Setting Warnings preferences............................................................................................................................................................ 406
Setting Auto Action preferences........................................................................................................................................................406
Setting Miscellaneous preferences.................................................................................................................................................. 407
Setting Manage tab preferences.....................................................................................................................................................409
Setting Auto-Preserve preferences......................................................................................................................................................409
Setting workspace tab preferences................................................................................................................................................. 410
Setting performance preferences........................................................................................................................................................ 410
Setting file format preferences.......................................................................................................................................................... 411
Setting file format associations......................................................................................................................................................413
Setting file locations..........................................................................................................................................................................413
Managing resources........................................................................................................................................................................... 415
Setting plug-in preferences.............................................................................................................................................................416
Selecting Web browsers.................................................................................................................................................................... 417
Setting Autosave preferences.............................................................................................................................................................418
Resetting all preferences....................................................................................................................................................................418
Switching languages........................................................................................................................................................................... 419
Adjusting general viewing options....................................................................................................................................................419
Accessing tools and commands from previous versions of PaintShop Pro......................................................................................... 421
Protecting and restoring the PaintShop Pro database...................................................................................................................... 421
Importing content and plugins from previous versions.................................................................................................................. 422

Editing 360° photos..........................................................................................................................................................................423
    What you need to know about 360° photos.....................................................................................................................................423
    Removing a tripod from a 360° photo..........................................................................................................................................423
    Straightening 360° photos............................................................................................................................................................424
    Correcting or applying effects to 360° photos............................................................................................................................425
    Applying Planet Effects to 360° photos.................................................................................................................................425
    Creating a panorama-style image from 360° photos..................................................................................................................426

Automating tasks.............................................................................................................................................................................429
    Scripting basics.............................................................................................................................................................................429
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing</td>
<td>441</td>
</tr>
<tr>
<td>Printing images</td>
<td>441</td>
</tr>
<tr>
<td>Creating layouts</td>
<td>444</td>
</tr>
<tr>
<td>Editing templates</td>
<td>446</td>
</tr>
<tr>
<td>Editing and saving layouts</td>
<td>448</td>
</tr>
<tr>
<td>Printing CMYK color separations</td>
<td>450</td>
</tr>
<tr>
<td>Understanding printing</td>
<td>450</td>
</tr>
<tr>
<td>Sharing photos</td>
<td>453</td>
</tr>
<tr>
<td>E-mailing photos</td>
<td>453</td>
</tr>
<tr>
<td>Creating images for the Web</td>
<td>455</td>
</tr>
<tr>
<td>Saving images for the Web</td>
<td>455</td>
</tr>
<tr>
<td>Working with GIF files</td>
<td>456</td>
</tr>
<tr>
<td>Working with JPEG files</td>
<td>459</td>
</tr>
<tr>
<td>Working with PNG files</td>
<td>460</td>
</tr>
<tr>
<td>Previewing images in Web browsers</td>
<td>461</td>
</tr>
<tr>
<td>Slicing images</td>
<td>462</td>
</tr>
<tr>
<td>Mapping images</td>
<td>465</td>
</tr>
<tr>
<td>Creating image rollovers</td>
<td>467</td>
</tr>
<tr>
<td>Using digital watermarks</td>
<td>468</td>
</tr>
</tbody>
</table>
Adding visible watermarks
Welcome

Corel® PaintShop® Pro 2023 is powerful image-editing software that helps anyone produce stunning photos and creative designs.

This section presents the following topics:
• “What’s new in Corel PaintShop Pro 2023” (page 15)
• “Installing and uninstalling Corel programs” (page 16)
• “Starting and exiting the program” (page 17)
• “Registering Corel products” (page 17)
• “Updates and messages” (page 17)
• “Corel Support Services” (page 18)
• “About Corel” (page 18)

The availability of features and options depends on the version of the software you have.

What’s new in Corel PaintShop Pro 2023

Make every shot your best shot with Corel PaintShop Pro 2023, an advanced photo editor delivering a versatile range of pro-level editing and graphic design tools along with time-saving AI-based solutions.

NEW! Haze Removal

Remove or reduce haze, fog, or smog in a photo in a couple of clicks. For more information, see “Removing haze” on page 150.

NEW! Interactive font sizing

Set font size quickly and easily right in the image window. For more information, see “To create text” on page 328.

NEW! Focus Stacking

Focus Stacking is a digital image processing technique that combines multiple shots of the same scene taken at different focus distances. You can choose exactly what areas in focus you want to keep or remove from each photo in the stack to produce a composite image that has a greater depth of field (DOF) than any of the individual source photos. For more information, see “Combining photos with Focus Stacking” on page 195.
Enhanced! Frame Tool

Create frames based on symmetrical and Preset Shapes or even vector text objects — or convert already existing vector objects and text into shapes — all with an enhanced Frame Tool. Then, fill them with images, patterns, or colors to achieve certain effects — surrealistic, avant-garde, playful, and more. For more information, see “Placing images in shapes or text with the Frame Tool” on page 169.

What’s more, you can now drag-and-drop a photo to replace an image already in a frame. For more information, see “To replace an image in a frame” on page 171.

New! AfterShot Lab

Enjoy powerful and complete editing of RAW files with pro-level tools in the new AfterShot Lab, now available in PaintShop Pro. For more information, see “Using AfterShot Lab” on page 101.

New! Blend Mode preview

Save time finding the right blend mode. You can now quickly preview layer blending simply by hovering your mouse pointer over an option in the Blend Mode drop-list in the Layers palette. For more information, see “Blending layers” on page 233.

New! Snap To Objects

Align objects with precision in no time with new Snap To Objects feature. Use the bounding box to precisely snap two objects together with automated, high-level control and avoid extra steps in the editing process. For more information, see “To snap a vector object to another vector object” on page 355.

Enhanced! Usability

Explore the updated layout of the New From Template page, now with more content visible, plus new Filtering and Sorting options. Get perfect results with a new precise rotation-angles control in vector editing. In addition, see a 30% performance improvement when using the Refine Brush, get support for the latest cameras, and more.

Exclusive Ultimate Bonus Software Collection

If you choose Corel PaintShop Pro 2023 Ultimate, it includes the following bonus collection:

- Sea-to-Sky™ workspace: This photo editing workspace is designed to take your drone and underwater photography to new heights.
- PhotoMirage™ Express: Effortlessly transform any image into a mesmerizing animation in a matter of minutes with PhotoMirage Express.
- Painter® Essentials™ 8: This easy-to-learn painting program — which includes 20 new brush packs — will transform your photos into amazing oil, pastel or impressionist works of art. Or learn to paint, draw and sketch from scratch in a welcoming environment, using pencils, pens, and particles.
- Corel® Creative Collection: Expand your creative capabilities with dozens of brushes, textures, and over 100 royalty-free backgrounds. Enhance your photo projects with playful designs, flowers, sunsets, and more, along with an array of lively brushstrokes.
- Highlight Reel: Creating quick videos showing off the highlights of your latest adventure just got a whole lot easier with new smart movie creator—Highlight Reel. Simply import your photos/videos and Highlight Reel will analyze and extract the best parts and compile them together for you, following the beat of the music. Creating videos to share your everyday moments just got easier.
- MultiCam Capture™ 2.0 Lite: Engage your viewers, grow your audience, and capture video with MultiCam Capture 2.0 Lite. Easily create how-to videos, gaming videos, record product demos, and more, with one easy-to-use recording software.
- 50 Free Fonts: Take advantage of 50 new modern fonts available in PaintShop Pro 2023. Enjoy beautiful typography, and experiment with font styles and colors to make your designs even more impressive and unique.

Installing and uninstalling Corel programs

The Installer makes it easy to install Corel programs and components.

Before installing

- Close all open programs. Note that antivirus software and firewall applications may affect installation.
- Ensure that you are logged in to your computer as Administrator or as a user with local administrative rights.
To install PaintShop Pro from download
1. Close all applications, including all virus detection programs.
   For smooth installation, we recommend that you restart Windows. This action will ensure that no restart is required by the latest system updates, and there are no memory issues.
2. Download the product from the link provided on your order confirmation.
3. In the installation wizard, follow the instructions for installing the software.

To install PaintShop Pro from DVD
1. Close any open applications.
2. Insert the DVD in the DVD drive or double-click the associated .exe file that you downloaded.
   If the DVD setup does not start automatically, navigate to the DVD drive on your computer, and double-click Setup.exe.
3. Follow the instructions on your screen.

To uninstall PaintShop Pro
1. Open the Windows Control Panel.
2. In the Programs category, click the Uninstall a program link.
3. In the Programs and Features window, click Corel PaintShop Pro 2023 in the list of applications.
4. Click Uninstall/Change.
5. Follow the instructions on your screen.

Starting and exiting the program
You can start PaintShop Pro from the Windows taskbar or your desktop icon, and exit the program from the File menu.

To start PaintShop Pro
• From the Start menu, choose Corel PaintShop Pro 2023 or use the Corel PaintShop Pro 2023 application icon or tile on your desktop or Start screen.
   If you associate specific file formats, such as JPEG and TIFF, with PaintShop Pro, you can double-click the associated file to start the program. For information about setting file format associations, see “Setting file format associations” on page 413.

To exit PaintShop Pro
• Choose File ➤ Exit.

Registering Corel products
Registering Corel products is important to ensure that you receive timely access to the latest product updates, as well as valuable information about product releases. Registration also gives you access to free downloads, articles, tips and tricks, and special offers.
You can register the program immediately after you install it. For more information about registering a Corel product, visit www.corel.com/support/register.

Updates and messages
Notification messages provide you with important information about your program. You can turn automatic program updates and messaging on or off. You can choose to check for updates and messages manually.
To turn notification messages on or off
2. Mark only the check boxes for the updates or messages that you want to receive.

To update your program
• Choose Help ➤ Check for Updates.

To check for messages
• Click Help ➤ Messages.

Corel Support Services
Corel® Support Services can provide you with prompt and accurate information about product features, specifications, pricing, availability, services, and technical support. For the most current information on available support and professional services for your Corel product, please visit www.corel.com/support.

About Corel
Corel products enable millions of connected knowledge workers around the world to do great work faster. Offering some of the industry’s best-known software brands, we give individuals and teams the power to create, collaborate and deliver impressive results. Our success is driven by an unwavering commitment to deliver a broad portfolio of innovative applications – including CorelDRAW®, MindManager®, Parallels® and WinZip® – to inspire users and help them achieve their goals. To learn more about Corel, please visit www.corel.com.
Learning PaintShop Pro

You can learn how to use PaintShop Pro in various ways: by accessing the Help and videos, by using the Learning Center palette, or by exploring the Corel Guide and by visiting the Corel website (www.corel.com), where you can access tips, tutorials, and information about training.

This section presents the following topics:
- “Documentation conventions” (page 19)
- “Using the Help” (page 20)
- “Corel PaintShop Pro 2023 User Guide PDF” (page 21)
- “Using the Learning Center palette” (page 21)
- “Learning with video tutorials” (page 22)
- “Using Web-based resources” (page 22)

Documentation conventions

The following table describes important conventions used in the Help.

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu ► Menu command</td>
<td>A menu item followed by a menu command</td>
<td>Choose File ► Open.</td>
</tr>
<tr>
<td>drop-list</td>
<td>A list of options that drops down when a user clicks a down arrow button</td>
<td>Choose an option from the Selection Type drop-list on the Tool Options palette.</td>
</tr>
<tr>
<td>palette</td>
<td>A window containing available commands and settings relevant to a specific tool or task</td>
<td>Double-click the name of the group on the Layers palette.</td>
</tr>
<tr>
<td>mark and unmark</td>
<td>Terms that refer to enabling or disabling check boxes by clicking them</td>
<td>To preserve the current print size, mark the Maintain original print size check box.</td>
</tr>
<tr>
<td>Enter</td>
<td>The Enter key on your keyboard</td>
<td>To save this gradient as a swatch that you can access later, click the Add to swatches button, type a name, and press Enter.</td>
</tr>
</tbody>
</table>
### Convention

<table>
<thead>
<tr>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>A note containing information that is important to the preceding steps. It may describe conditions under which the procedure can be performed.</td>
<td>Although you can apply the <strong>Texture Preserving Smooth</strong> command to the entire image, the command works best when you select the problem area.</td>
</tr>
<tr>
<td>A tip containing suggestions for performing the preceding steps. It may present alternatives to the steps, or other benefits and uses of the procedure.</td>
<td>You can also right-click in the image to set the source point for the Clone tool.</td>
</tr>
</tbody>
</table>

### Using the Help

The Help that is available from within the program is the most comprehensive source of information for PaintShop Pro. The Help provides two ways to find information. You can choose a topic from the Contents page, or use the Search page to search for specific words and phrases. You can also print topics from the Help.

#### Online and local Help

If you are connected to the Internet, the application displays the online Help. When you are online, you have access to the latest information, videos, and helpful links. If no Internet connection is available, the application displays the local Help that is installed on your computer.

#### To use the Help

1. Click **Help ➔ Product Help**.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse through topics in the Help</td>
<td>Click a topic heading in the left pane.</td>
</tr>
<tr>
<td>Search the full text of the Help for a particular word or phrase</td>
<td>Type a word or phrase in the search box. For example, if you are looking for information about the RGB color mode, you can type RGB to display a list of relevant topics. Choose a topic from the list that appears.</td>
</tr>
</tbody>
</table>

**Tip:** If your search results do not include any relevant topics, check whether you spelled the search word or phrase correctly. Note that the English Help uses American spelling (for example, “color,” “favorite,” “center,” and “rasterize”), so searching for British spellings (“colour,” “favourite,” “centre,” and “rasterise”) produces no results.

You can also access the Help by pressing **F1**. 

---

20 | Corel PaintShop Pro User Guide
View context-sensitive Help from within a dialog box by clicking the Help button in the dialog box.

**Corel PaintShop Pro 2023 User Guide PDF**

You can download the Corel PaintShop Pro 2023 User Guide PDF to your computer or tablet, or you can print the pages you want. You can find the PDF in Help menu (Help > User Guide (PDF)).

**Using the Learning Center palette**

The Learning Center palette contains helpful information about PaintShop Pro tasks, commands, and tools to help first-time users as well as experienced users get their work done faster. You can use the Learning Center in one of two ways: from the Home page, navigate through the task-based workflow, or simply click a tool in the Tools toolbar and follow the corresponding instructions that appear in the Learning Center palette.

Each task appearing on the Home page has its own topics with instructions that describe its related tools or commands. You can click a given topic to access a related tool or command. In this way, you can perform a task as you learn about it. You can also access the Help from the Learning Center palette to obtain additional information about a task.

To display or hide the Learning Center palette

**Edit tab**

- From the Edit tab, choose View > Palettes > Learning Center.
To use the Learning Center palette

Edit tab

1 From the Home page, click a task.
   The topics related to the task appear.

2 Click a topic.
   The procedure related to the topic appears.
   • For topics describing a tool, the tool becomes active. The Tool Options palette and any other relevant palettes appear.
   • For topics describing a command associated with a dialog box, the dialog box appears.

3 Read the procedure for using the tool or command.

Some tasks and commands are not available unless an image is open.

Learning with video tutorials

The Welcome tab and the Discovery Center window (English only) lets you find and view a range of videos that help you learn about the application and photography.

You can also find video links within some topics in the online Help and by visiting www.youtube.com/corelpaintshoppro.

To open the Discovery Center window

• Choose Help ➤ Video Tutorials.

Using Web-based resources

From the PaintShop Pro Help menu and the Corel website, you can access a number of Web pages dedicated to customer support and communities. You can find resources such as downloads, tutorials, tips, newsletters, newsgroups, and other online resources.
To access Web-based resources

- From the Help menu, select one of the following website links:
  - Corel Support — this link takes you to the Customer Support Web page
  - Check for Updates — checks the Corel Update Service to see if there are updates to your copy of PaintShop Pro

To access Corel learning resources

- Use your Internet browser to go to www.paintshoppro.com, and click the Learning tab.
Workspace tour

PaintShop Pro lets you choose between three main workspaces: Photography, Essentials and Complete. The Complete workspace is the classic PaintShop Pro workspace and includes the full set of tools for a wide range of projects. The Essentials workspace is a clean, easy-on-the-eyes workspace that includes a core set of tools. The Photography workspace is a touch-friendly, simple photo-editing workspace.

In addition to the main workspaces, you can choose a specialized workspace or you can create and save a custom workspace.

The availability of features depends on the version of the software you have.

This section presents the following topics:
- “Exploring workspace tabs” (page 25)
- “Switching tabs” (page 30)
- “Switching workspaces” (page 31)
- “About the Photography workspace” (page 31)
- “Choosing a workspace color” (page 32)
- “Using palettes” (page 32)
- “Using toolbars” (page 34)
- “Using tools” (page 35)
- “Customizing toolbars and palettes” (page 39)
- “Using dialog boxes” (page 40)
- “Viewing images” (page 43)
- “Using shortcut keys” (page 45)
- “Using context menus” (page 46)
- “Using rulers, grids, and guides” (page 46)

Exploring workspace tabs

Tabs are a way of organizing features and content. The Photography, Essentials and Complete workspaces show different tabs by default.
- Welcome — available in Photography, Essentials and Complete
- Manage — displays in Complete
- Adjust (optional) — available in Complete, but not a default tab
- Edit — available in Photography, Essentials and Complete, but customized to suit the editing profile of each workspace.

Each tab lets you access tools and controls to help you accomplish the task at hand quickly and efficiently.
For information about hiding and showing tabs, and setting the default tab for your workspace, see “Setting workspace tab preferences” on page 410.

Some workspaces (Complete, for example), let you save your current workspace configuration and state, including all open images, magnifications and screen positions, as well as positions and preferences of palettes, toolbars, dialog boxes, and windows. For more information, see “Using custom workspaces” on page 396.

The Welcome tab

The Welcome tab lets you access default workspace settings, start a new project or open a recent file, and it provides learning tools, offers, and important information about your product.

The Manage tab

In the Complete workspace, the Manage lets you access photo management features that help you preview, organize, and streamline your photo-editing workflow.
Manage consists of the following components:

- **Navigation palette** — helps you find and organize photos. You can use the Search box or click the Collections tab or Computer tab to display the folders on your computer, or you can sort photos by collection, tags, or ratings.
- **Preview area** — lets you choose between two views — a large single-image view or a multi-thumbnail view (expanded Organizer palette).
- **Info palette** — displays information about the selected image. It consists of a camera-style display of the settings used to take the photo and a tabbed area that lets you add information, such as tags and ratings, and access a full list of EXIF or IPTC data.
- **Organizer toolbar** — offers a range of commands and options for managing photos. You can hide or show the tools by clicking the button.

For more information about Manage, see “Reviewing, organizing, and finding photos” on page 79.

**The Edit tab**

The Edit tab lets you access editing features. Depending on the workspace, it includes menus, tools, and palettes that you can use to create and edit images.
(Photography workspace) A simplified, touch-friendly workspace, with a handy Split View makes editing in the Photography workspace easy for beginners and ideal for quick edits.
Workspace tour | 29

(Complete workspace) A photo displayed in Edit

**Edit** includes the following components:

- **Menu bar** — displays commands for performing tasks. For example, the Effects menu contains commands for applying effects to images.
- **Toolbars** — display buttons for common commands. For more information, see "Using toolbars" on page 34.
- **Palettes** — display image information and help you select tools, modify options, manage layers, select colors, and perform other editing tasks. For more information, see "Using palettes" on page 32.
- **Image window** — displays open files. You can choose from a tabbed view or a window view. For more information, see "Viewing images" on page 43.
- **Status bar** — displays information about the selected tool or menu command, as well as information about image dimensions, color depth, and pointer position. The status bar appears at the bottom of the window, and unlike other toolbars, it cannot be customized or moved. For more information about viewing image information, see “Displaying and editing photo information” on page 90.

Optional tabs: Adjust (Complete workspace)

**Adjust** is the place for quick edits. It lets you fix and enhance your photos by offering a set of the most commonly-used tools.
The **Adjust** includes the following components:

- **Adjust palette** — displays tools and controls for adjusting photos
- **Preview area** — displays the photo selected in the Organizer palette
- **Toolbar** — displays buttons for accessing common saving and viewing commands
- **Instant Effects palette** — displays preset effects that you can apply to your photo
- **Status bar** — displays information about the selected tool
- **Organizer palette** — this palette lets you select photos (as thumbnails) and includes a toolbar with a range of commands and options for managing photos. You can hide or show the tools by clicking the button.
- **Set Rating control** — lets you assign ratings to each photo, so that you can quickly find your favorites

### Switching tabs

PaintShop Pro lets you switch tabs quickly and easily so that you can accomplish your photo managing and editing tasks in the most efficient manner.

### To switch between tabs

- At the top of the application window, click one of the following tabs:
  - **Welcome** (Home icon)
  - **Manage** (in the Complete workspace)
  - **Adjust** (*optional tab in the Complete workspace)
  - **Edit**
Switching workspaces

You can switch between the Photography, Essential, Complete, specialized workspaces, or choose a custom workspace. For information about creating custom workspaces, see "Using custom workspaces" on page 396.

To switch workspaces

• Do one of the following:
  • On the Welcome tab, in the Workspaces area, choose the workspace that you want to use. Note: Custom workspaces are not listed on the Welcome tab.
  • Choose File ➤ Workspaces, and select the workspace you want to use from the submenu.

About the Photography workspace

The Photography workspace is a simplified, touch-friendly workspace, with a handy Split View that makes editing easy for beginners. It is also ideal for making popular corrections and enhancements.

Although the elements in this full screen workspace, including the icons, are simplified, the tools found in the Photography workspace can also be found in the Complete workspace. For information about specific tools or settings, search the Help for the tool name or setting.

Note: Split View is one feature that is not available in the Complete workspace. You can toggle Split View on or off by clicking the Split View button on the Standard toolbar.

Tool settings in the Photography workspace

In the Photography workspace, some tools are one-click, while others have settings. If a selected tool has settings, the settings display at the bottom of the window. You can click Cancel (x icon) or Apply (check mark icon) when you are finished adjusting the settings.

As in other workspaces, you can undo and redo your edits. Undo and Redo can be found on the left side of the Tools toolbar.

AI features in the Photography workspace

The Photography workspace includes some AI (artificial intelligence) tools. The analysis for these features takes a few moments. The processing time depends on the size of the image and your computer system. You’ll notice an animated blue overlay displays while the AI features are processing your image. At any time, you can click the Esc key if you want to cancel processing.

AI Style Transfer works through the Instant Effects palette. When you click AI Style Transfer, the Instant Effects palette displays (if not already open), and the AI-Powered category is selected. Clicking a style thumbnail once applies the style to the preview; clicking a style thumbnail twice applies it to your image. Styles cannot be layered—applying a new style replaces the previous style.
Choosing a workspace color

You can choose from a variety of workspace colors — from dark to light. You can also choose a background color for the image window and preview windows.

To choose a workspace color

1. Click View ➤ Workspace Color.
2. Choose one of the following colors:
   - Dark Gray (default)
   - Medium Gray
   - Light Gray

You can also change the workspace color by choosing User Interface ➤ Workspace Color

To change the background color

- Click View ➤ Background Color, and choose a color.

You can also change the background color by choosing User Interface ➤ Background Color

Using palettes

PaintShop Pro contains many palettes that organize information and commands to help you edit your images. Some palettes appear automatically, others appear when you activate certain tools, and some palettes appear only when you choose to open them. You can easily turn a palette on and off by choosing View ➤ Palettes. Some palettes are available only from specific tabs.
Palettes display information and may contain both controls and command buttons. Like toolbars, palettes can be moved from their default docked position. For more information about customizing palettes, see “Customizing toolbars and palettes” on page 39.

<table>
<thead>
<tr>
<th>Palette</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brush Variance</td>
<td>Lets you set additional brush options when you use a paint brush or any other raster painting tool. This palette is particularly useful when you use a pressure-sensitive tablet or a four-dimensional mouse. For example, you can vary the opacity of a brushstroke by applying pressure with the stylus. Some options also work well with a mouse.</td>
</tr>
<tr>
<td>Histogram</td>
<td>Displays a graph of the distribution of red, green, blue, grayscale, hue, saturation, and lightness values in an image. You can analyze the distribution of detail in the shadows, midtones, and highlights to help you decide how to make corrections.</td>
</tr>
<tr>
<td>History</td>
<td>Lists the actions taken on the active image; lets you undo and redo adjacent or nonadjacent actions; and lets you create a Quickscript that can be instantly applied to other open images</td>
</tr>
<tr>
<td>Info palette</td>
<td>(Manage tab) Displays information about the selected image. It consists of a camera-style display of the settings used to take the photo and a tabbed area that lets you edit and view information, such as tags and ratings, EXIF and IPTC data, and information about location.</td>
</tr>
<tr>
<td>Instant Effects</td>
<td>Provides quick access to thumbnails of preset effects that you can apply to your photos.</td>
</tr>
<tr>
<td>Layers</td>
<td>Lets you view, organize, and adjust settings for image layers</td>
</tr>
<tr>
<td>Learning Center</td>
<td>Displays information about workflow, tools, and commands to help you complete common tasks quickly and efficiently</td>
</tr>
<tr>
<td>Materials</td>
<td>Lets you choose colors and materials for painting, drawing, filling, and retouching</td>
</tr>
<tr>
<td>Mixer</td>
<td>Lets you place and mix pigments to use with the Oil Brush tool and the Palette Knife tool, allowing you to create realistic strokes with oil paints on Art Media layers</td>
</tr>
<tr>
<td>Overview</td>
<td>Displays a thumbnail of the active image; lets you set a zoom level, and displays image information</td>
</tr>
<tr>
<td>Organizer</td>
<td>Lets you gather and display photos from various folders so that you can select, edit, e-mail, or print them. You can add, remove, and rename custom trays within the palette to match your workflow.</td>
</tr>
<tr>
<td>Script Output</td>
<td>Displays a list of your actions and results when you run scripts</td>
</tr>
</tbody>
</table>
Palette Description

Tool Options Displays settings and controls for the active tool

To display or hide a palette
Edit tab
- Choose View Palettes, and click the palette name. Palettes that are currently displayed are denoted with a check mark.

You can display or hide a floating palette by pressing F2.

To resize a palette
Edit tab
- Drag the corner or edge of a palette.

You can also resize a docked palette by clicking the Minimize palette or Maximize palette button in the upper-right corner of the palette’s title bar.

Using toolbars
The workspace includes toolbars with buttons that are useful for performing common tasks. When you position the pointer over a button, its name appears in a tooltip, and the status bar displays additional information about the command. In addition, in the Edit tab, the Learning Center provides advice on using the tool.

The Edit tab is the main access point for the following toolbars:
- Effects — displays commands for applying effects to your images
- Photo — displays commands for enhancing photos
- Script — displays commands for creating and running scripts
- Standard — appears by default toward the top of the window and displays the most common file-management commands, such as saving images, undoing a command, and cutting and pasting items
- Status — appears by default at the bottom of the window and displays information about the selected tool
- Tools — contains tools for painting, drawing, cropping, typing text, and performing other image-editing tasks
- Web — displays commands for creating and saving images for the Web

To display or hide a toolbar
Edit tab
- Choose View Toolbars, and click the toolbar that you want to display or hide. A check mark beside the toolbar name in the menu indicates that the toolbar is displayed.

You can also display a toolbar by right-clicking any toolbar in the Edit tab, choosing Toolbars, and then choosing the toolbar name. To hide a specific toolbar, click the Close button on its title bar.

You can display or hide a floating toolbar by pressing F2.
Using tools

You can use the tools to perform a variety of image editing and creative tasks. When you hold the pointer over a tool, a tooltip displays the tool name and shortcut key, and the status bar displays hints for using the tool.

The Edit tab lets you access a wide selection of tools for advanced image creation and editing. Some of these tools, such as the Crop, Move, and Text tools, reside in their own space on the Tools toolbar. Most tools, however, are grouped with other tools that perform similar tasks. A group of tools is denoted by a small flyout arrow on the right side of the active tool.

Some tools are grouped together in flyouts. You can access all tools in a flyout by clicking the flyout arrow beside the active tool.

For information about hiding and showing tools, see "Viewing and hiding tools" on page 396.

For information about moving, hiding, and displaying the Tools toolbar, see "Using toolbars" on page 34.

Depending on the type of layer you are working on, some tools may not be available. For example, the Paint Brush and Clone Brush tools work only on raster layers; the Pen tool works only on vector layers. For more information about raster and vector layers, see "Understanding layers" on page 219.

The following table briefly describes each tool on the Tools toolbar of the Edit tab.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pan</td>
<td>Lets you control which part of the image is visible in the image window</td>
</tr>
<tr>
<td>Zoom</td>
<td>Zooms in when you click, or zooms out when you right-click. You can drag to define an area for zooming.</td>
</tr>
<tr>
<td>Pick</td>
<td>Moves, rotates, and reshapes raster layers, and selects and modifies vector objects</td>
</tr>
<tr>
<td>Move</td>
<td>Moves a raster layer or a vector layer on the canvas</td>
</tr>
<tr>
<td>Auto Selection</td>
<td>Selects the edges of an area automatically when you enclose the area in a selection rectangle.</td>
</tr>
<tr>
<td>Smart Selection Brush</td>
<td>Selects the edges of an area automatically when you brush over a sample area.</td>
</tr>
<tr>
<td>Selection</td>
<td>Creates a geometrically shaped selection, such as a rectangle, ellipse, or triangle</td>
</tr>
<tr>
<td>Freehand Selection</td>
<td>Creates an irregularly shaped selection</td>
</tr>
<tr>
<td>Magic Wand</td>
<td>Makes a selection based on pixel values within a specified tolerance</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Dropper</td>
<td>Lets you choose the foreground/stroke color by clicking or the background/fill color by right-clicking.</td>
</tr>
<tr>
<td>Crop</td>
<td>Trims or eliminates unwanted edges. Floating Crop toolbar also provides access to image enhancement options.</td>
</tr>
<tr>
<td>Straighten</td>
<td>Rotates a crooked photo to straighten it.</td>
</tr>
<tr>
<td>Perspective Correction</td>
<td>Squares the perspective of buildings or other objects that appear to be leaning.</td>
</tr>
<tr>
<td>Red Eye</td>
<td>Quickly corrects the red-eye effect commonly seen in photos.</td>
</tr>
<tr>
<td>Makeover</td>
<td>Provides five modes — Blemish Fixer, Toothbrush, Eye Drop, Suntan, and Thinify™ — which let you apply cosmetic fixes to subjects in your photos.</td>
</tr>
<tr>
<td>Clone</td>
<td>Removes flaws and objects by painting over them with another part of the image.</td>
</tr>
<tr>
<td>SmartClone</td>
<td>A content-aware cloning tool that lets you blend a source selection into a new background.</td>
</tr>
<tr>
<td>Scratch Remover</td>
<td>Removes wrinkles, wires, and similar linear flaws from digital photos, and removes scratches from scanned photos.</td>
</tr>
<tr>
<td>Object Remover</td>
<td>Covers unwanted elements of a photo with a neighboring texture in the same photo.</td>
</tr>
<tr>
<td>Paint Brush</td>
<td>Lets you paint on your image with colors, textures, or gradients.</td>
</tr>
<tr>
<td>Airbrush</td>
<td>Simulates painting with an airbrush or spray can.</td>
</tr>
<tr>
<td>Lighten/Darken</td>
<td>Lightens areas as you drag, or darkens areas as you drag with the right mouse button. This effect is stronger than the effects produced by the Dodge and Burn tools.</td>
</tr>
<tr>
<td>Dodge</td>
<td>Lets you lighten areas of a photo by clicking or darken areas by right-clicking.</td>
</tr>
<tr>
<td>Burn</td>
<td>Lets you darken areas of a photo by clicking, or lighten areas by right-clicking.</td>
</tr>
<tr>
<td>Smudge</td>
<td>Smears pixels by picking up new colors as you drag, or pushes pixels by not picking up new colors as you drag with the right</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Push</td>
<td>Pushes pixels by not picking up new colors as you drag, or smears pixels by picking up new colors as you drag with the right mouse button</td>
</tr>
<tr>
<td>Soften</td>
<td>Softens pixels as you drag, or sharpens pixels as you drag with the right mouse button</td>
</tr>
<tr>
<td>Sharpen</td>
<td>Sharpens pixels as you drag, or softens pixels as you drag with the right mouse button</td>
</tr>
<tr>
<td>Emboss</td>
<td>Creates an embossed effect by suppressing color and tracing edges as you drag</td>
</tr>
<tr>
<td>Saturation Up/Down</td>
<td>Makes colors more vivid as you drag, or less vivid as you drag with the right mouse button</td>
</tr>
<tr>
<td>Hue Up/Down</td>
<td>Shifts pixel hue values up as you drag, or shifts them down as you drag with the right mouse button</td>
</tr>
<tr>
<td>Change to Target</td>
<td>Recolors pixels while retaining detail</td>
</tr>
<tr>
<td>Color Replacer</td>
<td>Replaces the background/fill color with the foreground/stroke color when you click and drag, or replaces the foreground/stroke color with the background/fill color when you right-click and drag</td>
</tr>
<tr>
<td>Eraser</td>
<td>Erases raster layer pixels to transparency</td>
</tr>
<tr>
<td>Background Eraser</td>
<td>Erases around the edges of the areas you want to keep in a photo</td>
</tr>
<tr>
<td>Flood Fill</td>
<td>Fills pixels of a similar tolerance level with the current foreground/stroke material when you click, or with the current background/fill material when you right-click</td>
</tr>
<tr>
<td>Color Changer</td>
<td>Changes the color of an object while preserving the shading and luminosity of the original color</td>
</tr>
<tr>
<td>Gradient Fill</td>
<td>Adds a gradient fill that can be adjusted interactively on an image</td>
</tr>
<tr>
<td>Picture Tube</td>
<td>Places picture tubes, theme-based artistic elements, in your image</td>
</tr>
<tr>
<td>Text</td>
<td>Places text on your image</td>
</tr>
<tr>
<td>Frame Tool</td>
<td>Creates a container (frame) that you can fill with an image</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Preset Shape</td>
<td>Adds predefined shapes (such as callouts, arrows, and starbursts) to your image</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Creates a rectangle or square</td>
</tr>
<tr>
<td>Ellipse</td>
<td>Creates an ellipse or circle</td>
</tr>
<tr>
<td>Symmetric Shape</td>
<td>Creates symmetric or star-shaped objects</td>
</tr>
<tr>
<td>Pen</td>
<td>Creates connected or unconnected lines, freehand curves, and Bézier curve segments</td>
</tr>
<tr>
<td>Warp Brush</td>
<td>Shrinks, grows, twists, or distorts pixels</td>
</tr>
<tr>
<td>Mesh Warp</td>
<td>Distorts a photo by dragging points along an overlay grid</td>
</tr>
<tr>
<td>Oil Brush</td>
<td>Simulates oil brushstrokes on an Art Media layer</td>
</tr>
<tr>
<td>Chalk</td>
<td>Simulates drawing with chalk on an Art Media layer</td>
</tr>
<tr>
<td>Pastel</td>
<td>Simulates drawing with pastels on an Art Media layer</td>
</tr>
<tr>
<td>Crayon</td>
<td>Simulates drawing with crayon on an Art Media layer</td>
</tr>
<tr>
<td>Colored Pencil</td>
<td>Simulates drawing with colored pencil on an Art Media layer</td>
</tr>
<tr>
<td>Marker</td>
<td>Simulates drawing with an ink marker on an Art Media layer</td>
</tr>
<tr>
<td>Watercolor Brush</td>
<td>Simulates watercolor brushstrokes on an Art Media layer</td>
</tr>
<tr>
<td>Palette Knife</td>
<td>Simulates applying oil paint with a knife (instead of a brush) on an Art Media layer</td>
</tr>
<tr>
<td>Smear</td>
<td>Smears whatever pigment you’ve applied to an Art Media layer</td>
</tr>
<tr>
<td>Art Eraser</td>
<td>Erases whatever pigment you’ve applied to an Art Media layer</td>
</tr>
</tbody>
</table>
Customizing toolbars and palettes
You can dock, float, resize, and move the toolbars and palettes to customize your workspace, especially from the Edit tab. When docking is enabled, toolbars and palettes can be automatically integrated. When docking is disabled, toolbars and palettes can float anywhere on the screen without being integrated.

You can keep the open palettes and toolbars fully displayed or roll them up when you’re not using them.

To set docking preferences
Edit tab
1. Choose View > Docking Options.
   The Preferences dialog box appears.
2. In the Allow Docking Of group box, mark the palettes that you want to dock.

   Even if a palette is set for docking, you can still place it anywhere without docking it by dragging it while holding down Ctrl.

To dock a toolbar or palette
Edit tab
• Drag the toolbar or palette’s title bar to one edge of the window.
  The toolbar or palette snaps into place.

  You can also dock a toolbar or palette by double-clicking its title bar.

To float a toolbar or palette
Edit tab
1. Do one of the following:
   • Place the pointer over the toolbar’s handle. The pointer becomes a four-sided mover icon.
   • Place the pointer in the palette’s title bar.
2. Drag the toolbar or palette away from the window edge.

   The handle size and position vary, depending on the size of the toolbar and whether it is vertical or horizontal.

   You can also double-click the toolbar’s handle.

To move a toolbar or palette
Edit tab
• Drag its title bar to a new position.

To resize a toolbar or palette
Edit tab
• Drag a side or a corner of the toolbar or palette.
To display all toolbars and palettes

Edit tab

• Press Ctrl + Shift + T.

To roll up a toolbar or palette

Edit tab

• Click the Auto Hide pushpin button on the toolbar or palette’s title bar.

If the Auto Hide pushpin is pointing down, the toolbar or palette remains fully displayed.

When the Auto Hide pushpin is pointing to the left, the toolbar or palette rolls up when you move your pointer away.

If you perform an action in which the toolbar or palette remains in focus, the toolbar or palette remains displayed even after the pointer moves away. When you click anywhere else or perform another action, the toolbar or palette rolls up.

When you click away from the palette or toolbar with the Auto Hide button activated, it rolls up in one of two ways: If it’s floating, only the title bar is visible; if it’s docked, a tab appears with the palette or toolbar name.

Clicking the Auto Hide button again prevents the palette from rolling up.

To display the palette again, position your pointer over the tab.

Using dialog boxes

Dialog boxes are windows that open when you choose certain PaintShop Pro commands. You can use them to select and preview command options. All dialog boxes remember where you last positioned them on the screen and re-open in the same location.

There are two styles of dialog boxes. The following Adjust and Effect filters use a larger layout to make it easier to use interactive controls: Depth of Field, Digital Noise Removal, Graduated Filter, Red Eye Removal, Retro Lab, Selective Focus, Smart Photo Fix, and Vignette.

For an example of the other style of dialog box, see “Choosing effects” on page 271.

Common features found in many dialog boxes include the following:
• **Before** and **After** panes — let you see the effect of the dialog box settings on your image before the effect is applied
• **Zoom** and **Pan** controls — let you zoom in and out on the preview areas, and change the current viewing area
• **Presets** — display saved settings, or scripts, that you can use to make quick changes to images. For more information, see “Using and creating presets” on page 437.
• **Reset to Default** button — lets you reset dialog box settings to their initial values
• **Numeric edit** controls — let you select or enter numeric values
• **Color** boxes — let you select colors for a command setting
• **Randomize parameters** button — lets you preview random settings.

**Using preview areas**

Most dialog boxes that you use to correct images, apply effects, or modify selections contain Before and After panes that show the image with changes applied.

In some dialog boxes, you can show or hide the Before and After panes by clicking the Show/Hide Previews button:

- **Preview** — The Before and After panes are displayed.
- **Preview** — The Before and After panes are hidden.

When you hide the Before and After panes, you can still see the effects of the current settings on the image by marking the **Preview on Image** check box in the upper-right corner of the dialog box.

**Editing numeric values**

To edit values in PaintShop Pro dialog boxes, you can use the numeric edit control to enter values and change settings.

**Using color boxes**

In some dialog boxes, a color box displays the currently selected color for a given control. When you move the pointer over the color box, the pointer changes to a dropper and displays the RGB values.

**Randomizing parameters**

Many correction and effect dialog boxes contain a Randomize Parameters button that lets you update settings with random values.

**To zoom in or out of the image preview**

- Set the value in the Zoom control.

You can also expand the dialog box to create more room for the Before and After panes.
To pan the image preview
Edit tab
1 Move the pointer into the After pane.
   The pointer changes to a hand.
2 Drag the image.

You can also hold down the Pan button  and then center the selection rectangle over the part of the image you want to display.

To proof changes in the main image window
Edit tab
• Mark the Preview on Image check box.
   Any change to a dialog box setting will be applied to the main image window.

To edit numeric values
Edit tab
• Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter a specific value</td>
<td>Click in the control, press Delete or Backspace, and type a new value.</td>
</tr>
<tr>
<td>Increase or decrease the number by one</td>
<td>Click the up or down arrow.</td>
</tr>
<tr>
<td>Choose an approximate value</td>
<td>Click the slider.</td>
</tr>
<tr>
<td>Choose from the range of available settings</td>
<td>Move the slider.</td>
</tr>
</tbody>
</table>

If you enter a value that is out of range for the control, it turns red.

You can also double-click the number to highlight it, and type a new value.

To choose a color from a dialog box
Edit tab
• Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a color</td>
<td>Click the color box, and select a color from the Color dialog box.</td>
</tr>
<tr>
<td>Select from recently used colors</td>
<td>Right-click the color box, and select a color in the Recent Colors dialog box.</td>
</tr>
</tbody>
</table>
To randomize settings within a dialog box
Edit tab
• Click the Randomize parameters button.

You can try a variety of settings by continuing to click the Randomize parameters button until you get the effect you want.

Viewing images
You can view images in a tabbed format, in which a tab appears at the top of the image window. When you click a tab, the image in that window becomes the active image. You can also view images in windows, which you can move, resize, or close. You can open the same image in multiple tabs or image windows, which lets you see the image at different magnification levels.

The Tabbed Documents mode (left) lets you maximize your image viewing space. To view several images at the same time (right), turn Tabbed Documents mode off.

If you have multiple images open, you can arrange the image windows to view them side by side or stacked in cascading order.

If the image is larger than the image window, you can pan to view different parts of the image, or you can fit the window to the image. You can also see a thumbnail of the entire image in the Overview palette. For more information, see “Using palettes” on page 32.

The title bar at the top of the image window shows the filename and the magnification percentage. An asterisk after the filename indicates that the image has been modified and that those changes have not been saved.

If the image has an embedded watermark, a copyright symbol is displayed in front of its name. For more information, see “Using digital watermarks” on page 468.

To enable or disable the tabbed image window option
Edit tab
• Choose Window ➤ Tabbed Documents.

To view another image, click its tab. If an image tab is not in the current view, click the arrows in the upper-right corner of the image window to scroll left or right.

To close a tabbed-format image, click the Close button.

To move an image window
Edit tab
• Drag the title bar.
To resize an image window
Edit tab
• Drag a corner of the image window.

When you resize an image window, you are not changing the size of the image.

To minimize or maximize an image window
Edit tab
• Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimize the image window to display only the title bar</td>
<td>Click the Minimize button</td>
</tr>
<tr>
<td>Maximize the image window to fill the area</td>
<td>Click the Maximize button</td>
</tr>
<tr>
<td>Restore the image window to its previous size</td>
<td>Click the Restore Up button</td>
</tr>
</tbody>
</table>

To close an image window
Edit tab
• Choose File ➤ Close.

If you have made unsaved changes to your image, you are prompted to save.

You can also click the Close button on the title bar.

To close all windows, choose Window ➤ Close All.

To make a copy of the active image
Edit tab
• Choose Window ➤ Duplicate.

A copy of the active image opens. You can edit the copy independently of the original image.

You can also duplicate the active image by pressing Shift + D.

To open multiple views of the same image
Edit tab
• Choose Window ➤ New Window.

A new window opens with another view of the active image. When you make changes in one window, both windows are updated.

To arrange multiple windows
Edit tab
• Perform a task from the following table.
To Do the following

Display cascading windows
Choose Window ➤ Cascade.
The windows cascade from the upper left to the lower right of the window.

Display windows side by side vertically
Choose Window ➤ Tile Vertically.
Windows are resized to fit within the window.

Display windows side by side horizontally
Choose Window ➤ Tile Horizontally.
Windows are resized to fit within the window.

To view another area of the image
Edit tab
• Perform a task from the following table.

To Do the following

Pan the image
On the Tools toolbar, choose the Pan tool, and then drag in the image. If any other tool is active, hold down the Spacebar, and then drag in the image.

Change the view horizontally or vertically
Drag the horizontal or vertical scroll bar.

Change the view by small increments
Press the arrow keys.

Pan in the Overview palette
Press F9 to display the Overview palette, click the Preview tab, place the pointer inside the panning rectangle, and drag. You can also set the zoom level in the Preview tab of the Overview palette.

To fit the image in the image window
Edit tab
• Perform a task from the following table.

To Do the following

Fit the window to the image
Choose Window ➤ Fit to Image.

Fit the image to the window
Choose Window ➤ Fit to Window.

Fit the image and the window to the screen
Choose Window ➤ Fit to Screen.

Using shortcut keys

PaintShop Pro lets you use shortcut keys to execute menu commands, select tools, display palettes, edit nodes on vector objects, and execute Organizer commands. All of the menu commands, including those for opening palettes, list their shortcut keys. Shortcut keys for tools are displayed when you move the pointer over a tool.
You can customize the shortcut keys. For more information, see “Customizing keyboard shortcuts” on page 400.

**To access menu commands by using shortcut keys**

- Hold down **Alt**, and press the underlined letter in the menu item.
  
  For example, press **Alt + F** to open the File menu.

  ![Tip](tip.png)

  You can also scroll through the menus by using the arrow keys.

**To view all shortcut keys**

- **Edit tab**
- **Manage tab**

  * Choose **Help ➤ Keyboard Map**.

**Using context menus**

Context menus provide quick access to commands that are specific to a tool, selection, palette, or other item. You can open a context menu by right-clicking the item.

**To view a complete list of context menus**

- **Edit tab**

  1. Choose **View ➤ Customize**.
     
     The Customize dialog box appears.
  2. Click the **Menu** tab.
  3. Click the **Select context menu** drop-list.
     
     All of the context menu names appear in the drop-list. If you want to open a specific context menu, select it.

**To use a context menu**

1. Right-click an image, an empty area of a palette, a layer on the Layers palette, a thumbnail in the Organizer, or a toolbar.
2. Choose a command.

**Using rulers, grids, and guides**

The Edit tab displays the rulers by default. You can choose a ruler display in pixels, inches, or centimeters, change the color of the rulers, or altogether hide them.

**What is a grid?**

A grid is a series of horizontal and vertical lines overlaying your image. Grid lines can help you position image elements. You can display or hide grids and set grid preferences for spacing and appearance. When you display grids, they appear in all open image windows.

**What are guides?**

Guides are horizontal or vertical lines you position to overlay your image. With the rulers displayed, you drag guides onto your image to help with precision work, such as cropping, moving image elements, selections, as well as text and brushstroke placement. While grids place a series of horizontal and vertical lines at certain intervals, you place guides at the locations you want.

**Setting snapping**

You can use snapping to align your brushstrokes and image elements precisely to the nearest grid line or guide. The snap influence controls the distance, in pixels, that an element must be from a guide or grid line in order to snap to it. An item’s center point snaps to a guide or grid if the center point is the closest part of the item to a grid or guide.
To display the ruler, grid, or guides
Edit tab
• Choose the View menu, and select one of the following:
  • Rulers
  • Grid
  • Guides

You must first display rulers before you can drag guidelines onto your image.

To set ruler properties
Edit tab
Manage tab
1 Choose File ➤ Preferences ➤ General Program Preferences.
   The Preferences dialog box appears.
2 Choose Units from the list.
3 In the Rulers group box, choose an option from the Display Units drop-list.
4 Choose the ruler color by selecting one of the following options:
   • Black on white — displays black hash marks and numbers on a white background
   • Toolbar colors — displays black hash marks and numbers on a color background that is used in toolbars and palettes
5 Click OK.

To set default or current grid properties
Edit tab
1 Choose View ➤ Change Grid, Guide, Object & Snap Properties.
2 Click the Grid tab.
   The Default settings group box shows the default settings for the grid. The Current image settings group box shows settings for the grid in the current image.
3 Type or set a value in the Horizontal grids control to set the distance between horizontal grid lines (starting from the top of the image).
4 Type or set a value in the Vertical grids control to set the distance between vertical grid lines (starting from the left side of the image).
5 Choose a unit of measurement option from the Units drop-list.
6 Click OK.

You can also

Choose a grid color
   Click the Color box, and choose a color from the color palette.

Set the snap influence level
   Type or set a value in the Snap influence control.

To place a horizontal or vertical guide
Edit tab
1 If the rulers are not displayed, choose View ➤ Rulers.
2 Choose View ➤ Guides.
3 Do one of the following:
   • To place a horizontal guide, click the top ruler, and drag a guide into position.
• To place a vertical guide, click the left ruler, and drag a guide into position. As you drag, the Status bar displays the guide’s position (in pixels).

4 For further placement position, on a ruler, double-click a guide handle. The Guide Properties dialog box appears.

5 Type or set a value in the **Guide position** control.

6 Click **OK**.

**To change the color of a guide**

**Edit tab**

1 On a ruler, double-click a guide handle. The Grid, Guide, Object & Snap Properties dialog box appears.

2 On the Guides tab, click the **Color** box, and choose a color from the color palette.

3 Click **OK**.

**To set the default properties for guides**

**Edit tab**


2 Click the **Guides** tab. The **Default Settings** group box shows the default settings for guides. The **Current Image Settings** group box shows settings for the guides in the current image.

3 In the **Default Settings** group box, click the **Color** box, and choose a color from the color palette.

   If you want to choose a recently-used color, right-click the **Color** box, and choose a color from the Recent Colors dialog box.

4 Type or set a value in the **Snap influence** control to specify the distance (in pixels) that an item must be from the guide in order for it to snap.

5 Click **OK**.

   **Note:** You must choose the **Snap to Guide** command in the **View** menu.

**To delete guides from an image**

**Edit tab**

1 Choose **View** » **Change Grid, Guide, Object & Snap Properties**.

2 Click the **Guides** tab.

3 Mark the **Delete guides** check box.

4 Choose one of the following options:
   • From current image only
   • From all open images

5 Click **OK**.

   ![Tip]

   You can also drag a guide’s handle until the guide is off the image area, or right-click a guide handle and click **Delete** in the Guide Properties dialog box.

**To snap to the nearest guide or grid line**

**Edit tab**

• From the **View** menu, choose one of the following:
   • **Snap to Guides**
   • **Snap to Grid**
Sea-to-Sky workspace (Ultimate)

In the Ultimate version of PaintShop Pro, you can find **Sea-to-Sky**—a specialized workspace designed to take your drone and underwater photography to new heights. Whether it’s dealing with haze in aerial and landscape photos, color casts in underwater photos, or improving images captured in challenging lighting conditions, the Sea-to-Sky workspace offers a set of tools and presets to make impressive quick corrections and creative improvements.

This section presents the following topics:

- “Sea-to-Sky workspace (Ultimate)” (page 49)
- “Editing images in the Sea-to-Sky workspace (Ultimate)” (page 50)

The availability of features depends on the version of the software you have.

### Sea-to-Sky workspace (Ultimate)

Similar to the full screen and simplified user interface of the **Photography** workspace, **Sea-to-Sky** is a touch-friendly workspace, with a handy **Split View** that makes it easy to compare the original image with the edited image.

Although the elements in this full screen workspace, including the icons, are simplified, the tools found in the **Sea-to-Sky** workspace can also be found in the **Complete** workspace. For information about specific tools or settings, search the Help for the tool name or setting.

**Note:** **Split View** is one feature that is not available in the **Complete** workspace. You can toggle **Split View** on or off by clicking the **Split View** button on the **Standard** toolbar.
To open the Sea-to-Sky workspace

- In PaintShop Pro Ultimate, do one of the following:
  - On the **Welcome** tab, choose **Sea-to-Sky** in the **Workspaces** area.
  - On the **Edit** tab, click **File** ➤ **Workspace** ➤ **Sea-to-Sky**.

If the **Edit** tab isn’t open, click it to access the editing features.

Editing images in the Sea-to-Sky workspace (Ultimate)

Editing images in the **Sea-to-Sky** workspace is easy. It is recommended that you crop or use any of the other tools before you apply a preset. Although you can apply a preset before using editing tools, you must undo if you want to reapply a preset.

To edit an image in the Sea-to-Sky workspace

1. From the **File** menu or the **Standard** toolbar, choose **Open**, and select a file that you want to edit.
2. Apply any of the following transformation tools:
   - Crop
   - Flip Horizontal
   - Flip Vertical
   - Rotate Right
3. Choose one of the following preset categories:
   - Corrective
   - Scenic
   - Low Light
• Creative

4 Click the thumbnail for the preset that you want to apply.

   A purple progress bar displays below the image as the preview is updated.

   If you want to try another preset, click another thumbnail; if you decide not to apply a preset, click None.

   **Note:** Presets are not cumulative—when you apply a new preset, it replaces the previous preset.

5 Click **Apply** (check mark icon).
Getting started

You can bring your images into Corel PaintShop Pro in various ways: you can import photos that you have transferred to your computer, scan images directly into the application, capture images from the computer screen; or you can create an image.

After you bring your images into the application, you can access many basic commands that help you view images and image information. You can perform basic actions such as cut, copy, undo, and repeat.

This section presents the following topics:
• “Getting photos into PaintShop Pro” (page 53)
• “Connecting with image scanners” (page 54)
• “Opening and closing images” (page 54)
• “Saving images” (page 55)
• “Starting projects from a template” (page 58)
• “Starting from a blank canvas” (page 60)
• “Creating images from existing images” (page 62)
• “Viewing images and image information” (page 63)
• “Exporting the image editing history to a text file” (page 64)
• “Using Screenshot” (page 65)
• “Zooming and panning” (page 67)
• “Cutting, copying, and pasting” (page 68)
• “Copying images into other applications” (page 70)
• “Undoing and redoing actions” (page 71)
• “Repeating commands” (page 73)
• “Deleting images” (page 74)
• “Files supported by PaintShop Pro” (page 74)
• “How to open HEIC files from an iPhone or other device” (page 77)

Getting photos into PaintShop Pro

After you transfer your photos to your computer (by using Windows or the software for your camera), you can import your photos into PaintShop Pro. You import photos by browsing to folders. The photos in the folders are then cataloged automatically in a database. This makes it easy to find, edit, and update the information for your photos.

To import your photos into PaintShop Pro

1 In the Navigation palette, click the Collections tab, and click Browse More Folders.
In the Browse For Folder dialog box, navigate to the folder you want.

Click OK.

The folder is added to the folder list and all the images are cataloged in the application database.

You can open the Navigation palette by clicking the Show/Hide Navigation button on the Organizer palette.

**Connecting with image scanners**

Your scanning software may allow you to choose an application for scanning images. Many TWAIN, WIA, and USB scanners are compatible with PaintShop Pro.

**Scanner compatibility**

TWAIN is supported by PaintShop Pro. However, your scanner must support 64-bit applications (in some cases, scanner drivers install to the 64-bit version of Windows, but do not support interaction with 64-bit applications). How can you tell? After you install the 64-bit scanner driver from the manufacturer, a file appears in the following location: Windows/twain_64. If you do not see the twain_64 folder and a file within the folder, then the driver does not support 64-bit applications. For more information, please refer to the scanner manufacturer’s website.

PaintShop Pro also supports WIA (Microsoft Windows Image Acquisition) scanners.

**To get images from a scanner**

1. After installing the software that came with your scanner, connect your scanner to your computer.
2. In PaintShop Pro, choose File ➤ Import, and click From Scanner or Camera (WIA option) or TWAIN Acquire, depending on the type of scanner.
3. Use the scanner’s software to perform the scan.
   
   If you have set up your scanner to work with PaintShop Pro, the image is displayed in the application after it is processed. The scanner’s software may remain open, so you can either continue to acquire images or exit the software.

   After scanning multiple photos at the same time, you can quickly create individual image files by using the Crop as New Image feature. For more information, see “To create a new image by cropping” on page 117.

   After cropping an image, you might notice that the Width and Height values on the Tool Options palette are each set at 0.100. These settings do not reflect the cropped image size. To see the image size dimensions after cropping, choose Image ➤ Image Information.

**Opening and closing images**

You can open most image formats in PaintShop Pro. You can open the images by using the menu bar or from the Organizer palette. You can associate specific file formats with PaintShop Pro, such as JPEG, TIF, or PNG, so that these files will open in PaintShop Pro when you double-click them. For more information about setting file format associations, see “Setting file format associations” on page 413. For a list of the file formats that you can open in PaintShop Pro, see “Files supported by PaintShop Pro” on page 74. For information on RAW files, see “Supported RAW file formats” on page 99.

**To open an image**

1. Choose File ➤ Open.
2. In the Look in drop-list, choose the folder where the file is stored.
3. Click the name of the file that you want to open.

   If you want to open multiple files, hold down Ctrl, and click the filenames.
4 Click Open.

You can also

View information about an image
In the Open dialog box, click the filename, and click Details.

View a thumbnail in the preview area
In the Open dialog box, mark the Show preview check box.

To open an image from the Organizer palette
1 In the Organizer palette, click the Show/Hide Navigation button to display the Navigation palette.
2 In the Navigation palette, click one of the following tabs:
   • Collections — displays a custom list of cataloged folders and a list of virtual collections
   • Computer — displays a list of all folders and devices on your computer
3 Double-click a folder to display the subfolders it contains.
4 Click the folder that contains the photos that you want, and drag the corresponding image thumbnail into the image window.

To open a recently viewed file
Edit tab
• Choose File ➤ Recent Files, and choose the filename.

By default, the Recent Files menu lists four recently viewed files. You can choose to list up to 10 files. For more information, see “To set the number of files that appear in the Recent Files list” on page 407.

To open a RAW photo image
Edit tab
• Do one of the following:
   • Choose File ➤ Open.
   • Double-click on a RAW image thumbnail.
   • Hold down Ctrl, and click the filenames or thumbnails to open multiple files.

The Choose how to edit RAW files window opens, where you can choose a RAW-editing option.

To close an image
• Choose File ➤ Close.

Saving images

Before you save an image, you need to consider the file format in which you want to save it, and you must ensure that you don’t overwrite an original image that you may need in the future.

The Psplimage file format of PaintShop Pro supports layers, alpha channels, and other features used in creating images. It is recommended that you save and edit your images as Psplimage files. You can then save the files to common file formats. You can also save an image that is compatible with an earlier version of PaintShop Pro.

You can also use the Save for Office command if you want to optimize your images for placement in another application, such as a page layout, e-mail, or Web page design application.
The following list provides basic information about common file formats:

- **JPEG** — a standard file format for digital photos that is suitable for e-mail and the Web. It uses lossy compression, which ensures a small file size but entails a loss of image data each time you save. For this reason, this format is not recommended for editing photos unless a high quality setting is used. This file format supports EXIF and IPTC data, which can be used to provide information about the photo, such as when a photo was taken.

- **TIFF** — a standard file format for printing and sharing images between programs. This file format uses non-lossy compression. Although you do not lose image data when you save the file, the larger file size is less suitable for e-mail and the Web. TIFF can save data in the CMYK color mode for printing, and it supports EXIF and IPTC data.

- **PNG** — a file format widely used for Web images. It uses non-lossy compression to reduce the file size without losing image data.

- **RAW camera formats** — a file format typically used by professional photographers. RAW camera formats provide uncompressed, unprocessed image data and gives you the most control over how an image is processed. You must have a camera that captures digital image in a RAW format, and you need software that lets you open and work with the file, such as PaintShop Pro.

You can save a PspImage file with or without compression. Both compression methods that PaintShop Pro uses are lossless and reduce the file size without losing any image information. Uncompressed files require more disk space.

PaintShop Pro uses the following compression methods:

- **Run length encoding (RLE)** — a fast compression method, which compresses most multilayer images to about 75 percent of their original size. This method works well with images that contain large areas of the same color.

- **LZ77 compression** — a slower compression method that compresses most images to smaller sizes than with the RLE method. This method works well with photorealistic images.

When you save a new image, PaintShop Pro lets you select its location, name, and file format. When you save an image and then edit it, the image title bar displays an asterisk, or modifier tag, after the filename to indicate that the file has been modified. This tag disappears each time you save your work.

You can also automatically save your files at specific intervals to avoid losing your work if your computer shuts down unexpectedly. For more information, see “Setting Autosave preferences” on page 418.

If you want to save a version of a file, you can save a copy of an image. This is useful when you want to apply effects to an image but keep the original file.

**Important!** The Auto-Preserve Original preference setting can help you avoid overwriting original images. By default, this feature is on. For more information on this preference setting, see “Setting Auto-Preserve preferences” on page 409.

To save a new image

1. Choose File ➤ Save.
   The Save As dialog box appears.
2. From the Save in drop-list, choose the folder in which you want to save the file.
3. In the File name field, type a name for the file.
4. In the Save as type drop-list, choose a file format. The most commonly used formats are listed first.
   If you want to change the default settings for the file format (for example compression or color profile), click Options, and choose the settings you want.
5. Click Save.

You can also save your work by clicking the Save As button on the Standard toolbar to avoid overwriting your current file.

You can also adjust default settings for JPEG images by dragging the Compression slider the first time you save a JPEG in your editing session.

You can save in the last-used file format by choosing File ➤ Preferences ➤ General Program Preferences, and clicking Display and Caching from the list on the left side. In the Presentation group box, mark the Re-use last type in the file save-as dialog check box.
To save your work

Edit tab

• Choose **File ▶ Save**.

If the Auto-Preserve Originals preference setting is enabled, and this is the first time you’ve attempted to save changes to this image, you are prompted to save a copy of the original unedited image. If Auto-Preserve Originals is not enabled, the original image is overwritten by the modified image.

You can avoid overwriting the current file by using the **Save As** command.

You can also save your work by clicking the **Save** button on the Standard toolbar.

To save an image compatible with an older version of PaintShop Pro

Edit tab

1 Choose the **File ▶ Save As**.
2 Type a filename in the **File name** box.
3 From the **Save in** drop-list, choose the folder in which you want to save the file.
4 In the **Save as type** drop-list, choose **PSPIMAGE**.
5 Click **Options**.
6 In the Save Options dialog box, choose a version from the **Save as** drop-list.
7 Click **OK**.
8 Click **Save**.

To save a copy of an image

Edit tab

1 Choose the **File ▶ Save Copy As**.
   The Save Copy As dialog box appears.
2 From the **Save in** drop-list, choose a folder in which to save the image.
   If you want to create a new folder for the image, click the **Create New Folder** button.
3 In the **File name** box, type a name for the file.
   If you want to save the file in a different format, select the format from the **Save as type** drop-list. The most commonly used formats are listed first.
   If you want to change the default settings for the file format (for example compression or color profile), click **Options**, and choose the settings you want.
4 Click **Save**.

To save images for office applications

Edit tab

1 Choose **File ▶ Save for Office**.
   The Save for Office dialog box appears.
2 From the **Save in** drop-list, choose a folder in which to save the image.
   If you want to create a new folder for the image, click the **Create New Folder** button.
3 From the **Optimize** drop-list, choose one of the following:
   • **Desktop Printing** — sets the image resolution to 200 dpi. This option is ideal for when you are working in a general page layout application and you want high-quality images but not an overwhelming file size.
   • **Professional Printing** — sets the image resolution to 300 dpi. This option is ideal for when you need the highest image quality.
• **Screen or e-mail** — sets the image resolution to 96 dpi. This option is ideal for when you want a smaller file size that can be shared or displayed quickly.

4 In the **File name** box, type a name for the file.

5 Choose a file format from the **Save as type** drop-list.

6 Click **Save**.

**You can also**

- Define the maximum image size
  - Mark the **Advanced Settings** check box, and then adjust the **Width** and **Height** settings. Choose a unit of measure from the drop-list on the right.

- Adjust the image quality
  - Mark the **Advanced Settings** check box, and then choose a resolution from the **Image quality** drop-list.

- Use the most recent settings from the Save to Office dialog box
  - From the **Optimize** drop-list, choose **Last Used**.

- Use the default settings for the Save to Office dialog box
  - From the **Optimize** drop-list, choose **Default**. The settings are the same as the default **Screen or e-mail** settings.

**Starting projects from a template**

You can access a wide range of creative templates on the **New From Template** tab in the **New Image** dialog box—from cards, to collages, brochures, and social media templates. You can choose from a selection of free templates or you can purchase templates.

How the templates work

The templates use PaintShop Pro layers and masks to provide maximum flexibility—you can customize the templates any way you like and save the customizations to a .pspimage file so that you can use them again. The templates use placeholder images that you replace with your own images—all this is done in the **Layers** palette. For more information about layers, see “Working with layers” on page 219.
To start a project from a template

1. Do one of the following:
   • From the Welcome tab, click the Template button.
   • From the Edit tab, click File ➔ New From Template.
   The New Image dialog box appears with the New From Template page displayed.

2. Choose a template.
   To make it easier to find a template, you can filter and sort them. The criteria in the Filter by drop-list changes depending on the selected template category. Using the Sort by drop-list, you can sort templates by creation date, title, price, resolution, or file size.
   If the template isn't already installed, click Download or Buy.

3. Click OK.
   The template opens in the image window and the Layers palette.

4. In the Organizer palette, select a photo that you think will work well in one of the template frames, and drag the thumbnail to the Layers palette, under the mask layer (the mask layers appear in black and white) for the frame that you want to fill.

   ![Image showing dragging a thumbnail under a mask layer](image.png)
   It’s important to drag the image thumbnail under the black-and-white mask layer. The pointer displays a plus sign and a line displays between the layers to indicate that you are inserting an image layer.

   The image is inserted as a layer and is selected (highlighted in blue).

5. On the Tools toolbar, click the Pick tool.

6. In the image window, adjust the zoom level (you can use the Zoom Out tool on the Standard toolbar) until you can see the edges of the image layer if they extend beyond the image window.

   ![Image showing zoomed and adjusted image layer](image.png)
   A marquee indicates the edges of the image layer. The red arrow and circle show a corner node.

7. Drag a corner node to resize the image layer. You can move the image layer by positioning the cursor in the middle of the image layer (a four-arrow cursor appears), and dragging.
   If you want to move the image to a different frame in the template, in the Layers palette, drag the image layer under a different mask layer (might need to scroll in the Layers palette).

8. When you are finished filling the template, make any additional changes you want (add text etc...).

9. Click File ➔ Save As and save the file as a .pspimage file to keep a layered, editable version of the file.
If you want to share the final version, click **File** ➤ **Save As**, and save the file to a shareable file format, such as JPEG, PNG, or TIFF (for printing). Please note that most file formats flatten the image (merge all layers to one layer).

If your image appears clipped and you see the transparency grid when you move or resize the image layer, check to see if the mask group is selected in the **Layers** palette rather than the image layer. If so, undo until the image is restored and then select the intended layer.

Starting from a blank canvas

Starting an image from a blank canvas lets you build custom projects, such as collages, and painting or drawings.

You can choose a preset, such as a standard page, photo size, or Facebook timeline cover, or you can create a custom image. The section below describes some of the settings available.

There are two types of computer graphics: raster and vector. With PaintShop Pro, you can create both types of images. You can also create an image with both raster and vector layers. It is important to understand the differences between these two data types before you begin working with them.

**Raster graphics**

Raster images are composed of individual elements, called pixels, which are arranged in a grid. Each pixel has a specific location and color. If you magnify raster data, you can see the individual pixels as squares of colors. Raster images contain a fixed number of pixels, so when you magnify the image you are magnifying the display size of the pixels. As a result, raster images may display jagged rather than smooth edges when magnified on screen or when printed at a large magnification.

An object in a raster image is defined by its pixels. For example, the front door in an image of a house is made up of a mosaic of pixels at certain locations in the image. In bitmap images, you edit pixels rather than objects or shapes.

Raster images can display subtle changes in tones and colors, so they are most often used for images like photographs and digital artwork.

**Vector graphics**

Vector graphics use geometric characteristics — lines, curves, and their locations — to define objects. For example, a door in a graphic of a house is made up of a rectangle that has a certain width and height, is placed at a specific location, and is filled with a certain color. In vector images, you edit objects or shapes rather than pixels.

Vector graphics do not lose clarity or detail when they are scaled or printed, regardless of the change in size or resolution. For this reason, vector graphics are suited to technical illustrations or corporate logos.
Choosing to work with raster or vector data

With PaintShop Pro, you create and edit raster and vector data on separate layers. With some tools you create raster data (like brushstrokes with the Paint tool), and with other tools (like the Text and Preset Shapes tools) you can choose whether you want to create raster or vector data.

In general, it is best to use a vector object if you need to edit it as an element separate from other parts of the image. For example, if you add a star to an image, you may want to change its size, color, or location. You can make these changes more easily if the star is a vector object. You can create raster data on separate layers, which can be easily edited or moved.

To apply tools or commands to vector objects that work only on raster data (such as the painting tools or the Effects commands), you can create a raster selection of a vector object and then paste the selection to a new raster layer.

Understanding image size, resolution, and color depth

Before you create a new image, you need to consider how you will use it. For example, will you display the image on a website, send it as an e-mail attachment, or print it? How you use the image helps you determine its size, resolution, and color depth.

Image size is represented by the physical dimensions of the image. When you create a new image or resize an existing image with PaintShop Pro, you can define image height and width in pixels, inches, millimeters, or centimeters.

The following are guidelines for choosing a unit of measure:

- If you plan to print the images, use inches or centimeters. By starting with the final image dimensions, you can produce an image that fits the page.
- If you plan to export the images to another application (such as a word-processing application), and then resize and print them, you can use any of the options.
- If you plan to display the images on the screen, use pixels.

You can resize an image after creating it, but doing so may result in loss of image data. For more information about resizing images, see “Retouching and restoring images” on page 155.

Image Resolution is measured in pixels per inch (ppi) or pixels per centimeter. Low resolution can cause pixelation, a problem in which large pixels produce coarse output. High resolution can increase an image’s memory requirements without producing a proportional increase in its quality.

Color Depth is measured according to the number of colors that a pixel can display. Each pixel’s color information is stored in bits — from 1 to 48 bits. In a 1-bit image, each pixel can display only one of two colors (black or white). In a 24-bit image, each pixel can display 1 of 16 million colors. Images with a color depth of 16 million colors look good, but they also require more memory to store and edit. Not all computer monitors can display 16 million colors, so some file formats limit the number of supported colors. For example, GIF images, a popular format for the Web, contain up to 256 colors (8-bit depth).

Many of the commands in PaintShop Pro for applying effects and correcting images work on 16 million-color images only. Therefore, it’s best to create most images in 16 million colors. When you have finished working on the image, you can decrease its color depth and save it in another format.

When you create a new image in PaintShop Pro, you can specify its dimensions, resolution, and type. The options available depend on the type of graphic you want to create. If you’re uncertain as to what type of graphic you need for your project, or which settings to choose, review the information in the following procedure. For more information about creating Art Media graphics, see “Painting and drawing with the Art Media tools” on page 371.

To create an image from a blank canvas

Edit tab

   The New Image dialog box appears with the Blank Canvas page displayed.

2. To choose a preset, click one of the category buttons on the left, and choose a preset. To adjust the preset, or to define a custom image, follow the steps below.

3. In the Image Dimensions group box, type or set values for the following controls:
   - Units — specifies the unit of measure
• **Width** — specifies the width of the new image
• **Height** — specifies the height of the new image
• **Resolution** — specifies number of pixels contained in the chosen unit of measure

If you want to choose preset dimensions, choose an option from the **Load Preset** drop-list.

4 In the **Image Characteristics** group box, choose one of the following options:
• **Raster Background** — suitable for most graphics and painting tasks
• **Vector Background** — suitable for vector graphics
• **Art Media Background** — lets you use the Art Media tools

5 Choose an option from the **Color depth** drop list.

If you chose the **Raster Background** option, you can choose a background color for the image by clicking the color box and choosing a color from the Material Properties palette. To choose a transparent background (for 8-bit or 16-bit images only), mark the **Transparent** check box.

If you chose the **Art Media Background** option, you can choose a canvas texture from the **Select the canvas texture** drop-list. If you want to choose a color for the canvas, mark the **Enable fill color** check box, click the color box, and choose a color from the Color dialog box.

6 Click OK.

The **Memory Required** field displays the amount of memory required for the image. Your computer’s available memory should be at least two to three times the value displayed in the **Memory Required** field. To reduce the memory requirement, you can reduce the resolution or the dimensions of the image.

For more information on choosing colors or materials, see “Using the Materials palette” on page 253.

**Creating images from existing images**

You can create an image by copying aspects of an existing image. When you use an existing image as the source of your new image, you can copy the entire image (duplicate) or an individual layer. You can also create an image from any graphic data copied to the Clipboard from PaintShop Pro.

**To duplicate an image**

**Edit tab**

1 Open the image you want to duplicate.
2 Choose **Window ▶ Duplicate**.
   A new window containing a copy of the image appears in the workspace.

**To create an image from a layer**

**Edit tab**

1 On the Layers palette, click the layer you want to copy.
2 Choose **Edit ▶ Copy**, and click one of the following:
   • **Copy**
   • **Cut**
   The current layer is placed on the Clipboard.
3 Choose **Edit ▶ Paste As New Image**.
   A new window containing the layer appears in the workspace.

**To create a new image from a layered image**

**Edit tab**

1 On the Layers palette, click the layer you want to copy.
2 Choose **Edit ▶ Copy Special ▶ Copy Merged**.
All layers are copied to the Clipboard.

3 Choose **Edit ▶ Paste As New Image**.

A new image window appears in the workspace. The new image contains all layers merged into one raster layer.

**To create an image from the Clipboard contents**

*Edit tab*

1 Copy a selection or layer of an image, or an item from another program.

2 Choose **Edit ▶ Paste As New Image**.

The Clipboard contents are pasted as a new image.

If the **Paste As New Image** command is grayed out, then the data you have copied to the Clipboard cannot be pasted as a PaintShop Pro image.

A dialog box may appear and request additional information, such as the width and height of the new image window. You can change your preferences so that PaintShop Pro does not prompt you for size and options when you paste data. For more information about setting file format preferences, see “Setting file format preferences” on page 411.

**Viewing images and image information**

When you open an image in PaintShop Pro, it appears in an image window. The title bar of the image window displays the image filename and the level of magnification applied to the image. An asterisk after the filename indicates that the image has been modified and that the changes have not been saved.

You can view basic image information, such as the height and width of an image (in pixels) and its color depth. You can also view detailed information for the image, such as its resolution, color depth, layers and alpha channels, and EXIF data. You can also view the number of unique colors in an image.

You can also view and edit image information in the Info palette that you can access from the Manage tab. For more information, see “Displaying and editing photo information” on page 90.

The EXIF Information tab of the Image Information dialog box lets you view EXIF data for digital camera photos. When you take a photo with a digital camera, the camera attaches information to the image, such as the date and time that it was captured, the exposure, and the flash settings. When you load a photo from a digital camera into PaintShop Pro, you can view this extra information.

You can expand the workspace to preview an image without the menus, toolbars, or palettes visible.

The Status bar, which is located at the bottom of the application window, displays the cursor position, height and width in pixels, and color depth for the current image.

When the Organizer palette is open, you can use Quick Preview to quickly view larger versions of the thumbnails.

If you have two monitors, you can use **Dual Monitor** to open the Manage tab on one monitor and the Edit tab on a second monitor.

**To view digital photo information**

*Edit tab*

1 Open an image.

2 Choose **Image ▶ Image information**.

- Click the **Image Information** tab to view the filename, file format, image dimensions, resolution, color depth, modification status, number of layers and alpha channels, and the amount of RAM and disk space used for the image. This page also displays the image’s selections, masks, alpha channels, and Undo storage.

- Click the **Creator Information** tab to view or edit the image’s title, artist’s name, copyright, description, date of creation, and date of modification.

- Click the **Watermark Information** tab to view and add information about Digimarc watermarking.
• Click the **EXIF Information** tab to view information for images taken with digital cameras. In the **Section** group box, mark the check boxes for the information you want to display: **Input Device**, **Artist**, **Date**, **Image**, **Shot Conditions**, **GPS**, or **Makernote**. Some items are editable (as denoted by an asterisk). To add customized text for an editable item, click in the **Value** column, and then type your custom information.

• Click the **Edit History** tab to view a log file of the edits made to the image. Click **Save Edit History** to export the log file to a .log or .txt file.

You can also add IPTC data to the image information by using the Advanced Creator Information dialog box. This can be useful for photojournalists, for example, who may need to record IPTC data about when and where a photo was shot, and how urgently the photo needs to be reviewed. To access this dialog box, click the **Creator Information** tab, and then click **Advanced**.

**To view image color information**

**Edit tab**

• Choose **Image** ➔ **Count Image Colors** to display the number of unique colors in the image.

**To view layer color information**

**Edit tab**

• Choose **Layers** ➔ **Count Layer Colors** to display the number of unique colors in the current layer.

**To view an image on the full screen**

**Edit tab**

• Choose **View** ➔ **Full Screen Preview**.

The workspace disappears, and the image appears at its current magnification.

To return to the PaintShop Pro workspace, press any key.

**To view Organizer palette thumbnails with Quick Preview**

1. In the **Organizer** palette, click a thumbnail.
2. Press the space bar to display a large preview of the selected thumbnail.

**To activate or deactivate Dual Monitor mode**

• Choose **View** ➔ **Dual Monitor**.

A check mark displays when **Dual Monitor** mode is active.

**Exporting the image editing history to a text file**

You can track changes that you make to an image by exporting the list of changes (edit history) to a text file. The edit history can be used for reference if you want to recreate a look or create a tutorial. It can also be used as an official record of edits made to an image.

There are two ways to export the editing log for an image file:

• In the **History** palette, you can save a log file of the current editing session.
• In the **Current Image Information** dialog box, you can view and export the Edit history for an image file.

**To export an editing session from the History palette**

1. In the **History** palette, click the **Save session history to text file** button.
2. In the **Save As** dialog box, choose a destination, type a filename for the .log file and click **Save**.
To export an image edit history to a log file

1. Click **Image ➤ Image Information**, and click the **Edit History** tab.
   The edit log history displays.

2. Click **Save Edit History**.

3. In the **Save As** dialog box, choose a destination, type a filename for the .log file and click **Save**.

**Using Screenshot**

Screenshot is a tool within PaintShop Pro that lets you capture screen content (images known as screen captures, screen grabs, or screenshots). After you capture a screenshot, you can edit it with any of the PaintShop Pro tools. For example, you can annotate with drawing tools or the Text tool, and add preset shapes, such as arrows. You can then, share the screenshots through email or add them to documents such as reports, training guides, presentations, and Web pages.

To initiate the capture process, you must choose settings and then press a hot key, right-click, or set a delay timer. You can define your own hot key. You can also specify the delay period, so that you can set up elements such as menu lists or flyouts before capturing.

You can specify the method of capture. For example you can capture by area, or specify full screen, window, or object. You can also use Smart Capture, a flexible mode that auto-detects screen elements or lets you drag to set the capture area. For example, you can capture the active window, a menu, a button, an image, or a part of an image, or you can drag to capture a specific area. You can also use presets to capture specific screen dimensions.

You can also capture a multiple images and set destination and file format options.

If you frequently capture screens, you can add Screenshot activation and Screenshot Setup icons to your toolbar. You can also create presets for screenshots.

To specify the area that you want to capture

**Edit tab**

1. Choose **File ➤ Screenshot ➤ Setup**.

2. In the **Method** drop-list, choose one of the following options:
   - **Smart Capture** — captures an object by auto-detecting screen elements (buttons, menus, window areas) as you hover over the elements with the pointer
   - **Area** — captures the area of the screen that you select
   - **Full screen** — captures the entire screen
   - **Client Window** — captures the contents of the active program
   - **Window** — captures the active window
   - **Object** — captures an object within the program that you select, such as a menu bar, toolbar, icon, or document window
   - **Preset** — captures preset area size. When you choose this option, you can select a category from the **Category** drop-list, and select the preset size you want from the **Preset** drop-list.

3. If you want to modify other settings, click the **Settings** button and navigate the pages to adjust the settings you want.

4. Click **Start**.

   For **Preset** captures, the **Category** list is based on the categories available in the **New Image** dialog box.
   Hot keys and right-clicking cannot be used to capture user-defined areas.

To specify screenshot activation method

**Edit tab**

1. Choose **File ➤ Screenshot ➤ Setup**.
2 Click the **Settings** button.

3 On the **Activate Capture** page (click the first dot along the bottom of the dialog box), choose one of the following options:
   - **Hot key** — lets you use a keyboard shortcut to capture screen contents. Choose a key or key combination from the drop-list.
   - **Right-Click** — lets you capture screen contents by right-clicking to activate the capture, and clicking the selected area.
   - **Print Screen key** — lets you capture screen contents by pressing the **Print Screen** key.
   - **Delay before capture (1-60 sec.)** — lets you capture screen contents after a specified delay. Type a number in the seconds box.

To set screenshot options

**Edit tab**

1 Choose **File** ▶ **Screenshot** ▶ **Setup**.

2 Click the **Settings** button.

3 On the **Options** page (click the second dot along the bottom of the dialog box), set any of the following options:
   - **Include Cursor** — lets you include the pointer in the capture.
   - **Multiple Captures** — lets you capture multiple images. Each capture is added as a new image in PaintShop Pro.
   - **Hide PaintShop** — automatically minimizes PaintShop Pro when the **Screenshot** tool is active. Unmark this option if you want to capture PaintShop Pro.
   - **Highlight Color** — lets you change the color of the capture area preview.
   - **Add capture shortcut to toolbar** — add a quick access icon to the toolbar (Screenshot and Screenshot Setup).

4 Click **Start** to apply the settings.

   ![Tip]
   If you marked the **Multiple captures** check box, press the hot key, or right-click, for each capture. When you are finished, click the PaintShop Pro icon on the Windows task bar. The images appear in the workspace.

To set destination and format options for screenshots

**Edit tab**

1 Choose **File** ▶ **Screenshot** ▶ **Setup**.

2 Click the **Settings** button.

3 On the **Destination** page (click the fourth dot along the bottom of the dialog box), set the following options:
   - **Open in PaintShop** — adds the screenshot to PaintShop Pro as a new image.
   - **Save to** — lets you choose a save location for screenshots.
   - **Format** — lets you set a file format if you have marked the **Save to** option.
   - **Clipboard** — saves the screenshot to the Windows Clipboard.

To create a preset for screenshots

**Edit tab**

1 Choose **File** ▶ **Screenshot** ▶ **Setup**.

2 Click the **Settings** button.

3 On the **Presets** page (click the third dot along the bottom of the dialog box), choose a category from the **Category** drop-list.

4 In the **Units** drop-list, choose **Pixels** or **Ratio**.

5 Type values in the **Width** and **Height** boxes.

6 Click **Add**, and type a preset name, and click **OK**.
You can delete a preset by selecting the preset name on the Presets page and clicking **Remove**.

For general information about preset **Options**, see “Using and creating presets” on page 437.

**Zooming and panning**

By default, images that you open in PaintShop Pro appear at a magnification level that allows the full image to appear in the workspace. You can zoom in to get a closer look at image detail or zoom out to view a larger portion of the image. You can also magnify a specific area of an image.

You can view image areas that fall outside the current image window. For example, when you are working at a high magnification level, you can pan or jump to a different image area without having to adjust the magnification level. When an image is too large to fit within its window, scroll bars appear on the bottom and right sides of the image.

You can use the **Zoom** tool to magnify your image (left) or you can use the **Magnifier command** to view a specific area without changing the magnification of the image (right).

**To zoom**

**Edit tab**

1. On the Tools toolbar, choose the **Zoom tool**.
2. Click to magnify the area, or right-click to reduce the area.

The magnification changes to a preset percentage that appears in the **Zoom (%)** control on the Tool Options palette.

**You can also**

- **Magnify the image by a specified percentage**
  - On the Tool Options palette, type a value in the **Zoom (%)** control.

- **View the image at 100%**
  - Choose View ➤ **Zoom to 100%**, or click the **Zoom to 100%** button on the Tool Options palette.

By default, when you zoom in or out, the image window automatically resizes to fit the image.
You can also change the magnification when the **Zoom** tool is active by using the scroll-wheel if one is included on your mouse or stylus.

You can also change the magnification of an image by choosing **View > Zoom in** and **View > Zoom out**.

**To magnify an image area**

**Edit tab**

1. Choose **View > Magnifier** to place the cursor in magnifier mode.
2. Position the cursor over the image area that you want to magnify.
   - The area under the cursor is displayed at 500%.

To turn off the magnifier mode, choose **View > Magnifier** again.

**To pan around an image**

**Edit tab**

1. On the Tools toolbar, choose the **Pan** tool ⚡.
2. Drag within the image.

You can also

- **Pan while using another tool**
  - Hold down the **Spacebar**, and drag with the other tool.

- **Pan around an image by using the Overview palette**
  - Drag the preview rectangle on the Overview palette to a new position.

**To fit the window to the image**

**Edit tab**

- Choose **Window > Fit to Image**.

You can also fit the window to the image by clicking the **Fit Window to Image** button on the Tool Options palette when the **Pan** tool ⚡ or **Zoom** tool ⧫ is active.

**Cutting, copying, and pasting**

You can select an entire image, part of an image, or an entire layer, and cut it or copy it to the Clipboard. You can then paste the Clipboard content into the same image or another image, or into another application, such as an e-mail program or word processor. The basic commands for cutting, copying, and pasting are as follows:

- **Cut** — removes the selected content to the Clipboard and replaces it with the image background color or transparency
- **Copy** — copies the selected content to the Clipboard
- **Copy Merged** — copies a flattened (merged) version of all the layers in a selection to the Clipboard
- **Copy Special** — provides three options for optimizing copied content for subsequent pasting into another application
- **Paste** — pastes cut or copied content from the Clipboard into the same image or another image
- **Clear** — deletes the selected content

---

68 | Corel PaintShop Pro User Guide
• **Empty Clipboard** — erases the data from the Clipboard. Placing data on the Clipboard for cutting and pasting can slow your computer’s performance. Emptying the Clipboard can restore the performance speed of your computer. Once applied, this command cannot be undone.

You can cut or copy a selection, layer, or vector object. You can paste the selected content as a new image, a new layer, or a selection.

You can also copy a PaintShop Pro image into other applications, such as word-processing or desktop-publishing applications. For information about exporting PaintShop Pro files to other formats, see “Saving images” on page 55.

**Why does the pasted image look out of proportion?**

When you paste data into another image, the data keeps its original pixel dimensions. If one image is much larger or smaller than the other, the pasted content may look out of proportion. After you paste the selection, you can use the Pick tool to scale the pasted content. For more information about using the Pick tool to correct perspective, see “Scaling and transforming photos using the Pick tool” on page 183.

You can also resize the two images to make them a similar size before copying and pasting. For more information, see “Resizing images” on page 150.

**To cut a selection, layer, or vector object**

**Edit tab**

1. Select the area, layer, or object you want to cut.
2. Choose **Edit → Cut**.

You can also cut by pressing **Ctrl + X**.

**To copy a selection, layer, or vector object**

**Edit tab**

1. Select the area, layer, or object you want to copy.
2. Do one of the following:
   - To copy only the selection or the active layer, choose **Edit → Copy**.
   - To copy all layers of the selected area, choose **Edit → Copy Special → Copy Merged**.

You can also press **Ctrl + C** to copy the active layer, or **Ctrl + Shift + C** to copy merged layers.

**To paste content as a new image**

**Edit tab**

- Choose **Edit → Paste As New Image**.

You can also paste as a new image by pressing **Ctrl + Shift + V**.

**To paste content as a new layer**

**Edit tab**

1. Select the image in which you want to paste the selection.
2. Choose **Edit → Paste As New Layer**.

You can also paste a new layer by pressing **Ctrl + V**, or **Ctrl + L**.
To paste content as a selection

Edit tab

1. Select the image in which you want to paste a selection.
2. On the Layers palette, click the layer in which you want to paste the selection.
3. From the Edit menu, choose one of the following commands:
   - Paste As New Selection — pastes the contents of the Clipboard as a floating selection above the current layer. If the image already contains a floating selection, that selection is defloated.
   - Paste As Transparent Selection — lets you remove a specific color from the selection you are pasting. Any pixels in the Clipboard data that exactly match the current background color become transparent. The Clipboard contents are then pasted as a floating selection above the current layer.
   - Paste Into Selection — resizes the Clipboard contents and pastes them into the current selection.

Select the background color on the Materials palette before you paste.

To paste a vector object, choose Edit  Paste As New Vector Selection.

To copy a multilayer image to the Clipboard

Edit tab

• Choose Edit  Copy Special  Copy Merged.

To empty the Clipboard

Edit tab

• Choose Edit  Empty Clipboard.

Copying images into other applications

The proliferation of high-resolution digital cameras and scanners has resulted in images with very large file sizes. When copied to the Windows Clipboard, these images consume far more memory than what is required after they are pasted into another application. You can use the Copy Special commands to more efficiently place image data on the Clipboard for pasting into office productivity software, such as word-processing, presentation, and e-mail applications.

To copy images for use in other applications

Edit tab

1. Choose Edit  Copy Special.
2. In the Copy Special submenu, choose one of the following commands:
   - Copy for Professional Printing — copies the current image to the Clipboard at 300 dpi
   - Copy for Desktop Printing — copies the current image to the Clipboard at 200 dpi
   - Copy for Screen or e-mail — copies the current image to the Clipboard at 96 dpi

   Note: These three submenu commands all automatically flatten the current image to a single layer and convert the image depth to 8-bit/channel RGB.
3. Switch to the application into which you want to paste the image, and press Ctrl + V.

If you want a wider range of resizing and file format options for images to be used in other applications, choose File  Save for Office. For more information, see “To save images for office applications” on page 57.
Undoing and redoing actions

You can undo single or multiple actions as you edit an image. For example, you can undo brushstrokes, color adjustments, or effects that you have applied to the image. You can also redo single or multiple actions to reapply commands that you have undone.

You can also revert to the last saved version of the image.

The History palette lets you undo and redo actions selectively, regardless of their sequence.

*Important! The Undo control does not undo the following actions: renaming files, saving files, opening and closing files, emptying the Clipboard, making changes that are program-wide and not specific to the current image (such as changes to color settings and preferences), or using commands that do not change the image pixels (such as zooming or scrolling).*

Undo and redo controls on the History palette

You can undo multiple actions, as well as specific actions, by using the History palette. The History palette lists all actions performed on the active image. The most recent action is at the top of the list, and the first action performed is at the bottom of the list. Unlike the Undo and Redo commands, the History palette lets you undo or redo actions selectively, regardless of their sequence.

By default, the History palette lists the 250 most recently executed commands on the active image. You can set the Undo preferences and specify a higher or lower number of commands.

The table below lists the Undo/Redo controls on the History palette.

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo to Here</td>
<td>Undoes the selected action and all subsequent actions. Clicking this button is equivalent to clicking an item’s eye icon. The undone actions are denoted by a blank box.</td>
</tr>
<tr>
<td>Redo to Here</td>
<td>Redoes the selected action and all undone actions preceding it. Clicking this button is equivalent to clicking an item’s yellow-X eye icon.</td>
</tr>
<tr>
<td>Undo Selected</td>
<td>Undoes a selected action. Clicking this button is equivalent to holding down Ctrl and clicking an item’s yellow-X eye icon. Note: Undoing a selected action may interfere with subsequent actions and produce unintended results.</td>
</tr>
<tr>
<td>Redo Selected</td>
<td>Redoes a selected action. Clicking this button is equivalent to holding down Ctrl and clicking an item’s red-X eye icon.</td>
</tr>
<tr>
<td>Clear Selectively Undone Commands</td>
<td>Converts all selectively undone actions into commands that can no longer be undone or redone. You are prompted to confirm the performance of this action.</td>
</tr>
<tr>
<td>Show Non-Undoable Commands</td>
<td>Shows or hides the non-undoable commands. When shown, non-undoable items are grayed out.</td>
</tr>
<tr>
<td>Empty Command History</td>
<td>Converts all History palette items into non-undoable commands. You are prompted to confirm the performance of this action.</td>
</tr>
</tbody>
</table>

For more information about the History palette, “To undo and redo actions by using the History palette” on page 72.
To undo an action
Edit tab
• Choose Edit   Undo.

If you want to undo multiple actions, repeat the Edit   Undo command.

The Undo command undoes multiple actions in the order in which they were performed. To undo actions selectively, you can use the History palette.

If the action cannot be undone, the Undo command is unavailable.

You can also undo an action by clicking the Undo button  on the Standard toolbar, or by pressing Ctrl + Z.

To redo an action
Edit tab
• Choose Edit   Redo.

The Redo command redoes multiple actions in the order in which they were undone. To redo actions selectively, you can use the History palette.

Only actions that have been undone can be redone.

You can also redo an action by clicking the Redo button  on the Standard toolbar, or by pressing Ctrl + Alt + Z.

To revert to the last saved version of an image
Edit tab
• Choose File   Revert.

To undo and redo actions by using the History palette
Edit tab
• Choose an action on the History palette, and then perform one of the following actions.

To
 Undo an action
 Do the following

Click the Undo/Redo button  for the selected action, or click the Undo to Here button  . The undone actions are denoted by a blank box  .

Redo an undone action
 Do the following

Click the Undo/Redo button for the selected action, or click the Redo to Here button  . The selected action and all preceding actions are redone and no longer appear as blank icons. Note that selectively undone actions (denoted with a gray X) that precede the action you clicked are not redone. These actions can be redone only with the Redo Selected command.
Selectively undo an action

Hold down Ctrl, and click the Undo/Redo button for the selected action, or click the Undo Selected button. Selectively undone actions are denoted by a gray X.

Redo a selectively undone action

Hold down Ctrl, and click the Undo/Redo button for the selected action, or click the Redo Selected button.

To set Undo preferences

Edit tab

1 Choose File ➤ Preferences ➤ General Program Preferences.

2 From the left pane, click Undo.

3 Make sure that the Enable the undo system check box is marked.

Note: This check box must be marked if you want to undo actions in images that are currently open. If the check box is not marked, you cannot undo any actions in an open image after you click OK in the Preferences dialog box.

4 Mark or unmark the following check boxes:

- **Limit undo/redo disk usage to n MBytes of storage per open image** — lets you specify the amount of hard disk storage available for Undo/Redo operations by typing or setting a value in the control. The storage space needed depends on the current image size and the type of operations you’re performing. If you have a large amount of unused disk space, you don’t need to mark this option.

- **Limit undo/redo to n steps per open image** — lets you modify the default value of 250 steps. Decrease the value in the control if your unused disk space is less than 500 megabytes.

- **Enable Fast Redo** — lets you set the Redo command to work at optimal speed. Do not mark this option if you want the Undo command to work at optimal speed.

5 Type or set a value in the Non-undoable steps in the History Palette control.

This value specifies the number of non-undoable steps (steps that cannot be undone or redone) that are retained after the Undo/Redo limit has been reached. The default value is 10.

Non-undoable steps cannot be undone or redone. However, they can be reapplied to the current image or to other open images, saved to a Quickscript or to a regular PspScript file, or copied to the Clipboard.

Repeating commands

The Repeat command lets you reapply the previously applied effect or correction without having to re-access the corresponding dialog box.

The last command that can be repeated is always displayed in the Edit menu. If the previous command cannot be repeated, the Repeat command is unavailable.

To repeat a command

Edit tab

* Choose Edit ➤ Repeat.

You can repeat multiple commands by recording a script and running it on each image. For information on using scripts, see “Scripting basics” on page 429.

You can also repeat a command by holding down Shift while selecting any toolbar button or menu item. The last used settings are applied with the repeated command.
Deleting images
You can delete image files by using the Organizer palette.

To delete an image
Edit tab
• Right-click a thumbnail in the Organizer palette, and choose Delete from the context menu.

Files supported by PaintShop Pro
PaintShop Pro supports the file formats listed in the following table.

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
<th>Support</th>
</tr>
</thead>
<tbody>
<tr>
<td>3FR</td>
<td>Hasselblad RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>AI</td>
<td>Adobe Illustrator</td>
<td>Read/Write</td>
</tr>
<tr>
<td>ARW</td>
<td>Sony RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>BMP</td>
<td>Windows Bitmap</td>
<td>Read/Write</td>
</tr>
<tr>
<td>CAL</td>
<td>CALS Raster</td>
<td>Read/Write</td>
</tr>
<tr>
<td>CGM</td>
<td>Computer Graphics Metafile</td>
<td>Read only</td>
</tr>
<tr>
<td>CLP</td>
<td>Windows Clipboard</td>
<td>Read/Write</td>
</tr>
<tr>
<td>CR2</td>
<td>Canon RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>CRW</td>
<td>Canon RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>CT</td>
<td>PaintShop Pro graphics</td>
<td>Read/Write</td>
</tr>
<tr>
<td>CUT</td>
<td>Dr. Halo</td>
<td>Read/Write</td>
</tr>
<tr>
<td>DCR</td>
<td>Kodak RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>DCX</td>
<td>Zsoft Multipage Paintbrush</td>
<td>Read only</td>
</tr>
<tr>
<td>DIB</td>
<td>Windows DIB</td>
<td>Read/Write</td>
</tr>
<tr>
<td>DNG</td>
<td>Adobe Digital Negative</td>
<td>Read only</td>
</tr>
<tr>
<td>EMF</td>
<td>Windows Enhanced Metafile</td>
<td>Read/Write</td>
</tr>
<tr>
<td>Format</td>
<td>Description</td>
<td>Read/Write</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
<td>------------</td>
</tr>
<tr>
<td>EPS</td>
<td>Encapsulated PostScript</td>
<td>Read/Write</td>
</tr>
<tr>
<td>ERF</td>
<td>Epson RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>GEM</td>
<td>Ventura/GEM Drawing</td>
<td>Read only</td>
</tr>
<tr>
<td>GIF</td>
<td>Compuserve Graphics Interchange</td>
<td>Read/Write</td>
</tr>
<tr>
<td>HDP</td>
<td>HD Photo format</td>
<td>Read/Write</td>
</tr>
<tr>
<td>HEIC</td>
<td>High Efficiency Image Format (HEIF). HEIC is the extension used for the container file.</td>
<td>Read only</td>
</tr>
<tr>
<td>IFF</td>
<td>Amiga</td>
<td>Read/Write</td>
</tr>
<tr>
<td>IMG</td>
<td>GEM Paint</td>
<td>Read/Write</td>
</tr>
<tr>
<td>J2C</td>
<td>JPEG 2000</td>
<td>Read/Write</td>
</tr>
<tr>
<td>J2K</td>
<td>JPEG 2000</td>
<td>Read/Write</td>
</tr>
<tr>
<td>JIF</td>
<td>JPEG</td>
<td>Read/Write</td>
</tr>
<tr>
<td>JP2</td>
<td>JPEG 2000</td>
<td>Read/Write</td>
</tr>
<tr>
<td>JPG</td>
<td>JPEG – JFIF Compliant</td>
<td>Read/Write</td>
</tr>
<tr>
<td>JPS</td>
<td>Stereo JPEG</td>
<td>Read only</td>
</tr>
<tr>
<td>K25</td>
<td>Kodak Digital Camera File</td>
<td>Read only</td>
</tr>
<tr>
<td>KDC</td>
<td>Kodak Digital Camera File</td>
<td>Read only</td>
</tr>
<tr>
<td>LBM</td>
<td>Deluxe Paint</td>
<td>Read only</td>
</tr>
<tr>
<td>MAC</td>
<td>MacPaint</td>
<td>Read/Write</td>
</tr>
<tr>
<td>MEF</td>
<td>RAW format</td>
<td>Read only</td>
</tr>
<tr>
<td>MOS</td>
<td>Leaf RAW Image</td>
<td>Read only</td>
</tr>
<tr>
<td>MRW</td>
<td>Minolta RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>MSP</td>
<td>Microsoft Paint</td>
<td>Read/Write</td>
</tr>
<tr>
<td>NEF</td>
<td>Nikon RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>Format</td>
<td>Description</td>
<td>Readability</td>
</tr>
<tr>
<td>----------</td>
<td>--------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>NRW</td>
<td>Nikon RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>ORF</td>
<td>Olympus RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>PBM</td>
<td>Portable Bitmap</td>
<td>Read/Write</td>
</tr>
<tr>
<td>PCT (PICT)</td>
<td>Macintosh PICT</td>
<td>Read/Write</td>
</tr>
<tr>
<td>PCX</td>
<td>Zsoft Paintbrush</td>
<td>Read/Write</td>
</tr>
<tr>
<td>PDF</td>
<td>Adobe Portable Document File</td>
<td>Read only</td>
</tr>
<tr>
<td>PEF</td>
<td>Pentax RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>PGM</td>
<td>Portable Graymap</td>
<td>Read/Write</td>
</tr>
<tr>
<td>PIC (Lotus)</td>
<td>Lotus PIC</td>
<td>Read only</td>
</tr>
<tr>
<td>PIC (PC Paint)</td>
<td>PC Paint</td>
<td>Read/Write</td>
</tr>
<tr>
<td>PNG</td>
<td>Portable Network Graphics</td>
<td>Read/Write</td>
</tr>
<tr>
<td>PNS</td>
<td>Stereo PNG</td>
<td>Read only</td>
</tr>
<tr>
<td>PPM</td>
<td>Portable Pixelmap</td>
<td>Read/Write</td>
</tr>
<tr>
<td>PS</td>
<td>PostScript</td>
<td>Read only</td>
</tr>
<tr>
<td>PSD</td>
<td>Photoshop</td>
<td>Read/Write</td>
</tr>
<tr>
<td>Psplimage</td>
<td>PaintShop Pro Image</td>
<td>Read/Write</td>
</tr>
<tr>
<td>PSP</td>
<td>Animation Shop</td>
<td>Read</td>
</tr>
<tr>
<td>RAF</td>
<td>Fuji RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>RAS</td>
<td>Sun Raster Image</td>
<td>Read/Write</td>
</tr>
<tr>
<td>RAW</td>
<td>RAW Graphics File Format</td>
<td>Read/Write</td>
</tr>
<tr>
<td>RIFF</td>
<td>Corel Painter</td>
<td>Read/Write</td>
</tr>
<tr>
<td>RLE</td>
<td>Windows or CompuServe RLE</td>
<td>Read/Write</td>
</tr>
<tr>
<td>RW2</td>
<td>LUMIX RAW</td>
<td>Read only</td>
</tr>
<tr>
<td>SCT</td>
<td>SciTex Continuous Tone</td>
<td>Read/Write</td>
</tr>
</tbody>
</table>

### How to open HEIC files from an iPhone or other device

PaintShop Pro lets you open and edit HEIC image files that you’ve captured on your iPhone or other device. HEIC files are container files for the High Efficiency Image Format (HEIF). HEIF is based on HEVC encoding and compression. HEIF files tend to be much smaller and have better image quality than a corresponding JPEG file. The container file consists of one or more image files, as well as any sounds and image data. For example, if you captured a Live Photo with your iPhone, the HEIC file would contain all the components for the Live Photo.

When you open an HEIC file in PaintShop Pro, only the key image for the container file is available.

If you aren’t using a cloud service, then an easy way to transfer HEIC files (or any image files) from the your phone or tablet to your computer is by using a cable in the same way you would connect and download images from any other camera. The procedure below is a simple manual way of transferring photos.

**Note:** Your phone or tablet settings determine what file format is used to capture, store, and export image files. For more information, refer to the user guide for your device.

#### To transfer files from your iPhone to your computer

1. Connect your phone to your computer using a compatible USB cable (such as a Lightning cable).
2. In Windows File Explorer, navigate to your phone, and choose **Apple iPhone ➤ Internal Storage ➤ DCIM**. Depending on your device settings, you might have subfolders.
3. Copy the images that you want from your phone to your computer.
Reviewing, organizing, and finding photos

The Manage tab lets you access a photo management features that let you preview, organize, and streamline your photo-editing workflow.

This section presents the following topics:
- "Using the Manage tab" (page 79)
- "Browsing folders for photos" (page 82)
- "Finding images on your computer" (page 83)
- "Working with saved searches" (page 84)
- "Adding keyword tags to images" (page 85)
- "Viewing photos by tags" (page 86)
- "Using the calendar to find images" (page 86)
- "Working with thumbnails in the Manage tab" (page 86)
- "Capturing and applying edits to multiple photos" (page 89)
- "Displaying and editing photo information" (page 90)
- "Using Quick Review to review photos" (page 92)
- "Working with trays" (page 92)

Using the Manage tab

When you click the Manage tab, you’ll find the following four components: Navigation palette, Preview area, Organizer palette, and the Info palette. For information about each of these palettes, see “The Manage tab” on page 26.
Depending on your specific needs, you can customize Manage by choosing the Preview or Thumbnail mode, resizing, moving, or hiding the palettes, and selecting display and file preferences. For more information, see “Setting Manage tab preferences” on page 409.
To switch between Preview and Thumbnail modes
Manage tab
• In the upper-right corner, click one of the following buttons:
  • **Preview mode** — displays a large preview area of a single image
  • **Thumbnail mode** — expands and locks the Organizer palette content in the preview area

To resize the Manage tab palettes
Manage tab
1. Position the pointer over the edge of the palette that you want to resize until the pointer changes to a two-way arrow.
2. Drag to enlarge or shrink the panel.

When you customize the Manage tab, the program remembers the latest layout settings and automatically saves them for your next session.

To hide or show the Navigation palette and Info palette
Manage tab
• In the Organizer palette, click any of the following buttons on the Organizer toolbar:
  • **Show/Hide Navigation** — shows or hides the Navigation palette
  • **Image Information** — shows or hides the Info palette
A convenient way to minimize the Organizer palette (or any palette) is to click the Auto Hide button on the palette title bar. For more information, see “To roll up a toolbar or palette” on page 40.

**Browsing folders for photos**

You can browse for photos on your computer by using the Collections and Computer tabs in the Navigation palette:

- **The Collections tab** is your library of virtual and physical folders. It offers an easy way to find and search for favorite photos because files that are accessed from the Collections page are imported to the catalog (a type of indexing). This means you can take full advantage of file management features such as tags, captions, and ratings when you want to find and sort photos. You can add or remove folders from the Collections page at any time.

- **The Computer tab** displays a complete list of all folders on your hard drive and desktop. Files that you access from the Computer tab are not imported to the catalog, so you can’t find or sort photos by using the file management features such as tags, captions, and ratings. Why use the Computer tab? It is a quick way to access files from a location that you don’t want to import to the catalog or don’t have time to import at the moment. For example, if you want to access an image in a folder that has a large number of files that you rarely use or if you want to access files in a temporary folder, the Computer tab is a good option.

When you select a folder in the Navigation palette, the photos in this folder appear as thumbnails in the Organizer palette.

For more information, see “Getting photos into PaintShop Pro” on page 53.

You can specify formats and folders to exclude from the cataloging process. For more information, see “Setting Manage tab preferences” on page 409.

**To view the photos in a folder**

Manage tab

1. In the Navigation palette, click one of the following tabs:
   - **Collections** — displays a custom list of cataloged folders and a list of virtual collections
   - **Computer** — displays a list of all folders and devices on your computer

2. Double-click a folder to display the subfolders it contains.

3. Click the folder that contains the photos that you want to view.
   - The thumbnails of all supported photo files in the selected folder appear in the Organizer palette.

   You can also hide the list of subfolders in a folder by clicking the minus sign next to its name.

**To add a folder to the Collections page**

Manage tab

1. In the Navigation palette, click the Collections tab.

2. In the Folders list, click the Browse More Folders button.
   - The Browse For Folder dialog box appears.

3. Navigate to the folder containing the images you want to add, and then click OK.
   - **Note:** All subfolders in the selected folder are cataloged, so select your folder carefully. Adding your profile folder or a root folder on your computer is not recommended—it can initiate a large amount of cataloging that you might not require.
   - The folder is added to the Folders list.

   You can also create a folder on your computer by clicking the Make New Folder button in the Browse for Folder dialog box.
To remove a folder from the Collections page
Manage tab
1 In the Navigation palette, click the Collections tab.
2 In the Folders list, right-click the folder that you want to remove.
3 Choose Remove From List.
   Images within the folder retain their file management data (tags, ratings, captions), but removing the folder from the Collections page removes the folder from the catalog, so the photos aren’t searchable by their data.

To view all cataloged photos
Manage tab
1 In the Navigation palette, click the Collections tab.
2 In the Smart Collections list, click the All Photos button.

Finding images on your computer
When you import photos into PaintShop Pro by navigating to them from the Navigation palette, they are cataloged automatically. Cataloged images can be searched for quickly (real-time filtering) and easily from the Search box. You can do a simple text-based search, use more advanced search options, or use a calendar to search for images associated with a particular date or date range.

When you perform an advanced search, you can save the search rules and results as a Smart Collection.

To search for images quickly
Manage tab
• In the Navigation palette, type a search term in the Search box.

The search results appear in the Organizer palette.
   Note: Search terms may be filenames (including extensions), names of folders in which images reside (including letters designating drives), tags, caption text, or image metadata (EXIF or IPTC data).

For more information about the tags that you can assign to images, see “Adding keyword tags to images” on page 85. For more information about caption text and image metadata, see “Displaying and editing photo information” on page 90.

To do an advanced search
Manage tab
1 In the Navigation palette, click the Collections tab.
2 Double-click Smart Collections to open the list, and click Add Smart Collection.
   The Smart Collection dialog box appears.
3 In the Find photos that match drop-list, select one of the following options:
   • All — searches for images that match all of the specified rules
   • Any — searches for images that match any of the specified rules
4 From the first drop-list on the left, select a search option.
5 From the next drop-list, select an option to refine the search further.
   The options that appear in the drop-list depend on the search option that you chose in the previous drop-list.
6 In the text field, type or choose a search term.
Note: The search term you type must correspond to the search option that you choose in the first drop-list of the search rule. For example, if you choose **Image date**, modify the month, date, and year displayed, or press the down arrow button and click a date on the calendar that appears. If you choose **Rating**, click the number of stars matching the rating assigned to the image.

7 Click **Preview**.
   The search results appear in the Organizer palette.

You can also

- **Add an additional search rule**: Click the **Add Rule** button in the upper-right corner of the dialog box.
- **Remove the last search rule**: Click the **Remove Rule** button.
- **Save the search as a Smart Collection**: Click **Save** in the Smart Collection dialog box. In the Save as Smart Collection dialog box, type a name, and click **Save**. The collection appears in the Smart Collections list.

Working with saved searches

After you save a custom set of search criteria as a Smart Collection, you can run the search again simply by clicking it on the Collections tab. You can also edit, rename, or delete a saved search.

**To run a saved search**

*Manage tab*

1 In the Navigation palette, click the **Collections** tab.
2 Double-click **Smart Collections** to open the list.
3 Click the Smart Collection you want to use for your search.

**To edit a saved search**

*Manage tab*

1 In the Navigation palette, click the **Collections** tab.
2 Double-click **Smart Collections** to open the list.
3 Right-click the Smart Collection, and click **Edit**.
   The Smart Collection dialog box appears with the search criteria displayed.
4 Change the search parameters, and click **Preview**.
   The search results appear in the Organizer palette.
5 Click **Save**.
   The Save as Smart Collection dialog box appears, with the search name highlighted in the text field.
6 Click **Save**.
   The previous search is overwritten.

💡 To avoid overwriting the previous search, type a new name for the edited search in the text field, and click **Save**.

**To rename a saved search**

*Manage tab*

1 In the Navigation palette, click the **Collections** tab.
2 Double-click **Smart Collections** to open the list.
3 Right-click the Smart Collection, and click **Rename**.
   The Rename Smart Collection dialog box appears with the search name highlighted.
4 Type a new name, and click **Save**.

### To delete a saved search
Manage tab
1 In the Navigation palette, click the **Collections** tab.
2 Double-click **Smart Collections** to open the list.
3 Right-click the Smart Collection, and click **Delete**.

### Adding keyword tags to images

Keyword tags let you assign descriptive, natural-language terms to images. By creating tags such as “family,” “children,” or “birthday,” you can identify specific photos, and then simply click a tag from the list to view thumbnails of photos associated with the tag. The tags that you create are stored in a tags catalog accessible from the Navigation palette. You can create and assign as many tags as you like to an image.

#### To add a keyword tag to the tags catalog
Manage tab
1 In the Navigation palette, click the **Collections** tab.
2 Double-click **Tags** to open the list.
3 In the Tags list, click the **Add Tags** button.
   The Add Tag dialog box appears.
4 Type the tag text, and click **OK**.
   The new tag appears in the Tags list.

#### To delete a keyword tag from the tags catalog
Manage tab
1 In the Navigation palette, click the **Collections** tab.
2 Double-click **Tags** to open the list.
3 Right-click a tag, and click **Delete**.

#### To assign a keyword tag to one or more images
Manage tab
1 In the Navigation palette, click the **Collections** tab.
2 Double-click **Tags** to open the list.
3 In the Organizer palette, select one or more thumbnails of the images that you want to tag.
4 Drag the thumbnails onto a tag in the Tags list.

You can also assign one or more tags to the selected thumbnails by typing the text in the **Tags** box on the General page of the Info palette, and clicking the **Add Tag** button to the right of the text field.

#### To remove keyword tags from one or more images
Manage tab
1 In the Organizer palette, select one or more thumbnails.
2 In the Info palette, click the **General** tab to view the tag information.
3 In the list that appears below the Tags box, click one or more tags that you want to remove, and click the Delete Tag button that appears to the right of the tag name.

If the Info palette is not displayed, click the Image information button on the Organizer toolbar.

**Viewing photos by tags**

After you assign a tag to an image, you can find the image simply by clicking on the tag.

**To display photos by tags**

Manage tab

1 In the Navigation palette, click the Collections tab.

2 Double-click Tags to open the list.

3 Click a tag.

Photos associated with the tag display as thumbnails in the Organizer palette.

You can also type a tag name into the Search box at the top of the Navigation palette.

You can also display photos that have no tags by clicking the No Tags button in the Tags list.

**Using the calendar to find images**

The Calendar Search lets you find photos according to the date they were taken. You can search by a specific date or select a date range within a calendar month. The image creation dates are highlighted on the calendar. To perform a search across several months or years, see “To do an advanced search” on page 83.

Note: When you edit and save a photo, the modification date is also captured in the Calendar Search.

**To find images by using the calendar**

Manage tab

1 In the Navigation palette, click the Collections tab.

2 Click the Calendar button.

The Calendar Search dialog box appears. Dates shown in red indicate images created on those dates.

3 Choose one of the following options:
   - For photos taken today, click the Today button.
   - For a specific date and month, click the Previous (Year/Month) and Next (Month/Year) buttons, and select a date.
   - For a date range, use the Previous and Next buttons to select the month and year, hold down Shift, click the first date in the range, and then click the last date in the range.
   - For multiple dates not in sequence, use the Previous and Next buttons to select the month and year, hold down Ctrl, and click the dates.

When you click a date or a range, the Organizer palette displays thumbnails of the photos that match the date criteria.

4 Click Close to close the Calendar Search dialog box.

**Working with thumbnails in the Manage tab**

The Manage tab makes it easy for you to preview and organize photos by using thumbnails.
For a larger view of photos, use Preview mode, zoom in and out on thumbnails, or use Quick Review to view photos in full-screen mode. You can sort thumbnails by criteria such as name, rating, or date. You can also rotate photos by using thumbnails, or delete and rename the files.

For multi-image shooting, you can use Auto Group and RAW/JPG Pairs to group and view thumbnails according to bracketing settings or JPEG+RAW file pairs.

Thumbnails let you edit multiple photos by using Capture editing and Apply editing. For more information, see “Capturing and applying edits to multiple photos” on page 89.

In addition, you can select one or more RAW file thumbnails to convert the files to another format. For more information, see “Converting RAW photos to another file format” on page 106.

To preview an image in Manage
• In the Organizer palette, click a thumbnail.
  If you are not in Preview mode, click the Preview mode button in the upper-right corner of the application window.
  The photo is displayed in the Preview area.

You can also

Display the previous or the next image in the Preview area by using the keyboard
  Press the Left arrow or the Right arrow keys.

Preview an image in full-screen mode
  Click View ➤ Full Screen Preview, or double-click a thumbnail to open Quick Review. For more information, see “Using Quick Review to review photos” on page 92.

To zoom in or out on thumbnails
1 If the Manage tab is not in Thumbnail mode, click the Thumbnail mode button in the upper-right corner of the Manage tab.
2 On the Organizer toolbar, move the Zoom slider to the left to zoom out, or to the right to zoom in.

  The Zoom slider is not available when the Manage tab is in Preview mode.

To sort thumbnails
Manage tab
1 On the Organizer toolbar, click the Sort by drop-list.
2 Choose a sorting option.
3 Choose one of the following options:
  • Date Created - Newest — sorts thumbnails, from newest to oldest, by the date on which the photo was taken
  • Date Created - Oldest — sorts thumbnails, from oldest to newest, by the date on which the photo was taken
  • Date Modified — sorts thumbnails by the date on which the image was last modified
  • Folder — sorts thumbnails alphabetically by folder name
  • Filename — sorts thumbnails alphabetically by filename (image name)
  • Rating — sorts thumbnails by image rating
  • File Format — sorts thumbnails alphabetically by filename extension (for example, .psp image, .jpg, or .tif)
  • File Size — sorts thumbnails by the file size (in kilobytes) from smallest to largest
  • Place — sorts thumbnails by the location that is associated with the photo
To group thumbnails according to shooting time
• On the Organizer toolbar, click **Auto Group** and set a time interval.

Photos that have been captured within the time interval are displayed as sets (dividers appear between sets).

To control how RAW and JPEG pairs are displayed
• On the Organizer toolbar, click the **RAW/JPG Pairs** button, and choose one of the following options:
  • **ON - Show JPG Versions** — shows the JPEG versions as thumbnails and hides the RAW versions
  • **ON - Show RAW Versions** — shows the RAW versions as thumbnails and hides the JPEG versions
  • **OFF** — shows thumbnails for both the RAW and JPEG versions of the files.

If you delete a thumbnail when the RAW/JPG Pairs option is turned on, both versions of the files are sent to the Recycle Bin.

To select more than one thumbnail
**Manage tab**
• Do one of the following:
  • To select adjacent thumbnails, hold down **Shift**, and click the first and the last thumbnail in the sequence of thumbnails.
  • To select nonadjacent thumbnails, hold down **Ctrl**, and click the thumbnails.

To rotate one or more images in the Organizer palette
**Manage tab**
1 Select one or more thumbnails.
2 On the Organizer toolbar, click one of the following buttons:
  • **Rotate Right** — rotates thumbnails 90 degrees clockwise
  • **Rotate Left** — rotates thumbnails 90 degrees counterclockwise

You can also right-click a thumbnail and choose **Rotate Right** or **Rotate Left** from the context menu.

To delete one or more photos in Manage
1 Select one or more thumbnails, and press **Delete**.

The Delete File dialog box or Delete Multiple Items dialog box appears.
2 Click **Yes** to send the images to the Recycle Bin.

You can also delete photos by selecting thumbnails, right-clicking a selected thumbnail, and clicking **Delete** in the context menu.

To rename a file in the Manage tab
1 Right-click the thumbnail of the file that you want to rename and choose **Rename**.
2 In the Rename File dialog box, type the new filename, and click **OK**.

To open one or more images for advanced editing
**Manage tab**
• Select one or more thumbnails, and click the **Edit** tab.

The images open in the Edit tab.
Capturing and applying edits to multiple photos

You can copy the edits you make to one photo and apply them to as many photos as you want. For example, you can easily apply a lighting correction to multiple photos, or apply the same border and resizing options to a set of photos that you’re preparing for a website.

After you edit a photo in Edit, a small editing icon appears on the photo’s thumbnail. When you return to Manage, you can access the Capture editing and Apply editing commands to copy the changes to other photos.

An icon in the lower-left corner of a thumbnail indicates that the edits to the photo can be copied and applied to other photos.

You can capture and apply edits to most file types, but edits to RAW files can be applied only to other RAW files. You can undo the edits you apply to one or more photos.

**To capture edits**

1. After editing an image, save the changes.
2. In the Organizer palette, select the thumbnail of the photo that you edited.
   - A pencil icon or RAW icon appears in the upper-left corner of the thumbnail to indicate that the image has been edited.
3. Click the Capture Editing button on the Organizer toolbar.

You can capture the edits of both open or closed files for the current session only. When you close the program, all captured edits are automatically deleted.

You can also capture the edits by right-clicking the selected thumbnail and choosing Capture Editing.

**To apply captured edits**

1. In the Organizer palette, select one or more thumbnails.
2. Click the Apply Editing button on the Organizer toolbar.
3. Click OK in the Batch Progress dialog box.
   - For RAW files, the saved settings from the Camera RAW Lab dialog box are applied.

When you close the program, all captured edits are automatically cleared.
You can also apply the captured edits by right-clicking the selected thumbnails and choosing **Apply Editing**.

**To undo Apply Editing**

1. In the Organizer palette, select one or more thumbnails.
2. Right-click a selected thumbnail, and choose **Revert Current Editing** from the context menu.

You can also undo the editing to multiple photos by selecting the thumbnails of the edited photos, right-clicking a selected thumbnail, and choosing **Revert All Editing** from the context menu.

**Displaying and editing photo information**

The Info palette in the Manage tab lets you view, add, and edit information about your photos, such as filename, size, and creation date, as well as EXIF and IPTC metadata. You can also add tags and captions, and apply star ratings to photos. Adding and updating photo information makes it easier to organize and search for your photos. For example, you can search by caption text.

- For more information about adding keyword tags, see “Adding keyword tags to images” on page 85.
- For information about how to display EXIF info on your images, see “Displaying captions and info text on images” on page 340.

At the top of the Info palette there is a camera-style display that helps you quickly review the camera settings and lens that were used for the selected photo.

![Camera settings](image)

**White Balance Symbols**

- **Custom**
- **Flash**
- **Daylight**
- **Overcast**
- **Fluorescent**
- **Shade**
- **Tungsten**
- **Partial metering**
- **Auto-white balance**

**Metering Symbols**

- **Custom metering**
- **Spot metering**
Metering Symbols

- Averaged metering
- Multi-spot metering
- Center-weighted metering
- Pattern metering

To display or hide the Info palette
Manage tab
- On the Organizer toolbar, click the Image Information button. The Info palette is open by default but you can hide or display it depending on how much screen space you need.

To assign a rating to one or more images
Manage tab
1. Select one or more thumbnails.
2. In the Info palette, click a star, starting from left to right, to set a rating. For example, if you want to assign a five-star rating, click the right-most star and all stars will be selected.

You can also

Assign a rating by using the context menu
Right-click one or more selected thumbnails, choose Set Rating, and then click the number of stars that you want to assign.

Assign a rating by using keyboard shortcuts
Select one or more thumbnails, and press Ctrl + the number of stars you want to assign. For example, if you want to assign one star, press Ctrl + 1.

To remove the rating of an image
Manage tab
- Right-click a thumbnail, choose Set Rating, and click the number of stars that are currently assigned to the image. For example, to remove the rating of a three-star image, you would choose Set Rating * * *.

To add a caption to one or more images
Manage tab
1. Select one or more thumbnails.
2. In the Info palette, click the General tab, and type text in the Caption box.

To delete a caption from one or more images
Manage tab
1. Select one or more thumbnails that have the same caption text.
2. In the Info palette, click the General tab.
3. Highlight the text you want to delete in the Caption box.
4. Press Delete.

To view advanced image information
Manage tab
- In the Info palette, click the EXIF or IPTC tab.
  The EXIF or IPTC data for the image appears.
Note: You can edit only the EXIF or IPTC data that have entry fields.

Using Quick Review to review photos

You can use Quick Review to review images in full-screen mode. For example, after downloading photos from your camera, you can use Quick Review to quickly review all photos, delete the ones you don’t want, rotate photos, and apply star ratings.

To review images in full-screen mode

Manage tab

1. In the Organizer palette, double-click a thumbnail in the folder or tray that you want to review.

   The Quick Review window opens.

2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>View the next photo</td>
<td>Click the Next Image button.</td>
</tr>
<tr>
<td>View the previous photo</td>
<td>Click the Previous Image button.</td>
</tr>
<tr>
<td>Open the photo in Edit</td>
<td>Click the Edit Photo button.</td>
</tr>
<tr>
<td>Apply a star rating</td>
<td>Click a star below the photo, starting from left to right, to set a rating.</td>
</tr>
<tr>
<td>Change the Zoom level</td>
<td>Drag the Zoom slider, click the Zoom In or Zoom Out buttons, or click the Zoom to 100% button or the Fit to Window button.</td>
</tr>
<tr>
<td>Delete a photo</td>
<td>Click the Delete button.</td>
</tr>
<tr>
<td>Rotate a photo</td>
<td>Click the Rotate Right button or the Rotate Left button.</td>
</tr>
<tr>
<td>Exit Quick Review</td>
<td>Click the Exit button or press Esc.</td>
</tr>
</tbody>
</table>

You can also use the mouse wheel to change the Zoom level.

Working with trays

You can use trays to gather images from various folders. The images remain in their original location, but are referenced in the tray and can be accessed by clicking a thumbnail.

You can add, remove, and rename trays to suit your workflow. For instance, you can create a tray for images you want to edit, use for a project, print, or e-mail. Trays are created in the Organizer palette.

The default tray automatically displays the photos from the folder or collection that you currently have selected in the Navigation palette. A custom tray, called My Tray, is a blank tray that is created automatically.
To add a tray
Manage tab
1. In the Organizer palette, click the More Options button on the Organizer toolbar, and click Add Tray.
2. Type a name for the new tray in the Name field, and click OK.

To rename a tray
Manage tab
1. In the Organizer palette, select the tray that you want to rename.
2. Click the More Options button on the Organizer toolbar, and click Rename Tray.
3. Type a new name for the tray in the Name field, and click OK.

To remove a tray
Manage tab
1. In the Organizer palette, select the tray that you want to remove.
   Note: Removing a tray does not delete the photos in the tray.
2. Click the More Options button on the Organizer toolbar, and click Remove Tray.
   The default tray, “My Tray,” cannot be removed.

To add photos to a tray
Manage tab
1. In the Organizer palette, select the thumbnails of the photos that you want to add to the tray.
2. Right-click a selected thumbnail and click Add to Tray.
   The photos are added to My Tray.

To remove photos from a tray
Manage tab
1. In the Organizer palette, click a tray.
2. Select the photos that you want to remove.
3. Press Delete.

To save your tray content to a folder
Manage tab
1. In the Navigation palette, click the Collections tab.
2. Click Browse More Folders, navigate to the location you want, and click Make New Folder.
3. Type a name for the folder, and click OK.
4. In the Organizer palette, select all the photos in a tray (you can use Ctrl + A).
5. Drag the photos to the new folder.
Using Adjust

Taking lots of photos with your digital camera is fun and easy. Sometimes, though, the effort required to review them all, let alone edit them, can be laborious. The Adjust tab can make this task enjoyable. You can perform basic corrections, such as cropping, straightening, color correcting, and removing blemishes and red-eye. You can even apply star ratings and delete photos. This rapid-edit mode lets you quickly complete the first cut of photos before doing more detailed work on a select few.

Why use the Adjust tab?

The Adjust tab provides quick access to the most commonly used tools and features of PaintShop Pro — you have the controls right in front of you.

If you prefer to work in the advanced editing mode to access the application’s entire range of tools and features, you can simply click the Edit tab at the top of the application window. The most recently displayed Adjust tab photo becomes the active image.

This section presents the following topics:
- “Showing the Adjust tab” (page 95)
- “Working with the Adjust tab” (page 95)
- “Tools and features in Adjust” (page 96)
- “Using depth information to select areas” (page 98)

Showing the Adjust tab

You can show the Adjust tab by enabling it in Preferences.

To show the Adjust tab

1. Click File ➤ Preferences ➤ General Program Preferences.
2. Click Tabs in the list of categories.
3. In the Visible Tabs area, mark the Adjust check box.
   If you want to make Adjust your default tab, click the Set Adjust as default option.

Working with the Adjust tab

The Adjust tab lets you edit photos, one at a time. Your changes are applied each time you click a new tool or feature. You can also undo the changes. As you edit, you can flash back for a view of the original image. After you finish editing a photo, you can easily move to the next photo by clicking a thumbnail in the Organizer palette. You have the option to save each time you click another photo or you can choose to save automatically by enabling Autosave when you are prompted.
To edit or adjust photos in Adjust

• In the Adjust palette, do one of the following:
  • Click a tool, and adjust the controls to edit the photo. The edits are applied when you click the **Apply** button or when you click another tool or adjustment option.
  • Click the name of the adjustment feature you want to use. The adjustment controls display. The changes are applied when you click another feature.

To undo changes in Adjust

• Do one of the following:
  • Click the **Undo** button on the toolbar.
  • Click the **Reset** button at the bottom of the Adjust pane to undo all changes.

A photo displayed in the Adjust tab

To view original image

• At the bottom of the **Adjust** pane, click and hold the **Show Original** button. Release the button to return to the edited version of the image.

Tools and features in Adjust

The table below provides a list of the features available from the Adjust tab and links to help you find more information.
<table>
<thead>
<tr>
<th>Tools</th>
<th>Where to find more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crop tool</td>
<td>“Cropping images” on page 113</td>
</tr>
<tr>
<td>Straighten tool</td>
<td>“Straightening images” on page 117</td>
</tr>
<tr>
<td>Red Eye tool</td>
<td>“To remove red-eye quickly” on page 156</td>
</tr>
<tr>
<td>Makeover tool</td>
<td>“Applying cosmetic changes” on page 157</td>
</tr>
<tr>
<td>Clone Brush</td>
<td>“Removing flaws and objects with the Clone Brush or Object Remover” on page 161</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Adjustment features</th>
<th>Where to find more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Depth Selection</td>
<td>“Using depth information to select areas” on page 98</td>
</tr>
<tr>
<td>Smart Photo Fix</td>
<td>“Making basic photo corrections automatically” on page 119</td>
</tr>
<tr>
<td>White Balance</td>
<td>“Adjusting white balance” on page 129</td>
</tr>
<tr>
<td>Brightness/Contrast</td>
<td>“Adjusting brightness, contrast, and clarity” on page 131</td>
</tr>
<tr>
<td>Fill Light/Clarity</td>
<td>“Adjusting brightness, contrast, and clarity” on page 131</td>
</tr>
<tr>
<td>Vibrancy</td>
<td>“Adjusting hue and saturation” on page 137</td>
</tr>
<tr>
<td>Local Tone Mapping</td>
<td>“Adjusting brightness, contrast, and clarity” on page 131</td>
</tr>
<tr>
<td>High Pass Sharpen</td>
<td>“Sharpening images” on page 148</td>
</tr>
<tr>
<td>Digital Noise Removal</td>
<td>“Removing digital noise” on page 123</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>General commands and shared features</th>
<th>Where to find more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Saving</td>
<td>“Saving images” on page 55</td>
</tr>
<tr>
<td>Rotating</td>
<td>“Rotating images” on page 112</td>
</tr>
<tr>
<td>Undoing and redoing</td>
<td>“Undoing and redoing actions” on page 71</td>
</tr>
<tr>
<td>Deleting</td>
<td>“Deleting images” on page 74</td>
</tr>
<tr>
<td>Viewing and zooming</td>
<td>“Zooming and panning” on page 67</td>
</tr>
<tr>
<td>Setting ratings</td>
<td>“To assign a rating to one or more images” on page 91</td>
</tr>
<tr>
<td>Organizer palette</td>
<td>“The Edit tab” on page 27</td>
</tr>
</tbody>
</table>
Using depth information to select areas

If you have a camera that captures depth information (XDM metadata), you can apply adjustments or Instant Effects to specific areas of photos by using the Depth Selection feature available from the Adjust tab. The depth is based on the distance between a special depth sensor on a camera and the objects captured in the photo.

To select a region based on depth information

1. Click the Adjust tab.
2. Use the Navigator in the Organizer palette to navigate to a photo that includes depth information.
3. In the Adjust palette, click Depth Selection.
4. Click the Enable Selection check box to display a selection marquee.
5. Drag the markers on the Depth Range slider to set the minimum (Near) and maximum (Far) distance for the selection. You can view the selection in the Preview area.
6. To fine-tune the selection, drag the Size slider to set a brush size and do any of the following:
   - Click Add and in the Preview area drag over the edge of the area that you want to select.
   - Click Remove and in the Preview area, drag over the selected areas that you want to deselect.

If you want to invert the selection, mark the Invert Selection check box.
RAW photos

Most DSLR cameras give you the option to take photos in RAW mode. RAW mode records more image data than a typical JPEG. The RAW image data itself remains uncompromised and uncompressed, making it similar to a photo negative that you can print as you like. The Camera RAW Lab in PaintShop Pro acts like a digital darkroom and lets you apply a personal touch to your RAW files. You can also manually edit RAW files with a professional toolset in AfterShot Lab.

After processing a RAW image, you can leave it as a read-only RAW file, or export it to a JPEG, GIF, or PNG file so you can edit it. You can also read and save changes to XMP files.

This section presents the following topics:
• “Supported RAW file formats” (page 99)
• “Using the Camera RAW Lab” (page 99)
• “Using AfterShot Lab” (page 101)
• “Applying edits to multiple RAW photos” (page 106)
• “Converting RAW photos to another file format” (page 106)
• “Working with XMP files” (page 106)

Supported RAW file formats

Camera RAW Lab works with common RAW formats from the major camera manufacturers. You can find an updated list in the Corel Knowledgebase.

To find supported RAW file formats

Using the Camera RAW Lab

The Camera RAW Lab lets you develop a RAW image by saving a variety of processing settings. After processing a RAW image, you can leave it as a read-only RAW file, or from the Edit tab, save it to a different file format, such as JPEG, GIF, or PNG.
To launch the Camera RAW Lab
1. Do one of the following:
   • Click the Manage tab, select File ➤ Open, choose a RAW image file and click Open.
   • Click the Manage tab, right-click one or more thumbnails for RAW images, and choose Edit RAW.
   • Click the Edit tab, drag a RAW image thumbnail from the Organizer palette to the image window, or double-click the thumbnail.
2. Choose the Use Camera RAW Lab option.
3. Click Continue.
   The Camera RAW Lab dialog box opens with the image.

To adjust RAW-photo settings using the Camera RAW Lab
1. In the Camera RAW Lab dialog box, click the Basic tab, and do any of the following:
   • Drag the Brightness, Saturation, or Shadow sliders for a quick overall image adjustment.
   • In the White balance area, adjust color by clicking a preset lighting option from the Scenario drop-list, or by clicking the preview area to set the white point with the Dropper tool. You can also adjust or fine-tune color with the Temperature and Tint sliders.
   • In the Highlight recovery area, click an option in the drop-list. Highlight recovery works particularly well on images that are overexposed — it can help restore detail in blown-out areas.
   • In the Reduce noise area, drag the Threshold slider to smooth digital noise.
   You can preview the changes to the photo in the Preview area.
   If you want to keep the settings for future use, check the Save image settings checkbox.
   Click Reset at any time to clear all the settings.
2. Click one of the following:
   • OK — applies the settings, and exits the Camera RAW Lab
   • Cancel — exits the Camera RAW Lab without adjusting the photo’s settings
3. To correct lens issues, click the Lens tab. For information about Lens Correction options, see “Using Lens Correction to fix distortion, chromatic aberration, and vignetting” on page 127.
You can add more RAW photos to the **Camera RAW Lab** by clicking the **Add more photos** button in the thumbnail row (maximum of 30).

Image settings for RAW images are saved to a database. Changes to the file name or file location can be tracked in the database only if you make the changes in Corel PaintShop Pro.

**Using AfterShot Lab**

AfterShot Lab offers advanced features and tools for optimizing RAW images. AfterShot Lab is non-destructive; your original image files are always safe.

The **Basic Adjustments** section of the Standard tools panel contains the most commonly used image-adjustment controls.

The **Detail** section lets you correct a number of RAW-image issues:

- **RAW Noise** is an image improvement process that you can use very early in the image editing workflow to provide the highest quality final images. The feature can be applied only to RAW files.
- **Noise Removal** improves images by reducing noise, a graininess caused by color or luminance-related artifacts, without losing image detail. Noise occurs for a number of reasons, including low-lighting or limitations of the camera's sensors.
- **Lens correction** fixes lens distortion. While zoom lenses with a large range of focal lengths show the greatest lens distortion, even fixed-focal length, or 'prime' lenses, can cause some types of distortion. The following types of lens distortion can quickly and easily be corrected: Barrel and Pin Cushion distortion, Chromatic Aberration, and Vignetting.
- **Chromatic Aberration distortion** (known as CA distortion) is a result of the nonuniform bending of light as it passes through a lens. The result is a color fringe (often appears purple) and uneven colors around edge details in high contrast scenes, such as branches of a tree silhouetted against a bright sky. Zoom lenses, particularly at their widest and longest focal lengths, exhibit the most severe distortion.
- **Vignetting** is the darkening of corners of an image due to light fall-off, and can be caused by optics (the lens itself), the sensor (many sensors are less sensitive to light that hits the sensor at an angle), or from other causes like a filter or lens hood that shades the corners of an image. Vignetting can be corrected by brightening the corners of an image.

When you’re finished, you can continue working on a TIFF version of the image.
To launch AfterShot Lab
1 Do one of the following:
   • Click the Manage tab, select File ➤ Open, choose a RAW image file and click Open.
   • Click the Manage tab, right-click one or more thumbnails for RAW images, and choose Edit RAW.
   • Click the Edit tab, drag a RAW image thumbnail from the Organizer palette to the image window, or double-click the thumbnail.
2 Choose the Use AfterShot Lab option.
3 Click Continue.
The AfterShot Lab window opens with the image.

To make basic adjustments in AfterShot Lab
1 In AfterShot Lab, click the Standard tab in the Tools panel.
2 Do any of the following:
   • To examine the tonal range of your image and set the black and white points to be at points such that a fixed percent of the image will be pure black and pure white, mark the AutoLevel check box and adjust the settings in either edit box. The left box sets the percentage of the image to be set to pure black and the right box sets the percentage to be set to pure white.
   • To remove abnormal tint and restore faded photos, mark the Perfectly Clear check box, and choose Tint Max to apply the full range of tint correction, Tint Min to limit the tint correction (allowing some tint change to occur, but preserving some of the original tint), or Tint Off apply Perfectly Clear without tint correction, preserving the color of your original image.
   • To manually set the white balance, click the Enable the Click White tool button, click a neutral image area, and fine-tine the results with the Temp slider.
   • To rotate an image to level a horizon or otherwise straighten it, move the Straighten slider or set a value in the corresponding control.
   • To perform an overall exposure correction, either brightening or darkening all portions of an image, move the Exposure slider or set a value in the corresponding control.
   • To recover detail from apparently overexposed portions of an image, move the Highlights slider or set a value in the corresponding control.
• To control how much of the image is adjusted by Highlights, move the **HL Range** slider or set a value in the corresponding control. Lower numbers recover detail and color from only the lightest areas; higher numbers expand the recovery to a broader range of light areas.

• To brighten shadows and the darker portions of the image without overexposing highlights, move the **Fill Light** slider or set a value in the corresponding control.

• To control the black point in the image, move the **Blacks** slider or set a value in the corresponding control. Values lower than zero remove black from the image; values higher than zero darken the image.

• To control the difference between the lightest and darkest areas of an image, move the **Contrast** slider or set a value in the corresponding control. Increasing the contrast makes the dark areas in the image darker and the bright areas brighter.

• To adjust the intensity of the colors in the image, move the **Saturation** slider or set a value in the corresponding control. High saturation settings boost colors and provide rich, vivid color. Low saturation settings produce pastel and more muted colors. Setting **Saturation** to zero produces a pure monochrome, black-and-white image.

• To gently correct skin and other image areas that are already richly saturated, move the **Vibrance** slider or set a value in the corresponding control. Vibrance is a version of saturation.

• To change the colors in an image, move the **Hue** slider to rotate the “color circle” by the amount indicated in the control box. For example, if the **Hue** slider is set to 60, then 60 is added to the original hues in your image, so greens become cyan, blues become magenta, and reds become yellow.

• To make the high detail portions of the image stand out more by making the edge details more pronounced, mark the **Sharpening** check box, and move the slider or set a value in the corresponding control. This should be applied and evaluated while looking at a 100% Zoom of the image.

• To reduce digital noise, mark the **RAW Noise** check box, and move the slider or set a value in the corresponding control.

The AfterShot Lab toolbar also gives you quick access to frequently used tools — Crop, Straighten, Red Eye Removal, Pan, and White Balance.

**To apply an AfterShot Lab preset**

1. In AfterShot Lab, click the **Standard** tab in the Tools panel.
2. In the **Presets** section, click a preset in the list.

**You can also**

Create a preset

Click **Manage**. Click the Add Preset button [+] pick a name for the settings, choose which settings you want to save, and click **OK**.

Add or remove a preset to the My Favorites list

Click **Manage**. In the **Show** column, mark a check box to display the corresponding preset in the **My Favorites** drop-down list; unmark the check box to remove the preset from the list.

Create folders for presets

Click **Manage**. Click the Add Folder button [+] double-click the new folder that appears at the bottom of the preset list and type a name for the folder.

Move presets

Click **Manage**, and drag a preset from one folder to another folder.

Delete presets or preset folders

Click **Manage**, click the preset or folder that you want to delete, and click the **Delete** button or press **Delete** on your keyboard.

View the settings for a preset

Click **Manage**, click the preset and click the View preset settings button.
To sharpen a RAW image

1. In AfterShot Lab, click the Detail tab in the Tools panel.
2. In the Sharpen area, mark the Sharpening check box.
3. Do any of the following:
   • Move the Amount slider to adjust the overall sharpness.
   • Move the Sensitivity to limit what portions of the image are sharpened.

   A high Sensitivity value results in less of your image being sharpened. If sharpening your image makes noise or highly detailed areas too distracting or too sharp, then try raising the Sensitivity value.

To remove noise from a RAW image

1. In AfterShot Lab, click the Details tab in the Tools panel.
2. In the RAW Noise area, mark the Raw Impulse Noise Removal check box.

   You can control the strength of the noise reduction using the Raw Noise slider and set the level of sensitivity for noise detection in the image using the Threshold slider.
3. To improve images by reducing noise, a graininess caused low-lighting or limitations of the camera's sensors, mark the Enable Noise Removal check box in the Noise Removal area.

   You can choose automatic noise reduction based on some common noise-reduction options from the Preset drop-list, set how much noise reduction is applied using the Strength slider, or control how much detail is preserved using the Detail slider.

To correct lens distortion

1. In AfterShot Lab, click the Details tab in the Tools panel.
2. In the Lens Correction area, mark the Enable Correction check box.

   You can also

   Automatically scale the image to fill the image frame
   Mark the Resize image check box.
   Do not enable if you want to fill the empty sections of your image manually.

   Correct chromatic-aberration distortion
   Mark the Chromatic Aberration Correction check box, and adjust the R / C slider to control the shift of colors along the Red/Cyan color axis or the B / Y slider to control the shift of colors along the Blue/Yellow color axis.

   Re-read the EXIF data from the selected image, guess the camera and lens type, and select the appropriate entries in the drop-downs
   Click Reload EXIF.

   Brighten the corners of an image
   Mark the Enable vignette correction check box, adjust the Strength slider to control how light (positive or right) or dark (negative or left) the correction will be, and adjust the Radius slider to control how far into the image the correction should extend.

   This control is independent of other types of lens correction.

   Edit the currently selected lens correction profile
   Click Edit, and adjust the settings on the Manual tab.

   Open a saved lens correction profile (XML file)
   Click Load, navigate to the profile, and click Open.

   Save your changes to the current profile
   Click Save, navigate to the folder to which to save the profile, and
You can also

Remove all changes made to the profile during the current session

Click Reset.

The Manual tab lets you enter correction parameters instead of using correction parameters from profiles built into the application. This is useful for lenses that are not yet in the lens correction database.

The Manufacturer, Model, and Lens drop-lists on the Database tab show what camera and lens Corel PaintShop Pro assumes your image was taken with. Some cameras and lenses include data in the image file that allows the application to determine exactly what camera and lens was used, but other times the application estimates the closest option based on the data available. You can change incorrect guesses by selecting the correct manufacturer, camera model, and lens in the lists. These determine which Lens Distortion profile to use when removing distortion.

The Focal Length box shows the focal length setting for the lens at the time the image was taken. You can set the focal length manually if the image file doesn't include this information.

To mirror and invert a RAW image

1 In AfterShot Lab, click the Details tab in the Tools panel.
2 In the Mirror and Invert area, do any of the following:
   • Mark the Mirror check box to mirror your image (from left to right).
   • Mark the Invert check box to invert the colors (like a film negative).

This option can be useful when working with scanned negatives.

To work with metadata

• In AfterShot Lab, click the Metadata tab in the Tools panel.

This tool shows EXIF and IPTC metadata assigned to the Active Version, and allows you to add, remove or edit the IPTC data from all selected images.

You can select different metadata sets from the drop-down list at the top of the Metadata section, which changes the type of metadata that is shown. Some metadata is read-only, like Shutter Speed and ISO Rating, while other metadata is editable, like Caption, Rating, and Date.

You can also

Add a new metadata set

Click Manage check box, and click the Add a new Set button.

A new set with the default name New Set is created at the end of the Metadata Sets list.

Remove a metadata set

Click Manage check box, and click the Remove Set button.

Rename a metadata set

Double-click the metadata set that you want to rename, and type the new name.

Add metadata to a metadata set

Select the metadata entry in the left column, and drag it to the metadata set in the right column.
The left column in the Metadata Manager lists all metadata entries available in AfterShot Lab. The right column lists metadata sets and their current content.

To return to PaintShop Pro

- Click **Finish Editing**.
  
  A TIFF version of the image opens in PaintShop Pro.

Applying edits to multiple RAW photos

A photographer is often faced with organizing and processing large numbers of photos, especially if you use a DSLR camera. You may find that you’re downloading a batch of photos taken under similar conditions, all with similar processing needs. With PaintShop Pro, you can copy the edits you made to a photo in the Camera RAW Lab, and quickly apply the same edits to a batch of photos. For more information about applying edits to multiple photos, see “Capturing and applying edits to multiple photos” on page 89.

Converting RAW photos to another file format

The RAW file format is read-only and the settings for a RAW file are stored as a separate header. It is these settings that you can adjust in AfterShot Lab or the Camera RAW Lab. However, to use the editing features accessible from the Edit tab, you need save the RAW file to a different file format, such as JPEG, TIFF, or the native format, .pspimage. To quickly convert the file, you can use Convert RAW.

You can also automatically decode RAW files and open them in PaintShop Pro as TIFFs.

To convert a RAW file to another file type

1. In the Organizer palette, select one or more RAW file thumbnails.
2. Right-click a selected thumbnail, and click **Convert RAW**.
3. In the Batch Process dialog box, choose a file format from the **Type** drop-list.
   - If you want to change the default conversion settings, click **Options**, and adjust the settings.
4. Click **Browse** and choose a folder in which the converted file will be saved.
5. Click **Start**.

You can rename converted files by clicking **Modify**, choosing an option from the **Rename Options** list, and clicking **Add**.

Working with XMP files

XMP files are metadata sidecar files that accompany RAW files. They are a standard way of saving edits without changing the original RAW file. If you plan to use another RAW image-editor with your files, XMP files will let you work between the applications more easily. You can read, save, copy, and paste XMP metadata for your RAW files.

To read and import metadata in XMP files

- Click the Manage tab, right-click one or more RAW photo thumbnails, and choose **RAW Metadata → Read Metadata from File**.

To save edits to XMP files

- Click the Manage tab, right-click one or more RAW photo thumbnails, and choose **RAW Metadata → Save Metadata To File**.
To copy and paste metadata between XMP files

1. Click the Manage tab, right-click the thumbnail of the RAW image that has the metadata that you want to copy.
2. Choose RAW Metadata ➤ Copy.
3. Select one or more RAW photo thumbnails to which you want to apply the metadata.
4. Right-click the selected thumbnails and choose RAW Metadata ➤ Paste.
Adjusting images

When you view your photos in PaintShop Pro, you may notice problems that you want to correct. In some photos, the problems are obvious, such as when the subject is too dark. In other photos, you may sense the need for improvement but not know what to fix. With PaintShop Pro, you can correct specific aspects of a photo or allow the program to make basic photo adjustments.

This section presents the following topics:
- “Fixing common problems” (page 109)
- “Rotating images” (page 112)
- “Cropping images” (page 113)
- “Straightening images” (page 117)
- “Correcting photographic perspective” (page 118)
- “Making basic photo corrections automatically” (page 119)
- “Brightening images” (page 122)
- “Darkening images” (page 122)
- “Removing purple fringe” (page 123)
- “Removing digital noise” (page 123)
- “Removing chromatic aberrations” (page 125)
- “Using Lens Correction to fix distortion, chromatic aberration, and vignetting” (page 127)
- “Correcting lens distortions” (page 128)
- “Adjusting white balance” (page 129)
- “Adjusting brightness, contrast, and clarity” (page 131)
- “Adjusting hue and saturation” (page 137)
- “Adding or removing noise” (page 139)
- “Applying a depth of field effect with AI Portrait Mode” (page 143)
- “Controlling depth of field” (page 144)
- “Blurring images” (page 146)
- “Sharpening images” (page 148)
- “Softening images” (page 149)
- “Removing haze” (page 150)
- “Resizing images” (page 150)
- “Enlarging images by using AI-Powered upsampling” (page 153)

Fixing common problems

PaintShop Pro provides many fast and powerful commands and tools to help you correct some common photographic problems. You can use the table below as a starting point for making your photos as good as they can be. Some correction commands open a dialog box in which you can choose options and modify the correction.
If you intend to crop or resize the photo, you should perform this action first and then apply a correction from the following table.

<table>
<thead>
<tr>
<th>Problem</th>
<th>How to solve it from the Edit tab</th>
</tr>
</thead>
<tbody>
<tr>
<td>The overall photo should look better.</td>
<td>To apply a set of basic photo corrections automatically, choose Adjust ➔ One Step Photo Fix. To fine-tune and apply a set of basic photo corrections, choose Adjust ➔ Smart Photo Fix.</td>
</tr>
<tr>
<td>Part of the photo is too dark (underexposed).</td>
<td>To apply a quick adjustment to a photo's dark regions, choose Adjust ➔ Fill Flash or Adjust ➔ Brightness and Contrast ➔ Fill Light/Clarity. To apply a comprehensive set of adjustments, choose Adjust ➔ Smart Photo Fix. To access commands for correcting brightness and contrast, choose Adjust ➔ Brightness and Contrast. In particular, try the Curves and Levels commands.</td>
</tr>
<tr>
<td>Part of the photo is too light (overexposed).</td>
<td>To apply a quick adjustment to a photo's light regions, choose Adjust ➔ Backlighting. To apply a comprehensive set of adjustments, choose Adjust ➔ Smart Photo Fix. To access commands for correcting brightness and contrast, choose Adjust ➔ Brightness and Contrast. In particular, try the Curves and Levels commands.</td>
</tr>
<tr>
<td>A specific part of the photo is too dark or too light.</td>
<td>Carefully using a selection tool, select only the overexposed or underexposed part of the photo. Then, apply one of the adjustments previously described in this table. Note: The One Step Photo Fix and Smart Photo Fix commands work on the entire image, even if you’ve made a selection. For more information, see “Working with selections” on page 197.</td>
</tr>
<tr>
<td>The photo’s contrast is too low or too high.</td>
<td>To adjust the contrast and optionally adjust other settings, choose Adjust ➔ Smart Photo Fix. Or, choose Adjust ➔ Brightness and Contrast ➔ Brightness/Contrast.</td>
</tr>
<tr>
<td>You have a set of bracketed digital photos, but need a way to merge them into one.</td>
<td>Choose File ➔ HDR ➔ Exposure Merge, and use this command to combine the best details from two to nine bracketed photos into one photo.</td>
</tr>
<tr>
<td>The photo has a color cast or other unnatural colors resulting from its being taken indoors without a flash.</td>
<td>To remove a color cast, choose Adjust ➔ Brightness and Contrast ➔ Curves. To apply a comprehensive set of adjustments, choose Adjust ➔ Smart Photo Fix. To access commands for making various brightness and contrast corrections, choose Adjust ➔ Brightness and Contrast.</td>
</tr>
<tr>
<td>Someone in the photo has unnatural-looking skin tones.</td>
<td>To adjust the photo’s tonal balance, choose Adjust ➔ White Balance.</td>
</tr>
<tr>
<td>A scanned photo has scratches or tears.</td>
<td>On the Tools toolbar, choose the Scratch Remover tool,</td>
</tr>
</tbody>
</table>
Problem

Tiny specks (noise) of unnatural color can be seen, especially on a magnified view.

How to solve it from the Edit tab

the Makeover tool 🔨, or the Clone Brush tool 🎨. For more information, see “Retouching and restoring images” on page 155.

To apply noise correction automatically, choose Adjust ➔ One Step Noise Removal. To use advanced options for noise correction, choose Adjust ➔ Digital Noise Removal or AI Denoise.

To remove artifacts from compressed JPEG images, choose Adjust ➔ Add/Remove Noise ➔ AI Artifact Removal.

Purplish fringe and other color aberrations can be seen on edges in the photo.

To remove purple fringe automatically, choose Adjust ➔ One Step Purple Fringe Fix. To use advanced options for correcting chromatic aberrations, choose Adjust ➔ Chromatic Aberration Removal.

Someone in the photo has red-eye.

To remove red-eye quickly, choose the Red Eye tool 🕶️. To use advanced options for red-eye removal, choose Adjust ➔ Red Eye Removal.

Someone in the photo has skin blemishes, unpolished teeth, or washed out skin tone.

On the Tools toolbar, choose the Makeover tool 🔨. On the Tool Options palette, set the mode to Blemish Fixer 🩴, Toothbrush 🦷, or Suntan 🌞.

The photo appears foggy or hazy.

To improve a poorly exposed image, choose Adjust ➔ Brightness and Contrast ➔ Levels. To improve overall clarity, choose Adjust ➔ Brightness and Contrast ➔ Local Tone Mapping.

The photo doesn’t appear sharp.

To apply high-frequency sharpening, choose Adjust ➔ Sharpness ➔ High Pass Sharpen. To apply other forms of sharpening, choose Adjust ➔ Sharpness and choose a command.

The photo needs to be straightened.

On the Tools toolbar, choose the Straighten tool 🥂. For more information, see “Retouching and restoring images” on page 155.

The perspective of objects in the photo appears incorrect.

On the Tools toolbar, choose the Perspective Correction tool 🧩. For more information, see “Retouching and restoring images” on page 155.

The photo quality is affected by a lens distortion.

Choose Adjust ➔ Barrel Distortion Correction, Adjust ➔ Fisheye Distortion Correction, or Adjust ➔ Pincushion Distortion Correction. For more information about lens distortions, see “Correcting lens distortions” on page 128.
Problem

An unwanted pattern appears on a scanned image.

A scanned photo appears old and faded.

How to solve it from the Edit tab

Choose Adjust  ▶ Add/Remove Noise  ▶ Moire Pattern Removal.

Choose Adjust  ▶ Color  ▶ Fade Correction.

Rotating images

You can rotate an image by 90 degrees to change its orientation to landscape (horizontal) or portrait (vertical). If your camera contains sensors that tag photos taken in portrait orientation, your photos are automatically rotated to the correct orientation.

You can rotate an image in PaintShop Pro.

You can also rotate an image to any angle by specifying a degree of rotation or by rotating it interactively on the canvas. For information about rotating an image to straighten it according to reference points within the image, such as the horizon, see “Straightening images” on page 117.

You can also apply lossless rotation to JPEG images from the Manage tab while retaining all of the original image data.

To rotate an image

Edit tab

• Select an image, and perform a task from the following table.

To

Do the following

Rotate an image 90 degrees clockwise or counterclockwise

Choose Image  ▶ Rotate Right, or choose Image  ▶ Rotate Left.

Rotate an image to a specific angle

Choose Image  ▶ Free Rotate. In the Free Rotate dialog box, choose either the Right option or the Left option to set the direction of rotation. In the Degrees group box, choose the Free option, and type or set a value in the control.

Rotate an image interactively

On the Tools toolbar, choose the Pick tool. Rotate the image by dragging the rotation handle (the square connected by a line to the rotation pivot point). The cursor changes to two curved arrows when it is positioned over the rotation handle.

You can also rotate an image by clicking the Rotate Right or Rotate Left button on the Standard toolbar.

If you want to change the center of rotation before you interactively rotate the image, hold down Ctrl, and drag the rotation pivot point (the circle at the center of the image) to a new position.
Cropping images

You can remove unwanted portions of an image to create stronger compositions or to draw attention to another area of the image. PaintShop Pro helps you crop by providing presets to common image ratios, such as 1:1, 2:3, 3:4, and 16:9.

Cropping reduces the amount of hard drive memory required for storing the image. In addition, cropping can improve color corrections by eliminating extraneous areas of color. If a photograph requires both cropping and color correction, you should crop the image first and then apply the color correction.

Before printing an image, you can crop it to a specific print size. In addition, you can select an area within the image and then crop the image to the selection borders. You can also create a new image from the cropped area.

Floating toolbar for the Crop tool

You can rotate the image relative to the crop rectangle to straighten an image or angle the image for artistic reasons.

You can crop an image based on its opaque (nontransparent) areas. Cropping in this way is useful when you want to eliminate transparent areas at the edges of the image. You can also set the crop area to cover the opaque area of a single layer or of an entire image.

Composition guides

To further strengthen your composition when you crop, you can use composition guides. Composition guides include Rule of Thirds, Golden Spiral, Golden Ratio, Diagonal, Triangle, and a standard grid.
The Golden Spiral composition guide can be used to find a pleasing balance between the main focal point and any secondary focal points or negative (non-focal) space.

**Enhance photo options**

You can apply the following image enhancement options directly from the Floating Crop toolbar:

- One Step Photo Fix
- Depth of Field

**Important!** Cropping permanently removes the image area outside the crop rectangle. To preserve the original photo, use the Save As command, and save the cropped version of your image to a new filename.

**To crop an image**

**Edit tab**

1. On the Tools toolbar, choose the **Crop** tool.
   
   By default, the crop rectangle appears on the image, and the area outside the crop rectangle is shaded.

2. Adjust the crop area size by dragging any of the handles or edges. To reposition the crop rectangle, place the cursor inside and drag.
   
   You can use a preset crop size by choosing an option from the **Presets** drop-list on the floating toolbar for the Crop tool, or from the drop-list on the Tool Options palette.
   
   If you want to use a composition guide, on the floating toolbar click the **Composition Guide** button (this button toggles the guide on and off), and choose a guide from the drop-list.

3. When you’re ready to crop the image, click the **Apply** button on the Tool Options palette or on the floating toolbar for the Crop tool.

You can also

**Apply the crop by using your mouse or keyboard**

- Double-click inside the crop rectangle, or press **Enter**.

**Set the size of the crop rectangle on the Tool Options palette**

- Specify the **Pixel Dimensions** values in the **Width** and **Height** controls or the **Document size** values in the **Width**, **Height** and **Units** controls.
You can also

Constrain the crop area to its current proportions

Mark the **Maintain aspect ratio** check box on the Tool Options palette. This option is available only for custom-defined crop rectangles.

Rotate the crop rectangle by 90 degrees

Click the **Rotate Crop Rectangle** button on the floating toolbar.

Rotate the image relative to the crop rectangle by a specific angle

Specify the degree of rotation in the **Angle** controls on the Tool Options palette.

Freely rotate the image relative to the crop rectangle

Drag the square end of the rotation handle or a corner point. This feature can be helpful when, for example, you want to straighten and then crop a crookedly scanned photo.

Move the rotation axis point of the image relative to the crop rectangle

Specify the X and Y coordinates under **Pivot** on the Tool Options palette or hold down **Ctrl** and then drag the axis point of the rotation handle (the circular end of the handle) to a new position.

Move the rotation axis point to the center of the crop rectangle

Click the **Center Pivot** button on the Tool Options palette.

Modify the crop shading area

Choose **File** ➤ **Preferences** ➤ **General Program Preferences**, choose **Transparency and Shading** from the list, and specify the settings for **Color** and **Opacity** in the **Shading** group box.

Turn off the shading option

Choose **File** ➤ **Preferences** ➤ **General Program Preferences**, choose **Transparency and Shading** from the list, and unmark the **Enable crop shade area** check box in the **Shading** group box.

Turn off the floating toolbar for the Crop tool

Choose **File** ➤ **Preferences** ➤ **General Program Preferences**, choose **Transparency and Shading** from the list, and unmark the **Enable floating crop toolbar** check box in the **Shading** group box.

Choose not to display the crop rectangle when the tool is selected

Choose **File** ➤ **Preferences** ➤ **General Program Preferences**, choose **Transparency and Shading** from the list, and unmark the **Automatically display crop rectangle** check box in the **Shading** group box.

Clear the crop area

Click the **Clear** button on the floating toolbar for the Crop tool.
After cropping an image, you may notice that the Width and Height values on the Tool Options palette are each set at 0.100. These settings do not reflect the cropped image size. To see the image size dimensions after cropping, choose Image ➤ Image Information.

When rotating, the crop rectangle can extend beyond the bounds of the image. The area outside the original image will be transparent or filled with the background, depending on which layer you are working on. If you want to fill in these areas, Magic Fill is a good option. For more information, see “Using Magic Fill to erase image areas” on page 165.

To apply Enhance Photo options to an image when you crop
1. On the Tools toolbar, choose the Crop tool 📊.
2. Do any of the following before you crop the image:
   • Turn One Step Photo Fix on or off by clicking the corresponding icon.
   • Turn Depth of Field on or off by clicking the corresponding icon. To set the area you want in focus, click and hold the icon to display a grid, click the area of the grid where you want to maintain focus, and adjust the Blur and Size sliders.
3. Drag on the image to set your crop area, using any of the other crop settings you want.
4. When you’re ready to crop the image, click the Apply button ✓ on the floating toolbar for the Crop tool.

To crop an image for printing
Edit tab
1. On the Tools toolbar, choose the Crop tool 📊.
2. Define the crop area by dragging within the image.
3. On the Tool Options palette, mark the Specify Print Size check box.
   Note: If the Specify Print Size check box is marked, the image resolution changes when you change the values in the Height and Width controls of either the Pixel Dimensions or the Document size. The current resolution appears to the right of the Units drop-list.
4. In the Units drop-list, select Inches or Centimeters.
   Note: The Pixels option is unavailable for this method of cropping.
5. Type or set the dimension values in the Height and Width controls.
   The final crop area is sized as specified, and the image resolution is reduced or increased as needed.
6. Click the Apply button ✓ on the Tool Options palette, or on the floating toolbar for the Crop tool.

To crop to a selection in an image
Edit tab
1. Make a selection in the image.
2. Choose Image ➤ Crop to Selection.

The selection can be any shape. PaintShop Pro positions a crop area rectangle around irregularly shaped selections.

If you crop to a selection that is feathered, the current background color fills in the feathered region of the selection.

You can also crop to the selection by choosing the Crop tool 📊 and clicking Current Selection 📊 in the Snap crop rectangle to group box on the Tool Options palette. Adjust the crop area, and click Apply ✓.
To crop to an opaque area in a layer or an image
Edit tab

1 Click the Crop tool.
2 On the Tool Options palette, select one of these options from the Snap Crop Rectangle To group box:
   • Layer Opaque — selects opaque areas in the current layer
   • Merged Opaque — selects opaque areas in all layers
3 Adjust the crop area.
4 Click the Apply button on the Tool Options palette, or on the floating toolbar for the Crop tool.

If any layer has a solid-color (nontransparent) background, the entire layer or image is selected as the crop area.

Opaque areas that are not rectangular may have transparent areas remaining after cropping.

To create a new image by cropping
Edit tab

1 On the Tools toolbar, choose the Crop tool.
2 Define the crop area by dragging within the image.
3 Click the Crop as new image button on the Tool Options palette, or on the floating toolbar for the Crop tool.

A new image is created, but the cropped image remains unchanged, and remains the active image.

This feature offers a useful method of creating individual images from a scan of multiple images. For example, if you scan four photos in one scanning session, you can use this feature to quickly separate each photo into an individual image file.

Straightening images

You can easily straighten crooked images by aligning a straightening bar with an image feature. PaintShop Pro rotates the image so that this straightening bar is perfectly horizontal and vertical. This feature is especially useful when an image has a strong vertical or horizontal feature, such as a building or horizon.

The Straighten tool lets you position a straightening bar within an image.
To straighten an image

Edit tab

1. On the Tools toolbar, choose the **Straighten** tool.

   A straightening bar with end handles appears on the image.

2. Drag each handle of the straightening bar to align it with the part of the image that you want to straighten.

3. On the Tool Options palette, choose one of the following options from the **Mode** drop-list:
   - **Auto** — automatically straightens the image based on the position of the straightening bar
   - **Make vertical** — rotates the image to make the straightening bar vertical
   - **Make horizontal** — rotates the image to make the straightening bar horizontal

4. Click the **Apply** button.

You can also

- Straighten a single layer
  - Before clicking the **Straighten** tool, click the layer name on the Layers palette.

- Straighten all layers in the image
  - Mark the **Rotate all layers** check box on the Tools Options palette.

- Choose a specific angle for the straightening bar
  - Type or set a value in the **Angle** control on the Tools Options palette.

- Crop the edges of the image to make it rectangular after straightening
  - Mark the **Crop image** check box on the Tools Options palette.

- Fill the edge areas of your image with the background color
  - Unmark the **Crop image** check box on the Tools Options palette.

💡 You can also double-click the image to apply the command.

Correcting photographic perspective

When you take pictures of tall or wide objects, the resulting photographs may have perspective distortion — that is, the objects may seem to be leaning or angled. This distortion occurs when the camera is at an angle to the subject.

By using the Perspective Correction tool, you can fix perspective distortion, such as the angled sides of a building. You can also fix photographic perspective in an entire layer by using the Pick tool.

![Using the Perspective Correction tool changes the angle of the building.](image)
To correct perspective in a photo
Edit tab
1 On the Tools toolbar, choose the Perspective Correction tool.
   A bounding box with corner handles appears on the image.
2 On the Tool Options palette, choose settings for the following controls:
   • Grid lines — lets you type or set the number of gridlines to display
   • Crop image — recrops the image to a rectangular shape after the perspective is applied
     Note: Marking the Crop image check box deletes the areas of the image that fall outside the rectangle.
3 Drag each handle to the corner of the object that should be rectangular.
4 Click the Apply button.

You can also apply the command by double-clicking the image.
To reset the perspective correction box to the original rectangle, click Cancel on the Tool Options palette.

To correct perspective in an image layer
Edit tab
1 On the Layers palette, select the layer to correct.
2 Choose View ➤ Grid to display the gridlines.
   The gridlines help you correct lines in your photograph that should be vertical or horizontal.
   Note: To adjust the grid settings, choose View ➤ Change Grid, Guide, Object & Snap Properties, and then use the controls on the Grid page of the dialog box.
3 On the Tools toolbar, choose the Pick tool.
   A bounding box appears around the entire layer.
   Note: It may be helpful to expand the image window so that you can see all of the corner handles of the current layer. To expand the image window, drag from a corner or side.
4 Hold down Ctrl, and drag a corner handle on the selected layer.
   The image is updated when you finish dragging. Continue adjusting the perspective until the image looks correct.

If the correction causes some image data to fall outside the image canvas, you can restore that data by increasing the size of the canvas. For more information about changing the canvas size, see “Resizing the canvas” on page 184.

Making basic photo corrections automatically
If you are not sure what adjustments to make to a photo, you can apply either the One Step Photo Fix command or the Smart Photo Fix command and see if you like the results. The One Step Photo Fix command automatically applies a predetermined set of color balancing and sharpening corrections to your photo — all you need to do is select the command. If you want the option of fine-tuning the same corrections before applying them, you can use the Smart Photo Fix command.
You can use the One Step Photo Fix command to improve the exposure and white balance of images quickly and easily.

The advanced options of the Smart Photo Fix feature let you adjust white balance by identifying the neutral areas in the photo (black, gray, and white), which are used as sampling points. The advanced options also let you modify the darkest and lightest pixels of the photo without affecting the photo’s white balance.

To apply basic corrections with One Step Photo Fix
Edit tab

1. Choose Adjust  One Step Photo Fix.
   
   After a brief pause, several basic corrections are applied to your photo.
   
   The corrections applied are identical to what would be applied by accepting the suggested settings of the Smart Photo Fix feature.
   
   If you are not satisfied with the changes made to your photo, choose Edit  Undo. Then, choose Adjust  Smart Photo Fix, and adjust the available settings. You can also try using other Adjust menu commands, such as Brightness and Contrast  Curves or Brightness and Contrast  Levels.

To fine-tune basic corrections with Smart Photo Fix
Edit tab

1. Choose Adjust  Smart Photo Fix.
   
   The Smart Photo Fix dialog box appears. In the upper portion of the dialog box, the Before pane shows the original photo. The After pane shows how the photo would appear after applying the suggested set of basic adjustments.
   
   Perform one or more tasks from the following table, and click OK.
To adjust images, do the following:

**To brighten or darken the photo**
In the **Brightness** group box, type or set a value in the **Overall**, **Shadows**, and **Highlights** controls, or adjust their corresponding sliders.

**Note:** Positive settings brighten the photo, and negative settings darken the photo.

**To increase or decrease saturation**
Type or set a value in the **Saturation** control, or adjust the slider.

**Note:** Positive settings make colors more vibrant; negative settings make colors less vibrant.

**To sharpen the edges of the photo**
Type or set a value in the **Focus** control, or adjust the slider.

You can reset all settings to their initial values by clicking **Suggest Settings**, or to null settings by clicking the **Reset to Default** button.

To use advanced settings of the Smart Photo Fix feature, mark the **Advanced Options** check box.

**To use the advanced options of Smart Photo Fix**

**Edit tab**

1. In the Smart Photo Fix feature dialog box, mark the **Advanced Options** check box. Additional controls appear in the dialog box.
2. Perform one or more tasks from the following table, and click **OK**.

<table>
<thead>
<tr>
<th>To use advanced settings</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Use sampling points for color balancing</strong></td>
<td>Mark the <strong>White Balance</strong> check box. The photo’s neutral areas (black, gray, and white) are identified in the Before pane. <strong>Note:</strong> Some photos have no black, gray, or white areas, so no sampling points are identified.</td>
</tr>
<tr>
<td><strong>Ignore the photo’s sampling points</strong></td>
<td>Unmark the <strong>White Balance</strong> check box. Re-marking the check box restores the sampling points.</td>
</tr>
<tr>
<td><strong>Add sampling points</strong></td>
<td>Click areas in the Before pane that should be black, gray, or white. The After pane is updated.</td>
</tr>
<tr>
<td><strong>Delete a sampling point</strong></td>
<td>Click the sampling point in the Before pane. Both the Before and After panes are updated.</td>
</tr>
<tr>
<td><strong>Darken the darkest pixels in the photo</strong></td>
<td>Drag the <strong>Black</strong> slider to the right, or specify a value in the control beside the slider.</td>
</tr>
<tr>
<td><strong>Lighten the lightest pixels in the photo</strong></td>
<td>Drag the <strong>White</strong> slider to the right, or specify a value in the control beside the slider.</td>
</tr>
</tbody>
</table>
To avoid introducing errors in white balance when you add sampling points, do not click any color other than black, white, or gray (for example, do not click a region that you know is blue). Click only the points that you know should be black, white, or gray. Sampling points cannot be dragged or moved.

The histogram is for display only — you cannot drag or adjust any part it. The gray portion represents the original (Before) photo, and the red overlay portion reflects the adjustments. The black triangle moves in tandem with the Black slider, and the white triangle moves in tandem with the White slider. For more information about the Histogram, see “Adjusting brightness, contrast, and clarity” on page 131.

**Brightening images**

Lighting problems are common in photography. Photos taken in bright light often lack detail in the shadow areas. If your photo’s background is too dark, or if the difference between the photo’s light and dark areas is too great, you can lighten the darker, underexposed areas. You can adjust saturation, which is the purity or vividness of a color.

For more information about other brightening features, including Fill Light/Clarity, see “Adjusting brightness, contrast, and clarity” on page 131.

**To brighten a photo**

*Edit tab*

1. Choose **Adjust ➤ Fill Flash**.
2. Type or set a value from 0 to 100 in the **Strength** control to determine how much to lighten the darker areas.
3. Type or set a value in the **Saturation** control to determine the overall saturation of the photo’s colors.
   
   Values less than 0 reduce saturation; values greater than 0 increase saturation.
4. Click **OK**.

   If a photo has areas that are too light as well as areas that are too dark, choose **Adjust ➤ Fill Flash**, and then choose **Adjust ➤ Backlighting**.

**Darkening images**

Sometimes photos have too much lighting from the background, which essentially washes out the entire image. A similar problem involves photos with too much flash on the subject. You can darken the bright, overexposed areas of a photo.

**To darken a photo**

*Edit tab*

1. Choose **Adjust ➤ Backlighting**.
2. Type or set a value from 0 to 100 in the **Strength** control to determine how much to darken the lighter areas.
3. Type or set a value in the **Saturation** control to determine the overall saturation of the photo’s colors.
   
   Values less than 0 reduce saturation; values greater than 0 increase saturation.
4. Click **OK**.

   If a photo has areas that are too light as well as areas that are too dark, choose **Adjust ➤ Fill Flash**, and then choose **Adjust ➤ Backlighting**.
Removing purple fringe

A common problem of digital photos is the presence of purple halos surrounding overexposed areas of a color photo. This problem, which is called fringing, is often quite evident when a bright sky appears in the background of a photo and faint purple halos appear on the edges of the photo subject. With PaintShop Pro, you can quickly identify this problem and remove it from your photo.

To remove purple fringe from a photo

Edit tab

• Choose Adjust  One Step Purple Fringe Fix.

After a brief pause, your photo is automatically adjusted.

Removing digital noise

The term “noise” as it relates to photos refers to small specks of color that interfere with image clarity. These specks are usually caused by poor lighting conditions or the limitations of the sensor in your digital camera. For example, when you zoom in on a photo of a clear blue sky, you may see tiny specks of orange, red, purple, green, or other colors.

PaintShop Pro gives you three powerful commands for removing noise from your photos: One Step Noise Removal, AI Denoise, and Digital Noise Removal. When you use a noise removal command, the program analyzes your photo, identifies the noise artifacts, and applies corrections based on these identified areas, while preserving the important edge details of your photo.

The image on the left looks grainy because of digital camera noise. The image on the right appears smoother and less grainy after the noise has been removed.

• One Step Noise Removal: You can automatically apply noise correction to your photo with the One Step Noise Removal command.
• AI Denoise: You can use artificial intelligence (AI) to analyze the noise in your image. By choosing Enhanced, you can specify the strength of the noise correction.
• Digital Noise Removal: Lets you control more precisely how corrections are applied.

Digital Noise Removal command

The Digital Noise Removal command gives you more control over the removal of digital camera noise in your photos.

Photos taken with the same camera tend to have noise in the same areas. You can create a preset to apply the same corrections to all of these photos.

This command could be an ideal solution in the following scenarios:
• For photos that most likely contain excessive noise (such as a video whiteboard capture), using the command with low settings can help make the overall image clearer without excessive blurring.
• For photos taken with normal settings, this command is best used only on key areas needing correction, such as image artifacts surrounding the subject area.
• For photos containing areas that you want to exclude from the noise correction, you can specify the color ranges to preserve or discard. For example, you may want to protect skin tones in a photo from having any correction applied to them. You can define as many of these protected regions as you like.
To remove digital noise quickly
Edit tab
• Choose Adjust ➤ One Step Noise Removal.
  After a brief pause, the noise is automatically removed.

To use AI Denoise to analyze and remove noise
Edit tab
1 Choose Adjust ➤ AI Denoise.
2 Do one of the following:
   • Choose Simple for a fast fix.
   • Choose Enhanced, and drag the Strength slider to set the level of denoise applied.
     If you know that using GPU improves processing time, mark the GPU Acceleration check box.
3 Click OK.
  The green progress bar at the bottom of the application window lets you track the progress of the AI analysis.

To use advanced options for removing digital noise
Edit tab
1 Choose Adjust ➤ Digital Noise Removal.
   The Digital Noise Removal dialog box appears.
   Note: The three crosshairs appear on the image preview in the Remove Noise tabbed area. The crosshairs represent noise samples located in the image's light, midtone, and dark areas. You can move a crosshair by dragging the bounding box in the before pane, which moves the sampling region accordingly.
2 In the Remove Noise tabbed area, mark the Link detail sizes check box to adjust the Small, Medium, and Large settings in proportion to each other.
3 Type or set values in the Small, Medium, and Large controls.
   These controls define the amount of correction to apply to small, medium, and large noise patterns.
4 Type or set a value in the Correction blend control to determine to what degree the corrected image will be blended in with the original.
   The blending values range from 0.0 (no noise reduction) to 100.0 (full processing of the entire image). The default value is 70.
5 Type or set a value in the Sharpening control to determine the degree of sharpening, if any, to apply to the image after the noise reduction is applied.
   The default value is 0.
6 Click OK.

You can also

Set corrections for light, midtone, and dark areas independently
   Unmark the Link detail sizes check box, and type or set values in the Small, Medium, and Large controls.

View close-ups of sampling regions
   Click a crosshair to see the area close up in the Before and After panes.

Add a sampling region crosshair
   Drag in the Before pane.

Delete a sampling region crosshair
   In the Before pane, drag a corner of the correction box to its diagonally opposite corner.
You can have a maximum of 10 sampling regions. You should avoid sampling an image edge, or pure black or pure white regions of the image, which can result in excessive smoothing.

The Digital Noise Removal command is not designed to remove moire patterns. For information about removing moire patterns, see “To remove moire patterns” on page 141.

To save settings as a preset specific to an image and camera, mark the Camera preset check box and click the Save Preset button. When the Camera preset check box is marked, the Load Preset drop-list displays only previously saved camera presets, not the standard presets. To save settings as a standard preset, unmark the Camera preset check box, and click the Save Preset button.

For best results when working with JPEG images, choose Adjust ▶ Add/Remove Noise ▶ AI Artifact Removal before using a noise removal command.

To protect image areas from noise corrections
Edit tab

2. Click the Protect Image tab.
3. In the Before pane, pan and zoom as necessary so that you can view the region you want to protect.
4. Hold down Ctrl, and drag over the region you want to protect.
   Note: Holding down Ctrl does not create a corresponding crosshair in the image window of the Remove Noise tabbed area.
5. In the Selected hue range group box, type or set values in the Hue and Range controls.
   Note: The existing settings reflect the area sampled. You can manually adjust the hue knob by dragging it inside the ring.
6. In the Protect selected hue range group box, drag any of the seven graph handles downward to apply less correction and smoothing to the corresponding segment of the hue range.
   For example, dragging just the middle graph handle to the bottom of the graph completely suppresses the midtone of that hue range.
   Note: The graph handles cannot be dragged laterally.
7. Click OK.

You can remove color adjustments for a selected color range by clicking Reset Current. To remove all color adjustments, click Reset All.

Removing chromatic aberrations

Chromatic aberration occurs when the camera records incorrect colors within the image. In conventional film cameras, chromatic aberration is usually caused by a lens defect. In digital cameras, several factors can contribute to chromatic aberration, including the following:

• The inherent lens aberration in the camera may cause fuzziness at image edges. Photos taken with telephoto and zoom lenses are more prone to contain chromatic aberrations because of the way in which digital cameras capture light rays far from the optical axis.
• The auto-exposure feature of the camera, which estimates the correct exposure setting, may cause sensor blooming.
• Different colors may be caught by different camera sensor elements, and they may combine to make one pixel. This process is called demosaicing.
• Activities such as artifact removal, noise removal, and sharpening may occur inside the camera after processing.

In your own digital photos, you may notice chromatic aberrations in photos with the following content:

• the sky seen through tree branches or leaves
• the edges of interior doors or windows through which bright light enters
• fireworks or city lights
• fluorescent light fixtures or bare lightbulbs
• sun or light reflections on water
• reflections on chrome
• the edges of backlit objects
• sunlit white shirts against a dark background

After identifying these types of color defects, you can reduce or eliminate them.

**To remove chromatic aberrations from a photo**

*Edit tab*

1. Choose Adjust ➤ Chromatic Aberration Removal.
   The Chromatic Aberration Correction dialog box appears.
2. Ensure that the Before and After panes are visible at the top of the dialog box.
3. Set the zoom control in the dialog box to at least 200%.
   The zoom control is located below the Before and After panes. Zooming to 200% helps target the problem areas in the photo.
4. Click the Pan button ( ), and pan the image to set a viewable image area in the Before pane.
5. In the Before pane, drag to define the area needing correction.
   **Note:** The area needing correction is called the sample box. You can create up to 10 sample boxes. Each sample box is represented as “Sample n” (where n is a number from 1 to 10) in the List of Samples area in the center of the dialog box. Each sample listing has a color swatch to the left, indicating a color average for the sampled area.
6. Choose a sample entry from the List of Samples area.
7. Type or set a value in the Range control to determine the color range of the active sample, which affects the pixel range to be corrected.
   The range you specify is represented in the color box directly above the Range control.
8. Type or set a value in the Radius control to determine the size of the sample’s aberration.
   **Note:** The default value is 10. Values from 4 to 20 usually produce the most acceptable results. Values greater than 10 are useful on sampling areas that enclose sensor blooming aberrations. Values less than 10 are useful when you are removing 1- or 2-pixel aberrations caused by demosaicing, as well as when you are working on images of less than one megapixel. Set the Radius control to the smallest setting that effectively removes the aberration.
9. Click OK.

**You can also**

- **Resize a sample box** Drag a sample box handle.
- **Delete a sample box** Drag a corner onto its diagonally opposite corner, and stop dragging when the corners meet.
- **Delete a sample box button in the dialog box** Click a sample box, and click Remove.
- **Delete a sample box** Drag a corner onto its diagonally opposite corner, and stop dragging when the corners meet.
- **Display the affected image areas** Mark the **Show Differences** check box. The affected areas appear in the After pane as white areas on black. Brighter areas represent greater degrees of correction.
- **Preview the results on the image** Mark the **Show Differences** check box, and make sure the **Preview on Image** check box is marked.

To create more than 10 sample boxes, you can apply the corrections and then restart the effect.
You can automatically create a new layer on which the corrected image resides by marking the Result on New Layer check box. This option protects your original image on its own layer. If you do not mark this check box, the corrections are applied on the same layer as the original image.

You can limit the number of “false corrections” by making a selection and then marking the Result on New Layer check box. You can also use this command on separate layers of an image.

Using Lens Correction to fix distortion, chromatic aberration, and vignetting

Lens Correction is a collection of controls that lets you fix a range of lens-related issues in your photos. You can use Lens Correction with photos saved to JPEG, TIFF, and RAW formats.

Lens Correction can be used to fix a variety of issues, including Barrel distortion (above).

Distortion

While zoom lenses with a large range of focal lengths show the greatest lens distortion, even fixed-focal length, or “prime” lenses, can cause some types of distortion. Barrel and Pin Cushion distortion are caused from nonuniform magnification of the image from the outside of the image (perimeter) to the center. Barrel distortion refers to a rounded effect in an image caused by diminished lens magnification towards the edges. Pin cushion distortion refers to a pinched or narrowed appearance at the sides of an image. Each lens has its own Barrel and Pin Cushion characteristics, and by analyzing a set of images from a lens at all focal lengths, this distortion can be removed. Corel PaintShop Pro includes profiles for several hundred lens and camera combinations.

Chromatic aberration

Chromatic aberration is also a type of distortion (known as CA distortion) caused by the nonuniform bending of light as it passes through a lens. The result is a color fringe (often appears purple) and uneven colors around edge details in high contrast scenes, such as branches of a tree silhouetted against a bright sky. Zoom lenses, particularly at their widest and longest focal lengths, exhibit the most severe distortion. CA distortion can be removed by adjusting the data for the colors that show the most distortion.

Vignetting

Vignetting is the darkening of corners of an image due to light fall-off, and can be caused by optics (the lens itself), the sensor (many sensors are less sensitive to light that hits the sensor at an angle), or from other causes like a filter or lens hood that shades the corners of
an image. Vignetting can be corrected by brightening the corners of an image. In some cases, photographers chose to add a vignette effect to their photos to draw focus to the central subject. You can use **Lens Correction** to remove an unwanted vignette or add a vignette. When you add a vignette, it is always performed on the cropped portion of the image, while correcting vignette is applied to the entire original frame.

You can use the **Automatic** or the **Manual** controls to correct issues.

**Automatic** lets correct your images based on camera and lens profiles built into PaintShop Pro.

- **Enable correction** — toggles Lens Correction on or off
- **Auto crop** — scales the image to fill the image frame
- **Manufacturer** drop-list — automatically displays the camera manufacturer (if the image has metadata) or you lets you set it manually
- **Model** drop-list — automatically displays the camera model (if the image has metadata) or lets you set it manually
- **Lens** drop-list — automatically displays the lens used to capture the photo (if the image has metadata).

**Important!** In some cases the application chooses the closest match, based on data. You can change incorrect guesses by selecting the correct manufacturer, camera model, and lens in the lists. These determine which profile to use when removing distortion.

- **Focal Length** — shows the focal length setting for the lens at the time the image was taken (if the image has metadata) or you can set it manually

**Manual** lets you manually enter correction parameters instead of using correction parameters from profiles built into the application. This is useful for lenses that are not yet in the lens correction database.

If you want more information about lens correction parameters in general, and how to determine them, you can visit the following third-party site: [http://wiki.panotools.org/Lens_correction_model](http://wiki.panotools.org/Lens_correction_model).

**Chromatic Aberration correction** includes the following controls:

- **R / C** — controls the shift of colors along the Red/Cyan color axis
- **B / Y** — controls the shift of colors along the Blue/Yellow color axis

**Vignette correction** includes the following:

- **Enable vignette correction** — toggles vignette correction on or off. This control is independent of other types of lens correction.
- **Strength** — controls how light (positive or right) or dark (negative or left) the correction will be
- **Radius** — controls how far into the image the correction should extend

**To use Lens Correction**

1. Do one of the following:
   - For RAW images, open the image in the **Camera RAW Lab**, and click the **Lens** tab.
   - For JPEG and TIFF images, click **Adjust** ⇒ **Lens Correction**.

2. Click **Automatic** or **Manual**, and modify the settings you want.

**Correcting lens distortions**

Camera lenses can create distortions in photos. These distortions appear most often in wide-angle photos, in close-up photos taken with cameras with fixed focal ranges, and in photos taken with cameras that have low-quality lenses (such as disposable cameras).

**Important!** It is strongly recommended that you correct the lens distortion in a photo before cropping it.

**Types of lens distortion**

PaintShop Pro can correct three common types of lens distortion, all of which make straight lines appear curved:

- **Barrel distortion** — Photo looks pushed out at the centre. For distortion corrections to work properly, the axis of the camera lens must coincide with the centre of the image.
- **Fisheye distortion** — Photo looks as though it has been pasted onto a sphere or blown up like a balloon. The edges of the photo look compressed.
- **Pincushion distortion** — Photo looks pushed in at the center
To correct barrel distortion
Edit tab
1 Choose Adjust ➤ Barrel Distortion Correction. The Barrel Distortion Correction dialog box appears.
2 Look for curved lines in the image, and straighten them by typing or setting an appropriate value in the Strength control.
3 Click OK.

By marking the Preserve central scale check box, you can add or remove pixels from the image, which changes the scale at the center of the picture. Changes to the width and height of the original image are displayed in the Result Size group box.

To correct fisheye distortion
Edit tab
1 Choose Adjust ➤ Fisheye Distortion Correction. The Fisheye Distortion Correction dialog box appears.
2 Remove the distortion by typing or setting an appropriate value in the Field of View control.
3 Click OK.

By marking the Preserve central scale check box, you can add or remove pixels from the image, which changes the scale at the center of the picture. Changes to the width and height of the original image are displayed in the Result Size group box.

To correct pincushion distortion
Edit tab
1 Choose Adjust ➤ Pincushion Distortion Correction. The Pincushion Distortion Correction dialog box appears.
2 Look for lines in the image that are curved, and type or set a value in the Strength control until they become straight.
3 Click OK.

By marking the Preserve central scale check box, you can add or remove pixels from the image, which changes the scale at the center of the picture. Changes to the width and height of the original image are displayed in the Result Size group box.

Adjusting white balance

You can often improve a photo dramatically by adjusting the colors. Different types of lighting, cameras, and the processing that occurs inside the camera can cause incorrect coloring in photos. Scanned images may have unnatural color casts.

To create natural-looking colors and remove any color cast in your image, you can use the various color-balancing commands in PaintShop Pro. By applying the commands to a selection or an entire image, you can do the following:
• tonally balance a photo’s colors without affecting the luminance of the photo
• increase or decrease the red, blue, or green color channel by a percentage of the given channel
• restore color and contrast to faded photos
• create a photographic negative by replacing each pixel color with its opposite (for example, replace blue with yellow, black with white, yellow with blue, white with black, and so on)
• adjust the amount of red, green, and blue in your image as a way to make color corrections by changing the overall color cast
To adjust white balance
Edit tab
2. Mark the Smart White Balance check box. This allows PaintShop Pro to evaluate and make minor corrections to the image automatically.
3. Drag the temperature slider to the left for cooler colors (more blue), or to the right for warmer colors (more orange).
4. Click OK.

If you know what color temperature the photo should be, you can set precise tonal balance values by marking the Advanced Options check box and typing or setting the temperature values in the Temperature and Tint controls in the White Balance group box. You can tweak the colors by adjusting values in the Temperature and Tint controls in the Enhance White Balance group box.

To mix color channels
Edit tab
1. Choose Adjust  Color  Channel Mixer. The Channel Mixer dialog box appears.
2. Do one of the following:
   • To maintain a color image, select a color channel to edit from the Output channel drop-list.
   • To change the image to monochrome (which looks like grayscale but has a color depth of 16 million colors), mark the Monochrome check box. Grey appears in the Output channel drop-list.
3. In the Source Channels group box, type or set values in the Red, Green, and Blue controls, or adjust the corresponding sliders, to change the percentage of that color in the channel.
   For example, if you are editing the Red channel and set the Red control to 50%, the amount of red in the image is reduced to 50% of its original amount.
4. Adjust the Constant slider.
   The slider is originally set at zero. If you want to darken the color channel, drag the slider to the left. If you want to brighten the color channel, drag the slider to the right.
5. Click OK.

To correct faded colors
Edit tab
1. Choose Adjust  Color  Fade Correction. Drag in the Before pane to center an important part of the image (such as a face).
2. Adjust the value in the Amount of correction control until the image looks the most natural.
   The default value is 45.
   Note: Use the minimum value that produces a good correction. If you apply too much correction, highlight and shadow areas may lose detail, and objects may blend together.
3. Click OK.

To create a photographic negative
Edit tab
• Choose Image  Negative Image.

To change color cast
Edit tab
The Red/Green/Blue dialog box appears.

2 In the Red, Green, and Blue controls, type or set a value to change the percentage for each color. A value of 0% preserves the original value. To add more of a color, use a positive number. To remove some of a color, use a negative number. Note: Reducing the amount of blue adds a yellow cast to the image, reducing the amount of green adds a magenta cast to the image, and reducing the amount of red adds a cyan cast to the image.

3 Click OK.

Adjusting brightness, contrast, and clarity

PaintShop Pro lets you adjust the brightness, contrast, and clarity in your photos. Contrast is the difference between the photo’s lightest and darkest pixels. Clarity lets you adjust the level of detail in the image by analyzing contrast within localized areas.

By applying the commands to a selection or an entire image, you can do the following:
• manually adjust the brightness and contrast
• give your photo a crisp, focused look to make the subject more prominent
• adjust the individual brightness values in your image
• adjust the brightness and contrast of an image in unison
• adjust the highlights, midtones, and shadows to provide smooth tonal transitions
• correct the exposure
• distribute the lightness values of pixels more evenly across the lightness spectrum from black to white
• increase the overall contrast when the histogram does not cover the entire lightness spectrum
• make adjustments to the brightness, contrast, and gamma in the image
• create a purely black-and-white image

Histograms

A histogram lets you display the tonal range of an image and redistribute the balance of highlights, midtones, and shadows. In other words, the histogram can reveal whether your photo is underexposed, overexposed, or exposed properly.

Many digital cameras offer a histogram display on the camera’s LCD, and some cameras even let you adjust the scene’s histogram before you take the photo.

PaintShop Pro has various commands that display the histogram in the dialog box. These commands include Curves, Levels, the advanced mode of Smart Photo Fix, and Histogram Adjustment.

Note the following when you look at a histogram:
• The left portion of the histogram reveals how much of the photo is black or nearly black.
• The right portion of the histogram reveals how much of the photo is white or nearly white.

The graph in the Histogram Adjustment dialog box displays the number of pixels for each value of the selected channel. The vertical axis represents the number of pixels and ranges from zero to the highest number of pixels in the graph. The horizontal axis represents the value of the selected channel, from 0 to 255.

You can display a Histogram for an image at any time by choosing View ➤ Palettes ➤ Histogram.

To change brightness or contrast
Edit tab
   The Brightness/Contrast dialog box appears.
2. Type or set a value in the Brightness control.
   A positive number lightens the photo; a negative number darkens the photo. A value of zero preserves the original setting.
3. Type or set a value in the Contrast control.
   A positive number increases contrast; a negative number decreases contrast. A value of zero preserves the original setting.
4. Click OK.

You can use the zoom control in the dialog box to set your view of the image in the Before and After panes.

To brighten dark areas and adjust clarity
Edit tab
1. Choose Adjust ➤ Brightness and Contrast ➤ Fill Light/Clarity.
   The Fill Light/Clarity dialog box appears.
2. Type or set a value in the Fill Light control.
   Higher values lighten the darkest areas of the photo; a value of zero preserves the original setting.
3. Type or set a value in the Clarity control.
   A positive number increases detail; a negative number decreases detail and focus. A value of zero preserves the original setting.
4. Click OK.

To enhance depth and clarity
Edit tab
1. Choose Adjust ➤ Brightness and Contrast ➤ Local Tone Mapping.
   The Local Tone Mapping dialog box appears.
2. Type or set a value in the Strength control.
   Use the smallest value that produces a satisfying result. Values that are too high cause unwanted artifacts to appear in the photo.
3. Click OK.

You can use the zoom control in the dialog box to set your view of the image in the Before and After panes.

To change color channel brightness
Edit tab
1. Choose Adjust ➤ Brightness and Contrast ➤ Curves.
   The Curves dialog box appears.
2. In the Channel drop-list, select one of the following color channel options:
   • RGB — lets you edit the red, green, and blue channels in a combined histogram.
• **Red** — lets you edit the red channel only
• **Green** — lets you edit the green channel only
• **Blue** — lets you edit the blue channel only

3 Drag points on the graph to adjust the relationship between the input levels (the brightness of the original pixels) and the output levels (the brightness of the corrected pixels).

As you drag a curve point, the point’s original and modified values for pixel lightness are displayed in the upper-left corner of the histogram graph. The original or input value appears on the left, and the modified or output value appears on the right.

4 Click **OK**.

You can also

**Add a point to the curve**

Click where you want to add the point to the curve.

>Note: Adding more points to the curve lets you adjust its shape more precisely.

**Remove a curve point**

Drag the point to the left or right off the graph.

**Move the active curve point more precisely**

Press or hold down the **Arrow** keys.

**Automatically adjust the photo’s contrast**

Click the **Contrast** button in the **Auto** group box.

>Note: You can use this button when you’re satisfied with the photo’s colors but want to improve the contrast.

**Automatically adjust the photo’s white balance**

Click the **Color** button in the **Auto** group box.

>Note: You can use this button to find a black point and a white point in the photo automatically.

**Automatically adjust both the contrast and the color**

Click the **Levels** button in the **Auto** group box.

**Set your own black, gray, or white point**

Click the black, gray, or white dropper in the **Colors** group box to activate the dropper color. Then, move the cursor into the Before pane and click what you know to be a black, gray, or white point.

The After pane (and the image window if the **Preview on Image** check box is marked) is updated.

**Automatically determine the appropriate black, gray, or white point**

Hold down **Alt**, and position the cursor in the Before pane (or in the image window). As you move the cursor over dark, medium, and light areas, the appropriate color dropper becomes active. Click to set that point.

**Specify histogram clipping limits for the Auto Contrast, Color, and Levels buttons**

Click the **Options** button. In the Auto Color Options dialog box, set percentage values for the **Lower Limit** and **Upper Limit** controls, and for the **Strength** control.

>Note: For the **Lower Limit** and **Upper Limit** controls, higher values result in stronger automatic settings, and lower values result in weaker automatic settings. Lower **Strength** values result in less clipping.
You can also

Reset all modified values to the original values Click the Reset button located near the Colors droppers.
You can also click the Reset to Default button located next to the Save Preset button.

You can use the zoom control in the dialog box to set your view of the image in the Before and After panes.

To adjust brightness and contrast simultaneously

Edit tab

1 Choose Adjust ➤ Brightness and Contrast ➤ Gamma Correction.
   In the Gamma Correction dialog box, the graph shows the gamma curves for the three colors. If the three colors have the same gamma value, there is one white line representing the three colors. If the gammas are different values, there is a line for each color.
   The left side of the graph represents the shadows of the image; the right side represents the highlights.
2 Do one of the following:
   • To adjust the brightness and contrast in unison, mark the Link check box.
   • To change the color balance of the image rather than the brightness and contrast, unmark the Link check box.
3 Adjust the Red, Green, and Blue values, drag the sliders or type new numbers in the edit boxes.
   A value of 1 indicates the original gamma. If colors are linked, increasing the value lightens the image and decreasing the value darkens the image. If colors are not linked, increasing or decreasing a individual color value increases or decreases the amount of that color in the image.
4 Click OK.
   The Gamma Correction command can result in an image looking somewhat flat. You may want to increase the contrast after correcting the gamma. For more information, see “To change brightness or contrast” on page 132.
To apply this command to a selection, the image must be a 16 million (24-bit) color image (otherwise the command is applied to the entire image). To increase the color depth of an image, see “To increase the color depth of an image” on page 383.

To adjust a photo’s highlights, midtones, and shadows

Edit tab

1 Choose Adjust ➤ Brightness and Contrast ➤ Highlight/Midtone/Shadow.
   The Highlight/Midtone/Shadow dialog box appears.
2 Choose one of the following options:
   • Absolute adjustment method — sets the absolute positions of the 25% histogram point (Shadows), the 50% histogram point (Midtones) and the 75% histogram point (Highlights). Typical values are about 35 for Shadow, 50 for Midtone, and 65 for Highlight, but they vary, depending on the photo. Increasing the value lightens the region, and decreasing the value darkens the region.
   • Relative adjustment method — adjusts the lightness levels relative to their original states. Positive values lighten the region, and negative values darken it.
3 Type or set values in the Shadow, Midtone, and Highlight controls.
4 Click OK.
   You can use the zoom control in the dialog box to set your view of the image in the Before and After panes.
To correct exposure by using the histogram

Edit tab

1. Choose Adjust  Brightness and Contrast  Histogram Adjustment.

The Histogram Adjustment dialog box appears.

2. In the Edit group box, choose one of the following options:

- Luminance — lets you set the lightness values of the image to correct contrast
- Colors — lets you choose a color channel to edit

If you choose the Colors option, you must choose a color from the drop-list.

3. In the Load Preset drop-list, choose Default.

The default values represent no adjustment to the image.

4. Adjust the Low slider.

On the left side of the histogram, look for a gap between the left edge and the point where the graph starts to rise. A gap shows that the darkest pixels in the image are not completely black. Drag the Low slider (the black triangle) to the point where the graph rises. The Low control displays the low position (from 0 to 255). The bottom control displays the percentage of pixels that are between zero and the low value; contrast for these pixels will be lost. As a general rule, keep the Low value lower than 0.1%.

5. Adjust the High slider.

On the right side of the histogram, look for a gap between the right edge of the window and the point where the graph decreases to zero pixels. If there is a gap, drag the High slider (the white triangle) to that point on the graph. This action changes the lightest pixels in the image to white. As a general rule, keep the High value lower than 0.1%.

6. Adjust the Gamma slider.

If the overall image is too dark or too light, adjust the gamma, which is a standard measure of change in an image’s contrast. To lighten the image, increase the gamma by dragging the Gamma slider (the gray triangle) to the right. To darken the image, decrease the gamma by dragging the Gamma slider to the left.

7. Adjust the Midtones slider.

Note: If the graph has peaks on the left and right sides and contains low points in the center, the midtones need to be compressed. Shadows and highlights must be expanded to reveal the information they contain. Photography subjects that are too close to the camera appear brightly illuminated against a dark background. To compress the midtones, drag the Midtones slider up.

If the graph peaks in the center and has a low number of pixels at the left and right sides, expand the midtones by dragging the Midtones slider down.

8. Click OK.

You can create artistic effects by using the Output Max and Output Min controls on the left side of the histogram. The Max slider is the white circle within a gray square; the Min slider is the black circle within a gray square. To darken the image’s lightest pixels, drag the Max slider down. To lighten the image’s darkest pixels, drag the Min slider up. Even though you are dragging sliders along the vertical axis, the Max and Min values (from 0 to 255) affect the horizontal axis. All pixels outside the range are converted so that they fall within the range. You can choose another color component from the Edit drop-list and make similar adjustments.

To distribute lightness across a photo

Edit tab

- Choose Adjust  Brightness and Contrast  Histogram Equalize.

To increase contrast by stretching the histogram

Edit tab

- Choose Adjust  Brightness and Contrast  Histogram Stretch.

The Histogram Stretch command pulls the darkest pixel down to black and the lightest pixel up to white. This command does not affect images that already span from pure black to pure white. If the original image has pixels that are very close to black and
white, using this command will have a very small effect. If the original image is very flat (nothing close to black or white), using this command will have a strong effect.

To adjust brightness, contrast, and gamma simultaneously

Edit tab

1. Choose Adjust ➤ Brightness and Contrast ➤ Levels.

The Levels dialog box appears.

2. In the Levels group box, choose the color channel to adjust from the Channel drop-list:
   • RGB — lets you edit the red, green, and blue channels in a combined histogram
   • Red — lets you edit the red channel only
   • Green — lets you edit the green channel only
   • Blue — lets you edit the blue channel only

3. Adjust the black, gray, or white diamond sliders, or set values in the controls beneath them.
   • To darken the darkest pixels in the photo, drag the black diamond slider to the right (or set a value in the numeric control).
   • To adjust the photo’s midtones, drag the gray (middle) diamond to the left or right (or set a value in the numeric control).
   • To lighten the lightest pixels in the photo, drag the white diamond slider to the left (or set a value in the numeric control).
   **Note:** To see which pixels are being clipped as you drag either the black or white diamond slider, hold down Ctrl as you drag. The After pane displays the clipped colors.

4. Click OK.

You can also

- **Automatically adjust the photo’s contrast**

  Click the Contrast button in the Auto group box.
  **Note:** You can use this button when you’re satisfied with the photo’s colors but want to improve the contrast.

- **Automatically adjust the photo’s white balance**

  Click the Color button in the Auto group box.
  **Note:** You can use this button to find a black point and a white point in the photo automatically.

- **Automatically adjust both the contrast and the color**

  Click the Levels button in the Auto group box.

- **Set your own black, gray, or white point**

  Click the black, gray, or white dropper in the Colors group box to activate that dropper color. Then, move the cursor into the Before pane (or into the image window), and click what you know to be a black, gray, or white point.

  The After pane (and the image window if the Preview on Image check box is marked) is updated.

- **Automatically determine the appropriate black, gray, or white point**

  Hold down Alt, and position the cursor in the Before pane (or in the image window). As you move the cursor over dark, medium, and light areas, the appropriate color dropper becomes active. Click to set that point.

- **Specify histogram clipping limits for the Auto Contrast, Color, and Levels buttons**

  Click the Options button. In the Auto Color Options dialog box, set percentage values for the Lower Limit and Upper Limit controls and for the Strength control.
  **Note:** For the Lower Limit and Upper Limit controls, higher values
You can also

result in stronger automatic settings, and lower values result in weaker automatic settings. Lower Strength values result in less clipping.

Reset all modified values to the original values

Click the Reset button located near the Colors droppers.

You can also click the Reset to Default button located next to the Save Preset button.

Changes you make in the Auto Color Options dialog box are applied when you use the Contrast, Curves, and Levels buttons in the Auto group box of the Curves dialog box.

You can use the Levels command to spread out the histogram for a photo taken with an improper exposure. You may find it helpful to use this command before using the Curves command.

You can use the zoom control in the dialog box to set your view of the image in the Before and After panes.

To convert a photo’s pixels to black and white

1. Choose Adjust ▶ Brightness and Contrast ▶ Threshold.
   The Threshold dialog box appears.
2. Type or set a value for pixel lightness in the Threshold control to specify which pixels to change to white (those above the threshold) and which pixels to change to black (those below the threshold).
   Values range from 1 to 255. Lower values produce more white pixels; higher values produce more black pixels.
3. Click OK.

You can use the zoom control in the dialog box to set your view of the image in the Before and After panes.

Adjusting hue and saturation

Saturation is the purity or vividness of a color, expressed as the absence of white. A color with 100% saturation contains no white. A color with 0% saturation corresponds to a shade of gray. A hue is the property that defines a particular color. For example, blue, green, and red are all hues.

Hue refers to the actual color (such as red or yellow). Saturation is the vividness of the color. Imagine bright orange, which is a highly saturated color. As the saturation is reduced (keeping the hue and lightness unchanged), the orange color becomes brownish, then taupe, and finally a middle neutral gray (after the saturation has been reduced to zero). Reducing the saturation drains the color away, leaving just the grayscale component. Taupe and mauve are low-saturation colors because they are quite neutral, with just a touch of color. Apple red and banana yellow are high-saturation colors. Saturation is a measure of how different a color is from a neutral gray of the same brightness.

In digital images, increasing the saturation can give the image brilliant color and “punch,” but too much saturation distorts colors and causes problems such as unnatural-looking skin tones. You can use the Vibrancy control to target only those areas that are low on saturation without affecting the rest of the image. For example, you can boost color in less saturated parts of an image without significantly altering skin tone.

PaintShop Pro gives you four ways to alter the hue and saturation of a selection or of an entire image:

- You can replace all colors with a single color and saturation while leaving the lightness values unchanged. You can create sepia tones, like the brownish tones seen in old photographs, and other single-color effects.
• You can shift all colors and change their strength and lightness. Changing the hue shifts all pixels in an image to a different point on the color wheel. For example, if you change the red pixels to green, the green pixels turn to blue, and the yellow pixels turn to cyan. Adjusting the saturation changes the amount of gray in a color. (The level of gray increases as the saturation decreases.) Adjusting the lightness changes color brightness.

• You can replace one or more colors. For example, you can shift all greens to blues. You can also change the saturation or the lightness. When you adjust these values, all colors (both original and shifted colors) are adjusted.

• You can adjust only the least saturated colors in the image using the Vibrancy control and thus leave unaltered those pixels that are already relatively saturated. The result is that you will get a general improvement in the saturation in the colors of an image but not to the extent where colors become unrealistically bright. The Vibrancy control is recommended for adding saturation to portraits as it offers some protection for skin tones and is less likely to oversaturate and destroy the subject’s skin color.

To create a duotone photo

Edit tab

1. Choose **Adjust** ➤ **Hue and Saturation** ➤ **Colorize**.

   The Colorize dialog box appears.

   **Note:** To create a duotone with more subtle color changes, do the following before choosing the Colorize command: Choose **Image** ➤ **Greyscale**, and then choose **Image** ➤ **Increase Color Depth** ➤ **RGB - 8 bits/channel**.

2. Type or set values in the following controls:
   - **Hue** — specifies the hue to which all current colors are changed
   - **Saturation** — specifies the saturation of the selected hue

3. Click **OK**.

To adjust hue, saturation, and lightness

Edit tab

1. Choose **Adjust** ➤ **Hue and Saturation** ➤ **Hue/Saturation/Lightness**.

   • The Hue/Saturation/Lightness dialog box appears. The outer color ring in the dialog box represents the original values of colors in the image. The adjusted values will appear on the inner color ring.

2. In the **Edit** drop-list, do one of the following:
   - To edit all colors simultaneously, choose **Master**.
   - To edit a specific color range, choose **Reds**, **Yellows**, **Greens**, **Cyans**, **Blues**, or **Magentas**.

   If you choose to edit a color range, you can use the control ring that appears between the inner and outer color rings to modify the range to be edited. To change the range width, drag the two outer points on the control ring. To change the area in which the adjustment builds to full effect, drag the two inner bars (the full effect will be applied between the bars). To move the adjustment area, drag the white circles.

3. Adjust the **Hue** slider.

   The **Hue** value represents the change from the original pixel color as the number of degrees of rotation around the 360-degree color wheel. A positive value indicates a clockwise rotation, and a negative value indicates a counterclockwise rotation. For example, when the **Hue** value is 180, blue becomes yellow, and green becomes magenta.

4. Adjust the **Saturation** slider.

   Dragging the slider up increases the saturation; dragging it down decreases the saturation. Values range from –100 to 100. A value of 0 preserves the original setting.

5. Adjust the **Lightness** slider.

   Dragging the slider up increases the lightness; dragging it down decreases the lightness. Values range from –100 to 100. A value of 0 preserves the original setting.

6. Click **OK**.

You can turn an image into a duotone (two-color) image by marking the **Colorize** check box, which converts the image to grayscale. To colorize the image, you can select a hue and adjust the saturation and lightness values.
To shift colors

Edit tab

1. Choose Adjust ➤ Hue and Saturation ➤ Hue Map.

   The Hue Map dialog box appears.

   **Note:** In the Hue Shift group box, the top row of color boxes shows 10 original colors, and the bottom row of color boxes shows the shifted colors. Each color is represented as degrees of rotation around the 360-degree color wheel.

2. Adjust the slider for each color that you want to shift.

3. Click OK.

You can also

- Change the saturation of all colors: Type or set a value from –100 to 100 in the Saturation shift control.
- Change the lightness of all colors: Type or set a value from –100 to 100 in the Lightness shift control.
- Reset the colors to their default settings: In the Load Preset drop-list, choose Default.

To boost the color of the least saturated parts of an image

Edit tab

1. Choose Adjust ➤ Hue and Saturation ➤ Vibrancy.

   The Vibrancy dialog box appears.

2. Click the arrow next to Preview to open the Preview panel.

3. If you want to preview the result directly in the image, mark the Preview on Image check box.

4. Adjust the Strength slider.

   Dragging the slider to the right increases the saturation of the least saturated colors while leaving highly saturated colors unaltered; dragging it to the left decreases the saturation.

   Values range from –100 to + 100. A value of 0 preserves the original settings of the image.

5. Click OK.

Adding or removing noise

The term “noise” in photography refers to unwanted single pixels or groups of pixels that do not belong in the photo. The noise can be caused by various factors. Usually, the problems are either introduced electronically by the camera itself or caused by file formats such as JPEG. Noise appears as colored specks within the photo. You can display the noise best by zooming in. For example, you might see specks of red, pink, green, and yellow in a photo of a clear blue sky.

PaintShop Pro gives you many ways to remove various types of noise, and it even lets you add noise to an otherwise “clean” photo. You can make the following corrections by applying them to a selection or an entire image:

- You can reduce the detail in an image and add a grainy texture. By adding a small percentage of noise to an image, you can reduce the appearance of small imperfections and scratches that cannot be removed with other tools.
- You can find and eliminate small scratches that are either lighter or darker than the surrounding area.
- You can remedy a common problem seen in video capture images in which even- and odd-numbered scan lines are recorded at different rates. The problem is usually noticed if the subject was moving when the image was captured. Note that removing scan lines may make noise more visible.
- You can restore a JPEG image to its original appearance. When you save a file to the JPEG format from any software package (such as scanning software), the file information is compressed to create a smaller file. The compression may produce any of the following artifacts: halos or color leakage beyond the edges of objects, checkerboard patterns on smooth backgrounds, or blocky areas.
- You can remove undesirable patterns from scanned images. This problem sometimes occurs in scanned photographs printed on textured paper.
• You can remove single-pixel specks that are mostly white or black. The brightness of each pixel is analyzed and then compared to the surrounding pixels to determine whether it should be removed.

• You can remove noise in a photo without losing details in edges within the photo. For example, you can preserve the edges of facial features while correcting a blotchy complexion.

• You can remove small random specks or areas of noise that are distinctly different from the surrounding area. The intensity of each pixel is adjusted to the median intensity of surrounding pixels. (The median intensity is the middle value, not the average,) in the range of values.) To preserve object edges, you can use the Median Filter command. With this command, you can apply more adjustment to a pixel that differs greatly from surrounding pixels than to a pixel that is similar to surrounding pixels. You can specify the number of surrounding pixels to use in the calculation. If you choose a large number of pixels, more noise is removed, so more detail is lost.

• You can remove multipixel black or white specks, such as those caused by dust on film or video.

• You can remove noise or specks in an image while preserving details in textures. For example, you can preserve textures in clothing while removing noise from another area (such as a person’s face).

In addition, you can use the One Step Noise Removal and the Digital Noise Removal commands. For more information, see “To remove digital noise quickly” on page 124 and “To use advanced options for removing digital noise” on page 124.

To add noise
Edit tab

1 Choose Adjust  ➤ Add/Remove Noise ➤ Add Noise.
The Add Noise dialog box appears.

2 Choose a noise pattern option:
   • Random — creates a granular effect that adds texture
   • Uniform — changes the color of the noise to resemble the original pixels
   • Gaussian — makes most of the noise resemble the original pixels more than the Uniform option

3 Type or set a value in the Noise control to set the percentage of noise to add.

4 Click OK.

💡 You can use black-and-white noise pixels by marking the Monochrome check box. To use colored pixels, unmark the check box.

To remove scratches automatically
Edit tab

1 Choose Adjust  ➤ Add/Remove Noise ➤ Automatic Small Scratch Removal.
The Automatic Small Scratch Removal dialog box appears.

2 Mark one or both of the following check boxes:
   • Remove dark scratches — removes scratches that are darker than the background
   • Remove light scratches — removes scratches that are lighter than the background

3 In the Local Contrast Limits group boxes, type or set values in the Lower and Upper controls to set the contrast between a scratch and its background.
   Increase the Lower control setting to just below where scratches reappear. Decrease the Upper control setting to just above where the scratches reappear.

4 In the Strength group box, choose an option to set the strength of the scratch removal:
   • Mild
   • Normal
   • Aggressive
   Note: Select the lowest setting that removes scratches. Examine all areas of the image to make sure that important details are not lost.

5 Click OK.
To limit the correction to a specific area, make a selection. The command works better when applied to a selection than when applied to an entire image.

**To sharpen video capture images**  
*Edit tab*

1. Choose **Adjust > Add/Remove Noise > Deinterlace**.  
The Deinterlace dialog box appears.
2. In either the Before or After pane at the top of the dialog box, drag to pan to the image area where the scan lines are most apparent.
3. In the **Scanlines to retain** group box, choose an option that specifies whether to retain the odd-numbered or even-numbered scan lines.
4. Click **OK**.

You should apply the Deinterlace command before you resize the image. Resizing adds or removes pixels from the image, which makes it more difficult to identify scan lines. If your image has already been resized, you must return it to the original size as closely as possible so that each scan line is 1 pixel high. Using the zoom control in the dialog box, you can zoom until you can see how many pixels make up one scan line, and then you can resize the image so that each scan line is 1 pixel high. For example, if the enlarged image has scan lines that are 2 pixels high, you would resize it by 50 percent. Note that resizing the image causes it to lose clarity.

**To remove artifacts from JPEG images**  
*Edit tab*

1. Choose **Adjust > Add/Remove Noise > AI Artifact Removal**.
2. Click **OK**.

It might take a few moments to complete the AI (artificial intelligence) analysis and apply the results, depending on the size and complexity of the image and your computer system.

The green progress bar at the bottom of the application window lets you track the progress of the AI analysis.

You can apply the **AI Artifact Removal** command to a file in any format. For example, if you have saved a JPEG file to the PaintShop Pro (.pspimage) format, you can still apply the command.

Because JPEG compression discards image information, the ability to restore JPEG images is limited.

**To remove moire patterns**  
*Edit tab*

1. Choose **Adjust > Add/Remove Noise > Moire Pattern Removal**.  
The Moire Pattern Removal dialog box appears.
2. Type or set a value in the **Zoom** control to magnify the image until you can see the fine patterns clearly.
3. Type or set a value in the **Fine details** control to set the level of pattern removal.  
   Change the value one number at a time until the pattern disappears. Higher values may blur the image, so use the lowest value that removes the pattern.
4. Use the zoom control in the dialog box to reduce the image magnification until you can see bands or color blotches clearly in the After pane.  
   **Note:** Although bands or blotches may be visible when the image is displayed at a setting of 100%, they may be easier to see at lower settings.
5. Change the value one number at a time in the **Remove bands** control until any color bands or blotches become less visible (they may not disappear completely). To avoid desaturation of small objects, use the lowest value possible.
6. Click **OK**.
After you have removed the moire pattern, you may be able to use the **Sharpness** commands in the **Adjust** menu to restore detail and remove blurriness without reintroducing the pattern. The **Sharpness** commands work best when you choose a **Fine details** setting in the Moire Pattern Removal dialog box that is slightly higher than needed to remove the pattern.

**To remove single-pixel specks**

**Edit tab**
1. Select the area in the photo that contains the specks.
2. Choose **Adjust** ➤ **Add/Remove Noise** ➤ **Despeckle**.
   
   The selection is despeckled.

**To remove noise while preserving edges**

**Edit tab**
1. Select the area that contains the noise you want to remove.
2. Choose **Adjust** ➤ **Add/Remove Noise** ➤ **Edge Preserving Smooth**.
   
   The Edge Preserving Smooth dialog box appears.
3. Type or set a value in the **Amount of smoothing** control.
   
   Choose the smallest amount of smoothing that removes the specks while retaining image detail. You cannot enter a value lower than 1.
4. Click **OK**.

Although you can apply the **Edge Preserving Smooth** command to the entire image, the command works best when you select the problem area.

**To remove distinct areas of noise**

**Edit tab**
1. Select the area that contains the noise you want to remove.
2. Choose **Adjust** ➤ **Add/Remove Noise** ➤ **Median Filter**.
   
   The Median Filter dialog box appears.
3. Type or set a value in the **Filter Aperture** control to choose the number of surrounding pixels to include in determining the median pixel intensity.
   
   Values range from 3 to 31 in odd-numbered increments.
   
   **Note:** To preserve image details, choose the smallest filter that removes the noise. For single-pixel colored specks, set the filter to 3.
4. Click **OK**.

Although you can apply the **Median Filter** command to the entire image, the command works best when you select the problem area.

**To remove multipixel specks**

**Edit tab**
1. Select the area that contains the specks.
2. Choose **Adjust** ➤ **Add/Remove Noise** ➤ **Salt and Pepper Filter**.
   
   The Salt and Pepper Filter dialog box appears.
3. Type or set a value in the **Speck size** control to set the minimum size, in pixels, of the largest speck that can be completely removed. The value is always an odd number.
4. Type or set a value in the **Sensitivity to specks** control to set how different an area must be from its surrounding pixels to be considered a speck.
Although you can apply the Pepper Filter command to the entire image, the command works best when you select the problem area.

You can remove all specks that are smaller than theSpeck size value by marking theInclude all lower speck sizes check box.

You can intensify the strength of the correction by marking theAggressive action check box.

**To remove noise while preserving textures**

*Edit tab*

1. Select the area that contains the noise you want to remove.
2. Choose Adjust ➤ Add/ Remove Noise ➤ Texture Preserving Smooth.
   The Texture Preserving Smooth dialog box appears.
3. Type or set a value in the Amount of correction control to set a value for the strength of the correction.
   At lower values, a small amount of noise is removed, but textured areas are preserved. At higher values, more noise is removed, but textured areas may not be fully preserved.
4. Click OK.

Although you can apply the Texture Preserving Smooth command to the entire image, the command works best when you select the problem area.

**Applying a depth of field effect with AI Portrait Mode**

*AI Portrait Mode* uses artificial intelligence (AI) to detect people in your photos and apply a natural-looking depth of field effect to the background. You can control the depth of field effect by adjusting the amount of blur, the bokeh style, the focus range, and feather.

![AI Portrait Mode was used to draw attention to the family in the photo and reduce background distractions by applying a pleasing depth of field effect that blurs the background.](image)

**To apply a depth of field effect to portraits with AI Portrait Mode**

1. Open a portrait-style photo.
2. Click Adjust ➤ Artificial Intelligence ➤ AI Portrait Mode.
   It will take a few moments for the AI to analyze the image and to open the AI Portrait Mode window.
3. Review the red overlay that appears on the background areas.
Note: A buffer area appears around the subject. This buffer helps maintain clear edges for the subject when the blur is applied to the background.

If you need to fine-tune the selection, in the Brush Mode area, choose one of the following:

- **Add to Subject** — removes the red overlay from the subject
- **Remove from Subject** — adds the red overlay to areas that you want to identify as background

If you want to adjust the buffer area globally, drag the Expand Border slider.

For information about all the available controls, see “Fine-tuning a selection with the Refine Brush” on page 203.

Note: To change the brush size, drag the Brush Size slider or hold down Alt while dragging in the preview window.

When you are satisfied with the selection, click **Next**.

If you want to change the default result, you can adjust any of the following controls:

- **Blur** — lets you adjust the amount of blur
- **Aperture shape** — lets you choose between Circular Aperture Shape or Hexagonal Aperture Shape for pleasing bokeh effects in images that have points of light
- **Feather edge** — lets you adjust the softness of the edge along the subject
- **Focus range** — lets you fine-tune the size of the area in focus. This can be used to create a sense of background depth.

Click **Done**.

A new layer is created for the resulting image.

You can switch between the **Add to Subject** and **Remove from Subject** brush modes by right-clicking as you drag.

### Controlling depth of field

You can control the depth of field to create an area of focus that draws attention to the subject in your photo. For example, in a photo of a person surrounded by a field of flowers, you can defocus (blur) the surrounding flowers while retaining a clear focus on the person.
In photography, depth of field refers to the area that appears to be in focus. Different factors affect the depth of field, including the distance between the camera and your subject, the lens speed, and your camera’s aperture setting. Most automatic cameras use the smallest aperture setting possible to ensure that most of the image is in focus.

Selecting an area of focus

In PaintShop Pro, you can quickly choose an area of focus by creating a circular or rectangular selection, or you can trace around an area to create an irregularly shaped selection. You can also invert a selection. For more information about selections, see “Creating selections” on page 197.

Adjusting the blurred area

You can control the amount of blur applied to the area outside the selection, and you can adjust the transition between the area in focus and the blurred areas. PaintShop Pro also lets you choose between circular or hexagonal aperture shapes. The aperture shape can affect light patterns that appear in the out-of-focus areas. This effect is called bokeh, and it is most noticeable in small pinpoints of light on a dark background.

To create an area of focus by using the Depth of Field effect

Edit tab

1. From the Edit tab, select the area that you want to keep in focus.
   For information about selecting image areas, see “Creating selections” on page 197.
2. Click Adjust Depth of Field.
   The Depth of Field dialog box appears.
3. Move the Blur slider to adjust the amount of blur applied to the out-of-focus area.

You can also

Invert the selected area
Mark the Invert check box.

Control the aperture shape for the blurred area
Click one of the following buttons:
• Circular Aperture Shape

You can apply the Depth of Field effect to draw attention to the subject in your photo.
You can also

Adjust the transition between the area in focus and the blurred area

- **Hexagonal Aperture Shape**

  Move the **Feather edge** slider. Moving the slider to the right increases the feathering; moving the slider to the left decreases the feathering. Note that a setting of 0 produces a hard, undefined edge, which is probably not what you want. In general, do not set this slider to less than 2 or 3.

Fine-tune the size of the area in focus

- **Focus range**

  Move the **Focus range** slider to the left to shrink the area in focus. Move the slider to the right to expand the area in focus to the edge of the selection.

If you don’t have a pre-existing selection, you can select an area of focus using any of the selection tools in the Depth of Field dialog box: Circular, Freehand, Rectangular, or Raster Selection.

Make your selection slightly larger than the area you want to keep in focus, and then fine-tune the edge of the selection by using the **Focus range** slider.

Blurring images

PaintShop Pro provides several commands that let you apply a blurring effect to your images. You can apply the following corrections to a selection, a layer, or an entire image:

- You can remove noise that occurs throughout an image by adjusting the intensity of each pixel to the average intensity of its surrounding pixels. You can also remove color dithering that results from increasing the color depth of a paletted image to 24-bit.
- You can remove noise by applying smooth transitions and decreasing the contrast in your image.
- You can adjust the strength of the blurring effect by blending a specific number of pixels incrementally, following a bell-shaped curve. The blurring is dense in the centre and feathers at the edges.
- You can use a fixed exposure time to simulate taking a picture of a moving object.
- You can simulate a photo taken while spinning a camera in circles, or while zooming in quickly at a very slow shutter speed.

Why would I blur an image on purpose?

You can use blurring commands to soften a selection or an image, to retouch a photo, or to remove noise in an image. The Blur commands smooth transitions and decrease contrast by averaging the pixels near the edges and near areas of significant color transitions. You can apply any of the Blur commands multiple times to the same image to increase the blurring effect.

To apply blurring based on nearby pixel intensity

1. **Edit tab**

   Choose Adjust > Blur > Average.

   The Average dialog box appears.

2. **Type or set a value in the Filter aperture control.**

   Values range from 3 to 31 in odd-numbered increments. The higher the value, the greater the blur.

3. Click OK.
To apply minimal blurring
Edit tab
• Choose Adjust ▶ Blur ▶ Blur.

To double the effect, choose the command again.

To apply moderate blurring
Edit tab
• Choose Adjust ▶ Blur ▶ Blur More.

To double the effect, choose the command again.

To apply Gaussian blurring
Edit tab
1  Choose Adjust ▶ Blur ▶ Gaussian Blur.
   The Gaussian Blur dialog box appears.
2  Type or set a value in the Radius control to specify the distance (radius) within which dissimilar pixels are blurred.
   Values range from 0.00 to 100.00.
3  Click OK.

To apply motion blurring
Edit tab
1  Choose Adjust ▶ Blur ▶ Motion Blur.
   The Motion Blur dialog box appears.
2  In the Angle group box, drag the angle dial, or type or set a value in the control, to set an angle from which the blurring is applied.
3  Type or set a value in the Strength control.
   Values range from 1 to 100%. Lower values lessen the effect; higher values intensify the effect.
4  Click OK.

To apply radial blurring
Edit tab
1  Choose Adjust ▶ Blur ▶ Radial Blur.
   The Radial Blur dialog box appears.
2  In the Blur Type group box, choose one of the following options:
   • Spin — blurs pixels circularly around the image center
   • Zoom — blurs pixels away from the center
   • Twirl — blurs pixels in a spiraling manner. You can set the degree of the twirl by typing or setting a value in the Twirl degrees control.
3  In the Blur group box, type or set a value in the Strength control.
   Lower values lessen the effect; higher values intensify the effect.
   If you need to squeeze the radius to fit the image, mark the Elliptical check box. This option produces elliptical blurring on rectangular images and has no effect on square images. Circular blurring is produced when the check box is unmarked.
4  In the Center group box, type or set a value in the following controls to affect the center of the image:
   • Horizontal offset % — lets you set the horizontal center point of the blur
   • Vertical offset % — lets you set the vertical center point of the blur
• **Protect center %** — lets you determine how much to diminish blurring at the image center. Higher values increase the radius of the unblurred center area.

5 Click OK.

**Sharpening images**

Most digital photos need some level of sharpening because of the softness introduced in the capturing process of digital cameras. Camera movement at the moment of capture can also produce photos in need of sharpening, and digital cameras are more prone than film cameras to producing slightly out-of-focus photos. In most cases, this problem is easy to fix.

Color, tonal, and resizing corrections tend to soften your photo, so it is best to apply any necessary sharpening before you print, share, or archive your photos.

PaintShop Pro provides sharpening commands that improve blurry photos by increasing the contrast of adjacent pixels. The following sharpening commands can be applied to a selection, a layer, or the entire photo:

• You can sharpen high-frequency details, such as edges, while ignoring low-frequency details, such as large structures, gradients, and background colors.

• You can improve image focus and clarity by increasing the contrast between adjacent pixels, particularly along edges in the photo.

• You can sharpen the mid- to high-contrast edges in the image without enhancing noise, as is often done with professional color correction.

**To apply high-frequency sharpening**

**Edit tab**

1 Choose **Adjust ▶ Sharpness ▶ High Pass Sharpen**.

   The High Pass Sharpen dialog box appears.

2 Type or set a value from 0.00 to 250.00 in the **Radius** control to specify the distance (radius) within which dissimilar pixels are sharpened.

   **Note:** Photos with close-up subjects and softer details usually require higher **Radius** settings; photos with lots of fine detail usually require lower **Radius** settings.

3 Type or set a value from 0 to 100 in the **Strength** control to specify the overall strength of the command.

4 In the **Blend mode** drop-list, choose one of the following options to determine how the high-frequency sharpened areas are blended into the original image area:

   • **Overlay** — removes the neutral tones in the image and makes edge details stand out

   • **Hard Light** — produces greater contrast than the **Overlay** option

   • **Soft Light** — produces a softer-looking photo

5 Click OK.

**To apply minimal sharpening**

**Edit tab**

• Choose **Adjust ▶ Sharpness ▶ Sharpen**.

   To double the effect, choose the command again.

**To apply moderate sharpening**

**Edit tab**

• Choose **Adjust ▶ Sharpness ▶ Sharpen More**.

   To double the effect, choose the command again.
To apply low-frequency and high-frequency sharpening
Edit tab

1. Choose Adjust ▶ Sharpness ▶ Unsharp Mask.
   The Unsharp Mask dialog box appears.
2. Type or set a value from 0.01 to 100.00 in the Radius control to specify the distance (radius) within which dissimilar pixels are sharpened.
   Note: Photos with close-up subjects and softer details usually require higher Radius settings; photos with lots of fine detail usually require lower Radius settings.
3. Type or set a value from 1 to 500 in the Strength control to specify the overall strength of the command.
4. Type or set a value from 0 to 100 in the Clipping control to specify the lightness values that adjacent pixels must have in order to be sharpened.
5. Click OK.

Softening images

Softening a photo creates a dreamy, glossy effect that mimics the effect produced by a high-quality soft-focus lens. This effect is often used for magazine covers and glamour photos. Crisp, sharp photos appear warmer when you add a soft focus.

PaintShop Pro provides the following softening methods:
• You can apply a soft-focus camera lens effect to the photo or selection.
• You can apply a uniform, soft blur to the photo or selection.

To apply a soft focus to a selection or image
Edit tab

1. Choose Adjust ▶ Softness ▶ Soft Focus.
   The Soft Focus dialog box appears.
2. In the Focus group box, type or set a value in the following controls:
   • Softness — determines the strength of the adjustment. At lower percentages, the photo is softened by only a small amount. At higher percentages, the photo appears blurred.
   • Edge importance — determines how much softening to apply to edge details within the photo. At lower percentages, the edges are softened. At higher percentages, the edge details are retained, so less softening is applied to them.
3. In the Halo group box, type or set a value in the following controls:
   • Amount — determines the strength of the halo effect. At lower values, the halo is added only to very bright areas in the photo. At higher values, a halo effect is created around all bright areas.
   • Halo size — determines the size of the halo. At lower values, the halo is small. At higher values, the halo effect is large.
   • Halo visibility — determines the strength of the halo visibility. At lower values, the halo effect is subtle. At higher values, the halo effect is more obvious.
4. Click OK.

   You can soften bright areas in the photo’s background by marking the Include scattered light check box.

To apply minimal softening
Edit tab

• Choose Adjust ▶ Softness ▶ Soften.

To apply moderate softening
Edit tab

• Choose Adjust ▶ Softness ▶ Soften More.
Removing haze

You can remove haze from an image. It’s great for landscape photography when haze causes low contrast and low saturation. You can also improve photos taken in rainy and foggy weather.

To remove haze from an image

2. Type or set a value in the following controls:
   - **Strength** — sets the overall strength of haze reduction. Lower values lessen the effect; higher values intensify the adjustment.
   - **Block Size** — sets the extent of the area adjacent to a pixel used to calculate how the adjustment is performed. Higher values draw data from more neighboring pixels, ideal for correcting image-wide haze; lower values draw data from smaller image areas, which retains finer details and can produce better contrast.
   - **Guider** — balances haze reduction and local contrast in an image, with higher values removing more haze but potentially impacting local contrast, and lower values preserving finer details at the expense of lesser haze removal.
   - **Fill Light** — lightens the darkest areas of the photo at higher values and preserves the original setting at a value of 0.
3. Click OK.

Resizing images

After you adjust your image, you can resize it. It’s important to understand how resizing affects image pixels.

Effect of resizing on image resolution

Pixels have no set physical size. Each pixel represents one sample of a single color. When an image is resized, the number of pixels in the image may be reduced or increased, which causes the image to be resampled. Resampling changes the file size.

Print resolution is defined as the number of pixels per inch (ppi). A higher print resolution creates smaller printed pixels and therefore a smaller printed image. A lower print resolution creates larger printed pixels and a larger printed image. Resizing can be used to do the following:

- change the print resolution and print size while preserving the number of pixels and file size (no resampling)
- change the number of pixels and file size while preserving the print resolution and print size (resampling)
- change the print resolution, print size, number of pixels, and file size (resampling)

Consider these guidelines when you resize your images:

- Increasing the image size can cause a loss of detail and sharpness. Choose **AI-Powered** (artificial intelligence technology) options for best results. For more information, see “Enlarging images by using AI-Powered upsampling” on page 153.
- Resize an image only once. If you resize the image incorrectly, undo it and try again.
- Correct and retouch images before resizing.

Resampling methods

The **Resample** option lets you specify how pixels are changed in an image. The **Bicubic** method is the slowest method, but it usually produces the best results.

The resampling types available in PaintShop Pro are described in the following table.

<table>
<thead>
<tr>
<th>Resampling type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AI-Powered</strong></td>
<td>Available when you enlarge images (<strong>New</strong> size is larger than <strong>Original</strong>), this resampling type uses artificial intelligence (AI) to retain detail. For more information, see “Enlarging images by using AI-Powered upsampling” on page 153</td>
</tr>
<tr>
<td>Resampling type</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Smart Size</td>
<td>Chooses the best algorithm based on the new pixel dimensions you set</td>
</tr>
<tr>
<td>Bicubic</td>
<td>Minimizes the jaggedness that often results from expanded, irregular, or complex images</td>
</tr>
<tr>
<td>Bilinear</td>
<td>Uses the two nearest pixels around each existing pixel to determine the appearance of newly created pixels</td>
</tr>
<tr>
<td>Pixel Resize</td>
<td>Duplicates or removes pixels to achieve the selected width and height of the image (recommended for hard-edged images and simple graphics)</td>
</tr>
<tr>
<td>Weighted Average</td>
<td>Uses a weighted-average color value of neighboring pixels to determine the appearance of newly created pixels (useful for reducing photorealistic, irregular, or complex images)</td>
</tr>
</tbody>
</table>

**What happens to pixels when you resample an image?**

When you use the Resize command to increase the image dimensions, additional pixels must be interpolated from information in the existing pixels. Imagine that you have an image of 100 x 100 pixels, and that you want to enlarge the image by increasing the number of pixels to 200 x 200. You begin with 10,000 pixels and after resizing end up with 40,000 pixels. Thus, three-fourths of the final pixels are “made up.” Most methods of making up pixels involve interpolating the interpixel gaps produced by stretching the image dimensions. The Pixel Resize method copies the color of the nearest pixel. The Bilinear method is based on an average of four neighboring pixels (from a 2 x 2 pixel neighborhood). The Bicubic method is more sophisticated and uses 16 neighboring pixels (from a 4 x 4 pixel neighborhood). This larger neighborhood provides more information about how the color is changing in that particular part of the image and therefore can improve the colors in the made-up pixels.

When you use the Resize command to decrease the image dimensions, the pixel colors are averaged together. Imagine that you want to decrease an image from 100 x 100 pixels to 50 x 50 pixels. The result contains 2,500 pixels, which is one-fourth of the pixels used to represent the original image. The different resampling methods determine how much weight is given to the original pixels when they are averaged together.

**Are there other ways to resize an image?**

In addition to using the Resize command, you can also change the image size by changing the canvas size, cropping the image, printing at a different size, using the Copy Special command, or using the Save for Office command.

Increasing the canvas size adds pixels at the edge of the image. Decreasing the canvas size hides pixels at the edges of the image (full layer information is kept). For more information, see “Resizing the canvas” on page 184.

Cropping an image deletes the pixels outside the selected crop area. For more information, see “Cropping images” on page 113.

You can resize an image that you add to the Print Layout window by dragging its selection handles. Resizing the image in this way does not change the image file, which is helpful if you want to print the image at various sizes. For more information, see “To resize an image in print layout” on page 448.

The Copy Special command lets you copy the image to the Clipboard in one of three sizes, depending on whether you are copying the image to print professionally, to print from your desktop, or to copy to your computer screen or an e-mail message. After copying the image to the Clipboard, you can paste the resized image in a file in another application, such as a word processor. For more information, see “Copying images into other applications” on page 70.
The **Save for Office** command provides resizing options that are similar to those provided by the Copy Special command, except that you can save the file to disk as well as specify image size and resolution. For more information, see “To save images for office applications” on page 57.

**To resize an image**

**Edit tab**

1. Choose **Image** ➤ **Resize**. The **Resize** dialog box appears.

2. Choose one of the following resizing options:
   - **By Pixels** — lets you specify a size in pixels by typing values in the **Width** and **Height** boxes. You can also choose from a drop-list of standard sizes.
   - **By Percentage** — lets you change the size by a percentage (of the original) by typing a percentage into the **Width** or **Height** box.
   - **By Print Size** — lets you specify a size in inches, centimeters, or millimeters by typing values in the **Width** and **Height** boxes. You can also choose from a drop-list of standard sizes and set the **Resolution** value.
   - **Based on One Side** — based on pixels, you can specify the size of either the **Width** or **Height** and the image will be resized, using the current proportions.

3. For further adjustments, mark the **Advanced and AI-Powered Settings** check box, and adjust any of the following.

**You can also**

- **Resample image pixels**
  - Mark the **Resample using** check box, and choose a resampling method.
  - **Note:** Resampling changes the image’s pixel dimensions and lets you change the resolution setting independently from the width and height settings.

- **Sharpen the resized image**
  - Mark the **Resample using** check box, and choose **Bicubic** from the drop-list. Set the **Sharpness** control at approximately 100 to shrink an image; or at approximately 50 to enlarge an image.
  - **Note:** When the **Sharpness** control is set to 0, the sharpness of the resized image does not change.

- **Preserve the brightness of the resized image**
  - In the **Miscellaneous** options of the General Program Preferences dialog box, mark the **Preserve image brightness when resizing** check box.

- **Unlock the aspect ratio**
  - Unmark the **Lock aspect ratio** check box.

- **Resize only the selected layer**
  - Unmark the **Resize all layers** check box.

When you unmark the **Resample using** check box, the **Width**, **Height**, and **Resolution** controls work together — a change to one control causes the other controls to change. When you use this method, the pixel dimensions of the image remains unchanged.

Changing the aspect ratio distorts the image by stretching or contracting it in one dimension more than the other. A lock icon next to the **Width** and **Height** boxes indicates if the aspect ratio is locked.
You can preserve the image’s current print size by marking the Maintain original print size check box.

Enlarging images by using AI-Powered upsampling

When you use the PaintShop Pro Resize window to enlarge an image (upsample), AI-Powered options become available. AI-Powered options use artificial intelligence (AI) to analyze the pixels in your image so that newly added pixels provide a crisper more detailed result than standard upsampling methods. This can help you salvage low-resolution images that you might not otherwise be able to use. For example, you might have a photo that has been cropped to an area of interest, but the resulting resolution is too low to print, or you might have older JPEG images that were captured with a low-resolution camera.

Note: GPU Acceleration can sometimes improve the speed performance of the AI analysis. Results will vary according to your computer system, so experiment to see which setting works best.

Note: The maximum pixel dimensions for AI-Powered upsampling is 10,000 x 10,000 pixels—you cannot apply this option if the dimensions exceed the limit (settings are disabled).

To enlarge an image by using AI-Powered upsampling

Edit tab

   The Resize dialog box appears.

2. Enlarge the image by choosing one of the following options:
   • By Pixels — lets you specify a size in pixels by typing values in the Width and Height boxes. You can also choose from a drop-list of standard sizes.
   • By Percentage — lets you change the size by a percentage (of the original) by typing a percentage into the Width or Height box.
   • By Print Size — lets you specify a size in inches, centimeters, or millimeters by typing values in the Width and Height boxes. You can also choose from a drop-list of standard sizes and set the Resolution value.
   • Based on One Side — based on pixels, you can specify the size of either the Width or Height and the image will be resized, using the current proportions.

3. Mark the Advanced and AI-Powered Settings check box.

4. Mark the Resample using check box, and in the drop-list, choose AI-Powered.

5. From the Mode area, choose one of the following options:
   • Photorealistic: Choose this options for photos.
   • Illustration: Choose this option for drawings and other illustrations.

6. Set the amount of Noise Reduction you want to apply. Drag the slider to the left to maintain finer pixel details; drag the slider to the right for smoother edges.

7. Mark or unmark the GPU Acceleration check box, according to what works best for your computer system.

8. Click OK.
   The green progress bar at the bottom of the application window lets you track the progress of the AI analysis.
Retouching and restoring images

PaintShop Pro provides you with many ways to retouch your images. Whether you want to remove a small scratch, erase the entire background, or simply correct red-eye, you’ll find the tools you need.

This section presents the following topics:
- “Removing red-eye” (page 155)
- “Applying cosmetic changes” (page 157)
- “Removing scratches” (page 159)
- “Removing flaws and objects with the Clone Brush or Object Remover” (page 161)
- “SmartClone retouching and design” (page 163)
- “Using Magic Fill to erase image areas” (page 165)
- “Moving selected areas with Magic Move” (page 166)
- “Erasing image areas” (page 167)
- “Placing images in shapes or text with the Frame Tool” (page 169)
- “Cutting out image areas” (page 172)
- “Changing portrait backgrounds with AI Background Replacement” (page 173)
- “Retouching image areas by using brushes” (page 175)
- “Recoloring image areas for a realistic effect” (page 177)
- “Replacing colors, gradients, or patterns” (page 178)
- “Filling areas with colors, gradients, or patterns” (page 179)
- “Flipping and mirroring images” (page 180)
- “Adding borders” (page 181)
- “Scaling photos by using Smart Carver” (page 181)
- “Scaling and transforming photos using the Pick tool” (page 183)
- “Resizing the canvas” (page 184)

Removing red-eye

Red-eye in photos is a common problem. When light from the camera’s flash reflects off the retina of a photo subject, a red-eye effect is captured in the photo. PaintShop Pro has two methods of removing red-eye from a color photo.

The fastest method of removal is to use the Red Eye tool. A more powerful method is to use the advanced Red Eye Removal command, which lets you change the eye color.
The Red Eye tool replaces the red color in the subject’s pupil with a dark gray color, restoring a natural look.

To remove red-eye quickly
Edit tab
1. On the Tools toolbar, choose the Red Eye tool.
2. On the Tool Options palette, adjust the Size of Red-Eye control so that the pointer is about twice the size of the red area needing correction.
3. Position the pointer directly over the eye, and click.

You can zoom in on the photo, if necessary, for better control of the Red Eye tool.

You can size the pointer interactively by holding down Alt while dragging the Red Eye tool over the eye area.

To use advanced options for red-eye removal
Edit tab
2. In the After preview area, drag to center the red eyes of the subject. If necessary, use the Zoom control to see the eyes in more detail.
3. Choose a color variation option from the Hue and Color drop-lists.
   Note: The Hue drop-list is available only for the Auto Human Eye method.
4. From the Method drop-list, choose one of the following correction methods:
   - Auto Human Eye — automatically selects the correction area and chooses settings appropriate for a human eye
   - Auto Animal Eye — automatically selects the correction area and chooses settings appropriate for an animal eye. This method lets you rotate the selection.
   - Freehand Pupil Outline — lets you use the Freehand Selection tool to select the correction area for human or animal eyes
   - Point-to-Point Pupil Outline — lets you use the Point-to-Point Selection tool to select the correction area for human or animal eyes
   When more careful correction is needed, such as for a partially obscured pupil, it is best to use the Freehand Pupil Outline method or the Point-to-Point Pupil Outline method.
5. In the Before preview area, perform one of the following tasks:
   - For the Auto Human Eye or Auto Animal Eye method, click inside the red area of the eye to select the eye automatically, or drag from the center of the eye to the outside edge of the red area.
   - For the Freehand Pupil Outline method, drag around the edge of the red area of the pupil until you reach the beginning point of the selection.
   - For the Point-to-Point Pupil Outline method, click around the edge of the red area of the pupil, and double-click when you reach the beginning point. You can reverse a click by right-clicking.
   After you select the eye, a circle appears around the selected area, and a control box for making adjustments encloses the circle. The After preview area displays the corrected eye.
   Note: If you choose the Freehand Pupil Outline method or the Point-to-Point Pupil Outline method, confine the selection area to the pupil of the eye (the small dark circle at the eye’s center). These methods are designed to correct the pupil area, where red-eye occurs, without changing the surrounding iris.
6. Set the following controls to fine-tune the red-eye correction:
   - Pupil lightness — specifies the amount of lightness in the pupil so that the corrected eye matches the natural eye color
   - Iris size — specifies the size of the iris. Increasing the iris size decreases the pupil size.
   - Glint lightness — specifies the lightness of the glint. Lower values darken the glint; higher values lighten it.
   - Glint size — specifies the size of the glint
   - Feather — adjusts the edges of the corrected eye so that they appear to blend into the surrounding image areas or appear more defined. Lower values make the edges more defined; higher values blend the edges into the surrounding image areas.
• **Blur** — blends the eye with surrounding pixels when the photo has a grainy appearance. You can increase the setting one unit at a time until the eye blends naturally with the rest of the image.

7 Click **OK**.

You can also

- Move the glint to the center of the pupil
  - Mark the **Center glint** check box.
- Rotate a selection for an animal eye
  - Drag the center rotation handle.
- Reshape a selection
  - Drag the side handles of the selection.
- Delete a selection
  - Click **Delete Eye**.

The **Refine** slider helps you correct red-eye when the eye is partially obscured in the original photo. For example, if the eyelid covers part of the eye in the original photo, it should also cover that part of the eye in the corrected photo. Dragging the slider to the left reduces the correction and minimizes its overlap with the surrounding skin.

**Applying cosmetic changes**

You can quickly improve the appearance of the subjects in your photos by performing the following cosmetic changes:

- removing blemishes — by using the **Blemish Fixer** mode of the **Makeover** tool
- whitening teeth — by using the **Toothbrush** mode of the **Makeover** tool
- fixing bloodshot eyes — by using the **Eye Drop** mode of the **Makeover** tool
- adding a suntan — by using the **Suntan** mode of the **Makeover** tool
- thinning a photo subject — by using the **Thinify** mode of the **Makeover** tool
- removing wrinkles — by using the **Scratch Remover** tool
- smoothing skin tone quickly — by using the **Skin Smoothing** command in the **Adjust** menu

To remove facial blemishes

**Edit tab**

1 On the Tools toolbar, choose the **Makeover** tool.

2 On the Tool Options palette, choose the **Blemish Fixer** mode.

The pointer changes to concentric circles.

You can remove blemishes, whiten teeth, and apply a suntan.
3 On the Tool Options palette, adjust the **Size** control to the smallest size that allows the inner circle to enclose the blemish.
   The outer circle is for the material used to cover the blemish.
4 On the Tool Options palette, adjust the **Strength** control.
   Values range from 1 to 100. Higher values apply more of the source material (enclosed in the outer circle) to the blemish area (enclosed in the inner circle).
5 Click directly over the blemish.

   ![Note](image)
   You can zoom in on the photo for better control of the **Makeover** tool.

**To whiten teeth**

*Edit tab*

1 On the Tools toolbar, choose the **Makeover** tool.
2 On the Tool Options palette, choose the **Toothbrush** mode.
3 On the Tool Options palette, adjust the **Strength** control as desired.
   Higher settings produce more intense whitening but may also produce an unnatural appearance.
4 Click directly over the teeth.
   If the teeth are separated or partially obscured, you may need to apply this tool to each tooth individually.

   ![Note](image)
   The **Toothbrush** mode of the **Makeover** tool works only with color photos.

**To apply whitening eye drops**

*Edit tab*

1 On the Tools toolbar, choose the **Makeover** tool.
2 On the Tool Options palette, choose the **Eye Drop** mode.
3 Type or set a value in the **Strength** control.
   Higher values whiten more of the eye area but may spread the whitening beyond the affected area of the eye.
4 Zoom in as necessary, and then carefully click over the bloodshot portion of the eye.

**To apply a suntan**

*Edit tab*

1 On the Tools toolbar, choose the **Makeover** tool.
2 On the Tool Options palette, choose the **Suntan** mode.
3 Type or set a value in the **Size** control.
4 Type or set a value in the **Strength** control.
   Higher values produce a darker tan.
5 Carefully drag over the skin of the photo subject.

**To apply a thinning effect**

*Edit tab*

1 On the Tools toolbar, choose the **Makeover** tool.
2 On the Tool Options palette, choose the **Thinify** mode.
3 Type or set a value in the **Strength** control.
   Higher values compress more pixels in the horizontal axis.
4 Click the middle of the photo subject. 
The pixels compress on either side of the point you click. You can continue clicking to enhance the thinning effect.

To remove facial wrinkles
Edit tab
1 On the Tools toolbar, choose the Scratch Remover tool.
2 On the Tool Options palette, choose either the square edge or the beveled edge selection box.
3 Type or set a value in the Width control so that the wrinkle fits inside the inner portion of the selection box you drag.
4 Position the pointer just outside the wrinkle, and carefully drag over the wrinkle so that the wrinkle is enclosed in the inner rectangle. The wrinkle is covered by the surrounding skin texture.

If you need to start again, you can undo the correction, adjust the Width control, and redrag. For wrinkle lines that are not straight, correct just one portion at a time.

To smooth skin tone
Edit tab
1 Choose Adjust > Skin Smoothing.
2 In the Skin Smoothing dialog box, adjust the Amount slider.

Moving the slider to the right applies more smoothing; moving the slider to the left applies less smoothing.

The Skin Smoothing command smooths skin tones and diminishes the appearance of wrinkles and blemishes quickly.

The Skin Smoothing command automatically detects and smooths skin tones without affecting eyes or lips. However, if other areas in your photo are affected because they are similar in color to the skin tone, you can use a selection to isolate the area you want to smooth. For more information about selections, see “Creating selections” on page 197.

Removing scratches
The Scratch Remover tool lets you remove scratches, cracks, and other unwanted image areas from photos.
You can repair individual scratches by using the Scratch Remover tool.

You can use the tool to enclose the flawed area and fill it with the surrounding content that you want to keep. If the background is relatively smooth, the result is usually satisfying. Scratches on a textured or more complex background may be more effectively removed with the Clone Brush tool. For information about the Clone Brush tool, see “Removing flaws and objects with the Clone Brush or Object Remover” on page 161.

For images containing many small scratches, you can use the Automatic Small Scratch Remover command. For more information, see “To remove scratches automatically” on page 140.

**To remove scratches**

*Edit tab*

1. On the Layers palette, select the layer that contains the area you want to remove.
2. On the Tools toolbar, choose the **Scratch Remover** tool.
3. On the Tool Options palette, choose one of the following options to define the shape of the **Scratch Remover** tool:
   - square edge — corrects scratches that are perpendicular to object edges, in an open area, or of uniform color
   - beveled edge — corrects scratches that are at an angle to object edges
4. Position the pointer just outside the scratch on one end, hold down the left mouse button, and drag to set a selection box over the scratch.
5. Release the mouse button.
   
   The enclosed area is replaced with the surrounding pixels.

**You can also**

- Move the selection box starting point in 1-pixel increments
  - Before releasing the mouse button, press an **Arrow** key.

- Increase or decrease the width of the selection box in 1-pixel increments
  - Before releasing the mouse button, press **Page up** or **Page down**.

- Use surrounding pixels to fill the area perpendicular to the edge of the selection box
  - Before releasing the mouse button, press **Shift**.
  
  This technique is ideal for photos in which the background contains
You can also areas with defined borders and lines, such as a brick wall.

💡 To avoid removing important details from areas surrounding the scratch, you can limit the correction by creating a selection. For information about creating selections, see “Creating selections” on page 197.

If you are not satisfied with the result, click the Undo button, reselect the scratch, and try varying the width of the tool.

If the scratch extends over several different backgrounds, you can try removing the scratch one section at a time.

**Removing flaws and objects with the Clone Brush or Object Remover**

**Cloning to copy or fix image areas**

The Clone Brush tool is a versatile correction and copy tool that lets you paint over one area of an image (target) with another part of the image (source). The paint source can be a part of the same layer, another layer in the image, a merged image, or a layer from another image.

By default, a semi-transparent overlay (Show Overlay option) of the source material displays as you hover over a target area. The overlay serves as a preview that helps you confirm the source as you work.

![The Clone Brush tool was used to remove the cracks on the wall from the photo on the left.](image)

**Removing objects with the Object Remover**

The Object Remover tool lets you remove objects when the surrounding area is fairly uniform in color and texture. This tool is similar to the Clone Brush tool in that it lets you identify the area to remove and then choose a background for covering that area.
To clone a part of an image

1. On the Tools toolbar, choose the **Clone Brush** tool.
2. On the Tool Options palette, choose the brush tip, size, opacity, and other settings.
   - If you want the **Clone Brush** tool to reset the source point each time you resume painting, mark the **Aligned mode** check box. You can continue dragging over the target area to fill in the source image. Unmark the check box if you want every stroke to copy the same data from the original source point.
   - If you want to clone data from all layers merged together, mark the **Use all layers** check box. If you want to clone data from the current layer only, unmark the check box.
3. On the source image, right-click the center point of the source area.
   - If the image has more than one layer, click the name of the layer on the Layers palette before you define the source area.
4. Drag in the image where you want to paint the cloned area.
   - If you want to hide or show the clone source overlay, click the **Show Overlay** check box on the Tool Options palette or press **Ctrl + Alt + C**.

When you clone an image area, you must select a source area with data.

- If your image contains a selection, you must right-click within the selection to set your clone source. If you are using a pen tablet, you can achieve the same result by holding down **Shift**.
- You can also hold down **Shift** and click the image to set the source point.
- You can resize the brush interactively by pressing **Alt** while dragging in the image window.

To remove objects from a photo

1. On the Tools toolbar, choose the **Object Remover** tool.
2. On the Tool Options palette, choose the **Selection Mode** button.
3. Drag around the object that you want to remove.
4. On the Tool Options palette, choose the **Source Mode** button.
   - A rectangle is displayed in the image window.
5. Position the rectangle over the area that will replace the previous selection.
6. Drag the handles on the rectangle to resize it, or drag the rotation handle on the rectangle to rotate it.
   - It is recommended that you make the rectangle as large as, or slightly larger than, the area you are removing.
On the Tool Options palette, click the **Apply** button.

Choose **Selections** → **Select None** to deselect the selection.

You can also

- Feather a selection made with the **Freehand Selection** tool
  - Before making the selection, adjust the **Feather** control on the Tool Options palette.
- Adjust the opacity of the source material
  - Before clicking the **Apply** button, adjust the **Opacity** control on the Tool Options palette.
- Choose source material from all layers or from the current layer
  - Mark the **Use all layers** check box to choose source material from all layers as though they were merged. Do not mark this check box if you want to choose source material from the current layer only.
- Blend edges and use the object’s tonal ranges when applying the source material
  - Choose the **Smart Blending** option on the Tool Options palette.

You can also create a selection by using any of the selection tools before you activate the **Object Remover** tool.

You can deselect the selection by pressing **Ctrl + D**.

**SmartClone retouching and design**

SmartClone is a content-aware cloning tool that lets you blend a source selection into a new background. Like the Clone Brush, SmartClone can be used for retouching (covering an unwanted area), but it can also be used to create simple collage images and textured effects.

Retouching: Temporary tattoo removal in a few clicks with SmartClone in Original mode.
Copying: The swan (left) was saved as a SmartClone image, then resized and the SmartClone tool was used to place it into the scene (right), beside the original swan, with one click.

Collage: Using a selection on the woman’s face produces a precise result when the SmartClone leopard image source is applied.

Blend modes let you choose how your source selection blends with the new background:

- **Original** — Blends the source selection into the new destination, maintaining most of the original source color.
- **Blend** — Blends the source selection into the new destination, merging the colors of both the source and destination.
- **Black and White** — Desaturates the source selection so that the destination colors are not affected. This option works well for cloning textures.

Experiment with the different modes to see which one provides the best results for your project.

**Adjusting size and rotation with SmartClone images**

Saving a source selection as a SmartClone image lets you modify the size and rotation of the source and save the source for future projects. SmartClone images are saved to a library that is accessed from a drop-list on the Tool Options palette (similar to the brush tip or Picture Tube library).

**Tips for SmartClone success**

- **Selection edges**: When creating a SmartClone source selection (for immediate use or to save in the SmartClone library), it’s best to keep the selection marquee inside the edges of the area that you want to select—more uniform colors provide more natural results.
• **Color consistency**: If you’re looking for a seamless cloning result, choose a source and destination that share the same color palette. If you’re getting creative, then experiment with the *Blend* mode on different colored backgrounds for unique effects.

• **Using layers and selections**: Duplicating a layer for SmartClone and/or applying a selection (*Selection* tool) to the area where you want to apply a SmartClone image gives you more control over the final result. A layer gives you the ability to erase parts of the SmartClone or to adjust the transparency of the entire layer.

**To use the SmartClone tool**
1. In the Tools toolbar, choose the *SmartClone* tool (in the Clone Brush flyout).
2. Do one of the following:
   • To select a source from the current image, on the Tool Options palette, choose a *Selection type*: *Ellipse*, *Rectangle*, or *Freehand*. Drag around the area that you want to select as a source.
   
     If the image has more than one layer, click the name of the layer on the *Layers* palette before you define the source area.

   • To select a SmartClone image from the library, on the Tool Options palette, click the SmartClone drop-list, and choose the image you want. You can adjust the *Size* and *Rotation* of SmartClone images before you apply them.
3. On the Tool Options palette, choose a *Mode*: *Original*, *Blend*, or *Black and White*.
4. In the document window, click to apply the SmartClone source to an open image (raster).

   You can undo and redo to experiment with different blend modes.

**To save a source selection to the SmartClone library**
1. In the Tools toolbar, choose the *SmartClone* tool (in the Clone Brush flyout).
2. On the Tool Options palette, choose a *Selection type*: *Ellipse*, *Rectangle*, or *Freehand*.
3. Drag around the area that you want to select as a source.

   If the image has more than one layer, click the name of the layer on the *Layers* palette before you define the source area.
4. On the Tool Options palette, click the SmartClone drop-list, and click the *Create SmartClone image from selection* button.
5. In the *Create SmartClone* dialog box, type a name in the *Name* box, fill in any optional fields, and click *OK*.

   The source selection is saved as an image in the SmartClone library.

**Using Magic Fill to erase image areas**
Magic Fill is a content-aware feature that can make unwanted elements of your photos vanish. Use your favorite selection tools to select an area or object that you want to remove and apply Magic Fill to replace the selection with a background that matches the surrounding area—even when the surrounding area is textured or varied. For more information about selections, see “Working with selections” on page 197.

![Magic Fill example](image)

**To erase an image area with Magic Fill**
1. In the Tools toolbar, choose one of the following selection tools:
   • *Selection Tool*
Freehand Selection

2 On the Tool Options palette, adjust the settings you want.

3 In the image, select the area that you want to erase. You don’t need to be precise. Magic Fill works best when some of background is included in the selection.

4 On the Tool Options palette, click the Magic Fill button.

   The selected area is filled with the color and texture sampled from the background.

   If you don’t get the results that you expect the first time, it’s easy to undo the fill and readjust the selection, or simply create a new selection and reapply Magic Fill only to the areas that you want to touch up.

Moving selected areas with Magic Move

Magic Move lets you move part of an image to a new position and automatically fills the remaining empty area so that it matches the surrounding background—even if the background is textured or varied. This content-aware feature works with your favorite selection tools.

To move a selected area with Magic Move

1 In the Tools toolbar, choose one of the following selection tools:
   • Selection Tool
   • Freehand Selection

2 On the Tool Options palette, adjust the settings you want.
   Note: Adjusting the Feather amount (for example, try a setting of 5-20) can improve how the selection blends into the new background.

3 In the image, select the area that you want to move. You don’t need to be precise. Magic Move works best when some of background is included in the selection.

4 On the Tool Options palette, click the Magic Move button.

5 In the image window, drag the selected area to a new position.

   The remaining empty area is filled with a content-aware fill that matches the surrounding background.

💡 If you don’t get the results that you expect the first time, try these tips:
   • It’s easy to undo and readjust the selection, and reapply Magic Move.
   • You can use the Clone Brush to touch up areas
   • You can blend areas using retouch tools, such as Smudge or Soften
Erasing image areas

You can use the Eraser tool to erase areas of a layer to transparency or semi-transparency. A gray-and-white checkerboard pattern indicates transparent areas.

You can quickly remove the background from an image by using the Background Eraser tool.

You can use the Background Eraser tool to erase pixels selectively. For example, in a photo of a mountain range, you can erase the sky, or you can isolate an object from the surrounding image area.

The difference between undoing and erasing

When you undo an action in PaintShop Pro, the detail from the original image is restored. To understand the difference between undoing and erasing, consider the example of paint strokes. If you make a mistake with a paint stroke and erase it, the image detail under the stroke is lost. You can erase paint when you want to make certain pixels transparent. You can also erase to create an effect, such as when you want one layer to show through another layer.

Settings for the Background Eraser tool

You can adjust the default settings for the Background Eraser tool on the Tool Options palette. For example, you can change the opacity, color tolerance, and sample area settings.

You can set the following controls when you use the Background Eraser tool:

- **Opacity** — specifies the level of opacity. A setting of 100% erases pixels to complete transparency, and a lower setting erases pixels to partial transparency.
- **Tolerance** — determines how closely the selected pixels match the sampled pixel. The range of values is 0 to 512. At lower settings, only pixels with very similar colors are erased. At higher settings, more pixels are erased. (This option is unavailable if the Auto Tolerance check box is marked.)
- **Sharpness** — specifies how much the softness of the erased edge depends on the color difference between the object and the background. The range of values is 0 to 100. You can use lower settings when the edges that you are erasing form a gradient (a more gradual color transition); you can use higher settings when the edges that you are erasing have a more abrupt color transition.
- **Sampling** — specifies the basis on which pixels are erased. This control has the following options:
  - Once — samples the point at which you first click and then erases all matching pixels for the duration of the stroke. This setting erases similar colors and preserves the areas you want to keep.
  - Continuous — samples continuously and erases all matching pixels. If the area to erase is quite variable, you can use this option and set the Step value low, so that the area is sampled frequently as you erase. The tool can erase any color it encounters, including foreground colors if the sampled pixel falls into the foreground area.
  - BackSwatch — erases all pixels that match the current background color on the Materials palette
  - ForeSwatch — erases all pixels that match the current foreground color on the Materials palette
• **Limits** — specifies whether erased pixels are adjacent to each other. This control has the following options:
  - **Discontiguous** — erases all pixels in the tool’s path that match the sampled pixels, even if they are nonadjacent. You can use this mode to correct areas in which the background shows through holes in the image.
  - **Contiguous** — erases only contiguous pixels that match sampled pixels. You can use this mode when the background pixels are of a color that is similar to that of the edges of the object you want to isolate.
  - **FindEdges** — uses the edge information to restrict the erasing
  - **Auto Tolerance** — determines the tolerance based on the pixels in the tool’s path. The tolerance may change continuously as the tool moves over different parts of the layer. You can unmark this check box to specify a Tolerance setting.
  - **Use all layers** — samples data from all layers merged together. Only pixels in the current layer are erased. To sample data from the current layer only, you can unmark the check box.
  - **Ignore Lightness** — ignores sharp differences in color lightness and saturation. You can mark this check box when the colors in the object that you want to isolate are strongly saturated and the background is unsaturated, or vice versa.

**Should I use automatic or manual tolerance?**

You should start by marking the Auto Tolerance check box. If you find that too much or too little is erased from the image, you can unmark the Auto Tolerance check box and increase or decrease the value in the Tolerance box.

**To erase an image area**

**Edit tab**

1. On the Tools toolbar, choose the **Eraser** tool.
2. On the Tool Options palette, choose the brush options you want.
   - For more information about setting brush options, see “Choosing brush options” on page 366.
3. Drag in the image to erase.

**You can also**

- **Restore erased pixels**
  - Hold down the right mouse button, and drag over the erased area.
- **Erase a straight line**
  - Click at the beginning of the line, hold down **Shift**, and click the end of the line. To continue erasing the line, move to the next point, hold down **Shift**, and click again.

If you erase the background layer, the Eraser tool erases to transparency, and the layer is automatically promoted to a raster layer.

**To erase the background area of an image**

**Edit tab**

1. On the Layers palette, click the layer that contains the image element that you want to isolate.
2. On the Tools toolbar, choose the **Background Eraser** tool.
3. On the Tool Options palette, choose the brush options you want.
   - For more information about setting brush options, see “Choosing brush options” on page 366.
4. Drag around the edges of the image area that you want to isolate.
   - Slow, careful strokes give you the best results. Keep the center of the brush on regions you want to erase, while keeping the edges of the brush on regions you want to preserve.
You can also

**Restore erased pixels**
Right-click and drag.

**Erase a straight line**
Click once at the beginning point, hold down **Shift**, and click the endpoint. To continue erasing the line, move to the next point, hold down **Shift**, and click again.

**Switch to the Eraser tool**
Hold down the **Backspace** key while you drag the mouse.

The background layer is automatically promoted to a raster layer when you work on it with the **Background Eraser** tool.

You can preserve the transparent background (when you want to place the visible content on another layer or background) by saving your file in the following file formats: PSPImage, PNG, GIF.

### Placing images in shapes or text with the Frame Tool

The **Frame Tool** lets you place images in shapes and text. It offers a fast and easy way to place images into a layout. The frame and image can then be moved and sized as a unit, or adjusted separately. Images added to frames can be extracted and changed easily, making frames ideal for layout placeholders.

![The Frame tool was used to fill this template with photos in just a few moments. Note: The original template was also created in PaintShop Pro (using layers, shapes, and picture tubes).](image)

When you create a frame, a **Frame Group** is added to the **Layers** palette. When you drag an image to the frame, the image appears in the **Layers** palette as part of a **Frame Group**. It’s helpful to have the **Layers** palette open when you work with frames—it makes it easy to select the element that you want to adjust.
You can convert a shape drawn with the **Rectangle**, **Ellipse**, **Symmetric Shape** or **Preset Shape** tool into a frame. You can also convert text created with the **Text** tool into a frame.

**To place an image in a shape or text with the Frame Tool**

1. On the **Tools** toolbar, click the **Frame Tool**.

2. On the **Tool Options** palette, do one of the following shapes:
   - Choose **Rectangle**, **Ellipse**, **Preset Shape**, or **Symmetric Shape** and drag in the image window (on the Background or a Raster layer) to draw a frame.
   - Choose **Text**, and type in the image window.

When drawing a rectangular or elliptical frame, you can constrain the shape to a square or circle by holding down **Shift** as you drag.

3. To fill the frame with an image, do one of the following:
   - Click **File > Embed Image**, and navigate to the image that you want to use.
   - From the **Organizer** palette, drag an image thumbnail into the frame.
   - From Windows File Explorer, drag an image file into the frame.

The image automatically fills the frame according to the longest edge, maintaining the image aspect ratio. Both the frame and the bounding box for the image are displayed.

**Note:** At this point, the image is active, and you can simply drag the image or an image node to reposition or resize the image. For full editing options, continue to the next step.
In the example above, a square frame is filled with a rectangular image. A bounding box indicates the area of the image that exceeds the frame.

4 Do any of the following to adjust the frame or image:
   • To reposition the image, in the Layers palette, select the image layer in the Frame Group, and in the image window drag the center node for the image to the position you want.
   • To resize the image, in the Layers palette, select the image layer, and in the Image window drag a node on the image bounding box.
   • To reposition or resize both the frame and the image, double-click inside the frame (or select the Frame Group layer in the Layers palette), and drag the center node to a new position or drag a node on the bounding box to resize it.
   • To reposition the frame only, in the Layers palette, select the Frame layer, and in the image window, drag the center node to a new position.

   If at any time you experience issues selecting or creating a frame, check to see what is active in the Layers palette. If adding multiple frames, it can be helpful to select the original layer (such as the Background layer) before adding a new frame.

To replace an image in a frame
   • Do one of the following:
     • Click the frame, then choose File ➤ Embed Image, and navigate to the replacement image.
     • From the Organizer palette, drag an image thumbnail into the frame.
     • From Windows File Explorer, drag an image file into the frame.
   The image automatically fills the frame according to the longest edge, maintaining the image aspect ratio. Both the frame and the bounding box for the image are displayed.
   Note: At this point, the image is active, and you can simply drag the image or an image node to reposition or resize the image.

To extract an image from a frame
1 On the Tools toolbar, click the Frame Tool.
2 Right-click the image that you want to remove from a frame, and choose Extract Image from the context menu.
   The image is removed from the frame group and appears as an independent layer that you can keep or delete. You can now drag a new image to the frame.

To convert a shape to a frame
1 Do one of the following to select a shape previously created with the Rectangle or Ellipse, Preset Shape, or Symmetric Shape tool:
   • On the Tools toolbar, click the Pick tool, and click a shape.
   • In the Layers palette, click a vector layer for the shape that you want to select.
   If there are multiple vector shapes, you might need to expand the vector layer group so that you can select a specific shape. A marquee indicates that the shape is active.
2 On the Tools toolbar, click the Rectangle or Ellipse, Preset Shape, or Symmetric Shape tool.
3 In the image window, right-click the active shape and choose **Convert to Frame Object** from the context menu.
4 Drag an image to the frame.

**To convert text to a frame**
1 Do one of the following to select text previously created with the **Text** tool:
   - On the Tools toolbar, click the **Pick tool**, and click the text.
   - In the **Layers** palette, click a vector layer for the text that you want to select.
     A marquee indicates that the text is active.
2 On the Tools toolbar, click the **Text** tool.
3 In the image window, right-click the text and choose **Convert text to Frame Object** from the context menu.
4 Drag an image to the frame.

**Cutting out image areas**

You can use the Object Extractor to cut out an image area from the surrounding background. You can then edit the cutout separately from the background, display it against a different background, or combine it with other images.

![Image showing the Object Extractor workflow:](image)

**Object Extractor workflow:** (1) Outline the edges of the image area; (2) add a fill; (3) preview the cutout, and touch it up if necessary; (4) bring the cutout into the image window; (5) place the cutout against a different background image (optional).

**To cut out an image area**

**Edit tab**
1 On the Layers palette, click the layer that contains the image area that you want to cut out.
2 Choose **Image > Object Extractor**.
   The **Object Extractor** dialog box appears, with the **Brush tool** activated by default.
3 Adjust the brush size by moving the **Brush size** slider.
4 In the preview area, draw a line along the edges of the image area that you want to cut out.
   Ensure that the selection outline slightly overlaps the surrounding background and completely surrounds the area in a closed ring.
5 Choose the **Fill tool**, and click inside the area you want to cut out.
   An overlay covers the image area that you clicked.
   **Note:** If the selection outline is not closed, the fill covers the entire image. If this is the case, click the **Eraser tool** to clear the fill, and then complete the selection outline with the **Brush tool**.
6 Click **Process** to preview the result.
   If you are not happy with the result, click **Edit Mask** to return to the previous view and touch up the cutout.
You can also

Erase parts of the selection outline
Choose the Eraser tool, and drag over the selection marquee that you want to delete.

Refine the edge detail in the final result
Move the Accuracy slider to a higher value if the object has an intricate or complex outline.

The Accuracy slider is available only after you click Process.

Revert to the original image
Click Reset. The Reset button is available only before you click Process and clears both the fill and the selection outline.

Hide the fill overlay and the edge outline
Mark the Hide Mask check box.

Specify an exact size for the brush or eraser nib
Type or set a value in the Brush size box.

Zoom in and out
Type or set a value in the Zoom box.

Display an image at its actual size
Click the Zoom to 100% button 1:1.

Display an image in the entire preview area
Click the Fit Image to Window button.

Pan to another area of the image
Using the Pan tool, drag the image until the area you want to see is visible.

The background layer is automatically promoted to a raster layer when you use the Object Extractor command.

You can switch from the Brush tool to the Eraser tool by right-clicking and dragging in the preview area.

Changing portrait backgrounds with AI Background Replacement

AI Background Replacement uses artificial intelligence (AI) to select people in portrait and group photos and extract the background so that you can replace it with one of many preset background images or a custom image. For example, you can easily replace a distracting or unwanted background with a studio-style backdrop, a beach scene, a mountain view, or a famous landmark. You can also choose to output your subject with a transparent background.
The original background (left) was replaced with a custom image (right) by using AI Background Replacement.

After you replace the background, the resulting image is output with layers for the subject, the new background, and the original image.

Tips for background replacement success
- Choose portrait photos where the subject is fully in the foreground—it is best if no background area is in front of the subject.
- Group photos can be used but results will vary depending on the complexity of the image. It is best if subjects are closely grouped together with few gaps.
- After you output the result, you can apply effect or adjustment filters to the subject layer or background layer to match the color and tone of the layers. For example, select the subject layer, and choose Effects » Photo Effects » Film and Filters to warm, cool, or tint the layer. You can also apply a flattering Glamour effect to your subjects. For more information, see “Applying film and filter effects to photos” on page 307.

To change a background by using AI Background Replacement
1. Open a portrait photo.
2. Click Adjust » Artificial Intelligence » AI Background Replacement.
   It will take a few moments for the AI to analyze the image and to open the AI Background Replacement window.
3. Review the red overlay that appears on the background areas. If you need to fine-tune the selection, in the Brush Mode area, choose any of the following:
   - Refine — lets you drag along the edge of the selection to create a more precise result and lets you include complex edge detail, such as fly-away hair
   - Feather — lets you soften edge areas
   - Add to Subject — removes the red overlay from the subject
• **Remove from Subject** — adds the red overlay to areas that you want to identify as background

**4** Adjust the **Brush Size** slider, and drag in the preview area, changing brush modes as needed to get the result you want.

If you want to adjust the brush size interactively, hold down **Alt** while dragging in the preview window.

For information about all the available controls, see “Fine-tuning a selection with the Refine Brush” on page 203.

**5** When you are satisfied with the selection, click **Next**.

**6** In the **Select from** area, choose one of the following options:

- **Preset** — choose a category from the drop-list and click a thumbnail to apply a new background from a selection of included images
- **Custom** — click the **Browse** button and navigate to the image that you want to use as a background
- **Original** — does not change the background, but creates two new layers when you output: a layer with the subject and a layer with the background
- **Transparent** — removes the background content and outputs the subject as a layer with a transparent background

If you choose a **Preset** or **Custom** background, you can use the **Scale** slider (below the preview window) to resize the background and you can drag in the preview window to reposition the background.

**7** Click **Done**.

You can switch between the **Add to Subject** and **Remove from Subject** brush modes by right-clicking as you drag.

### Retouching image areas by using brushes

You can retouch images by applying brushstrokes. Some retouch brushes mimic photographic effects, while others change pixels based on their lightness, saturation, hue, or color values. Some retouch brushes create effects that are similar to those produced with the color-correction commands. The retouch brushes are described in the following table.

<table>
<thead>
<tr>
<th>Brush</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lighten/Darken</td>
<td>Increases or decreases brightness; affects the RGB or Lightness value of pixels</td>
</tr>
<tr>
<td>Dodge</td>
<td>Lightens and brings out details of areas that are in shadow (mimics the traditional photographic darkroom technique of holding back light to produce lighter areas in printed photos)</td>
</tr>
<tr>
<td>Burn</td>
<td>Darkens areas of the image that are too light</td>
</tr>
<tr>
<td>Smudge</td>
<td>Spreads color and image details from the starting point and picks up new color and image details as it moves, as though smearing paint</td>
</tr>
<tr>
<td>Push</td>
<td>Spreads color and image details from the starting point but does not pick up any new color or image details</td>
</tr>
<tr>
<td>Soften</td>
<td>Smooths edges and reduces contrast</td>
</tr>
<tr>
<td>Sharpen</td>
<td>Heightens edges and accentuates contrast</td>
</tr>
<tr>
<td>Emboss</td>
<td>Causes the foreground to appear raised from the background by suppressing color and tracing edges in black</td>
</tr>
</tbody>
</table>
Saturation Up/Down

Increases or decreases saturation; affects the HSL value of pixels

Hue Up/Down

Increases or decreases hue; affects the HSL value of pixels

Change to Target

Changes pixels based on a characteristic of the current foreground color on the Materials palette: color, hue, saturation, or lightness
  - If you choose the color as the target, the brush applies the foreground color without affecting the luminance.
  - If you choose the hue, saturation, or lightness as the target, the brush applies the hue, saturation, or lightness value of the foreground color without changing the other values.

Color Replacer

For information about the Color Replacer tool, see "Replacing colors, gradients, or patterns" on page 178.

To use a retouch brush

Edit tab
1. On the Tools toolbar, choose a retouch brush.
2. On the Tool Options palette, set the brush controls.
3. Drag in the image to apply the tool.

You can also

Reverse the tool behavior

Retouch data from all layers

Lighten or darken an image with the Lighten/Darken tool based on the lightness or RGB values

Choose a characteristic of the foreground color to target with the Change to Target tool

Apply brush strokes only to specific areas that match the brush stroke sample area

Limit the changes to shadows, midtones, or highlights with the Dodge and Burn tools

On the Tool Options palette

Mark the Swap mouse button check box when using the Lighten/Darken, Saturation Up/Down, or Hue Up/Down tools.

Mark the Use all layers check box when using the Smudge, Push, Soften, Sharpen, or Emboss tools.

Choose RGB or Lightness from the Mode drop-list.

Choose an option from the Mode drop-list.

Mark the Smart Edge check box.

Choose an option from the Limit drop-list.

For more information about setting brush options, see “Choosing brush options” on page 366.
You can apply the opposite effect of a retouch brush by right-clicking as you apply the brush to the image.

Recoloring image areas for a realistic effect

You can use the Color Changer tool to realistically recolor an object or a region in an image. What sets the Color Changer tool apart from other tools and commands (such as the Flood Fill tool, some of the retouching brushes, or the Colorize, Hue/Saturation/Lightness, or Hue Map commands) is that it takes into account the shading of the specified color. The Color Changer tool detects and analyzes variations in image brightness and applies the recoloring based on that illumination.

It lets you adjust Tool Options palette settings for Tolerance and Edge Softness, and it updates the current recoloring as you modify settings on the Tool Options palette or modify the color in the Materials palette.

The Color Changer tool works best on matte objects such as clothing, carpet, and painted objects that are a solid color. It may not work as well on shiny or reflective objects and is not designed to work with gradients or patterns.

One click can change the color of the girl's dress.

To recolor by using the Color Changer tool

Edit tab

1. On the Tools toolbar, choose the Color Changer tool.
   - The Color Changer tool is grouped with the Flood Fill tool.

2. On the Materials palette, click the Color button on the Style drop-list, and choose a solid color.
   - If the Materials palette is not displayed, choose View ➤ Palettes ➤ Materials.
   - For realistic-looking colors, set the Saturation value (in the Material Properties dialog box) closer to 100 than to 255 (full saturation).

3. Position the Color Changer pointer over the color you want to change in the image, and then click to recolor with the Foreground/Stroke color, or right-click to recolor with the current Background/Fill color.

4. Click Apply to set the color change on the object.

You can also

- Use a color from the current image

Choose the Dropper tool, click the color you want in the
You can also

Instantly change the color you want to apply

Before clicking **Apply**, click a color on the Materials palette.

Adjust the color application

Before clicking **Apply**, adjust any of the following controls on the Tool Options palette:

- **Tolerance** — determines how closely the current color needs to match similar colors for recoloring to be applied. Higher settings cause more pixels to be recolored.
- **Edge Softness** — determines how pixels that border the recolored pixels are affected. Higher settings cause more “bleeding” of the recoloring.

While using the Color Changer tool, you can undo and redo actions such as adjusting colors or adjusting settings on the Tool Options palette.

To isolate the area you want to recolor, you can create a selection. For more information about creating selections, see “Creating selections” on page 197.

To prevent the Color Changer from affecting areas of the photo that you do not want to change, you can duplicate the layer on which the photo resides, apply the Color Changer to the new layer, and use the Eraser tool to erase the areas of changed color that you want to restore. You can then merge the layers.

Re replacing colors, gradients, or patterns

You can use the Color Replacer tool to replace one color in a selection or layer with another color. You can use brushstrokes to replace only those pixels that the brush touches, or you can replace all pixels of a certain color in a selection or layer.

You can set a tolerance value so that the Color Replacer tool changes within a given color value range. The Color Replacer tool also works with gradients and patterns.

You can also use the Flood Fill tool to replace all pixels of a certain color in a selection or a layer. For information about the differences between the Color Replacer tool and the Flood Fill tool, see “Filling areas with colors, gradients, or patterns” on page 179.

Why does nothing happen when I apply the Color Replacer tool?

You must select a foreground or background color that appears in the image. If there are no pixels that match your selected color, then no pixel colors are replaced.

For more information about picking a foreground or background color directly from the image, see “Choosing colors from an image or the desktop” on page 257.

To replace a color, gradient, or pattern

**Edit tab**

1. On the Tools toolbar, choose the **Color Replacer** tool.

2. Choose the material (color, gradient, or pattern) that you want to replace. Click the material to apply it as the Foreground/Stroke, or right-click the material to apply it as the Background/Fill.

3. Choose a material to use as a replacement material. The replacement material can be any material in the current image, or you can choose one from the Materials palette.
• If the material you want to replace is the current Foreground/Stroke material, right-click the replacement material to set it as the Background/Fill.

• If the material you want to replace is the current Background/Fill material, click the replacement material to set it as the Foreground/Stroke.

4 In the **Tolerance** box, set a value from 0 to 200 to specify how closely the replacement material should match the material you are replacing.

At lower **Tolerance** settings, only pixels with very similar colors are replaced; at higher settings, more pixels are replaced.

5 Position the cursor over the area of a selection or layer that contains the material you want to replace, and perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Swap all occurrences of a background or foreground material</td>
<td>Double-click to swap the Background/Fill material with the Foreground/Stroke material; double-click the right mouse button to swap the Foreground/Stroke material with the Background/Fill material.</td>
</tr>
<tr>
<td>Replace all matching pixels with the current Foreground/Stroke material</td>
<td>On the Tool Options palette, click the Replace all pixels button.</td>
</tr>
<tr>
<td>Replace materials by using brushstrokes rather than replacing all pixels in the layer</td>
<td>On the Tool Options palette, choose the brush tip, size, opacity, and other options. Drag in the image to replace the Background/Fill material with the Foreground/Stroke material; drag with the right mouse button to replace the Foreground/Stroke material with the Background/Fill material.</td>
</tr>
</tbody>
</table>

To limit changes to a specific area, make a selection in the image before using the **Color Replacer** tool.

### Filling areas with colors, gradients, or patterns

You can fill a selection or a layer with the foreground or background color, gradient, or pattern. You can fill all pixels or fill only those pixels that match the options you specify. When you click in the image, the Flood Fill tool finds and fills all contiguous pixels that match the pixel you select.

Contiguous pixels are like continuous chains of matching pixels radiating from the initial pixel you click. When the Flood Fill tool finds a pixel that does not match the selected pixels, the chain breaks. Even if a pixel is only one pixel away from a matching pixel, it is treated as discontiguous.

What is the difference between the Flood Fill tool and the Color Replacer tool?

The Flood Fill tool can fill pixels that match certain criteria (such as RGB value); in this way, it is similar to the Color Replacer tool.

The Flood Fill tool fills matching pixels that are contiguous to the initial pixel you click, whereas the Color Replacer tool changes pixels either within its brushstrokes or in the entire layer.

The Color Replacer tool changes the color of pixels based on RGB value. The Flood Fill tool changes pixels based on RGB, hue, brightness, or opacity values.

### To fill an area with a color, gradient, or pattern

**Edit tab**

1. On the Tools toolbar, choose the **Flood Fill** tool.
2. Choose the foreground or background color, gradient, or pattern with which to fill the area.
From the **Match Mode** drop-list on the Tool Options palette, choose one of the following options:

- **None** — fills all pixels
- **RGB Value** — fills pixels that match the red, green, and blue values of the pixel you click
- **Color** — fills pixels that match the shading variations of the pixel you click
- **Brightness** — fills pixels that match the perceptual lightness value of the pixel you click
- **Perceptual** — fills pixels that match the perceptual shading variation and lightness of the pixel you click
- **Traditional** — fills pixels that match red, green, and blue values, with a bias toward lightness variations. This match mode is therefore more discriminating than the RGB Value match mode.
- **All Opaque** — fills all pixels that are not completely invisible (that is, having an opacity value of 1 or greater). Choosing this option disables the **Tolerance** control.
- **Opacity** — fills pixels that match the opacity value of the pixel you click

Type or set a value from 0 to 200 in the **Tolerance** control to specify how closely the selected pixels match the initial pixel you click. At lower settings, only pixels with very similar colors are filled; at higher settings, more pixels are filled.

Choose an option from the **Blend Mode** drop-list to specify how filled pixels are blended with pixels of underlying layers. The blend modes are the same as the layer blend modes.

Type or set a value in the **Opacity** control to specify the opacity of the fill. At 100 percent opacity, the paint covers everything; at 1 percent opacity, the paint is almost completely transparent.

Position the cursor over the area of the selection or image that you want to fill, and either click to fill with the foreground material or right-click to fill with the background material.

To limit changes to a specific area, make a selection in the image before you apply the Flood Fill tool. For information about selections, see “Working with selections” on page 197.

You can limit the flood fill to matching pixels of the current layer only by unmarking the **Use all layers** check box.

For more information about using blend modes, see “Blending layers” on page 233. For more information about choosing brush options, see “Choosing brush options” on page 366.

### Flipping and mirroring images

You can flip or mirror an image so that the left side becomes the right side or the top becomes the bottom. When you choose Flip, layers or selections are flipped in position. When you choose Mirror, layers or selections are flipped along their horizontal (left to right) or vertical (top to bottom) axis.

#### To flip a selection, layer, or image

**Edit tab**

- Click **Image ➔ Flip**, and choose one of the following:
  - **Flip Horizontal** — the left side switches to the right side
  - **Flip Vertical** — the top switches to the bottom

Flipping a selection converts it into a floating selection, leaving the original layer unchanged.

#### To mirror a selection or layer

- Click **Image ➔ Mirror**, and choose one of the following:
  - **Mirror Horizontal** — flips the selection or layer along the horizontal axis (left to right)
  - **Mirror Vertical** — flips the selection or layer along the vertical axis (top to bottom)
Adding borders

You can add a colored frame or border around an image. When you add a border to an image, the dimensions of the image are expanded to the border.

For multilayer images, PaintShop Pro prompts you to flatten the image before adding the border; however, you can also add a border without flattening the image by changing the canvas size. For more information, see “Resizing the canvas” on page 184.

To add a border to an image

Edit tab

1. Choose **Image** ➤ **Add Borders**.
   The Add Borders dialog box appears.
2. Do one of the following:
   - To create an equal-width border on all sides, mark the **Symmetric** check box.
   - To create borders of varying widths, unmark the **Symmetric** check box, and set border width values in the controls in the **Size In Pixels** group box.
3. Click the **Color** box to choose a color for the border.
4. Click **OK**.

You can change the units of measurement for the border by choosing an option from the drop-list in the **Original Dimensions** group box.

Scaling photos by using Smart Carver

Smart Carver™ lets you make a photo narrower, wider, shorter, or longer without distorting the content. By automatically detecting and removing zones in the picture that have little structural detail, this feature lets you change the aspect ratio without noticeably changing the image. You can also target a specific zone to remove from the photo, regardless of its level of detail, or preserve specific objects or image areas.
Smart Carver lets you selectively remove or protect areas when you scale an image.

To remove or preserve an object by using Smart Carver
Edit tab

1. Choose Image ➤ Smart Carver.
   The Smart Carver dialog box opens.

2. To remove or preserve an object or area from a photo, do one or both of the following:
   - Click the Remove button and apply the Remove brush to the areas of the photo that you want to remove.
   - Click the Preserve button and apply the Preserve brush to the area of the photo that you want to protect.
   In the Object Removal area, you can move the Brush Size slider to the left to decrease the size of the brush, or to the right to increase the size of the brush.

3. Scale the photo by applying one or more of the Smart Carving options.

   You can also

   - Delete brushstrokes: Click the Eraser button, and apply it to the brushstrokes that you want to erase.
   - Zoom in or out: In the Zoom box, enter a magnification level, or use the slider or the arrows to adjust the zoom level.
   - Pan to view hidden areas of the photo: Click the Pan button, and drag in the preview area.
   - Hide the brushstrokes in the preview area: Mark the Hide Mask check box.
   - Reset the photo to its original state: Click Reset.

To scale a photo by using Smart Carver
Edit tab

1. Choose Image ➤ Smart Carver.
   The Smart Carver dialog box opens.

2. In the Smart Carving area, perform one or more tasks from the following table, and click OK.
   You can view the scaling results in the preview area.
To | Do the following
--- | ---
Set a photo width | Type or set a value in the Width box.  
**Note:** The maximum width is double the width of the original photo.

Set a photo height | Type or set a value in the Height box.  
**Note:** The maximum height is double the height of the original photo.

Reduce the photo width by 1-pixel increments | Click the Contract the image horizontally button until the image is the desired width.

Reduce the photo height by 1-pixel increments | Click the Contract the image vertically button until the image is the desired height.

Increase the photo width by 1-pixel increments | Click the Expand the image horizontally button until the image is the desired width.

Increase the photo height by 1-pixel increments | Click the Expand the image vertically button until the image is the desired height.

Reduce the photo width by automatically removing the areas to which you have applied the Remove brush | Click the Auto-contract horizontally button to remove red-painted areas.

Reduce the photo height by automatically removing the areas to which you have applied the Remove brush | Click the Auto-contract vertically button to remove red-painted areas.

**Scaling and transforming photos using the Pick tool**

The Pick tool lets you transform images interactively in the following ways:
- Scaling resizes an image horizontally, vertically, or proportionally.
- Shearing skews an image vertically or horizontally.
- Distorting an image stretches or contracts it in any direction.
- Applying perspective to an image corrects the perspective or applies a false perspective. For information about correcting image perspective, see “Correcting photographic perspective” on page 118.
- Rotating an image moves it around a pivot point. For information about rotating images, see “Rotating images” on page 112.

When you transform an image, the transformations are applied to the layer on which the image resides. You can apply transformations to any raster layer or selection.

**Setting scaling and transformation options**

You can precisely control many of the deform settings. The following options appear on the Tool Options palette when the Pick tool is active:
- **Pivot X, Pivot Y** — sets the X and Y coordinates of the rotation pivot point
- **Position X, Position Y** — sets the X and Y coordinates of the top left corner handle
- **Scale X (%), Scale Y (%)** — sets the percentage of change for the horizontal (X) and vertical (Y) resizing
- **Shear** — sets the offset of a side. Positive values shear to the right, and negative values shear to the left.
• **Angle** — sets the rotation around the pivot point. The image is rotated clockwise, from 0 to 360 degrees.

• **Reset Rectangle** button — resets the deformation rectangle to its original shape but keeps any current deformations.

• **Perspective X**, **Perspective Y** — adjusts the perspective of the deformation.

  **Note:** The best way to create and adjust perspective is by dragging the control handles. When you create a perspective effect with the control handles, you manipulate many variables. Changing the values in the Perspective X and Perspective Y controls may affect the scale, shear, and position values.

  **Important!** The **Pick** tool works on grayscale and 16 million-color images only. For more information about increasing the color depth of an image, see “Increasing the color depth of an image” on page 382. For more information about deforming vector objects or text, see “Sizing, shaping, and rotating vector objects” on page 352 or “Sizing and transforming text” on page 339.

**To scale or transform a selection, layer, or image**

**Edit tab**

1. Choose a selection, layer, or image by clicking its name on the Layers palette.

2. On the Tools toolbar, choose the **Pick** tool.

   A bounding box with handles appears.

3. Perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resize while keeping the current proportions</td>
<td>Drag a corner handle.</td>
</tr>
<tr>
<td>Resize while changing the current proportions</td>
<td>Right-click and drag one of the corner or edge handles.</td>
</tr>
<tr>
<td>Change the center of rotation</td>
<td>Drag the rotation pivot point.</td>
</tr>
<tr>
<td>Rotate the image</td>
<td>Drag the rotation handle.</td>
</tr>
<tr>
<td>Change perspective symmetrically</td>
<td>Hold down Ctrl, and drag a corner handle horizontally or vertically.</td>
</tr>
<tr>
<td>Change perspective asymmetrically</td>
<td>Hold down Ctrl + Shift, and drag a corner handle horizontally or vertically.</td>
</tr>
<tr>
<td>Shear the image</td>
<td>Hold down Shift, and drag a side handle.</td>
</tr>
<tr>
<td>Distort the image</td>
<td>Hold down Ctrl + Shift, and drag a side handle.</td>
</tr>
</tbody>
</table>

By default, you must hold down Ctrl + Shift to distort an image. To distort an image without holding down keys, choose a different **Mode** setting on the Tool Options palette. The **Scale** mode is the default setting, so you must hold down a key or keys. The **Shear** mode lets you shear without holding down Shift. The **Perspective** mode lets you change perspective without holding down Ctrl. The **Free** mode lets you distort without holding down Ctrl + Shift.

When the **Pick** tool is active, you can scale and transform precisely by setting values in any of the boxes on the Tool Options palette.

**Resizing the canvas**

The image canvas is the work area of the image and defines the image dimensions — for example, 200 x 300 pixels. If you need more space to add elements to an image, you can increase the canvas size, or you can resize the canvas to make it smaller.
If you want to resize by adjusting the image size, see “Resizing images” on page 150.

What is the difference between reducing the canvas size and cropping an image?
Reducing the canvas size is not always the same as cropping an image. For images with layers, reducing the canvas size does not delete the pixels outside the new canvas area — it just shows less of the layer. Background layer information is always deleted, even when there are other layers in the image.

To change the canvas size
Edit tab

1. Choose Image ➤ Canvas Size.
   The Canvas Size dialog box appears.
2. In the New Dimensions group box, mark the Lock aspect ratio check box.
3. Set or type values in the Width and Height controls.
4. In the Placement group box, click a button to set the placement of the image in the new canvas, or set values in the Top, Bottom, Left, and Right controls.
   The values show the amount of canvas added or subtracted from each edge.
5. Click OK.

   If you increase the canvas size, you can choose a color for the added canvas area by clicking the Background box and choosing a color.
   You can resize the height and width independently by unmarking the Lock aspect ratio check box, and setting values in the Height and Width controls.
   You can change the units of measurement for the border by choosing an option from the drop-list in the New Dimensions group box.
Merging exposures and content

When you combine two or more photos, you can achieve some impressive results. What can you do?

• Use HDR (high dynamic range) Exposure Merge to create a perfectly exposed image.
• Seamlessly replace unwanted areas (cars, people, birds that flew into your frame) with the correct background.
• Creatively combine elements from multiple photos into one image.
• Combine photos of the same scene taken using different focus distances and choose which areas in focus to retain from source images.

If you have a DSLR camera, you likely have features that can help you take multiple photos of the same scene.

This section presents the following topics:

• “Understanding HDR” (page 187)
• “Taking photos for HDR processing” (page 188)
• “Combining photos by using HDR Exposure Merge” (page 188)
• “Using Single RAW Photo to create an HDR effect” (page 192)
• “Merging batches of photos into HDR images” (page 193)
• “Combining photos with Photo Blend” (page 193)
• “Combining photos with Focus Stacking” (page 195)

Understanding HDR

In photography, HDR refers to “high dynamic range”. Dynamic range is the range of luminance that can be captured in a photo, from the darkest shadows to the brightest highlights.

Unlike the human eye, digital camera sensors (or film in traditional cameras), can only capture a limited dynamic range when photographing scenes with both very bright and very dark areas, such as an interior with a large window. HDR processing creates a 32-bit image which has twice as much information, and therefore many more steps between tones, than an ordinary JPG. This HDR image is then evenly exposed, resolving details in the darkest areas, without losing definition in the brightest areas. And when pushed beyond the “corrective” boundaries, HDR can produce an unreal, plastic, or even “hyper-real” tone, and as such has become a creative technique in itself. Typically, an HDR file needs to be converted back to a 16-bit image format for final output.
Taking photos for HDR processing

If you are new to HDR processing, the information below can help you get started.

What camera features work well with HDR?

You can use automatic exposure bracketing if your camera offers it or use the aperture priority mode and adjust the shutter speed to achieve different exposures. Avoid aperture changes because the depth of field may shift enough to cause blurring in some of the photos. Review the user manual for your camera for information about bracketing options and aperture priority mode.

How many photos should I take for my HDR set?

Usually, three photos is a good base (minimum is two), but to capture a very high contrast scene, take five or more (up to a maximum of nine).

What exposure settings should I use?

Try an initial setting of 2.0 exposure value (EV) between photos. If you are taking a greater number of photos, you can set the exposure at lower increments, but make sure that the number of shots is enough to cover a wide range of exposure. If you’re using auto-bracketing, your camera might limit the EV interval (sometimes to a maximum of +/- 1.0).

Should I use a tripod?

Yes, it’s best to use a tripod, but at the very least, you need to ensure that you have a steady hand (for example, stabilized against a wall). Using a tripod means that you are less likely to have alignment issues with the photos when you use HDR processing.

Combining photos by using HDR Exposure Merge

You can use Exposure Merge to combine two or more photos by using HDR (high dynamic range) processing.
Exposure Merge (Step 1 window)

For more information about taking photos that work well with Exposure Merge, see "Taking photos for HDR processing" on page 188.

Exposure Merge uses a three-step process:

- **Merge** — Choose your merge settings, and if required, apply custom editing.
- **HDR Adjustments** — After merging your photos, you can adjust them and save the results to an editable HDR file before finalizing the merge and fine-tuning.
- **Fine-Tune** — Refine your image, with noise-reduction and sharpening options, along with some other familiar tools. When you’re done, you can save to a standard file format and close Exposure Merge.

Please see the topics below for more detailed information about each step.

**Step 1: Merge**

Merge settings include:

- **Camera response curve profile** — applies a curve adjustment to the image, based on the known characteristics of the sensor in your camera.
- **Alignment** — Choose between Feature-based (detects features in the photos) or Edge-based (detects edges within the photos).
- **Custom editing** — Choose which areas you want to keep (Brush in) or remove (Brush out) from each photo. Often, custom editing is applied to remove “ghosting” — the semitransparent effect caused by merging photos that captured moving objects.

**Step 2: HDR Adjustments**

After you merge your photos, you can adjust the resulting HDR image by applying a preset, customizing a preset, or creating the look you want from scratch. The key is to experiment. You can save your custom settings as a new preset. You can manage your presets by saving, loading, deleting or resetting them.

All the adjustment options in the HDR Adjustments window let you work on an HDR, 32-bit file. You can save the HDR file with all settings, so you can reopen and modify it again in the future. When you are finished with Step 2 and move to Step 3, the final step, the application prepares the image for output by saving it to a 16-bit image.

**Step 3: Fine-Tune**

The final step is fine-tuning the merged image before you exit Exposure Merge. The controls in the Fine-Tune window are based on the controls found when you click the Adjust tab. For more information, see "Using Adjust" on page 95.

Some fine-tuning tips:

- **Digital Noise Removal** is a great tool for cleaning up noise that can result from merging photos.
• **High Pass Sharpen** can help reduce blurred areas that may result from movement between photos.
• **Smart Photo Fix** and **White Balance** let you tweak the colors.
• To brighten the entire image, try adjusting **Brightness/Contrast**. To brighten only the dark areas, try **Fill Light/Clarity**.
• **Local Tone Mapping** and **Fill Light/Clarity** can be used to further enhance details in the image.

### To choose merge options for Exposure Merge (Step 1)

1. Click the **Manage** tab, and select the thumbnails for the photos that you want to merge. An orange outline appears around the thumbnails of selected photos.
2. Click **File** ‹**HDR** ‹**Exposure Merge**.
3. In the Step 1: Merge window, choose a profile from the **Camera response curve profile** drop-list. If you are not sure what to choose, select **Auto Select**. If the **EV interval** slider appears, set the exposure value that you used between photos.
4. In the Alignment area, choose an alignment type from the **Method** drop-list. If you want to crop any edges that don't overlap, mark the **Auto crop** check box.
5. Click **Align**. To see the results, enable the **Preview Alignment** check box (near the bottom of the panel).
6. If you want to keep or remove specific areas from individual photos, use the controls in the Custom editing area. See “To brush in or brush out artifacts in Exposure Merge” on page 190.
7. Click **Process**. The merge settings are applied and the Step 2: HDR Adjustments window appears. If you want to tweak your merge settings, click **Back** to return to the Step 1 window.

**HDR Exposure Merge and Photo Blend** are part of the same merge utility and therefore cannot be opened simultaneously. If your photos were not taken with a tripod or steady rest, there is likely some misalignment between shots. If the misalignment is significant, you may not be able to use the photos for HDR.

You can also add photos to or remove photos from the merge tray by clicking the **Add Photos** button or **Remove Photos** button in the tray at the bottom of the Exposure Merge window.

### To brush in or brush out artifacts in Exposure Merge

1. In the tray that appears below the Step 1: Merge preview area, click a thumbnail.
2. In the Custom editing area, do any of the following:
   - Click **Brush in**, and in the preview area, drag over the area that you want to preserve. You don't need to be exact.
   - Click **Brush out**, and in the preview area, drag over the area that you want to remove.
   - Click **Auto brush** if you want the application to auto-detect and remove ghosting. Auto brush works well for removing ghosting along feature edges in photos taken without a tripod. It is not recommended for larger ghost objects, such as cars and people.
3. Repeat the process for each of the photos that you want to edit.

You can also:

- **Change the brush size**
  - Drag the **Brush size** slider.
- **Refine or erase brushstrokes**
  - Click **Eraser**, and drag across a brushstroke in the preview area.
You can also

Remove all brushstrokes  Click Clear.

Change the color of brushstrokes  Click the arrow beside the Brush in or Brush out color swatch and click a new color.

Hide or display brushstrokes in the preview area  Mark or unmark the Show brushstrokes check box.

To adjust HDR images in Exposure Merge (Step 2)
1  In the Step 2: HDR Adjustments window, do any of the following to achieve the look you want.
   • In the Presets area, click a preset thumbnail.
   • Mark the White Balance check box, click Auto or click the Dropper tool, and click the image to set the white point. Drag the Temperature slider to warm or cool the colors in the image and drag the Tint slider to fine-tune the color.
   • Drag the Contrast, Highlights, Midtones, and Shadows sliders to adjust the overall tone and contrast.
   • Drag the Vibrancy slider to saturate or desaturate the colors.
   • From the Detail drop-list, choose Natural detail or Creative detail, and drag the respective sliders to adjust the amount of local detail.

2  To save your HDR image for further editing, click Create HDR file, navigate to the folder you want, type a file name, and click Save. This saves the image content. You can also save your adjustments as a preset.
3  Click Process.
   The settings are applied to the image and it is saved as a 16-bit file in preparation for the final output. The Step 3: Fine-Tune window appears.

To manage presets in Exposure Merge
• In the Presets area of the Step 2: HDR Adjustments window, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save your adjustments as a preset</td>
<td>Click the Save Preset button, and type a name in the Save Preset dialog box. A thumbnail is added to the preset area.</td>
</tr>
<tr>
<td>Import a preset file</td>
<td>Click the Preset Options button, click Load, and navigate to the file.</td>
</tr>
<tr>
<td>Delete a preset</td>
<td>Click the thumbnail for the preset, click the Preset Options button, and click Delete.</td>
</tr>
<tr>
<td>Restore the default presets list</td>
<td>Click the Preset Options button and click Reset. Click Yes in the confirmation dialog box. All custom presets are deleted.</td>
</tr>
<tr>
<td>Hide or display presets</td>
<td>Click the arrow on the Presets bar.</td>
</tr>
</tbody>
</table>

To fine-tune and save an HDR-processed image (Step 3)
1  In the Step 3: Fine-Tune window, apply any of the tools or adjustment options to adjust the final image.
2  Do one of the following:
• Click the **Edit** tab to continue editing the photo. The Exposure Merge window remains open.
• Click **Save and close** to save the file, close Exposure Merge, and return to the workspace you were last using.

When the size of a zoomed-in image exceeds that of the preview area, you can click the Pan tool and move the rectangle to choose a preview area.

**Using Single RAW Photo to create an HDR effect**

You can split a single RAW photo into three exposures and recombine the exposures to create an HDR effect. Although this is not “true” HDR (you aren’t extending the tonal range by combining multiple photos), you can still optimize the tonal range of a single photo with powerful HDR tools.

![Single RAW Photo was used to create an HDR effect to optimize the tonal range of the photo.](image)

**To create an HDR effect by using Single RAW Photo**

1. Click the **Manage** tab, and select a RAW photo. An orange outline appears around the thumbnail of the selected photo.
2. Click **File** ➔ **HDR** ➔ **Single RAW Photo**.
3. In the Step 1: Split Photo window, choose a profile from the **Camera response curve profile** drop-list. If you are not sure what to choose, select **Auto Select**.
4. Drag the **EV Interval** slider to set the simulated exposure interval. This value is used to split the photo into three versions. If you don’t want the middle exposure to be set at 0, drag the **Center Exposure** slider to set a new value.
5. Click **Split Photo** to break the photo into three versions. Three thumbnails appear in the tray.
6. If you’re happy with the results, click **Process**. You can now optimize the photo using the HDR controls in the Step 2 and Step 3 windows. For more information, see “To adjust HDR images in Exposure Merge (Step 2)” on page 191 and “To fine-tune and save an HDR-processed image (Step 3)” on page 191.
You can also use Single RAW Photo with camera-generated TIFF files (not saved as TIFF in image-editor).

Merging batches of photos into HDR images

If you use auto-bracketing on a regular basis, you may accumulate many sets of photos that can be processed as HDR (high dynamic range) images. You can use the Batch Merge feature to quickly merge each of your bracketed sets into HDR images. You can then evaluate which sets make good candidates for the more powerful HDR tools in the Exposure Merge feature. In some cases, Batch Merge might be the only HDR processing you need to do.

Batch Merge organizes photos into sets, based on the time between photos (within a defined timeframe) or a defined number of photos per set.

To merge batches of photos into HDR images

1. Click the Manage tab, and select the thumbnails for the photos that you want to merge. An orange outline appears around the thumbnails of selected photos.
2. Click File ➤ HDR ➤ Batch Merge. The photos are sorted into groups of three by default.
3. In the Presets area, click a thumbnail to set a processing style. For more information on presets, see “To manage presets in Exposure Merge” on page 191.
   - If you want to apply the application to perform the standard HDR processing instead of applying preset adjustments, skip this step.
4. Click the folder icon beside the Save processed files in box, and browse to the folder where you want to save the processed files.
5. Choose a file type from the Save as drop-list. If you choose JPEG, drag the JPEG quality slider to set the file size and quality for the processed images.
   - If you want to save .hdr versions of the processed files (so you can edit them in Exposure Merge), mark the Save .hdr file check box.
6. In the Group photos by drop-list, choose one of the following:
   - Sets — lets you choose a number in the Photos per set box. This option works well if you consistently shoot bracketed photos in predetermined batches.
   - Time — lets you choose a time interval in the Seconds per group box. This option works well if you vary the number of photos in a bracketed set.
7. If the photos were taken without a tripod, enable the Auto-align check box and choose an alignment option from the Method drop-list. If you want to crop unaligned edges along the borders of the photos, mark the Auto crop check box.
8. Click Process.
   - Processing might take a few moments, depending on the size and number of photos.
   - You can now navigate to the location where you saved your process files and evaluate them.

To remove thumbnails from the Batch Merge window, select the photos and press Delete.

Combining photos with Photo Blend

Photo Blend lets you combine two or more photos of the same scene and choose exactly what you want to keep or remove from the scene. Here are some examples:
- Remove moving objects, such as people or cars, from a photo — you can create an empty street in a busy city.
- Fix a group shot in which one person blinks or looks away — simply swap in a better pose from another photo.
- Get creative by showing the same person multiple times in a single photo.
Photo Blend can be used to create perfect group shots.

How do I take photos that work with Photo Blend?

From a tripod or with a steady rest, shoot two or more photos a few seconds apart. Use the same camera settings for all the photos.

Photo Tip: Use the manual setting on your camera to ensure that the photos have the same size, aperture, shutter speed, and ISO.

To use Photo Blend

1. Click the Manage tab, and select the set of photos that you want to blend.
2. Click File ➤ Photo Blend.
3. In the Alignment area, click Align.
   To see the results, enable the Preview Alignment check box (near the bottom of the panel).
   If you want to crop unaligned edges along the borders of the photos, mark Auto crop.
4. Click a thumbnail in the tray.
   The corresponding photo displays in the preview area.
5. In the Custom editing area, do any of the following:
   • Click Brush in, and in the preview area, drag over the area that you want to preserve. You don't need to be exact.
   • Click Brush out, and in the preview area, drag over the area that you want to remove.
   • Click Auto brush if you want the application to auto-detect the differences between the images. Leave the brushmarks as they are to remove ghosting and other differences, or use it as a starting point for custom brushstrokes.
   • Enable the Include moving objects check box, and click Auto brush to auto-detect and preserve the differences between photos (for example, if you want to create a multi-pose image).
6. Repeat the editing process for other photos by clicking thumbnails in the tray and applying brushstrokes.
7. Click Process.
   Review the results in the preview area. If you want to adjust your settings or continue editing, click Back.
8. In the Step 2: Fine-Tune window, use any of the tools or adjustment controls to fine-tune the image. For more information, see “Using Adjust” on page 95.
9. Do one of the following:
   • Click Edit to continue editing the photo. The Photo Blend window remains open.
   • Click Save and close to save the file, close the Photo Blend window, and return to the workspace.
You can also

Change the brush size Drag the Brush size slider.

Refine or erase brushstrokes Click Eraser, and drag across a brushstroke in the preview area.

Remove all brushstrokes Click Clear.

Change the color of brushstrokes Click the arrow beside the Brush in or Brush out color swatch and click a new color.

Hide or display brushstrokes in the preview area Unmark or mark the Show brushstrokes check box.

💡 For best results, in the tray of the Step 1 window, click the thumbnail of the image that will change the least, and click the lock button 🏛 to use the selected image as background. To unlock the background, click the lock button again.

Combining photos with Focus Stacking

Focus Stacking lets you combine two or more photos of the same scene taken using different focus distances. You can choose exactly what areas in focus you want to keep from source photos to expand the focal range and customize the depth of field in the output composite image.

How do I take photos that work with Focus Stacking?

Set your camera to manual focus. From a tripod or with a steady rest, shoot a series of photos, adjusting the focal ring to change aperture settings between shots.

To use Focus Stacking

1. Click the Edit tab.
2. Click File ➤ Focus Stacking.
3 In the Step 1: Add Photos and Stack window, click the Add button (plus sign) in the tray.

4 In the Open dialog box, navigate to the photos that you want to stack, and click Open.

5 Click Stack.
   A composite of the stack is created in the tray.

6 In the Step 2: Choose Areas of Focus window, click a thumbnail in the tray.
   The corresponding photo displays in the preview area.

7 Click Brush in, and in the preview area, drag over the area that you want to preserve.
   Repeat for every source image. You don't need to be exact.
   Clicking Brush in automatically activates Preview Stacking, which displays the results. You can disable this by unmarking the Preview Stacking check box.

8 Click Blend.
   If you want to adjust the stack, click Back.

9 In the Step 3: Crop and Remove Noise window, in the Digital Noise Removal area, do any of the following:
   • Type or set a value in the Correction Blend control to determine to what degree the corrected image will be blended in with the original.
     The blending values range from 0.0 (no noise reduction) to 100.0 (full processing of the entire image). The default value is 70.
   • Type or set a value in the Sharpening control to determine the degree of sharpening, if any, to apply to the image after the noise reduction is applied.

10 Click Finish in PSP.
Working with selections

Selecting the parts of images to edit is an important step in your workflow. By creating a selection, you can edit an area while leaving the rest of the image unchanged. You can use drawing or painting tools to modify selected areas of your image. You can also apply commands to flip, copy, crop, or perform other actions on the selected areas.

The border of a selection is identified by a selection marquee, which is a series of black and white dashes that outlines the selection.

This section presents the following topics:
- “Creating selections” (page 197)
- “Fine-tuning a selection with the Refine Brush” (page 203)
- “Hiding and displaying the selection marquee” (page 206)
- “Moving, clipping, and rotating selections” (page 206)
- “Modifying selections” (page 208)
- “Inverting and clearing selections” (page 211)
- “Using feathering with selections” (page 212)
- “Using anti-aliasing with selections” (page 213)
- “Modifying the edges of selections” (page 214)
- “Creating custom patterns from selections” (page 214)
- “Saving and loading selections” (page 215)

Creating selections

You can create a selection when you want to isolate part of an image. For example, you can use a selection to adjust or retouch one area of a photo, or to copy a portion of a photo and paste it into another photo. The way you make a selection depends on whether you are working on a raster layer or a vector layer.
You can create a selection by using a Selection tool shape (left), by creating a freehand selection (center), or by using the Magic Wand tool to select specific areas of color or opacity (right).

The following selection tools can be used to create raster selections:

- **Auto Selection tool** — lets you create a smart selection by enclosing an image area in a rectangle that automatically snaps to the edges it detects.
- **Smart Selection Brush** — lets you create a selection by brushing over a sample area. The selection expands automatically to the edges based on the information that is sampled by the brush.
- **Selection tool** — lets you create a selection of a specific shape, such as a rectangle, square, ellipse, circle, or star.
- **Freehand Selection tool** — lets you create a selection around the edges of an object, such as petals of a flower or fingers on a hand. You can make four types of selections with the Freehand tool:
  - **Edge Seeker** — finds the edges between two areas with color differences when you click on the edges of irregularly shaped areas
  - **Freehand** — lets you quickly select an area by dragging
  - **Point to Point** — lets you draw straight lines between points to create a selection with straight edges
  - **Smart Edge** — automatically finds the edges of irregularly shaped areas when you click along the edges
- **Magic Wand tool** — makes a selection based on the color, hue, brightness, or opacity of an object. This tool is designed to select an area that has distinctly different pixels than those in other areas of an image — for example, a pink rose surrounded by green leaves, or a dark area in an otherwise bright image.

The selection tools can also be used on vector layers to create selections from vector objects. For example, if you copy a selection and paste it as a new image, it is copied to a raster layer as individual pixels rather than as a vector object.

For information about vector text, see “Applying text” on page 327.

You can make a selection with one tool and then switch to another tool to add to or subtract from the selection. For more information, see “Modifying selections” on page 208.

You can also use the Paint tool to create a selection. For more information, see “Working with brushes” on page 365.

You can use text selections to apply effects to text; for example, when you create a text selection on a solid-color layer and then delete the selection, the letters appear transparent and outlined with the layer’s solid color.

By creating a raster selection on a vector object, you can use raster-only tools and commands to edit the vector object.
You can create a selection from a mask, which lets you omit the masked (black) areas and select the non-masked (non-black) areas. The selection is clipped to the canvas. For more information, see "Working with masks" on page 245.

**To create a selection by using the Auto Selection tool**

**Edit tab**

1. On the Tools toolbar, choose the **Auto Selection** tool.

2. Drag across the image to enclose the area that you want to select.

3. Release the mouse button to view the auto-selection.

   If you want to redo the selection, press **Ctrl + D** and reselect an area. If you want to refine the selection, on the Tools toolbar, choose another selection tool, and add or remove areas from the auto-selection.

**To create a selection by using the Smart Selection Brush**

**Edit tab**

1. On the Tools toolbar, choose the **Smart Selection Brush**.

2. On the Tool Options palette, adjust the **Size** setting. You can also adjust any of the following settings:
   - **Mode** — specifies whether to replace, add, or remove an existing selection. **Replace** is the default setting.
   - **Feather** — softens the edges of a selection by specifying a fade width (0 to 200 pixels)
   - **Anti-alias** — applies a smooth edge to a selection by making the pixels along its edges semitransparent
   - **Tolerance** — controls how closely the selected pixels match the pixel you click in the image. At low settings, only similar pixels are chosen; at high settings, a wider range of pixels is selected.
   - **Use all layers** — searches for an edge in all layers of the selected area. This option is available when you enable Smart Edge on multilayer images.

3. Drag the brush across the image area that you want to select. You don’t need to be precise; the selection expands automatically to the edges based on the image information that is sampled by the brush.

4. Release the mouse button to review the smart selection.

   If you want to refine the selection, you can press **Shift** and drag to add to the selection or press **Ctrl** and drag to remove from the selection.

   You can use the Smart Selection Brush in manual mode by unmarking the **Smart Edge** check box on the Tool Options palette.
To create a selection by using the Selection tool

**Edit tab**

1. On the Tools toolbar, choose the **Selection** tool.

2. Check the settings of the following controls on the Tool Options palette, and modify them if necessary:
   - **Selection Type** — specifies the shape of the selection area
   - **Mode** — specifies whether to replace, add, or remove an existing selection. **Replace** is the default setting.
   - **Feather** — softens the edges of a selection by specifying a fade width (0 to 200 pixels)
   - **Anti-alias** — applies a smooth edge to a selection by making the pixels along its edges semitransparent
   - **Selection style** — lets you choose from three styles: **Normal** is a free form style, **Fixed Size** lets you specify values in the **Width** and **Height** boxes, and **Fixed Ratio** maintains only the proportions set in the **Width** and **Height** boxes.

3. Drag to make the selection.

As you drag, a border indicates the selection. When you finish dragging, the selection’s border becomes a selection marquee.

You can also

- **Create a selection of a specific size**
  
  On the Tool Options palette, click the **Custom Selection** button. In the Custom Selection dialog box, specify the selection position, in pixels, for the left, top, right, and bottom edges.

- **Replace an existing selection by placing a rectangular selection around it**
  
  Choose the **Selection** tool, and click the **Current selection** button.

- **Create a rectangular selection around all nontransparent areas of the current layer**
  
  Click the **Layer opaque** button.

- **Create a rectangular selection around all nontransparent areas of all layers within the image**
  
  Click the **Merged opaque** button.

After you create a selection, changes to the settings on the Tool Options palette apply to the next action, not to the current selection. You can modify the options for the current selection by choosing **Selections** > **Modify** and choosing a command from the menu.
To create a selection by using the Freehand Selection tool

**Edit tab**

1. On the Tools toolbar, choose the **Freehand Selection** tool.

2. On the Tool Options palette, choose one of the following from the **Selection Type** drop-list:
   - Edge Seeker
   - Freehand
   - Point to Point
   - Smart Edge

3. Check the settings of the following controls on the Tool Options palette, and modify them if necessary:
   - **Feather** — softens the edges of a selection by specifying a fade width (0 to 200 pixels)
   - **Smoothing** — specifies the amount of smoothing to apply to the selection border
   - **Anti-alias** — applies a smooth edge to a selection by making pixels semitransparent
   - **Use all layers** — searches for an edge in all layers of the selected area. This option is available when you use the Edge Seeker or the Smart Edge selection type on multilayer images.

4. Depending on the selection type you chose, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make a Freehand selection</td>
<td>Drag to select an image area.</td>
</tr>
<tr>
<td>Make an Edge Seeker selection</td>
<td>Click precisely along the edge of the area you want to select, and double-click or right-click to complete the selection.</td>
</tr>
<tr>
<td>Make a Smart Edge selection</td>
<td>Click along the edge of the area that you want to select, ensuring that the rectangular cursor encloses the edge. Double-click or right-click to complete the selection.</td>
</tr>
<tr>
<td>Make a Point to Point selection</td>
<td>Click around the area you want to select, and double-click or right-click to complete the selection.</td>
</tr>
</tbody>
</table>

When making an Edge Seeker selection, you can set the distance used to search for an edge by typing a value in the **Range** control on the Tool Options palette.

You can increase the accuracy of Edge Seeker and Smart Edge selections by clicking more frequently along the edge you are following.

You can delete a previous point by pressing **Delete**.

To create a selection by using the Magic Wand tool

**Edit tab**

1. On the Tools toolbar, choose the **Magic Wand** tool.

2. On the Tool Options palette, choose a **Match mode** option:
   - **None** — selects all pixels
   - **RGB Value** — selects pixels that match the red, green, and blue values of the pixel you click
   - **Color** — selects pixels that match the shading variations of the pixel you click
   - **Brightness** — selects pixels that match the perceptual lightness value of the pixel you click
   - **Perceptual** — selects pixels that match the perceptual shading variation and lightness of the pixel you click
• **Traditional** — selects pixels that match red, green, and blue values, with a bias toward lightness variations. This match mode is therefore more discriminating than the RGB Value match mode.

• **All Opaque** — selects all pixels that are not completely invisible (that is, having an opacity value of 1 or greater). Choosing this option disables the Tolerance control.

• **Opacity** — selects pixels that match the opacity value of the pixel you click.

3 Check the settings of the following controls on the Tool Options palette, and modify them if necessary:

• **Tolerance** — controls how closely the selected pixels match the pixel you click in the image. At low settings, only similar pixels are chosen; at high settings, a wider range of pixels is selected.

• **Feather** — softens the edges of a selection by specifying a fade width (0 to 200 pixels)

• **Use all layers** — searches for matching pixels across all layers in the image

• **Contiguous** — selects only pixels that connect to the pixel you click

• **Anti-alias** — produces a smooth-edged selection by partially filling in pixels along the edge, making them semitransparent. You can use this option inside or outside the selection marquee.

4 Click the image area that contains the pixels you want to match.

The selection marquee surrounds all matching pixels.

You can change the number of pixels you select by undoing the selection, adjusting the Tolerance setting, and making a new selection.

---

**To create a selection by using a Painting tool**

**Edit tab**

1 Choose **Selections ▶ Edit Selection**.
   A selection layer is added to the Layers palette.

2 Select a painting tool from the Tools toolbar.

3 Choose settings for the painting tool on the Tool Options palette and the Brush Variance palette.

4 Paint on the image.
   A ruby-colored overlay displays the brush strokes. The selection changes according to the following:
   • Painting with white adds to the selection.
   • Painting with black subtracts from the selection.
   • Painting with shades of gray adds to or subtracts from the selection, depending on the level of gray.

5 Choose **Selections ▶ Edit Selection**.
   The selection marquee surrounds the selected area.

You can also click the **Edit Selection** button 
[Edit Selection] on the Layers palette instead of choosing **Selections ▶ Edit Selection**.

---

**To create a selection by using the Text tool**

**Edit tab**

1 On the Tools toolbar, choose the **Text** tool 

2 On the Tool Options palette, choose **Selection** from the **Create as** drop-list to create a selection shaped like the text.

3 Click where you want to start the text selection.

4 Set the text formatting controls, and type the text.

5 Click the **Apply changes** button 

[Apply changes]
To create a raster selection from a vector object

Edit tab
1. On the Tools toolbar, choose the Pick tool, and select one or more vector objects.
2. Choose Selections ▶ From Vector Object.
   A selection marquee surrounds each vector object.

After you create a raster selection from a vector object, you can copy and paste the selection as needed. The original vector objects remain unchanged.

To select all pixels in a layer or an image

Edit tab
- Choose Selections ▶ Select All.
  A selection marquee appears around the layer on the canvas.

You can also select all pixels in a layer or an image by pressing Ctrl + A.

To select all non-masked areas

Edit tab
1. On the Layers palette, select the mask layer.
2. Choose Selections ▶ From Mask.
   The selection marquee surrounds the non-masked areas.

If you saved a mask to an alpha channel, you can load it as a selection by choosing Selections ▶ Load/Save Selection ▶ Load Selection From Alpha Channel.

Fine-tuning a selection with the Refine Brush

The Refine Brush feature lets you fine-tune the edges of a selection to pick up details like hair or fur that are notoriously difficult to select. The Refine Brush window includes a brush tool as well as sliders, for more global adjustments.
The wolf selection on the right was created with the Smart Selection Brush, then fine-tuned with Refine Brush. Previewing the selection with the White background helps reveal the edge details.

Start with the brush

In most cases, simply dragging across the image with the brush is the most effective way to refine your selection, including areas with fly-away hair strands and edges that vary. Brush modes include Refine (used in most situations), Feather, Add, and Remove.

Optional sliders for global adjustments

Although you don’t need to use the sliders in most cases, they can be used to make global adjustments if the selection edges are fairly consistent, for example, if you are refining a selection of an animal with short fur.

- **Border Width** — lets you specify the area that will be refined (along the edges of the selection)
- **Expand Border** — lets you expand the border area to the inside or outside.
- **Smooth** — reduces variation in the edge by smoothing from the outer border edge inward
- **Feather** — applies a blur effect to the border area

Previewing your selection

As you work, previewing your selection against different backgrounds is helpful. Starting with Overlay helps you see the areas to select, Black and White lets you identify the outline and semi-transparent areas, and Black, White, or Transparent help you see what your final selection will look like.

In addition, you can mark or unmark the Hide/Show Results check box to view the changes made to the original selection by the Refine Brush.
If at any point you want to undo or redo some work, you can open the History palette for the Refine Brush and review your actions. For information about history palettes, see “To undo and redo actions by using the History palette” on page 72.

Output

When you are finished, you can output your refined selection in a number of ways, including selection, mask, and layer options.

What kind of images work best?

- Sharp images where the entire selection is in focus
- Images with consistent lighting where there is good contrast between the subject you want to select and the background

You can improve the performance of the Refine Brush by using hardware acceleration to leverage your system’s graphics processing unit (GPU). By default, hardware acceleration is disabled. To enable it, see “To enable hardware acceleration” on page 410.

To fine-tune a selection with the Refine Brush

1. On the Tools toolbar, choose any of the selection tools and create a selection.
2. On the Tool Options palette, click the Refine Brush button.
3. In the Refine Brush window, choose Overlay from the Preview drop-list.
4. Ensure the Brush Mode is set to Refine, and adjust the Brush Size slider so that you can easily follow the edge of the selection.
5. In the document window, drag the brush over the details that you want to include in the selection.
6. In the Preview drop-list, choose a background that helps you evaluate the results.
7. If required, you can change the Brush Mode to soften the edge (Feather), add areas to the selection (Add), or remove areas from the selection (Remove).
8. When you are satisfied with the selection, choose one of the following options from the Output drop-list:
   - Selection — selection displays on the image; no additional layers
   - Mask — the selection displays on a transparent background; no additional layers
   - New Layer — the selection displays on a new layer with a transparent background; the original image appears on a separate layer
   - New Mask Layer — a mask group is created with three layers: a layer with the selection (transparent background), a mask layer (alpha), and the original image layer
9. Click Apply.

An example of New Mask Layer output
If your selection is fairly uniform, you can use the global sliders to refine the selection. You can also use a combination of the sliders and the brush.

You can resize the brush interactively by pressing Alt while dragging in the image window.

**Hiding and displaying the selection marquee**

The selection marquee is visible by default. When you work with a selection, it is sometimes helpful to hide the selection marquee temporarily without disabling the selection. For example, you may want to see the results of pasting a selection or of feathering a selection’s edges.

**To hide or display the selection marquee**

*Edit tab*

- Choose **Selections ▶ Hide Marquee**.

When you hide the selection marquee, it does not deselect or clear the selection. The tools and commands you use while the selection marquee is hidden apply only to the selected area.

You can also hide or display the selection marquee by pressing Ctrl + Shift + M.

**Moving, clipping, and rotating selections**

You can move, clip, or rotate a selection. If you want to change the selection area, you can also move the selection marquee.

When you move a selection, you can leave the space empty or you can move a copy of the selection and leave the original unchanged. When you move a selection, it becomes a floating selection. When you perform a new action, PaintShop Pro automatically promotes the floating selection to a new layer.

You can also float a selection, which creates a copy of the selection that you can move or modify without changing the original image. A floating selection temporarily rests above the image or layer on the Layers palette, and an icon indicates that the layer contains a floating selection. After you edit the floating selection, you can defloat it.

You can also move a selection to a separate layer. When you do this, the original selection contents are unchanged, and a copy of the selection becomes the new layer. You can edit this new layer without changing the original image.

**Important!** This command works on 16 million–color and grayscale images only. For more information about increasing the color depth of an image, see “Working with colors and materials” on page 253.

After making a selection, you can move the selection anywhere on the image, or off the canvas. If you expand the image window to show the off-canvas gray area, you can see the selection you moved. You can also clip a selection to remove the portion that is not within the image borders.

**To move the selection marquee**

*Edit tab*

- Using the Selection tool, right-click and drag the selection marquee to a new position.

You can also move the selection marquee by right-clicking and dragging with the Move tool.
### To move a selected image area

**Edit tab**
- Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the selection any distance</td>
<td>In the Tool Options palette set <strong>Mode</strong> to <strong>Replace</strong>, and then drag the selection with one of the selection tools (Selection, Freehand, or Magic Wand tool).</td>
</tr>
<tr>
<td>Move the selection 1 pixel</td>
<td>Press an arrow key.</td>
</tr>
<tr>
<td>Move the selection 10 pixels</td>
<td>Hold down <strong>Ctrl</strong>, and press an arrow key.</td>
</tr>
<tr>
<td>Move the selection 50 pixels</td>
<td>Hold down <strong>Shift</strong>, and press an arrow key.</td>
</tr>
<tr>
<td>Move the selection 100 pixels</td>
<td>Hold down <strong>Shift</strong> and <strong>Ctrl</strong>, and press an arrow key.</td>
</tr>
</tbody>
</table>

### To copy and move a selected image area

**Edit tab**
- With the **Selection** tool active, set the Mode control to **Replace**, hold down **Alt**, and drag the selection.

**You can also**

| Copy and move the selection 1 pixel | Hold down **Alt**, and press an arrow key. |
| Copy and move the selection 10 pixels | Hold down **Alt** and **Ctrl**, and press an arrow key. |
| Copy and move the selection 50 pixels | Hold down **Alt** and **Shift**, and press an arrow key. |
| Copy and move the selection 100 pixels | Hold down **Alt**, **Shift**, and **Ctrl**, and press an arrow key. |

### To float a selection

**Edit tab**
- Choose **Selections** ➤ **Float**.

### To defloat a selection

**Edit tab**
- Choose **Selections** ➤ **Defloat**.

### To promote a selection to a layer

**Edit tab**
1. Create a selection in the image.
2. Choose **Selections** ➤ **Promote Selection to Layer**.

The new Promoted Selection appears above the original layer.
To place a selection as a layer within another image, copy the selection, open the other image, and choose Edit ➤ Paste As New Layer.

**To clip a selection to the canvas**

*Edit tab*

1. Move part of the selection off the image canvas. If necessary, expand the image window to reveal the gray area that appears outside the image borders.
2. Choose Selections ➤ Defloat. The selection is defloated, which makes more edit options available.
3. Choose Selections ➤ Clip to Canvas. The selection area outside the image borders is removed.

**To rotate a selection**

*Edit tab*

2. In the Direction group box, choose either Right or Left to specify the rotation direction.
3. In the Degrees group box, set the number of degrees to rotate. If you want to type a value between 0.01 and 359.99, mark the Free option.
4. Unmark the All layers check box.
5. Click OK.

When you rotate a selection, the selection becomes a floating selection, and the original image remains unchanged.

You can also rotate a selection interactively by using the Pick tool. Before the rotation is applied, the selection is promoted to a layer.

**Modifying selections**

Selections can be modified in various ways. You can modify a selection by adding image content to it or by subtracting image content from it. For example, in a picture of a person carrying a large sign, you can select the sign by using the rectangular Selection tool and then add the person to the selection by using the Freehand Selection tool.

![Image description](image-url)

After you create a selection, you can add to it.

You can also expand or contract a selection by a specific number of pixels.
You can add or remove a color from a selection, or from the selection border. When the color is added or removed, the selection border changes.

You can also add pixels to a selection based on color values.

If specks or holes appear in a selection, you can remove them by defining an area in square pixels. For example, if your image is 20 pixels wide by 20 pixels high, you can define an area of 5 pixels multiplied by a scale factor of 100 to cover an area of 500 pixels. Because the image covers an area of only 400 pixels (20 x 20 = 400), all specks and holes will be removed.

You can also modify a selection by using tools and effects.

**To add to or subtract from a selection**

**Edit tab**

1. On the Tools toolbar, choose a selection tool (Selection, Freehand Selection, Magic Wand tool, or Smart Selection Brush).
2. Choose settings for the tool on the Tool Options palette.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add to a selection</td>
<td>From the Mode drop-list, choose Add, and select the image areas that you want to add to the selection. The areas do not need to be adjacent.</td>
</tr>
<tr>
<td>Subtract from a selection</td>
<td>From the Mode drop-list, choose Remove, and select the image areas that you want to remove from the selection.</td>
</tr>
</tbody>
</table>

You can also add to a selection by holding down Shift while clicking the image areas that you want to add, or subtract from a selection by holding down Ctrl while clicking the image areas that you want to remove.

**To expand a selection by a specific number of pixels**

**Edit tab**

1. Choose Selections ➤ Modify ➤ Expand.
   
   The Expand Selection dialog box appears.
2. Specify a value in the Number of pixels control by which to expand the selection.
3. Click OK.
   
   The selection marquee expands while retaining its original shape.

**To contract a selection by a specific number of pixels**

**Edit tab**

1. Choose Selections ➤ Modify ➤ Contract.
   
   The Contract Selection dialog box appears.
2. Specify a value in the Number of pixels control by which to contract the selection.
3. Click OK.
   
   The selection marquee contracts while retaining its original shape.
To add pixels to a selection according to color values

**Edit tab**

1. Choose **Selections** ➔ **Modify** ➔ **Select Similar**.
2. Check the settings of the following controls on the Tool Options palette, and modify them if necessary:
   - **Tolerance** — specifies how closely pixels must match the colors of the initial selection. At lower settings, the values are closer, and more pixels are excluded from the selection. At higher settings, the values do not need to be as close, and more pixels are included in the selection.
   - **Sample Merged** — selects matching pixels in the merged image. If the check box is unmarked, only pixels in the active layer are selected.
   - **Anti-alias** — produces a smooth-edged selection by partially filling in pixels along the edge, making them semitransparent. Mark the **Inside** or **Outside** options, depending on whether you want the areas inside or outside the selection marquee to be anti-aliased. To retain the original edges, unmark the **Anti-alias** check box.
   - **Contiguous** — selects all pixels of a similar color in adjacent areas
   - **Discontiguous** — selects all pixels of a similar color anywhere within the image
3. Click **OK**.
   
   The selection changes to include similar pixels.

The Select Similar command produces the best results when the selection is not anti-aliased.

To add or remove a color from a selection

**Edit tab**

1. Choose **Selections** ➔ **Modify** ➔ **Select Color Range**.
2. Choose one of the following options:
   - **Add color range**
   - **Subtract color range**
3. Click a color in the image that you want to add or remove from the selection.
4. In the **Tolerance** box, specify a color tolerance value (0 to 256).
   
   Shades of the color or related colors are added or removed from the selection.
5. In the **Softness** box, specify the amount of softness for the referenced color.
6. Click **OK**.
   
   The selection borders change to add or exclude the color you specified.

You can click the **Toggle Selection** button in the Select Color Range dialog box to toggle between a preview of only the selection and a preview of the selection with the rest of the image.

You can also choose a color to add or remove by clicking in the **Reference color** box in the Select Color Range dialog box.

To remove a color from a selection, you can also choose **Edit** ➔ **Paste As Transparent Selection** as you paste a selection. This command removes only the color you specify as the background color.

To remove holes and specks from a selection

**Edit tab**

1. Choose **Selections** ➔ **Modify** ➔ **Remove Specks and Holes**.
   
   The Remove Specks and Holes dialog box appears.
2. Choose one of the following options:
   - **Remove Specks**
   - **Remove Holes**
• Remove Specks and Holes

3 In the **Square area smaller than** boxes, enter the number of pixels and the scale factor. Start at low values, and increase them as necessary until the specks and holes are removed.

4 Click **OK**.

The holes and specks in the selection are removed.

You can click the **Toggle Selection** button in the Remove Specks and Holes dialog box to toggle between a preview of only the selection and a preview of the selection with the rest of the image.

**To modify a selection by using tools and effects**

**Edit tab**

1 Choose **Selections** ➤ **Edit Selection**.

A ruby overlay appears in the selected area.

2 Apply a tool or effect to the selection area.

3 When you are finished editing the selection, choose **Selections** ➤ **Edit Selection** to display the selection marquee.

You can also modify a selection by clicking the **Edit Selection** button.

**Inverting and clearing selections**

Sometimes, the easiest way to make a complicated selection is to select the part of the image that you don’t want and then invert the selection. For example, in a picture of a person against a solid-color background, you can select the background and then invert the selection, so that the person is selected instead of the background.

![Image of a sunflower with selection marquee](attachment:selection_marquee.png)

*By selecting a solid background (left) and inverting the selection, you can isolate a complex, multicolored foreground (right).*

You can also clear a selection, which removes the selection marquee and integrates the selection back into the image. After clearing the selection, you can resume your editing of the entire image.

**To invert a selection**

**Edit tab**

• Choose **Selections** ➤ **Invert**.

The selection marquee now encloses the previously unselected image area and excludes the previously selected image area.
To clear a selection

Edit tab

• Choose Selections    Select None.

If you deselect a floating selection, the selection is defloated and placed in the underlying layer if the layer is a raster layer. If the underlying layer is a vector layer or an Art Media layer, a new raster layer is created, and the selection is defloated to it.

You can also clear a selection by right-clicking in the image outside the selection marquee or by pressing Ctrl + D.

Using feathering with selections

Feathering softens the area between a selection and the rest of the image by gradually increasing the transparency of the pixels along the edge of the selection. You can specify the width of the feathered area.

When you copy or move a selection, feathering helps blend the selection into the surrounding area so that the image appears more natural. The higher the feathering value is, the softer the edges are. A feathering value of 0 creates a selection with distinct edges.

You can apply feathering as you make a selection, or you can apply it after the selection is created. The level of feathering and its position around the selection marquee can be adjusted after the selection is created. For more information about creating selections, see "Creating selections" on page 197.

To change the amount of feathering in a selection

Edit tab

1  Choose Selections    Modify    Feather.

2  Type a pixel value in the Feather amount control.
   The feathering is applied both inside and outside the selection.

3  Click OK.

To adjust the position of feathering

Edit tab

1  Choose Selections    Modify    Inside/Outside Feather.

2  Mark one of the following options to set the position of the feathering:
   • Inside

An unfeathered selection (left) and a feathered selection (right)
• Outside
• Both
3 Type a value in the Feather amount control to set the feathering width (in pixels).
4 Click OK.

You can click the Toggle Selection button in the Inside/Outside Feather dialog box to toggle between a preview of only the selection and a preview of the selection and the rest of the image.

To unfeather a selection
Edit tab
1 Choose Selections ➤ Modify ➤ Unfeather.
2 Type a value in the Threshold control to specify the amount of feathering you want to remove.
3 Click OK.

Using anti-aliasing with selections
Anti-aliasing produces a smooth-edged selection by partially filling in pixels along the edge, making them semitransparent. You can apply anti-aliasing to selections as you create them. For more information about creating selections, see “Creating selections” on page 197.

After a selection is created, you can apply anti-aliasing based on the selection’s shape. You can also restore the original anti-aliasing of an object that was pasted into an image. Restoring anti-aliasing is useful if you made the selection without anti-aliasing and you want to smooth the edges of the selection.

To apply anti-aliasing based on shape
Edit tab
1 Choose Selections ➤ Modify ➤ Shape Based Anti-alias.
   The Shape Based Anti-alias dialog box appears.
2 Mark one of the following options:
   • Inside — applies anti-aliasing to the inside of the selection marquee
   • Outside — applies anti-aliasing to outside of the selection marquee
3 Click OK.
   The selection edges are anti-aliased.

To recover anti-aliasing
Edit tab
1 Choose Selections ➤ Modify ➤ Recover Anti-alias.
   The Recover Anti-alias dialog box appears, with the anti-aliased selection displayed in the After preview area.
2 Mark one of the following options:
   • Inside — applies anti-aliasing inside the selection marquee
   • Outside — applies anti-aliasing outside the selection marquee
3 Click OK.

To apply anti-aliasing to all layers in the selection, mark the Use all layers check box.
To apply anti-aliasing and copy the result to a new layer, mark the Result on new layer check box.
Modifying the edges of selections

You can modify the edges of a selection by smoothing its boundary or by adding a border.

To smooth the boundary of a selection

1. Choose Selections ▶ Modify ▶ Smooth.
   The Smooth Selection dialog box appears.
2. Mark or unmark the following options:
   - Anti-alias — smooths the edges of the selection
   - Preserve Corners — preserves the shape of the corners. Unmark this check box if you want to smooth the corners.
3. Specify values for one or both of the following controls:
   - Smoothing amount — specifies the amount of smoothing to apply around the selection
   - Corner scale — specifies the amount of smoothing to apply around the corners of the selection. This control is not available when the Preserve Corners check box is not marked.
4. Click OK.

   You can click the Toggle Selection button in the Smooth Selection dialog box to toggle between a preview of the selection and a preview of the selection and the rest of the image.

To add a border to a selection

1. Choose Selections ▶ Modify ▶ Select Selection Borders.
   The Select Selection Borders dialog box appears.
2. Mark one of the following options to set the position of the feathering:
   - Inside
   - Outside
   - Both
3. Type a value in the Border width box.
   If you want to smooth the edges of the selection border, mark the Anti-alias check box.
4. Click OK.

Creating custom patterns from selections

You can convert a selection into a seamless custom pattern, which you can use for painting, adding text, or creating Web page backgrounds.

To create a custom pattern

1. Make a selection.
2. Choose Effects ▶ Image Effects ▶ Seamless Tiling.
   The Seamless Tiling dialog box appears.
3. Choose an option from the Tiling Method group box.
4. Choose an option from the Direction group box.
   If you choose Bidirectional, you need to choose a setting from the Corner Style group box.
5. Modify any of the settings in the Settings group box.
Click OK.

**Saving and loading selections**

You can save complicated selections that you may want to reuse. You can also save selections as files or as alpha channels.

When you save a selection, it is saved as a separate file with a `.PspSelection` filename extension. When you load a selection into an image, PaintShop Pro creates a selection based on luminance, non-black pixels, or opacity.

Alpha channels in images are data storage areas that hold selections and masks. When you save a selection as an alpha channel, the selection is stored as part of the image on which it was originally created, rather than as a separate file. Selections and masks stored in alpha channels have no effect on the look of an image.

When you save the image in a file format other than the PspImage file format, its alpha channels are not saved. Therefore, it is best to keep a master copy of your image in PspImage format.

When you save a selection to an alpha channel within a PspImage image, you can load that selection from the alpha channel into the same image or into any other image.

If you saved selections to alpha channels that you no longer need, you can delete them. Only alpha channels from the current image can be deleted.

**To save a selection to a file**

**Edit tab**

1. Choose `Selections ▶ Load/Save Selection ▶ Save Selection to Disk` to open the Save Selection to Disk dialog box.
   
   The Selection Files group box displays selection files in `Documents\Corel PaintShop Pro\2023\Selections`. To change the default folder, or to add another folder, click the File Locations button in the Selection Files drop-list.

2. In the File name box, type a name for the selection.

3. Click Save.

**To load a selection file from disk**

**Edit tab**

1. Choose `Selections ▶ Load/Save Selections ▶ Load Selection From Disk`.
   
   The Load Selection from Disk dialog box appears.
   
   The Selection group box shows selection files in all folders. To change the default folder for locating selections, click the File Locations button in the Selection drop-list.

2. Choose a selection from the Selection drop-list.

3. In the Operation group box, choose one of the following options:
   - Replace selection
   - Add to current selection
   - Subtract from current selection

4. In the Create Selection From group box, choose one of the following options:
   - Source luminance
   - Any non-zero value
   - Source opacity

5. Click Load.

**To save a selection to an alpha channel**

**Edit tab**

1. Choose `Selections ▶ Load/Save Selections ▶ Save Selection to Alpha Channel`.
   
   The Save Selection to Alpha Channel dialog box appears.
2 Choose an image from the Add to document drop-list in the Alpha Channels group box. Any existing alpha channels in the image are shown in the preview box below the drop-list.

3 Click Save. The selection is saved to the alpha channel.

You can also

Save a selection to the alpha channel of another image

Select the image name in the Add to document drop-list, and click Save.

Note: The second image must be open in PaintShop Pro for it to appear in the Add to document drop-list.

Change the default name for the new alpha channel

Type a new name in the Name box.

Move the selection to the upper-left corner of the image canvas

Mark the Move to upper left of canvas check box.

Note: This option is useful when a selection does not appear on the canvas because it is larger than the image.

To load a selection from an alpha channel

Edit tab

1 Choose Selections ➔ Load/Save Selection ➔ Load Selection From Alpha Channel. The Load Selection from Alpha Channel dialog box appears.

If you want to show the area around the selection as either transparent or black, click the Toggle transparency checkerboard button in the Preview group box.

2 From the Load From Document drop-list, choose the filename of the image that contains the alpha channel you want to load.

Note: The image must be open in PaintShop Pro for it to appear in the Load From Document drop-list.

3 In the Operation group box, choose one of the following options:

• Replace selection
• Add to current selection
• Subtract from current selection

A message in the Operations group box indicates how the alpha channel intersects the canvas of the current image.

Note: If the alpha channel does not intersect the image canvas or intersects it only partially, you can move the selection onto the image canvas by marking the Move to upper left check box.

4 In the Options group box, choose one or more of the following options:

• Move to upper left
• Clip to canvas
• Invert selection

5 Click Load.

You can also

Clip the selection wherever it extends beyond the image canvas

In the Options group box, mark the Clip to canvas check box.

Select everything outside the original selection

In the Options group box, mark the Invert image check box.
To delete an alpha channel

Edit tab

1. Choose Image ➤ Delete Alpha Channel.
   The Delete Alpha Channel dialog box appears.

2. Choose the alpha channel you want to delete from the drop-list in the Alpha Channels group box.
   If you want to delete all alpha channels, mark the Delete all alpha channels check box.

3. Click Delete.
Working with layers

When you work with layers in PaintShop Pro, you can add elements to your images, create artistic effects and illustrations, and edit your images more easily. You can add or delete layers, rearrange the order in which they are stacked, and blend their pixels in various ways. Unless you merge the layers, you can edit each one independently of the others.

This section presents the following topics:
- “Understanding layers” (page 219)
- “Using layers with photos” (page 222)
- “Using layers with illustrations” (page 223)
- “Using the Layers palette” (page 223)
- “Creating layers” (page 226)
- “Promoting the background layer” (page 227)
- “Deleting layers and clearing layer contents” (page 227)
- “Duplicating and copying layers” (page 228)
- “Renaming layers” (page 228)
- “Viewing layers” (page 229)
- “Finding layers” (page 229)
- “Organizing layers by color” (page 230)
- “Changing the order of layers in an image” (page 230)
- “Moving layers on the canvas” (page 231)
- “Grouping layers” (page 231)
- “Linking layers” (page 232)
- “Blending layers” (page 233)
- “Setting layer opacity” (page 235)
- “Protecting transparent areas of raster layers” (page 236)
- “Merging layers” (page 236)
- “Using adjustment layers” (page 238)
- “Using layer styles” (page 239)

Understanding layers

When you create or import an image in PaintShop Pro, the image has a single layer. Depending on the type of image you create or import, the single layer is labeled as Background, Raster, Vector, or Art Media. When you open a photo, scan, or screen capture, the single layer is labeled as Background on the Layers palette.
For most simple corrections and retouching, you do not have to add layers to an image. However, it is a good practice to duplicate the single layer before making image corrections, so that you preserve the original image on its own layer. If you intend to do more complex work, such as creating a collage with text and other elements or creating a photo composition with layers of effects — the use of layers is highly recommended.

Layers are like separate sheets that you combine to create a final composition.

Each layer you add begins as a transparent sheet over the background. As you add brushstrokes, vector objects, or text, you cover up parts of the Background layer. Transparent areas let you see the underlying layers. You can stack multiple layers to create artistic compositions, photo collages, or complex illustrations.

There are ten types of layers: Background, Raster, Vector, Art Media, Mask, Adjustment, Group, Frame, Selection, and Floating Selection. For more information about Frame layers, see “Placing images in shapes or text with the Frame Tool” on page 169. For information about selections, see “Working with selections” on page 197.

Only grayscale and 16 million-color images can have multiple raster-based layers (Vector layers are the only non raster-based layers). When you add a new raster-based layer to an image of another color depth, such as a 256-color indexed image, PaintShop Pro automatically converts the layered image to 16 million colors.

PaintShop Pro supports up to 500 layers. The actual number of layers allowed in an image may be limited by the available memory in your computer.

You can create layer groups or promote selections to layers. For information about promoting selections to layers, see “Moving, clipping, and rotating selections” on page 206.

Background layers

The background layer is the bottom layer of an image. When you import JPEG, GIF, or PNG images into PaintShop Pro, they have only this single layer, which is named “Background” on the Layers palette.

The background layer contains raster data and is promoted to a raster layer when you change its properties, such as its blend mode or opacity. You cannot change its stacking order unless you promote it to a raster layer.

To position a background layer higher in the layer stack, you can promote it to a regular raster layer. For information about promoting the background layer, see “Promoting the background layer” on page 227.

If you create a new image with a transparent background, it does not have a background layer, and its bottom layer is a raster layer named “Raster 1.” You can move this layer anywhere within the stacking order. You can also change its opacity and blend mode.

PaintShop Pro supports transparency on layers other than the background. To create an image without transparent areas, you can choose a solid-colored background. The image contains a background layer as the bottom layer.
To create a new image with transparent areas, choose a transparent background. The image contains a raster layer as the bottom layer. For more information, see “Starting from a blank canvas” on page 60.

Raster layers

Raster layers are layers with raster data only. Raster data is composed of individual elements, called pixels, arranged in a grid. Each pixel has a specific location and color. Photographic images are composed of raster data. If you magnify raster data, you can see the individual pixels as squares of colors.

Raster layers let you display subtle changes in tones and colors. Some tools, options, and commands apply only to raster layers. For example, the painting tools and the commands that are used to add effects can be applied only on raster layers. If you try to use a raster tool while a vector layer is selected, PaintShop Pro prompts you to convert the vector layer into a raster layer.

For more information about raster and vector data, see “Understanding raster and vector objects” on page 341.

Vector layers

Vector layers are layers with only vector objects (lines and shapes), vector text, or vector groups. Vector objects and text are composed of geometric characteristics — lines, curves, and their locations. When you edit vector objects and text, you edit these lines and curves, rather than the individual pixels. Vector graphics and vector text maintain their clarity and detail at any size or print resolution.

Objects or text created with vector layers can be easily edited. Images of any color depth can include multiple vector layers. Each vector layer contains a list of all individual vector objects on that layer. You can expand or collapse the group to view the individual objects. For more information, see “To expand or collapse layers” on page 225. Vector objects can be moved from their layer group to another vector group.

You cannot move a vector object to a nonvector layer; vector objects must be placed on vector layers. If you create a vector object while a raster layer is selected, PaintShop Pro creates a vector layer just above the selected layer.

For more information about raster and vector data, see “Understanding raster and vector objects” on page 341.

Art Media layers

Art Media layers are automatically created when you use any of the Art Media tools.

When creating a new image, you can choose to create the image with an Art Media layer.

Art Media layers can be converted to raster layers, but not to vector layers.

Mask layers

Mask layers show or hide portions of underlying layers. A mask is an adjustment layer that modifies opacity. You can use masks to create sophisticated effects, such as a picture frame that fades away at the center to reveal the subject.

Mask layers cannot be bottom layers. You cannot delete other layers if deleting them would cause a mask layer to become the bottom layer.

For more information about working with masks, see “Working with masks” on page 245.

Adjustment layers

Adjustment layers are correction layers that adjust the color or tone of underlying layers. Each adjustment layer makes the same correction as an equivalent command on the Adjust menu, but unlike the command, the adjustment layer does not change image pixels.

Adjustment layers cannot be the bottom layer. You cannot delete other layers if deleting them would cause an adjustment layer to become the bottom layer. For more information, see “Using adjustment layers” on page 238.
## Using layers with photos

When you open a digital photo or a scanned image, the image appears on the background layer. For most photographic enhancements, such as cropping, correcting colors, or retouching, you do not need to add additional layers. By adding layers as you work, however, you can create interesting effects and make corrections more easily. The following table provides examples.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preserve the original image before making changes</td>
<td>Make a duplicate of the background layer by choosing <strong>Layers</strong> ➤ <strong>Duplicate</strong>. To work on the duplicate layer, make it the active layer by clicking it on the Layers palette.</td>
</tr>
<tr>
<td>Make color and tonal corrections</td>
<td>Use adjustment layers instead of changing the image directly. For more information about using adjustment layers, see “Using adjustment layers” on page 238.</td>
</tr>
<tr>
<td>Add text or graphics</td>
<td>Create text and graphics, such as lines and shapes, on vector layers to make them easier to edit. For more information about adding text, see “Working with text” on page 327. For more information about vector graphics, see “Drawing and editing vector objects” on page 341.</td>
</tr>
<tr>
<td>Create effects</td>
<td>Duplicate the background layer, apply an effect to the duplicate, and then blend the two layers by changing the opacity or blend modes of the layers.</td>
</tr>
<tr>
<td>Create a painting</td>
<td>Choose an Art Media tool from the Tools toolbar and mark the <strong>Trace</strong> check box on the Tool Options palette (an Art Media layer is created automatically). Use the Art Media brushes to create impressionistic effects.</td>
</tr>
<tr>
<td>Combine photos to create a photo collage</td>
<td>Open the photos that you want to combine and decide which image to use as your base image. Copy the other images into the base image by clicking an image, choosing <strong>Edit</strong> ➤ <strong>Copy</strong>, clicking the base image, and choosing <strong>Edit</strong> ➤ <strong>Paste As New Layer</strong>. Position each layer with the <strong>Move</strong> tool. Use the opacity setting and blend mode to control how much of each layer shows through. Use a mask layer to hide parts of a layer or to create soft edges around it.</td>
</tr>
<tr>
<td>Create a panoramic photo</td>
<td>Take a series of photos with overlapping subject matter. Create an image with a canvas large enough to display a panorama, and then copy each photo onto a separate layer. Decrease the opacity of one layer so that you can see through it, and use the <strong>Move</strong> tool to match up the edges of the next layer. After all layers have been positioned, return their settings to 100 percent opacity.</td>
</tr>
</tbody>
</table>
Using layers with illustrations

Using layers is invaluable when you work with illustrations. The following table provides examples.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make changes easier</td>
<td>Create individual components on separate layers to make them easier to edit. For example, for an illustration of a car speeding down a highway in the mountains, create the car, the driver, the highway, and the mountains on separate layers.</td>
</tr>
<tr>
<td></td>
<td>For more information, see “Creating layers” on page 226.</td>
</tr>
<tr>
<td>Move multiple layers together on the image canvas</td>
<td>Link or group layers that need to move together. For example, link the car and the driver in the previous example so that when you move the car, the driver moves with it.</td>
</tr>
<tr>
<td></td>
<td>For more information, see “Linking layers” on page 232.</td>
</tr>
<tr>
<td>Edit graphical elements</td>
<td>Create vector objects on vector layers for objects that you need to fine-tune or edit.</td>
</tr>
<tr>
<td></td>
<td>For more information, see “Creating layers” on page 226.</td>
</tr>
<tr>
<td>Apply raster-only commands and effects to vector objects</td>
<td>Create a new layer with raster copies of the vector objects. To do this, duplicate the vector layer, and then convert it to a raster layer. Turn off the visibility of the vector layer to work on the raster layer.</td>
</tr>
<tr>
<td></td>
<td>For more information about duplicating layers, see “Duplicating and copying layers” on page 228. For more information about hiding layers, see “To show or hide all layers” on page 229.</td>
</tr>
<tr>
<td>Experiment with changes</td>
<td>Make a copy of a layer, and make changes to it. Copy other layers, and make changes to them. Turn the visibility of layers off and on to find which layer works best for the overall image.</td>
</tr>
<tr>
<td>Save work in progress</td>
<td>Keep a copy of the intermediate steps of transformations, and then turn off the visibility of those layers. Keeping a copy lets you retrace your steps later if you need to.</td>
</tr>
</tbody>
</table>

Using the Layers palette

The Layers palette lists all layers in an image. The order of layers on the palette is the order of layers in the image. The top layer is listed first, and the bottom layer is listed last. You can change the stacking order of layers on the Layers palette, depending on the layer types.

For information about layer types, see “Understanding layers” on page 219.
You can create layer groups to organize the Layers palette. You can also link layers or groups so that they move together when you use the Move tool in the image.

By default, a thumbnail view of the layer’s contents appears to the left of the layer name. You can set the size of the thumbnail or turn the thumbnail off. By default, the settings of the active layer appear above the topmost thumbnail preview, but you can modify the appearance of these settings. For more information about changing the appearance of the Layers palette, see “To modify the look of the Layers palette” on page 225.

The Layers palette displays the names of layers and layer groups. You can customize the names of layers in the palette (see examples in the illustration above). It also indicates the types of layers (background, raster, vector, art media, mask, adjustment, group, selection, or floating selection) and lets you toggle the layer visibility on or off. If there are too many layers for the palette to display at one time, you can use the scroll bars on the right side to move the list up or down.

The Layers palette toolbar, positioned along the bottom edge of the palette, includes controls for tasks such as adding new layers, grouping and deleting layers, and provides a quick access button for setting preferences.

At the top of the Layers palette are controls that let you change the blend mode and opacity of layers, collapse or expand all layers, display the Quick Search, enable Edit Selection, display Layer Effects, link layers, lock transparency, and access layer styles.

You can display or hide the Layers palette or move it anywhere on the screen. For more information about moving, docking, and undocking the Layers palette, see “Using palettes” on page 32.

If an image has more than one layer, you must select the layer that you want to work on. Changes to the image affect only the selected layer (also called the active layer). You can select only one layer at a time.

The Layers palette displays its components as a “tree” of folders and subfolders. Items with subcomponents have a down-facing arrow in front of them when expanded, and a right-facing arrow in front of them when contracted. You can expand a vector layer or layer group to see the names of its subcomponents, or contract a vector layer or layer group to navigate the Layers palette more easily.

To display or hide the Layers palette

Edit tab

• Choose View ➤ Palettes ➤ Layers.

This command toggles the display of the Layers palette on and off.
To select a layer
Edit tab
• On the Layers palette, click the name of a layer.

To expand or collapse layers
Edit tab
• On the Layers palette, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expand the group</td>
<td>Click the right-facing arrow [] in front of the layer or layer group name.</td>
</tr>
<tr>
<td>Collapse the group</td>
<td>Click the down-facing arrow [] in front of the layer or layer group name.</td>
</tr>
<tr>
<td>Expand all layer groups</td>
<td>Click the Expand All Layers button [].</td>
</tr>
<tr>
<td>Collapse all layer groups</td>
<td>Click the Collapse All Layers button [].</td>
</tr>
</tbody>
</table>

To modify the look of the Layers palette
Edit tab
1 Choose File ➤ Preferences ➤ General Program Preferences. The General Program Preferences dialog box appears.
2 On the left pane of the dialog box, choose Palettes.
3 Perform a task from the following table, and click OK.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resize thumbnails</td>
<td>In the Layers palette group box, mark the Palette thumbnails check box, and type or set a value in the Size control. (The default setting is 50 pixels.)</td>
</tr>
<tr>
<td>Turn off thumbnails and display the right pane</td>
<td>In the Layers palette group box, unmark the Palette thumbnails check box, and mark the Right Pane check box. (This is how the Layers palette appeared in earlier versions of the application.)</td>
</tr>
<tr>
<td>Resize the right pane</td>
<td>With the right pane of the Layers palette displayed, drag the pane flyout control horizontally.</td>
</tr>
<tr>
<td>Display layer settings at the top of the palette</td>
<td>In the Layers palette group box, unmark the Right Pane check box.</td>
</tr>
</tbody>
</table>

💡 You can hide the right pane by clicking when the arrow on the vertical divider points to the right. When the arrow points to the left, clicking the control restores the right pane to its previous view.
Creating layers

You can create a layer from the Layers palette. When you create a layer, you can specify properties such as the layer type, opacity, or blend mode. These properties can be modified as you work with the layer. You can create layers from selections, vector objects, or other images.

Layers are created automatically when you use the Text tool, Art Media tools, or vector drawing tools, such as the Pen tool or the Preset Shape tool.

You can also create layers by merging existing layers. For more information, see "Merging layers" on page 236.

To create a layer from the Layers palette

Edit tab

1. On the Layers palette, click the layer above which you want create a layer.
2. From the drop-list on the toolbar of the Layers palette, choose a layer type:
   - New Raster Layer
   - New Vector Layer
   - New Art Media Layer
   - New Layer Group
   - New Mask Layer
   - New Adjustment Layer
3. Adjust the available controls for the layer properties.
4. Click OK.

The new layer is added above the active layer. It is named with the layer type and a number, such as "Vector 1."

For more information about renaming layers, see “Renaming layers” on page 228.

Only grayscale and 16 million-color images can have multiple raster-based layers (Vector layers are the only non raster-based layers). When you add a new raster-based layer to an image of another color depth, such as a 256-color indexed image, PaintShop Pro automatically converts it to 16 million colors.

You can create a layer quickly by holding down Shift, and choosing an option from the New Layer drop-list.

To create a raster layer from a selection

Edit tab

- Choose Selections ➤ Promote Selection to Layer.

The new layer is named “Promoted Selection.”

When you promote a selection, some pixels surrounding the selection border may be included, especially if the selection is anti-aliased or feathered. For information about cleaning up a selection before you copy or promote it, see “Modifying selections” on page 208.

You can also create a raster layer by choosing Edit ➤ Copy and then choosing Edit ➤ Paste As New Layer. The name of the new layer contains “Raster” plus a number, for example, “Raster 1.”
To create a vector layer from vector objects

1. On the Tools toolbar, choose the Pick tool, and select one or more vector objects.
2. Choose Edit Copy.
3. Choose Edit Paste As New Layer.

To create a layer from another image

1. In the image window, click the image you want to copy for the new layer, and choose Edit Copy.
2. Click the image on which you want to paste the new layer, and choose Edit Paste As New Layer.

The layer is pasted on the center of the canvas in the second image.

You can also drag a layer from the Layers palette and drop it onto an image.

Promoting the background layer

To have the Background layer function like other layers, you can promote it to a regular raster layer. Raster layers support transparency and can be moved anywhere within the stacking order. For more information about the background layer, see "Understanding layers" on page 219.

To promote the background layer to a regular raster layer

1. Choose Layers Promote Background Layer.
2. You can also right-click on the layer and choose Promote Background Layer.

Deleting layers and clearing layer contents

You can remove a layer from an image or clear the contents of a layer. Clearing a layer’s contents keeps the layer within the image; raster and vector layers become transparent, and the background layer is filled with the current background color and material.

To delete a layer

1. On the Layers palette, select the layer or layer group you want to delete.
2. Click the Delete Layer button.

You can also

Delete a selected layer from the Layers menu

Choose Layers Delete.

Delete a selected layer by right-clicking

Right-click on the Layers palette, and choose Delete.

Delete a selected layer by dragging

Drag the layer to the Delete Layer button.
To clear the contents of a layer
Edit tab
1. On the Layers palette, click the name of the layer you want to clear.
   Make sure that nothing is selected outside the layer.
2. Choose Edit ➤ Clear.

You can also clear a layer by pressing Delete.

Duplicating and copying layers
You can duplicate a layer within an image. You can use the duplicated layer as a starting point for a new layer, or you can try out edits and effects on the duplicated layer while keeping the original layer intact. You can also copy a layer to another image by copying and pasting or by dragging the layer into another image.

To duplicate a layer within an image
Edit tab
- Select the layer you want to duplicate, and choose Layers ➤ Duplicate.
  The duplicated layer is added just above the selected layer.

You can also right-click the layer name and choose Duplicate.

You can also choose Edit ➤ Copy to copy the layer and then choose Edit ➤ Paste As New Layer.

To copy a layer to another image
Edit tab
1. On the Layers palette, select the layer you want to copy.
2. Choose Edit ➤ Copy.
3. Open the image in which you want to paste the layer.
   If the image has layers, click a layer. When the copied layer is pasted, it will appear above the selected layer.
   The layer is pasted on the center of the canvas.

To copy a layer and drag it into another image
1. Choose the Edit tab, open both images.
2. In the Layers palette, drag the layer that you want to copy from one image to the tab of the other image, and when the other image becomes active, drop the layer in the position you want in the Layers palette.

The Edit tab must be in Tabbed Documents mode (Window ➤ Tabbed Documents) to drag and drop layers between images.

Renaming layers
As you add layers to an image, you may find it convenient to rename them so that they are easy to identify on the Layers palette.
To rename a layer
Edit tab
1. On the Layers palette, click the layer you want to rename, pause a moment, and click again. The name appears highlighted in a box.
2. Type the new name in the box, and press Enter.

You can also rename a layer by double-clicking the layer to display the Layer Properties dialog box and typing a new name in the Name box.

Viewing layers
You can make layers, layer groups, or vector objects visible or invisible in the image. The invisible layers remain in the image but are hidden from view. You can also invert visible and hidden layers.

To display or hide a layer
Edit tab
• Click the Visibility Toggle button for the layer that you want to display or hide.
  — Visibility Toggle button when the layer is displayed
  — Visibility Toggle button when the layer is hidden

Hiding a layer group hides all layers within that group.

To show the selected layer only, choose Layers ➤ View ➤ Current Only.

To show or hide all layers
Edit tab
• Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>View all layers</td>
<td>Choose Layers ➤ View ➤ All.</td>
</tr>
<tr>
<td>Hide all layers</td>
<td>Choose Layers ➤ View ➤ None.</td>
</tr>
</tbody>
</table>

To invert visible and hidden layers
Edit tab
• Choose Layers ➤ View ➤ Invert.
  All previously visible items are hidden, and all hidden items become visible.

Finding layers
When you have a complex project that has many layers and layer groups, you can use Quick Search to find a specific layer by its layer name.
To search for a layer by layer name
1. On the Layers palette, click the Show/Hide Quick Search button to display the Quick Search box at the top of the palette.
2. Type a search word.
   All layers are hidden except for the layers or sublayers that match the search word.
3. Click the X in the Quick Search box to clear the search results and display all layers.

Organizing layers by color
To organize the Layers palette visually, you can specify highlight colors for layers and layer groups. The highlight color appears as the background of the icon to the left of the layer or group name. It has no effect on the image itself.

In a layer group, layers that have not been assigned individual highlight colors inherit the color of the parent layer. You can use the same highlight color for all layers in a layer group and different colors for layers in other layer groups.

To set a highlight color for a layer icon
Edit tab
1. On the Layers palette, double-click the layer to open the Layer Properties dialog box.
2. Mark the Highlight in Layers Palette check box.
3. Click the color box next to the check box.
4. Choose a color, and click OK.
5. In the Layer Properties dialog box, click OK.
   The icon appears with the highlight color.

To choose a highlight color for recently used colors, right-click the color box, and click a color.

Changing the order of layers in an image
The order of layers within an image is critical to the appearance of the image. To rearrange layers in the image, you can easily change the stacking order of layers in the Layers palette. If a layer or a layer group has components, such as vector objects or grouped layers, all of the components move with the layer or layer group when its position in the stacking order is changed.

To move a layer or layer group
Edit tab
- On the Layers palette, select the layer or layer group, and drag it to a new position in the stack.
  A gray line shows the layer's position as you drag.

When you drag a layer, the cursor changes to a hand. A cursor displaying a null symbol indicates that the selected item cannot be moved to a particular position.

You can also move a layer or layer group by choosing Layers ➔ Arrange and then choosing an option.
Moving layers on the canvas

You can move the contents of an entire layer anywhere within the image canvas. If you move part of a layer off the canvas, the layer is not cropped — you can move it back to the canvas or increase the canvas size to display the hidden area. For more information, see “Resizing the canvas” on page 184.

To move a layer on the canvas

Edit tab

1. On the Layers palette, select the layer that you want to move.
2. On the Tools toolbar, click the Move tool.
3. Drag in the image to move the layer to a new position.

You can also select and move layers with the Pick tool.

Grouping layers

You can create layer groups to group multiple layers together. Layer groups let you

- organize the Layers palette
- set layer properties, such as opacity and blend mode, for the whole group
- limit the effect of adjustment and mask layers to the layers underneath the active layer rather than to the entire image
- move all grouped layers together in the stacking order
- move linked layers together on the image canvas
- delete all layers in the group

Layer groups can contain raster, vector, art media, mask, and adjustment layers and must contain at least one layer. Layer groups can also contain other layer groups, called nested groups. If you move all of the layers out of a layer group, PaintShop Pro deletes the layer group.

For information about viewing layer groups, see “To expand or collapse layers” on page 225.

To create a layer group

Edit tab

1. On the Layers palette, select the first layer you want to include in the layer group.
2. From the drop-list on the toolbar of the Layers palette, choose New Layer Group.

The layer group is created, and the selected layer becomes part of the layer group. By default, the layer group name contains “Group” plus a number (for example, “Group 1”).

You can also

Add a layer to a layer group from the Layers palette

On the Layers palette, drag a layer into the layer group. (A black line shows the layer’s position as you drag.)

Add a layer to a layer group from the Layers menu

Choose Layers ▶ Arrange ▶ Move Into Group.

Position a layer group within another layer group

On the Layers palette, drag a layer group into another layer group. (A black line shows the layer group’s position as you drag.)

Move a layer to the bottom of a layer group

Drag the layer to the second-to-bottom position, and then drag the bottom layer up one level.
You can also

Create a layer group from the Layers menu

To remove a layer from a group
Edit tab
- Drag the layer to a new position outside the layer group.

You can also remove a layer from a group by choosing Layers ➤ Arrange ➤ Move Out of Group.

To ungroup layers
Edit tab
- Select the layer group that you want to ungroup, and choose Layers ➤ Ungroup Layers.

Linking layers
You can link layers to have them move together on the image canvas when you move one layer with the Move tool.

You can link grouped layers, which allows all layers within a layer group to move together on the image canvas. You can also link individual layers from different layer groups and move them together without moving other layers in the layer group.

Does linking affect the stacking order?
Linking does not affect the stacking order; it affects only the movements you make with the Move tool on the image canvas. The only way to move layers together in the stacking order is to group them. When you move a layer group in the stacking order, all layers move, regardless of whether the group is linked or unlinked.

To link layers
Edit tab
- On the Layers palette, select the layers that you want to link, and click the Link/Unlink button.

To unlink layers
Edit tab
- On the Layers palette, select the layer you want to unlink, and click the Link/Unlink button.

The link icon is removed from the layer.

To link or unlink a layer group
Edit tab
- On the Layers palette, select the layer group you want to link or unlink, and click the Link/Unlink group button.

The button appears highlighted on the toolbar when a linked group is selected; the button is not highlighted when you select an unlinked group.
You can also link or unlink a group by double-clicking the layer group to display the Layer Properties dialog box, marking or unmarking the **Group is linked** check box, and clicking **OK**.

**Blending layers**

You can create interesting effects by changing the way the pixels on one layer blend with pixels on underlying layers. PaintShop Pro offers a variety of blend modes. By default, the image displays the blended pixels while the individual layers remain unchanged.

When layers are blended, each layer has a blend mode of Normal, which blends pixels based on the opacity of the selected layer. The selected layer is blended with all underlying layers, not just the layer directly beneath it.

You can set the blend range of a layer in addition to its blend mode. By default, the blend mode applies to all pixels. The blend range limits the pixels that the blend mode affects. Blend ranges set the opacity based on brightness or color channel, so that colors drop out of the selected layer and other colors show through.

You can quickly preview layer blending by hovering your mouse pointer over an option in the **Blend Mode** drop-list in the **Layers** palette.

**Understanding blend modes**

The table below describes each of the blend modes.

<table>
<thead>
<tr>
<th>Blend mode</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>Displays pixels of underlying layers based on the opacity of pixels on the selected layer. If the selected layer is fully opaque, no pixels show through. As the opacity decreases, more pixels from underlying layers show through.</td>
</tr>
<tr>
<td>Darken</td>
<td>Displays pixels in the selected layer that are darker than the underlying layers. Pixels lighter than the underlying layers disappear.</td>
</tr>
<tr>
<td>Lighten</td>
<td>Displays pixels in the selected layer that are lighter than the underlying layers. Pixels darker than the underlying layers disappear.</td>
</tr>
<tr>
<td>Hue</td>
<td>Applies the hue of the selected layer to the underlying layers (without changing the saturation or lightness).</td>
</tr>
<tr>
<td>Hue (Legacy)</td>
<td>Functions similarly to the Hue blend mode. This blend mode is retained for the sake of compatibility with earlier versions of the program.</td>
</tr>
<tr>
<td>Saturation</td>
<td>Applies the saturation of the selected layer to the underlying layers, without affecting the hue or lightness. This blend mode is available for 16 million–color images only.</td>
</tr>
<tr>
<td>Saturation (Legacy)</td>
<td>Functions similarly to the Saturation blend mode. This blend mode is retained for the sake of compatibility with earlier versions of the program.</td>
</tr>
<tr>
<td>Blend Mode</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Color</td>
<td>Applies the hue and saturation of the selected layer to the underlying layers (without affecting the lightness). This blend mode is available for 16 million–color images only.</td>
</tr>
<tr>
<td>Color (Legacy)</td>
<td>Functions similarly to the Color blend mode. This blend mode is retained for the sake of compatibility with earlier versions of the application.</td>
</tr>
<tr>
<td>Luminance</td>
<td>Applies the luminance (or lightness) of the selected layer to the underlying layers, without affecting the hue or saturation. This blend mode is available for 16 million–color images only.</td>
</tr>
<tr>
<td>Luminance (Legacy)</td>
<td>Functions similarly to the Luminance blend mode. This blend mode is retained for the sake of compatibility with earlier versions of the program.</td>
</tr>
<tr>
<td>Multiply</td>
<td>Combines the colors of the selected layer with the underlying layers to produce a darker color. Multiplying any color with black produces black; multiplying any color with white leaves the color unchanged. This blend mode produces the same result regardless of the order in which the layers are stacked on the Layers palette.</td>
</tr>
<tr>
<td>Screen</td>
<td>Lightens the colors of underlying layers by multiplying the inverse of the selected layer and of the underlying layers. The result is a color that is the same or a lightened version of the selected layer. This blend mode produces the same result regardless of the order in which the layers are stacked on the Layers palette.</td>
</tr>
<tr>
<td>Dissolve</td>
<td>Randomly replaces the colors of some pixels on the selected layer with those of the underlying layers to create a speckled effect. The opacity of the selected layer determines the number of pixels replaced: the lower the opacity, the greater the number of pixels replaced.</td>
</tr>
<tr>
<td>Overlay</td>
<td>Combines the Multiply and Screen blend modes. If the color channel value of underlying layers is less than half the maximum value, the Multiply blend mode is used. If the color channel value is greater than or equal to half the value, the Screen blend mode is used. The Overlay blend mode shows patterns or colors of the selected layer while preserving the shadows and highlights of underlying layers.</td>
</tr>
<tr>
<td>Hard Light</td>
<td>Combines the Multiply and Screen blend modes. If the color channel value of the selected layer is less than 128, the Multiply blend mode is used. If the color channel value is greater than or equal to 128, the Screen blend mode is used. You can use the Hard Light blend mode to add highlights or shadows.</td>
</tr>
<tr>
<td>Soft Light</td>
<td>Combines the Burn and Dodge blend modes. If the color channel value of the selected layer is less than 128, the Burn blend mode is used. If the color channel value is greater than or equal to 128, the</td>
</tr>
</tbody>
</table>
Dodge blend mode is used. You can use the Soft Light blend mode to add soft highlights or shadows.

Difference
Subtracts the color of the selected layer from the color of the underlying layers. This blend mode produces the same result regardless of the order in which the layers are stacked on the Layers palette.

Dodge
Lightens the image by using the lightness values of the colors in the selected layer to lighten the colors of underlying layers. Light colors produce the most lightening; black has no effect.

Burn
Darkens the image by using the lightness values of the selected layer to reduce the lightness of underlying layers.

Exclusion
Creates an effect similar to, but softer than, the Difference blend mode. The Exclusion blend mode produces the same result regardless of the order in which the layers are stacked on the Layers palette.

To set the blend range of a layer
Edit tab
1. On the Layers palette, double-click the layer to open the Layer Properties dialog box.
2. Click the Blend Ranges tab.
3. In the Blend Channel drop-list, select a channel to use when blending layers.
   - Select Grey Channel to base opacity on the lightness values of layers. Select Red Channel, Green Channel, or Blue Channel to base opacity on the respective color values.
4. Drag the upper arrows to set the values at which the opacity is 100 percent.
   - For example, you can set a layer’s opacity at 100 percent between the lightness values of 43 and 126, with the opacity falling off at the lightest and darkest areas.
5. Drag the lower arrows to set the values at which the opacity is 0 percent.
6. Click OK.

Setting layer opacity
To create interesting effects, you can vary the opacity of a layer from the default of 100 percent (fully opaque) down to 0 percent (fully transparent). When a layer is partially transparent, the underlying layers show through.

You can also change the opacity of a layer group.

The Opacity setting on the Layers palette determines the opacity of each layer. The overall opacity of a layer and the opacity of individual pixels are independent of each other. For example, if a pixel starts at 50 percent opacity and the layer is set to 50 percent opacity, the pixel appears as 25 percent opaque. If the layer is in a layer group that is set to 50 percent opacity, then the pixel appears as 12.5 percent opaque.

To set the opacity of a layer
Edit tab
1. On the Layers palette, select the layer or layer group.
2. Drag the Opacity slider to the desired percentage.
You can also set layer opacity by double-clicking the layer, changing the **Opacity** setting in the Layer Properties dialog box, and clicking **OK**.

**Protecting transparent areas of raster layers**

To apply tools and effects only to certain areas of a raster layer with data, you can use the Lock Transparency feature. Transparent areas remain protected when you paint, apply effects, paste selections, or make other modifications.

*Important! The Lock Transparency feature applies to raster layers only. You cannot lock the transparency of vector, art media, adjustment, mask, or group layers. Background layers do not support transparency.*

**To lock or unlock transparent areas of a raster layer**

**Edit tab**

- On the Layers palette, select the layer, and click the **Lock/Unlock** button.

  The **Lock/Unlock** button appears on the layer when transparency is locked. Click the button again to unlock the transparency. The icon on the layer disappears when the layer is unlocked.

  You can also lock or unlock transparent areas by double-clicking the layer, marking or unmarking the **Lock transparency** check box in the Layer Properties dialog box, and clicking **OK**.

**Merging layers**

Merging layers in an image is also referred to as “flattening” an image. You can choose to merge all layers or only selected layers in an image. Merging layers decreases the memory requirements for the image. Layers are merged according to blend modes, vector data and vector text are converted to raster data, and transparent areas of the background layer are replaced with white.

You can also merge existing layers to create a new layer.

Many file formats, such as JPEG, GIF, and TIF, do not support multilayer images. When you save images to these formats, PaintShop Pro merges all layers into a single background layer. When you save to the PSD (Photoshop) format, the image maintains raster and adjustment layers, but vector layers and art media layers are converted to raster layers.

The following table describes how layer types are merged.

<table>
<thead>
<tr>
<th>Top layer</th>
<th>Merged with</th>
<th>Results in</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any layer</td>
<td>Raster layer</td>
<td>Raster layer</td>
</tr>
<tr>
<td>Vector layer</td>
<td>Vector layer</td>
<td>Vector layer</td>
</tr>
<tr>
<td>Art Media layer</td>
<td>Background</td>
<td>Background</td>
</tr>
<tr>
<td>Mask layer</td>
<td>Mask layer</td>
<td>Mask layer</td>
</tr>
<tr>
<td>Any layer</td>
<td>Background</td>
<td>Background</td>
</tr>
</tbody>
</table>

*Important! You should always make a backup copy of the original Psplimage image before you merge layers. After you merge layers, you cannot edit the layers separately.*
To merge two layers together

**Edit tab**

1. Make sure that one layer is located directly above the other on the Layers palette.
2. Select the top layer.

To merge all layers, choose Layers ➤ Merge ➤ Merge All (Flatten).

To merge selected layers

1. On the Layers palette, select the layers that you want to merge.
   You can Ctrl-click to select non-consecutive layers.
2. Choose Layers ➤ Merge ➤ Merge Selected.

You can also merge selected layers by right-clicking one of the selected layers and choosing Merge ➤ Merge Selected.

To merge selected layers to a new layer

1. On the Layers palette, select the layers that you want to merge to a new layers.
   You can Ctrl-click to select non-consecutive layers.
2. Choose Layers ➤ Merge ➤ Merge Selected To New Layer.

You can also merge selected layers to a new layer by right-clicking one of the selected layers and choosing Merge ➤ Merge Selected To New Layer.

To merge all visible layers

**Edit tab**

1. On the Layers palette, click the Visibility Toggle button for each layer that you do not want to merge.
   When the layer is hidden, the Visibility Toggle button changes to .
2. Choose Layers ➤ Merge ➤ Merge Visible to merge all visible layers into one raster layer.

Invisible layers are not affected. The merged layer, which maintains the transparency information of the original layers, appears at the position of the active layer.

If the selected layer is in a group, only the visible layers in that group are merged. If the layer group is marked as invisible (making all layers within the group invisible), then none of the layers within the group are merged.

To merge visible layers to a new layer

1. On the Layers palette, click the Visibility Toggle button to hide each layer that you do not want to merge.
   When the layer is hidden, the Visibility Toggle button changes to .
2. Choose Layers ➤ Merge ➤ Merge Visible to New Layer to create a new layer from the visible layers.
To merge all layers in a group

**Edit tab**

1. On the Layers palette, select the layer group, or the layer within the group, that you want to merge.
2. Choose **Layers ➤ Merge ➤ Merge Group** to merge all layers in the group into one raster layer.

**Using adjustment layers**

Adjustment layers are correction layers that adjust the color or tone of underlying layers without modifying the image layers themselves. You can add adjustment layers to test various color corrections or combinations of corrections. You can hide, delete, or edit adjustment layers.

An adjustment layer affects all layers below it. If an adjustment layer is in a layer group, it affects only the layers that are below it in the group. To apply an adjustment layer to a single layer without affecting the underlying layers, you can create a layer group with one layer and then add the adjustment layer above the layer in the group. Only the layer in the layer group is affected.

**To add an adjustment layer**

**Edit tab**

1. On the Layers palette, click a layer. When the adjustment layer is added, it will appear above the selected layer.
2. From the drop-list on the palette toolbar, choose **New Adjustment Layer**, and select an adjustment layer type. In the dialog box that appears, the preview areas show the image before and after you make changes. To reset the values to default settings, choose **Default** from the **Load Preset** drop-list.
3. Click the **Adjustment** tab, and set the controls for the adjustment layer.
4. Click **OK**.

You can also add an adjustment layer by choosing **Layers ➤ New Adjustment Layer**.

You can also reset the values to the default by double-clicking the adjustment layer and clicking the **Reset to Default** button in the Properties dialog box.

**To hide or view the adjustment layer overlay**

**Edit tab**

- Choose **Layers ➤ View Overlay**.

You can also hide or display the adjustment layer overlay by clicking the **Highlight mask area** button on the Layers palette.

**To edit an adjustment layer**

**Edit tab**

1. On the Layers palette, double-click the name of the adjustment layer that you want to edit. The Layer Properties dialog box appears.
2. Click the **Adjustment** tab, and modify the color or tonal correction settings.
3. Click the **General** tab to modify the general layer properties such as layer name, blend mode, and opacity.
4. On the **Overlay** tab, adjust the color and opacity of the overlay.
   - The default overlay is a reddish, mask-like layer with 50 percent opacity.
5. Click **OK**.
You can also open the Layer properties dialog box by choosing Layers ➤ Properties.

Using layer styles

You can apply a variety of effects, either alone or in combination, by using the Layer Styles tabbed area of the Layer Properties dialog box. With this feature, you can create visually interesting and creative effects to a layer in real time, and you can fine-tune the effect before applying it. The Layer Styles feature provides six effects: Reflection, Outer Glow, Bevel, Emboss, Inner Glow, and Drop Shadow.

When you apply these effects on a separate layer and save the resulting file in a layer-capable file format (such as the PsdImage format), your original image remains unedited on its own layer. In this sense, layer styles are similar to adjustment layers. They differ, however, in that layer styles are applied not to the underlying canvas, but just to the boundaries of the individual layer.

If you resize a layer with one or more layer styles applied to it, the effects are resized proportionally.

Layer styles can be applied only to raster and vector layers.

Some layer styles (such as Drop Shadow) are applied outside the layer’s data. Some layer styles won’t be seen unless the layer includes areas of transparency.

You can save layer styles as a preset and you can copy and paste layer styles between different layers in the same project. This makes it easy to apply the same drop shadow, glow, or reflection effect across text or objects on different layers.

Why is there a “Layer” check box?

When marked, this check box lets you show the layer data with the effects applied. When unmarked, this check box lets you turn off the layer data and just show the effects. Unmarking the Layer check box makes the original layer data behave as if a mask were applied to it.

Is there a reason for the check box order?

Yes. The effects need to be composited in a particular order to obtain sensible results. For example, you would not want a Drop Shadow effect placed on top of its source object, nor would you want an Outer Glow effect placed under a Drop Shadow effect. Thus, the Reflection effect is placed on top, followed by the Outer Glow effect, the Bevel effect, and so on. The Drop Shadow effect is applied last.

What happens when I edit layers with effects?

Whether you edit a vector layer by adding new text or shapes, or edit a raster layer by painting with a brush tool, the effects previously applied to the layer are applied to any modifications you make.
To apply a Reflection layer style

Edit tab

1. Click a layer, and click the Layer Styles button.
2. In the Layer Properties dialog box, click the Layer Styles tab.
3. In the group box that lists the effects, mark the Reflection check box.
   - The After pane is updated to show the initial Reflection effect. If you want to preview the changes on the actual image, mark the Preview on Image check box.
   - Note: The Reflection effect may create data that extends beyond the viewable image canvas, so you may need to expand the canvas to see the entire effect.
4. Drag the Size slider to set the speed with which the reflection fades in comparison with the original layer data.
5. Drag the Opacity slider to set the intensity of the reflection’s overall lightness.
6. Drag the red Reflection Distance control line to set the horizontal axis about which all layer data is reflected.
7. Click OK.

Tip: You can save Layer Styles settings as a preset and then apply them at any time to another layer. For more information on saving and applying presets, see "Using and creating presets" on page 437.

To apply an Outer Glow layer style

Edit tab

1. Click a layer, and click the Layer Styles button.
2. In the Layer Properties dialog box, click the Layer Styles tab.
3. In the group box that lists the effects, mark the Outer Glow check box.
   - The After pane is updated to show the initial Outer Glow effect. If you want to preview the changes on the actual image, mark the Preview on Image check box.
   - Note: The Outer Glow effect may create data that extends beyond the viewable image canvas, so you may need to expand the canvas to see the entire effect.
4. Drag the Size slider to set how far the glow extends outside the layer data.
5. Drag the Opacity slider to set the lightness intensity and visibility of the glow.
In the rainbow color picker, click a glow color. The current color appears along the bottom row of the color picker.

Click OK.

You can save Layer Styles settings as a preset and then apply them at any time to another layer. For more information on saving and applying presets, see "Using and creating presets" on page 437.

To apply a Bevel layer style
Edit tab

1. Click a layer, and click the **Layer Styles** button.
2. In the Layer Properties dialog box, click the **Layer Styles** tab.
3. In the group box that lists the effects, mark the **Bevel** check box.
   The After pane is updated to show the initial Bevel effect. If you want to preview the changes on the actual image, mark the **Preview on Image** check box.
4. Drag the **Size** slider to set the distance from the outer edge of the layer data to the extent of the bevel.
5. Drag the **Opacity** slider to set lightness intensity and visibility of the bevel.
6. Drag the two-dimensional lighting control to set the direction and distance of the light applied to the effect.
7. In the rainbow color picker, click a bevel color. The current color appears along the bottom row of the color picker.
8. Click OK.

You can save Layer Styles settings as a preset and then apply them at any time to another layer. For more information on saving and applying presets, see "Using and creating presets" on page 437.

To apply an Emboss layer style
Edit tab

1. Click a layer, and click the **Layer Styles** button.
2. In the Layer Properties dialog box, click the **Layer Styles** tab.
3. In the group box that lists the effects, mark the **Emboss** check box.
   The After pane is updated to show the initial Emboss effect. If you want to preview the changes on the actual image, mark the **Preview on Image** check box.
4. Drag the **Size** slider to set the distance from the outer edge of the layer data to the extent of the embossing.
5. Drag the **Opacity** slider to set lightness intensity and visibility of the embossing.
6. Drag the two-dimensional lighting control to set the direction and distance of the light applied to the effect.
7. Click OK.

You can save Layer Styles settings as a preset and then apply them at any time to another layer. For more information on saving and applying presets, see "Using and creating presets" on page 437.

To apply an Inner Glow layer style
Edit tab

1. Click a layer, and click the **Layer Styles** button.
2. In the Layer Properties dialog box, click the **Layer Styles** tab.
3. In the group box that lists the effects, mark the **Inner Glow** check box.
   The After pane is updated to show the initial Inner Glow effect. If you want to preview the changes on the actual image, mark the **Preview on Image** check box.
4 Drag the Size slider to set how far glow extends inside the layer data.
5 Drag the Opacity slider to set the lightness intensity and visibility of the glow.
6 In the rainbow color picker, click a glow color. The current color appears along the bottom row of the color picker.
7 Click OK.

You can save Layer Styles settings as a preset and then apply them at any time to another layer. For more information on saving and applying presets, see “Using and creating presets” on page 437.

To apply a Drop Shadow layer style
Edit tab
1 Click a layer, and click the Layer Styles button.
2 In the Layer Properties dialog box, click the Layer Styles tab.
3 In the group box that lists the effects, mark the Drop Shadow check box.
The After pane is updated to show the initial Drop Shadow effect. If you want to preview the changes on the actual image, mark the Preview on Image check box.
Note: The Drop Shadow effect may create data that extends beyond the viewable image canvas (particularly on a layer the same size as the Background layer), so you may need to expand the canvas to see the entire effect.
4 Drag the Size slider to set the distance between the layer data and the shadow.
As you increase the size, the shadow becomes more blurred.
5 Drag the Opacity slider to set lightness intensity and visibility of the shadow.
6 Drag the two-dimensional lighting control to set the direction and distance of the light applied to the effect.
7 In the rainbow color picker, click a shadow color. The current color appears along the bottom row of the color picker.
8 Click OK.

You can save Layer Styles settings as a preset and then apply them at any time to another layer. For more information on saving and applying presets, see “Using and creating presets” on page 437.

To adjust the layer data visibility
Edit tab
1 Click a layer that has effects applied, and click the Layer Styles button.
Note: When you modify the visibility of layer data, you are not changing the visibility of the effects applied to the layer.
2 In the Layer Properties dialog box, click the Layer Styles tab.
3 In the group box that lists the effects, mark the Layer check box.
The After pane is updated to show the effect of marking the box. If you want to preview the changes on the actual image, mark the Preview on Image check box.
Drag the Opacity slider to set the light intensity and visibility of the layer data.
4 To turn off layer data visibility, unmark the Layers check box.
5 Click OK.

To display or hide layer effects
Edit tab
1 On the Layers palette, click a layer that has effects applied.
2 Click the Layer Effects Visibility Toggle button to display or hide the effects.
A layer effect icon displays on the layer when the effect is visible. The icon disappears when the effect is hidden.
To copy and paste layer styles

Edit tab

1. On the Layers palette, right-click the layer that has the style you want to copy and choose **Copy Layer Styles**.
2. On the Layers palette, right-click the layer to which you want to apply the style and choose **Paste Layer Styles**.
Working with masks

In PaintShop Pro, you can use masks to hide or show parts of a layer, fade between layers, and create other special effects.

This section presents the following topics:
- “Understanding masks” (page 245)
- “Displaying masks” (page 245)
- “Creating masks” (page 246)
- “Deleting masks” (page 249)
- “Editing masks” (page 249)
- “Loading masks” (page 250)
- “Saving masks” (page 251)

Understanding masks

Masks are grayscale raster layers that cover parts of the layers in your image, either completely or with varying levels of opacity. You can use masks to fade between layers, or to create special effects with precision. For example, you can mask the details around the main subject in a photo, or you can use a mask to create a fading navigation bar for a Web page.

Mask pixels display 256 shades of gray, with each shade corresponding to levels of opacity. White pixels show underlying layers, black pixels hide underlying layers, and gray pixels show varying amounts of underlying layers.

Mask layers cannot be the bottom layer in the image or in a layer group. If the mask layer is at the main level (rather than in a layer group), the mask applies to all layers below it in the stacking order. If a mask layer is in a layer group, it applies only to layers within the group that are lower in the stacking order.

Displaying masks

A mask overlay is displayed over protected areas to make it easy to differentiate between masked and unmasked areas. The mask overlay is a red-tinted, transparent sheet. If you adjust the transparency of a mask in certain areas, the degree of red displayed by the mask overlay in those areas varies accordingly.

When you paint or modify the mask, the mask overlay shows what is painted or changed.

You can hide or show a mask layer while you edit an image.
To display or hide the mask overlay
Edit tab
• On the Layers palette, click the Highlight mask area button in the upper right corner of the palette.

The button appears highlighted when the overlay is displayed.

💡 You can also display or hide the mask overlay by choosing Layers ▶ View Overlay.

To change the mask overlay color and opacity
Edit tab
1 On the Layers palette, right-click the mask layer and choose Properties.
2 Click the Overlay tab.
3 Click the Overlay color area, and choose a color.
4 Drag the Opacity slider to set the level of opacity.
5 Click OK.

To display or hide a mask
Edit tab
• Click the Visibility Toggle button on the Layers palette.

— Visibility Toggle button when the mask is displayed
— Visibility Toggle button when the mask is hidden

Creating masks
You can create a mask from an image by loading the image file from disk. When you use an image as a mask for another image, PaintShop Pro applies the mask as a grayscale image. The source image is not altered. You can also create a mask by customizing one of the sample masks included with PaintShop Pro.

An example of an image used as a mask

You can use a selection to create a mask that shows or hides the selection. You can use this mask as a starting point for creating artistic effects.

An example of a selection used as a mask

You can also create a mask from a channel by first splitting an image into its RGB, HSL, or CMYK channels. PaintShop Pro creates a grayscale image for each channel. You can use one of these channel images to create a mask for the original image or for another image.
To create a mask layer

Edit tab
1. On the Layers palette, choose the layer that you want to mask.
2. Choose Layers ▶ New Mask Layer, and choose one of the following options:
   - Show All — shows all underlying pixels
   - Hide All — hides all underlying pixels

You can also

Display the mask on the image
On the Layers palette, click the Highlight mask area button 🕵️.

View the image as it will appear in print or online (without the transparency grid or the mask overlay)
Choose View ▶ Palettes ▶ Overview.

Reorder the layers on which the mask is applied
Drag the mask layer on the Layers palette to a new position in the stacking order.

To apply the mask layer to all underlying layers, drag it from the layer group to the main level.

You can paint on the image to show portions of the underlying layer. For information about editing the mask, see “Editing masks” on page 249.

For information about stacking layers, see “Changing the order of layers in an image” on page 230.

To create a mask from an image

Edit tab
1. Open the image that you want to use as a mask.
2. On the Layers palette, choose the layer that you want to mask.
3. Choose Layers ▶ New Mask Layer ▶ From Image to open the Add Mask From Image dialog box.
4. Open the Source Window drop-list, and choose the image.
5. In the Create Mask From group box, choose one of the following options:
   - Source luminance — determines the degree of masking based on the luminance value of the pixel color. Lighter colors produce less masking; darker colors produce more masking. Transparent areas completely mask the layer.
   - Any non-zero value — applies masking without gradation. Pixels with an opacity between 1 and 255 pixels become white; transparent pixels become black. Transparent areas completely mask the layer.
   - Source opacity — determines the degree of masking based on the opacity of the image. Fully opaque pixels produce no masking; partially transparent pixels create more masking; transparent pixels produce full masking.
If you want to reverse the transparency of the mask, mark the **Invert mask data** check box.

6 Click **OK**.

The mask layer and the selected layer are added to a new layer group. The mask layer applies to the selected layer only.

For information about editing a mask, see “Editing masks” on page 249.

To display the mask on the image, click the **Highlight mask area** button on the Layers palette.

To apply the mask layer to all underlying layers, drag it from the layer group to the main level on the Layers palette.

**To create a mask from a selection**

**Edit tab**

1 Make a selection on a layer by using the **Selection** tool, the **Freehand Selection** tool, or the **Magic Wand** tool.

2 Do one of the following:
   * To mask the selection, choose **Layers**  **New Mask Layer**  **Hide Selection**.
   * To mask everything except the selection, choose **Layers**  **New Mask Layer**  **Show Selection**.

You can also

Display the mask on the image

On the Layers palette, click the **Highlight mask area** button.

Apply the mask layer to all underlying layers

On the Layers palette, drag the mask layer from the layer group to the main level.

If you apply a mask layer to the background, the background is automatically converted to a raster layer.

The mask layer and the selected layer are added to a new layer group. The mask layer applies to the selected layer only.

For information about editing masks, see “Editing masks” on page 249.

**To create a mask from a channel**

**Edit tab**

1 Choose **Image**  **Split Channel**, and choose one of the following:
   * Split to RGB
   * Split to HSL
   * Split to CMYK

2 Select the grayscale image in which you want to create the mask.

3 Choose **Layers**  **New Mask Layer**  **From Image** to open the Add Mask From Image dialog box.

4 In the **Source Window** drop-list, choose the channel that you want to use for the mask.

5 In the **Create Mask From** group box, choose the **Source luminance** option.
   * If you want to reverse the transparency of the mask data, mark the **Invert mask data** check box.

6 Click **OK**.

The mask layer and the selected layer are added to a new layer group. The mask layer applies to the selected layer only.
You can also

Display the mask on the image
On the Layers palette, click the Highlight mask area button.

Apply the mask layer to all underlying layers
On the Layers palette, drag the mask layer from the layer group to the main level.

For information about editing the mask, see “Editing masks” on page 249.
For information about color channels, see “Working with colors and materials” on page 253.

Deleting masks
You can delete a mask from an image, or you can merge it with the underlying layer and then delete the mask layer. However, if you merge the mask with the underlying layer, you can no longer edit the mask independently from the layer.

To delete a mask
Edit tab
1 On the Layers palette, right-click the mask layer, and choose Delete. A message appears asking if you want to merge the mask with the underlying layer.
2 Choose one of the following:
   • Yes — merges the layers and deletes the mask layer
   • No — deletes the mask layer without affecting the underlying layer

You can also delete a mask by choosing Layers ▶ Delete.

Editing masks
When you edit a mask, you change either its area or the degree of masking. For example, painting over an object to mask it changes the area, whereas applying a gradient fill changes the degree of masking.

You can invert the transparency of a mask, so that black pixels become white, white pixels become black, and shades of gray become their mirror value, which is the maximum value (255) minus the current value.

You can use a gradient, pattern, or texture mask to create interesting effects. A gradient mask varies the opacity of an image from fully hidden to fully transparent by fading the image in or out. A pattern or texture mask varies the image opacity in a repeated pattern throughout the image.

Using a gradient mask
You can edit the layer properties of a mask, such as the name, visibility, or opacity. For more information, see "Working with layers" on page 219.

To invert a mask
Edit tab
1. On the Layers palette, click a mask layer.
2. Choose Layers ➤ Invert Mask/Adjustment.

To create a gradient, pattern, or texture mask
Edit tab
1. Create a new mask.
2. Click the Highlight mask area button on the Layers palette to display the mask overlay.
3. On the Tools toolbar, click the Flood Fill tool.
   If you want to fill all pixels in the mask, set the Match mode control on the Tool Options palette to None.
4. On the Materials palette, choose a gradient, texture, or pattern.
5. Click the mask to apply the foreground material; right-click the mask to apply the background material.

For information about creating masks, see “Creating masks” on page 246.
For information about gradients, patterns, or textures, see “Using gradients” on page 258, “Using patterns” on page 264, or “Using textures” on page 265.

Loading masks
When you save a mask to an alpha channel within an image that is saved in Psplmage format, you can load that mask from the alpha channel into the same image or into any other image.

The Masks folder of the PaintShop Pro program folder contains sample masks that you can load into images, such as gradients and several types of circles and squares that frame images. Mask files have a .PspMask filename extension.

To load a mask from an alpha channel
Edit tab
1. On the Layers palette, choose the layer that you want to mask.
2. Choose Layers ➤ Load/Save Mask ➤ Load Mask From Alpha Channel to open the Load Mask from Alpha Channel dialog box.
3. In the Load from Document drop-list, choose the image that contains the alpha channel that you want to load. Choose only open images with existing alpha channels.
4. In the drop-list under the document name, choose the alpha channel that contains the mask.
5. In the Orientation group box, choose one of the following options:
   • Fit to canvas
   • Fit to layer
6 In the Options group box, choose one of the following options:
- **Hide all mask** — hides pixels surrounding a loaded mask that is smaller than the current image canvas
- **Show all mask** — shows pixels surrounding a loaded mask that is smaller than the current image canvas

If you want to invert the transparency of the mask image, mark the **Invert transparency** check box.

7 Click **Load**.

The mask layer and the selected layer are added to a new layer group.

The mask layer applies to the selected layer only. To apply the mask layer to all underlying layers, drag it from the layer group to the main level.

### To load a mask from disk

**Edit tab**

1 On the Layers palette, click the layer that you want to mask.

2 Choose **Layers ➤ Load/Save Masks ➤ Load Mask From Disk** to open the Load Mask From Disk dialog box.

3 In the **Mask** group box, click the drop-list to choose from mask and image files.

The Preview group box displays the selected mask on the image canvas.

4 In the **Orientation** group box, choose one of the following options:
- **Fit to canvas** — adjusts the mask to fit the current image canvas (stretching or contracting as needed)
- **Fit to layer** — adjusts the mask to fit the current layer data (stretching or contracting as needed). If the layer has not been shifted beyond the edges of the canvas, this option produces the same results as the **Fit to Canvas** option.
- **As is** — positions the mask in the upper-left corner of the current layer. This option does not change the mask proportions. If the mask image is smaller than the current layer, PaintShop Pro masks all pixels outside of the mask image boundaries.

5 In the **Options** group box, choose an option to specify whether any pixels surrounding the loaded mask data are shown or hidden. These options affect the mask only if the Orientation option is **As is** and the loaded mask is smaller than the current image canvas.
- **Invert transparency** — inverts the transparency of the mask image
- **Hide all mask** — makes surrounding pixels black to hide underlying pixels
- **Show all mask** — makes surrounding pixels white to show underlying pixels
- **Use image value** — makes surrounding pixels white or black, depending on whether the Show All Mask option or the Hide All Mask option was applied to the original mask.

6 Click **Load**.

PaintShop Pro adds the mask layer and the selected layer to a new layer group. The mask layer applies to the selected layer only. To apply the mask layer to all underlying layers, drag it from the layer group to the main level.

### Saving masks

PaintShop Pro saves masks as separate files in PspMask format. You can load a mask into another image without opening the original image. After the mask is loaded, it is automatically saved with the image in PspImage format. If you want to share a mask or use it in another image, you can save the mask to your hard drive or to an alpha channel.

An alpha channel is a data storage area within an image. Masks and selections stored in alpha channels have no effect on the appearance of an image. You can save a mask to an alpha channel within the current image or within another image. For more information on saving or loading selections in alpha channels, see “Saving and loading selections” on page 215.

**Important!** When you save the image to a file format other than PspImage format, the alpha channels are not saved. To retain the alpha channels, you should always save a master copy of your image in PspImage format.
To save a mask to disk

1. On the Layers palette, click the mask layer.
2. Choose **Layers > Load/Save Mask > Save Mask to Disk** to open the Save Mask To Disk dialog box. The Mask Files group box displays the filenames of the masks in the default Masks folder. The New Mask group box displays the current mask.
3. Click **Save**.

By default, mask files are stored in `Documents\Corel PaintShop Pro\2023\Masks`. For information about setting file locations, see "Setting file locations" on page 413.

To save a mask to an alpha channel

1. On the Layers palette, click the mask layer.
2. Choose **Layers > Load/Save Mask > Save Mask To Alpha Channel** to open the Save Mask to Alpha Channel dialog box.
3. In the **Add To Document** drop-list, choose an alpha channel.
   - If you want to save a mask to an alpha channel in another image, open the other image in PaintShop Pro, and click it to make it active.
   - If you want to change the name of the alpha channel, type a new name in the **Name** group box.
4. Click **Save**.
Working with colors and materials

Whether you are applying color to an image, creating Web projects, or designing scrapbook pages, it’s important to understand how to choose and manage colors and materials in PaintShop Pro.

This section presents the following topics:
- “Using the Materials palette” (page 253)
- “Choosing colors in the Material Properties dialog box” (page 255)
- “Choosing colors for paletted images” (page 257)
- “Choosing colors from an image or the desktop” (page 257)
- “Using gradients” (page 258)
- “Editing gradients” (page 261)
- “Exporting and importing gradients” (page 262)
- “Applying a color or transparency gradient with the Gradient Fill tool” (page 263)
- “Using patterns” (page 264)
- “Using textures” (page 265)
- “Working with custom color palettes and swatches” (page 267)

Using the Materials palette

PaintShop Pro lets you paint, draw, and fill with a variety of styles and materials.
- A style is a color, gradient, or pattern.
- A material is the style plus an optional texture.

Both styles and materials can be selected from the Materials palette.

You can display the Materials palette at any time. You can leave it open while you work, or you can display it only when you need it.

You can also reverse the foreground and background colors or materials.
The Materials palette

1. Swatches tab
2. HSL Map tab
3. Sliders tab
4. Foreground and Stroke Properties
5. Background and Fill Properties
6. Foreground and Background color boxes
7. Swap Colors button
8. Transparent option
9. Texture button
10. Style — Color, Gradient, Pattern
11. Recently Used
12. Sample Color tool
13. Add to Palette and Remove from Palette
14. Set to Black and White
15. Current palette
16. Palette selection menu

Main components of the Materials palette

- **Swatches** tab — displays swatches for the currently selected palette. Swatches are materials you can save to use again. For more information about swatches, see "Working with custom color palettes and swatches" on page 267.

- **HSL Map** tab — displays a Saturation and Lightness box that you can click to adjust the currently selected color or click to adjust a new color that you select by dragging the slider on the Color (hue) bar.

- **Sliders** tab — displays sliders and value boxes that you can use to set a color in the following color spaces: RGB, HSL, CMYK, Lab, Web safe. You can also set a shade using Grayscale.

- **Foreground and Stroke** and **Background and Fill Properties** boxes — display the current foreground and background materials, which consist of the style (color, gradient, or pattern) and optional texture. You can click either box to display the Material Properties dialog box, in which you can set material options. These boxes can be used in the following ways:
  - You can use foreground materials for brush strokes and background materials for fills.
  - When you apply strokes with a brush (including the fill tools), clicking lets you paint with the foreground material, and right-clicking lets you paint with the background material.
  - When you are using the Art Media tools, you can set the foreground color for the pigment that you apply to the canvas.
  - For text and vector shapes, you can set the foreground color for the stroke (or outline) of the text or shape, and the background color for the fill of the text or shape. For more information about changing the color of text and vector objects, see “To modify vector object properties” on page 347.

- **Foreground and Background Color** boxes — display the current foreground and background color and let you set colors regardless of current material

- **Style** button — shows which style is currently selected: color, gradient, or pattern. To change between the most recently selected color, gradient, and pattern, you can click the Style button and select a new style from the drop-list. Note that these options are disabled for the Art Media tools, which use only solid colors.

- **Texture** button — turns the current texture on or off
• **Set to Black and White** button — sets the foreground to black and the background to white. This is helpful when you use the Edit Selection command.

• **Transparent** button — specifies whether the foreground or background material is transparent. You use a transparent material primarily with vector objects and text. A transparent foreground has no outline (only the objects or letters are filled), and a transparent background has no fill (only the objects or letters are outlined). This button is unavailable for tools that require a foreground or background material.

• **All tools** check box — specifies whether the selected foreground and background materials apply to all tools. If the check box is unmarked, the selected materials apply only to the active tool.

**Why does the Materials palette have both properties and color boxes?**

You can select colors by clicking the Foreground and Background Properties boxes, so you may wonder why the Materials palette also includes color boxes. The color boxes provide a quick way to change colors without changing the other materials. This means that you can select a new color even when the properties box displays a gradient or pattern.

If the properties boxes and the color boxes on the Materials palette are showing different colors, the brush paints with the gradient, texture, or pattern shown in the properties boxes rather than with the color in the color boxes. The colors shown in the color boxes become active when you select Color from the Style buttons for the Foreground and Background Properties boxes.

**To display or hide the Materials palette**

Edit tab

• Choose **View ▶ Palettes ▶ Materials**.

You can also close the palette by clicking the **Close button** in the palette’s title bar or by pressing **F2**.

**To swap the foreground and background colors or materials**

Edit tab

• From the Materials palette, click the **Swap Colors button** or click the **Swap Materials button**.

**Choosing colors in the Material Properties dialog box**

When you edit images in PaintShop Pro, you often need to choose a color before painting, drawing, or filling, making manual color corrections, or choosing a background for a new raster image. The Color page in the Material Properties dialog box is the most versatile tool for choosing colors, especially if you're building a custom color palette. The color harmonies help you choose colors that look great together.

The Color page appears when you click the Foreground/Stroke Properties box, the Background/Fill Properties box, or one of the two smaller Color boxes. It also appears when you click a Color box found in other dialog boxes.
The appearance of the Color page depends on the color depth of the active image (16 bits/channel, 8 bits/channel, 256 colors, 16 colors, or 2 colors). For example, for paletted colors, the Wheel, Slider, and Color Harmonies options are not available—swatches display.

The Color page offers many ways to select colors:

- **Wheel** — clicking the Wheel button displays the Color (hue) wheel and the Lightness bar.
- **Slider** — clicking the slider button displays a color space drop list and the corresponding sliders and value boxes. You can select RGB, HSL, CMYK, Lab, Web safe, Grayscale.
- **Swatch** — clicking the Swatch button displays a palette of color swatches. The Standard Palette displays by default, but you can choose any custom palettes from the drop-list.
- **Color Harmonies** — clicking one of the following color harmony settings helps you choose multiple colors that look good together: Complementary, Triad, Tetrad, Analogic, Accented. The Mono setting is the default for a single color.

The associated color swatches appear in the lower left corner of the Color page. Click a swatch and click Add to Palette to add one or more color swatches to a custom palette.

- **HTML color code** lets you enter HTML color values.

For more information about color and how it is perceived, displayed, and printed, see “Understanding color and color models” on page 389.

To choose a color in the Material Properties dialog box

Edit tab

1. On the Materials palette, do one of the following:
   - To choose a foreground color, click the Foreground and Stroke Properties box or the Foreground Color box.
   - To choose a background color, click the Background and Fill Properties box or the Background Color box.

   The Material Properties dialog box appears.

   Click the Color button to display the Color page.

2. Do one of the following:
   - Click Wheel, and click a color on the color wheel to select the approximate color. Drag the color indicator from the center of the circle to the outer edge to adjust the saturation. Darken or lighten the color by dragging the slider on the Lightness bar that appears to the right of the color wheel.
• Click **Slider**, and choose a color space from the drop-list. Adjust the corresponding sliders or type values in the boxes to set the color you want.

• Click **Swatch**, choose a palette from the drop-list, and click a color swatch.

• In the **HTML** box, enter a hex color value.

  The current and previous color swatches appear in the lower right corner of the dialog box.

3  Click **OK**.

You can also

Choose more than one color by using color harmonies. Click one of the following color harmony buttons: **Complementary**, **Triad**, **Tetrad**, **Analogic**, **Accented**. The associated color swatches appear in the lower left corner of the Color page. Drag the color indicator in the color wheel to adjust the colors. Click a swatch and click **Add to Palette** to add one or more color swatches to a custom palette.

You can also choose a color directly on the Materials palette.

To use the current colors with all tools, mark the **All tools** check box on the Materials palette. If you unmark this check box, the current materials are used by the active tool only.

Choosing colors for paletted images

Paletted images are images that have a color depth between 2 and 256 colors. With paletted images, you must choose foreground and background colors from the Materials palette rather than from the Color page.

To choose colors for paletted images

1  On the Materials palette, do one of the following:

   • To choose the foreground color, click the **Foreground and Stroke Color** box.

   • To choose the background color, click the **Background and Fill Color** box.

   Clicking a color box opens the Color page and displays the palette.

2  In the **Sort order** drop-list, select the way in which the colors are sorted:

   • **Palette** — sorts by order of colors in the palette

   • **Hue** — sorts by color

   • **Luminance** — sorts by lightness

3  Click a color.

4  Click **OK**.

To ensure that only the colors available for paletted images are displayed in the Materials palette, the **Show document palette** option must be enabled. Choose **File ➤ Preferences ➤ General Program Preferences**, click **Palettes** in the list, and choose the **Show Document Palette** option. For more information, see “Setting Display and Caching preferences” on page 402.

Choosing colors from an image or the desktop

You can choose a foreground or background color from any open image, or from any color within PaintShop Pro (such as a color on a toolbar). This feature is useful when you want to use the color of a specific icon, or when you want to match the Windows desktop colors. You can also choose a color from other applications or from Web pages displayed in a browser.
You can enable **Sample and Fill** mode to sample a color in an image and click another area or another image to apply the color as a fill.

### To choose a color from the active image with the Dropper tool

**Edit tab**

1. On the Tools toolbar, choose the **Dropper tool** 🖼.
2. On the Tool Options palette, set the options you want:
   - **Sample Size** drop-list — specifies the pixel area for sampling
   - **Use all layers** check box — mark this check box to sample from all image layers
3. Click a color in the image to make it the foreground color, or right-click to make it the background color.

You can also choose a color from the image while using brush tools, such as the Paint Brush or the Eraser tool, by holding down **Ctrl** and clicking in the image to choose a foreground color or right-clicking to choose a background color.

### To sample and fill with a color selected with the Dropper tool

1. On the **Tools** toolbar, choose the **Dropper tool** 🖼.
2. On the **Tool Options** palette, click the **Sample and Fill** button 🖼
3. In the image window, click the color you want to sample. The tool icon changes to a fill icon automatically.
4. Click the area that you want to fill with the sampled color.
   **Note:** The last settings for the **Flood Fill** tool determine how the fill spreads and interacts with the background. For more information, see “To fill an area with a color, gradient, or pattern” on page 179.

### To choose a color from the desktop

**Edit tab**

1. Make sure that the color you want is displayed on the screen.
2. In the Materials dialog box, click the **Sample Color** button 🖼
3. Position your pointer over the area of the desktop that has the color you want. This includes other open windows or displayed Web pages.
4. Click to select the color.
   The selected color appears in the active color or properties box.

When positioned over areas that can be sampled, the Sample Color dropper icon displays.

### Using gradients

Gradients are gradual blends between two or more colors. You can paint, draw, or fill with gradients to create interesting effects or color transitions. You can use gradients to create Web buttons with shadows and highlights, to make objects look shiny or glowing, or to add dimension to objects. You can also use gradients to fade Web page graphics into other content, and you can use a black-to-white gradient as a mask.
For information about editing, creating, and sharing gradients, see “Editing gradients” on page 261 and “Exporting and importing gradients” on page 262.

**Important!** Gradients are available for grayscale and 16 million color–images only. For more information about increasing the color depth of an image, see “Increasing the color depth of an image” on page 382.

**To apply the current gradient**

**Edit tab**

- On the Materials palette, click the **Gradient** button on the **Style** drop-list for the Foreground and Stroke Properties box or the Background and Fill Properties box.
  
  The most recently chosen gradient becomes active.

**To choose a gradient**

**Edit tab**

1. On the Materials palette, do one of the following:
   
   - To choose a foreground gradient, click the **Foreground and Stroke Properties** box.
   
   - To choose a background gradient, click the **Background and Fill Properties** box.
   
   The Material Properties dialog box appears.

2. Click the **Gradient** button.

3. If necessary, choose a gradient category from the **Category** drop-list containing the desired gradients.

4. Click a gradient thumbnail.

5. Choose one or more of the following options:
   
   - **Style** — lets you choose a **Linear**, **Rectangular**, **Sunburst**, or **Radial** gradient.
   
   - **Angle** — specifies the angle or direction of the gradient, from 0 to 359 degrees. This option applies to linear, rectangular, and radial gradients only.
   
   - **Repeats** — sets the number of times (from 0 to 999) to repeat the gradient pattern
   
   - **Invert** — inverts the colors of the gradient
• **Center Point** — determines the horizontal and vertical coordinates of the point from which the gradient disperses or radiates. The distance is measured as a percentage of the fill area’s width. You can change the center point to create fills in circles or other shapes in which the center of the gradient is not at the center of the object. This option applies to rectangular, sunburst, and radial gradients only.

• **Focal Point** — determines the horizontal and vertical coordinates of the point where the foreground color of the gradient begins. The distance is measured as a percentage of the fill area’s width. You can change the focal point to create fills in circles or other shapes in which the effective light source is not at the center of the object. This option applies to rectangular and sunburst gradients only, and is available only when the **Link** check box is unmarked.

• **Link center and focal points** — assigns the same values to the center and focal points. Unmark the check box to edit the focal point separately from the center point. This option applies to rectangular and sunburst gradients only.

6. Click **OK**.

**You can also**

- Save this gradient as a swatch that you can access later
- Click the **Add to Palette** button.

- Apply the current materials to all tools
- On the Materials palette, mark the **All tools** check box. If you unmark this check box, the current materials are applied to the active tool only.

   ![Note](Note-icon.png) You can also move the center point by dragging the control needle or crosshairs shown in the gradient preview. If you unmark the **Link** check box, you can move the focal point by dragging the crosshairs on the gradient.

**To save an edited gradient**

**Edit tab**

1. On the Gradient page, click **Save**.
   - The New Gradient dialog box appears.
2. Enter a unique name for the gradient, and then click **OK**.

**To create a gradient**

**Edit tab**

1. On the Gradient page, click the **New Gradient** button.
   - The **New Gradient** dialog box appears.
2. Type a name for the new gradient, and click **OK**.
   - The gradient is created with two markers at 0% and 100% that use the custom color.

   ![Hint](Hint-icon.png) For more information about gradients, see “Using gradients” on page 258.

**To rename a gradient**

**Edit tab**

1. On the Gradient page, click the **More Options** button, and choose **Resource Manager**.
2. In the Resource Manager dialog box, click the gradient that you want to rename.
3. Click **Rename**, type a name in the **Rename Resource** dialog box, and click **OK**.
To delete a gradient

1. On the Gradient page, click a gradient that you have created.
2. Click the Delete Gradient button.
3. When you are prompted to confirm the deletion, click Yes.

Editing gradients

You can change the colors, transition points, and transparency of gradients. You can edit default gradients or create your own gradients. You can also rename, delete, and save gradients.

The colors, transition points, and transparency of a gradient are indicated by markers and midpoints on the Gradient Editor:
- Markers — transparency markers appear along the top of the gradient bar. Color markers appear below the gradient bar.
- Midpoints — indicate the positions where two colors are equally blended or the 50% opacity position. Each pair of markers has a midpoint that can be located anywhere between the markers.

Important! When you edit and save a default gradient, you permanently change the gradient. To maintain default gradients, save changes to a new gradient file. For more information about saving a gradient, see “To save an edited gradient” on page 260. For more information about restoring default settings, see “Installing and uninstalling Corel programs” on page 16.

To change the location of a marker or a midpoint

1. Drag the marker or midpoint to a new location on the Gradient Editor.

You can also click the marker or midpoint to select it, and then enter a value in the Location field.

To add a marker

1. On the Gradient Editor, click a position under the gradient bar to add a color marker or click above the gradient bar to add a transparency marker.

The marker is created with the currently highlighted Fore, Back, or Custom color on the gradient bar.

To delete a marker

1. On the Gradient Editor, drag a marker away from the gradient bar.

To change the color for a marker

1. On the Gradient Editor, click a marker below the gradient bar to select it.

The triangle at the top of the marker turns black.
2 Perform one of the following tasks, and click OK.

To

Do the following

To use the foreground color

Click the Fore button.

To use the background color

Click the Back button.

To use the currently defined custom color

Click the User button.

To choose a new custom color

Click the swatch beside the User button and select from the Color page, or right-click to select from recently used colors.

To select a color from within the gradient itself

Click the gradient bar.

When you next apply the gradient that contains the foreground or background color, it uses the current foreground and background colors of the image (gradient colors are dynamic). To create a gradient that always contains the same colors (gradient colors are static), use custom colors from the User swatch for all markers.

To change the transparency of a marker

Edit tab

1 On the Gradient Editor, click the marker above the gradient bar to select it.

2 Type or set a value in the Opacity control.

Values range from 0% (completely transparent) to 100% (opaque). At 100%, the underlying pixels are covered completely.

To edit a gradient applied to a vector object and view changes in real-time

1 On the Tools toolbar, click the Pick Tool, and in the image window, select a vector object that has a gradient applied.

2 On the Materials palette, click the Background and Fill Properties swatch to open the Material Properties dialog box.

3 Click the Gradient tab, and adjust any of the gradient settings. Changes appear in real-time in the image window.

Exporting and importing gradients

After creating a new gradient, you may want to export it to use in another program. The default gradients are stored in the GRD file format, which is commonly used in other applications.

You can also import gradients in the GRD file format.

To export a gradient

Edit tab

1 On the Gradient page, select the gradient that you want to export.

2 Click the More Options button, and choose Export.

The Export dialog box appears.

3 Select the folder in which you want to save the gradient.

The default gradients are stored in the Gradients folder within the PaintShop Pro program folder.

4 In the File name field, type a name for the new gradient.

5 Click Save.
To import a GRD gradient

1. On the Gradient page, click the More Options button and choose Import.

   The Import dialog box appears.

2. Select the folder that contains the gradient you want to import.
   All GRD files are listed in the folder.

3. Select the gradient’s filename, and click Open.

Applying a color or transparency gradient with the Gradient Fill tool

The Gradient Fill tool lets you interactively apply a gradient to the canvas, a selection, or shape. You can adjust the colors, gradation, and transparency, as well as the direction, directly in the image window.

By default, the Gradient Fill tool applies the last gradient selected in the Material Properties Gradient page, and modifies it with the current settings in the Tool Options palette.

You can adjust the overall transparency of a color gradient by creating the gradient on a new layer and adjusting the transparency of the layer. For more information, see “Setting layer opacity” on page 235.

You can adjust the transparency of individual nodes (opacity stops).

An interactive gradient fill line appears onscreen when you use the Gradient Fill tool.

To apply a color gradient with the Gradient Fill tool

1. On the Tools toolbar, click the Gradient Fill tool (grouped in a flyout with the Flood Fill tool).

2. In the image window, drag across the canvas, a selection, or an object, to set the gradient line.
   Note: By default, the last foreground gradient selected on the Gradient page of the Material Properties dialog box is applied.
   If you right-click and drag, the last gradient selected for the background swatch is applied.

3. Do any of the following to customize the color of the gradient:
   • To adjust the angle of the gradient, drag the rotation handle.
   • To add a color, drag a color swatch from the Materials palette to the gradient line.
   • To remove a color, drag a swatch away from the gradient line.
   • To change a color, click a swatch on the gradient line (a blue swatch outline indicates that it is selected), and from the Materials palette, drag a new color swatch to the selected swatch, or click the Color Picker on the Tool Options palette, and choose a color.
   • To adjust the transition between colors, drag the swatches along the length of the gradient line.
   • To change the gradient type or to invert the gradient, adjust the controls on the Tool Options palette.
4 To adjust the transparency of the gradient, on the Tool Options palette, mark theOpacity stop check box, and do any of the following:
• On the gradient line, click an opacity stop, and adjust theOpacity setting on the Tool Options palette.
• To add an opacity stop, click the gradient line.
• To remove an opacity stop, drag the selected node away from the gradient line.
• To change the transition between opacity stops, drag the node along the length of the gradient line.

5 To return to color swatch editing, on the Tool Options palette, mark theColor stop check box.

Note: If you can’t see the end of the gradient line, zoom out.

Using patterns
You can paint, draw, or fill patterns to create interesting effects. PaintShop Pro includes many patterns that you can choose from (such as bricks, stained glass, and zebra stripes). You can also create patterns from an image or part of an image.

Patterns add creative flair to your images. You can apply patterned brush strokes, create objects with patterned fills or edges, and create patterned text. You can use patterns to create stationery or to create tiled images for Web pages. Patterns are especially helpful for projects that require interesting backgrounds such as CD covers, calendars, or greeting cards.

Important! Patterns are available for grayscale and 16 million-color images only. For more information about increasing the color depth of an image, see “Increasing the color depth of an image” on page 382.

What is the difference between patterns and textures?
On the Materials palette you can select both a pattern and a texture as part of a material. What is the difference between the two?

A pattern is an opaque, repeated image with specific colors and details. A pattern is a style, just like a solid color or gradient. Patterns do not use the current foreground or background colors. For example, if you select the Bricks pattern and apply brush strokes with the Paint Brush tool, each brush stroke paints the brick pattern.

A texture gives the effect of having textured canvas or paper. Textures use the current style (such as a solid color). For example, if you select the Crumpled Paper texture and if the foreground color is yellow, each brush stroke paints yellow with the texture of crumpled paper.

Textures can be applied at the same time you apply a solid color, gradient, or pattern. This means that you can have both a pattern and a texture selected at the same time.

To apply the current pattern
Edit tab
• On the Materials palette, click the Pattern button on the Style drop-list for the Foreground and Stroke Properties box or the Background and Fill Properties box.

The most recently chosen pattern becomes active.

To choose a pattern
Edit tab
1 On the Materials palette, do one of the following:
• To choose a foreground pattern, click the Foreground and Stroke Properties box.
• To choose a background pattern, click the Background and Fill Properties box.

The Material Properties dialog box appears.
2 Click the Pattern button.
3 On the Pattern page, click a pattern thumbnail.
4 Adjust the following controls:
• **Angle** — specifies the angle (or direction) of the pattern, from 0 to 359 degrees
• **Scale** — specifies the scale (from 10 to 250) of the image’s actual size. At smaller values, the image is repeated more frequently throughout the pattern. At larger values, the image may be cropped, or may lose detail and become blurry.

5 Click **OK**.

You can also

Save this pattern as a swatch that you can access later

Apply the current materials to all tools

Click the **Add to Palette** button.

On the Materials palette, mark the **All tools** check box. If you unmark this check box, the current materials are applied to the active tool only.

💡 You can also change the angle of the pattern by dragging the control needle on the pattern preview on Pattern page.

**To use the active image or a selection as a pattern**

**Edit tab**

1 Open the image you want to use.
2 To select a part of the image as the pattern, make a selection in the image.
   The pattern appears in the Pattern thumbnails on the Pattern page of the Material Properties dialog box.

**To save an image as a pattern**

**Edit tab**

1 Create an image in PaintShop Pro or another application.
2 Save the image file in the Patterns folder of the PaintShop Pro program folder, or in the ...Documents/Corel PaintShop Pro/2023/Patterns folder.
   The pattern appears in the Pattern drop-list on the Pattern tab of the Material Properties dialog box.

💡 To change the default location of pattern files, click the **More Options** button, and choose **File Location**. For more information about setting file locations, see “Setting file locations” on page 413.

**Using textures**

You can paint, draw, or fill with a texture to create the effect of a textured canvas or paper. You can use textures with the current color, gradient, or pattern for foreground and background strokes or fills. PaintShop Pro includes many textures you can choose from, such as clouds, cracked cement, and old paper. You can also create your own textures from an image.

For information about the difference between patterns and textures, see “Using patterns” on page 264.

**To apply the current texture**

**Edit tab**

• On the Materials palette, click the **Texture** button on the **Foreground** and **Stroke Properties** box or the **Background and Fill Properties** box.
   The most recently chosen texture becomes active.
To choose a texture

Edit tab
1 On the Materials palette, do one of the following:
   • To choose a foreground texture, click the Foreground and Stroke Properties box.
   • To choose a background texture, click the Background and Fill Properties box.
   The Material Properties dialog box appears.
2 Click the Texture button.
3 On the Texture page, mark the Add Texture check box.
4 Click a texture thumbnail.
5 Adjust the following controls for the texture:
   • Angle — specifies the angle (or direction) of the texture, from 0 to 359 degrees
   • Scale — specifies the scale (from 10 to 250) of the image’s actual size. At smaller values, the image is repeated more frequently throughout the texture. At larger values, the image may be cropped or may lose detail and become blurry.
   As you adjust these controls, the Current preview box displays the resulting material (the style plus the texture).
6 Click OK.

You can also

Change the style of the material Click the Color, Gradient, or Pattern button and adjust the controls.

Apply the current materials to all tools On the Materials palette, mark the All tools check box. If you unmark this check box, the current materials are applied to the active tool only.

You can apply strokes or fills multiple times to gradually darken and fill in the texture.
You can also change the angle of the texture by dragging the control needle in the texture preview on the Pattern page.

To save an image as a texture

Edit tab
1 Create an image in PaintShop Pro or another application.
2 Save the image as a BMP file in the Textures folder of the PaintShop Pro program folder or in the ...Documents/Corel PaintShop Pro/2023/Textures folder.
   The texture appears in the Texture thumbnails on the Texture page of the Material Properties dialog box.

   The texture thumbnails include all the available files in the Textures folder of the PaintShop Pro program folder.

To change the default location of texture files, click the More Options button, and choose File Location. For more information about setting file locations, see “Setting file locations” on page 413.
Working with custom color palettes and swatches

When you save swatches, you save them to a custom palette. You can create multiple palettes. For example, you can save all the colors and materials for a particular project on a custom palette. You can delete palettes that you no longer need.

You can also load a custom color palette created in PaintShop Pro. For example, a business can share corporate color by using a palette with custom swatches, artists drawing the same cartoon characters can share palettes, or graphic designers can take inspiration from one of the pre-loaded palettes.

Swatches

Swatches are styles or materials created from colors, gradients, patterns, or textures that you can save to use again. Swatches offer a way to save your favorite colors, styles, and materials so that you can access them quickly when you are working on projects.

You can select, create, edit, delete, and rename swatches. You can also change the way swatches are displayed.

Palettes are saved as folders, with the collection of swatch files (.pspscript) within the folder. By default, they are saved in the following location: \[C:\Users\[user name]\Documents\Corel PaintShop Pro\2023\Swatches\...

To choose a color palette

1. On the Materials palette, click the Swatches tab.
2. Click the Palette selection menu and choose a palette from the drop-list.

The swatches for the selected palette display on the Materials palette.

To create a palette

1. On the Materials palette, click the Swatches tab.
2. Click the More Options button, and choose New Palette.
3. Type a name for your palette and click OK.

The palette is added to the drop-list above the swatches. You can now add swatches to the palette. By default, the palette is saved in [C]: \Users\[user name]\Documents\Corel PaintShop Pro\2023\Swatches\...

To delete a palette

1. On the Materials palette, click the Swatches tab.
2. From the palette drop-list, choose the palette you want to delete.
3. Click the More Options button, and choose Delete Palette.
To import a palette of swatches

Edit tab

1. Do one of the following:
   - Copy the palette folder (contains the .pspscript files for each swatch in the palette) to the default user location: 
     
     [C]:\Users\[username]\Documents\Corel PaintShop Pro\2023\Swatches
     
   - Copy the palette folder ((contains the .pspscript files for each swatch in the palette) to the location of your choice and choose File ➤ Preferences ➤ File Locations, click Swatches in the File types list, and click Add to navigate to the location where you stored the palette folder.

To create a swatch

Edit tab

1. On the Materials palette, click the Swatches tab.
2. Click the Add to Palette button.
3. In the Add to Palette dialog box, choose a palette and click OK, or click New to create a palette.
4. In the New Swatch dialog box, type a name for your swatch.
   - This name appears as a tooltip when you hold the pointer over the swatch on the Materials palette.
5. Click OK.
   - The swatch appears on the Materials palette.

   You can also click the More Options button on the Materials palette, and choose New Swatch.

To select a swatch

Edit tab

1. On the Materials palette, click the Swatches tab.
2. Do one of the following:
   - To select a swatch as the foreground material, click the swatch.
   - To select a swatch as the background material, right-click the swatch.

To edit a swatch

Edit tab

1. On the Materials palette, click the Swatches tab.
2. Double-click the swatch you want to edit.
   - The Material Properties dialog box appears.
3. Edit the style (color, gradient, or pattern) or the texture for the material.
4. Click OK.

   You can also click the swatch, click the More Options button, and then choose Edit Swatch.

To delete a swatch from a palette

Edit tab

1. On the Materials palette, click the Swatches tab.
2. Click the swatch you want to delete.
3 Click the Remove from Palette button.

You can also click the More Options button and choose Delete Swatch.

To rename a swatch
Edit tab
1 On the Materials palette, click the Swatches tab.
2 Click the swatch you want to rename.
3 Click the More Options button and choose Rename Swatch.

To change how swatches are displayed
Edit tab
- On the Materials palette, click the Swatches tab and perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select which swatch types are displayed</td>
<td>Click the More Options button, choose View, and then choose the swatch type to display.</td>
</tr>
<tr>
<td>Change how swatches are sorted</td>
<td>Click the More Options button, choose Sort By, and then choose Style or Name. By default, the swatches are sorted by style.</td>
</tr>
<tr>
<td>Change swatch thumbnail sizes</td>
<td>Click the More Options button, and choose Small Thumbnails, Medium Thumbnails, or Large Thumbnails. Medium thumbnails are displayed by default.</td>
</tr>
</tbody>
</table>
Applying effects

PaintShop Pro has many special effects that you can apply to your images, including 3D, artistic, illumination, reflection, and photographic effects. You can also add frames to your images, paint with images, or warp image areas to create unique effects.

This section presents the following topics:

• “Choosing effects” (page 271)
• “Applying 3D effects” (page 274)
• “Applying Art Media effects” (page 277)
• “Applying Artistic effects” (page 279)
• “Applying environment maps and bump maps” (page 287)
• “Applying Distortion effects” (page 287)
• “Using the Displacement Map effect” (page 292)
• “Applying Edge effects” (page 293)
• “Applying Geometric effects” (page 295)
• “Applying Illumination effects” (page 297)
• “Applying Image effects” (page 298)
• “Applying Photo effects” (page 299)
• “Using Retro Lab” (page 303)
• “Applying a gradient with the Graduated Filter effect” (page 304)
• “Creating vintage-style photos with the Time Machine” (page 305)
• “Applying film and filter effects to photos” (page 307)
• “Applying Reflection effects” (page 310)
• “Applying Texture effects” (page 311)
• “Adding picture frames to images” (page 318)
• “Creating your own effects” (page 319)
• “Combining images” (page 319)
• “Using the Picture Tube tool” (page 320)
• “Warping images” (page 323)
• “Working with deformation maps” (page 325)

Choosing effects

You can choose effects by using the Effects menus, the Instant Effects palette, or the Effect Browser.

You can customize most effects by adjusting their settings in dialog boxes. The dialog boxes for applying effects contain several common features:

• The Before pane shows the original image, and the After pane lets you preview the image with the current settings applied.
The Load Preset drop-list is set by default to Last Used. Presets let you apply the same settings to multiple images.

To save and load your own presets for effects, see “Using and creating presets” on page 437.

Using the Instant Effects palette

You can quickly apply preset effects by using the Instant Effects palette. It is an easy way to apply an effect when you don’t want to adjust controls. When you create a preset in any effects dialog box, your preset automatically displays in the Instant Effects palette in the User Defined category. In the AI Style Transfer category, you can control the effect with Strength, Color Match, and Smooth Image controls.

Using the Effect Browser

You can use the Effect Browser when you want to preview multiple effects before applying them to your image. The Effect Browser displays the presets that come with PaintShop Pro as well as any that you create.

To display the thumbnail previews that you see in the Effect Browser, PaintShop Pro applies an effect’s default preset and any presets that you saved to the image. The preset is saved as a script in the file format for PaintShop Pro (PspScript).
The Effect Browser displays thumbnails that let you preview and choose effects.

To choose an effect from the Effects menu

Edit tab

1. From the Effects menu, choose an effect category, and choose an effect. (For example, choose Effects ▶ Distortion Effects ▶ Twirl.) For most effects, a dialog box appears.

2. Specify the desired settings, or choose a preset from the Load Preset drop-list.
   You can preview the effect in the After pane.
   **Note:** Presets are not available for all effects.

3. Click OK.

You can also

Save settings for reuse

Click the Save Preset button  
, type a name in the Preset name box, and click OK.

Reset settings to default values

From the Load Preset drop-list, choose Default.

Limit an effect to a specific area

Make a selection before choosing the effect.

For information about creating selections, see “Creating selections” on page 197.

To choose an effect from the Instant Effects palette

1. In the Instant Effects palette, choose a category from the drop-list below the preview at the top of the palette.

   If the Instant Effects palette is not displayed, choose View ▶ Palettes ▶ Instant Effects.

2. Click a thumbnail to apply the effect to the preview in the palette.

3. To apply the effect to the active image or the selected images, double-click a thumbnail.

   With the exception of the AI-Powered effect, effects are cumulative; each time you double-click, the new effect is added to the previous effect.

   To undo an effect, click the Undo button  (Adjust and Edit tabs).

From the Manage tab, if you apply effects to an image that is in a RAW file format, a JPEG version of the image is created.
Custom presets (saved in any effect dialog box) appear in the User Defined category in the Instant Effects palette the next time that you launch the application.

**To choose an effect from the Effect Browser**

**Edit tab**

1. Choose **Effects** ➔ **Effect Browser**.
   
The Effect Browser appears.

2. From the hierarchical list in the left pane, do one of the following:
   
   • To preview all effects applied to the image, click the **Presets** folder.
   
   • To preview an effect category, click a subfolder of the **Effects** folder (for example, **3D Effects**, **Artistic Effects**, or **Photo Effects**).
   
   PaintShop Pro scans the selected folder and creates thumbnails of the image with each effect applied to it.

3. Click a thumbnail image to choose an effect preset.

4. Click **Apply**.

You can also

- **Modify the selected preset**
  
  Click **Modify**, and adjust the settings in the dialog box for the effect.

  Note: This button is unavailable for effects that cannot be adjusted.

- **Resize the thumbnail preview**
  
  Choose **File** ➔ **Preferences** ➔ **General Program Preferences**, and click **Display and Caching** along the left side. In the **Effect browser thumbnails** group box, set a value in the **Size (Pixels)** control.

- **Limit an effect to a specific area**
  
  Make a selection before choosing the effect.

  For information about creating selections, see “Creating selections” on page 197.

The thumbnail previews displayed in the Effect Browser for a given effect include the default preset and any presets that you have saved. Presets are saved as script files (with a .PspScript filename extension) and are located in the Presets folder of the main program folder. You can change the location for storing preset files. For information about changing where preset files for effects are stored, see “To change file locations for resources” on page 414.

**Applying 3D effects**

You can create images or selections that appear to have three dimensions by using the 3D effects. These effects are particularly useful for Web page images.

**Buttonize**

**Edit tab**

You can use the Buttonize effect to simulate square or rectangular buttons created from any selection, layer, or flattened image. With this effect, a 3D border is applied to makes the image or selection appear raised. You can access the Buttonize dialog box by choosing **Effects** ➔ **3D Effects** ➔ **Buttonize**.

The Buttonize dialog box contains the following controls:

- **Height** — specifies the height of the button in pixels
• **Width** — specifies the width of the button in pixels
• **Opacity** — specifies the opacity of the shading applied to the edges of the button
• **Transparent** — produces a rounded effect by applying soft shading to the edges of the button
• **Solid** — produces sharp, distinct edges by applying a solid color to the edges of the button. To create a button with a colored edge, you can select the solid color before choosing the Buttonize command.
• **Color** — lets you apply a specific color to the edges of the button. You can click the color box to choose a color from the Color dialog box, or right-click the color box to choose a color from the Recent Colors dialog box.

**Chisel**
Edit tab

The Chisel effect adds a three-dimensional border around a selection or layer to make it appear as though it were cut out of stone. You can make the chiseled area transparent, allowing the underlying colors to show through, or you can create the chiseled area be from the background color. You can access the Chisel dialog box by choosing Effects 3D Effects Chisel.

The Chisel dialog box contains the following controls:
• **Size** — sets the size of the chiseled area in pixels
• **Transparent** — allows the underlying colors to show through
• **Solid color** — makes the chiseled area a solid color
• **Color** — lets you choose a background color for the chiseled area. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.

**Cutout**
Edit tab

The Cutout effect creates the illusion that part of the image has been removed, allowing you to see through the image to a lower level.

Although a selection is not required, you can select part of the image before applying this effect. You can access the Cutout dialog box by choosing Effects 3D Effects Cutout.

The Cutout dialog box contains the following controls:
• **Vertical** — determines the vertical position of the interior and outline. Increase the setting to move the interior toward the bottom of the image, and decrease the setting to move the interior toward the top.
• **Horizontal** — determines the horizontal position of the interior and outline. Increase the setting to move the interior toward the right, and decrease the setting to move the interior toward the left.
• **Opacity** — controls the shadow’s opacity
• **Blur** — sets the shadow’s blur. As you increase the blur level, the shadow widens and its edges soften.
• **Shadow color** — lets you choose a shadow color. You can click the color box to choose a color from the Color dialog box, or right-click the color box to choose a color from the Recent Colors dialog box.
• **Fill interior with color** — fills the interior with the currently selected color. To choose a different color, you can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box. When unmarked, this check box fills the cutout with the image.

**Drop Shadow**
Edit tab

The Drop Shadow effect adds a shadow behind the current selection. It is most often used to give text a three-dimensional appearance.

To add a drop shadow to the entire image, you must first create white space around the image. You can do this by choosing the Add Borders command or the Canvas Size command from the Image menu. You can access the Drop Shadow dialog box by choosing Effects 3D Effects Drop Shadow.

The Drop Shadow dialog box contains the following controls:
• **Vertical** — determines the height of the shadow. You can also set the height by dragging the crosshair end of the offset indicator line in the left side of the dialog box.
• **Horizontal** — determines the width of the shadow. You can also set the width by dragging the crosshair end of the offset indicator line in the left side of the dialog box.
• **Opacity** — determines the shadow’s opacity. As this value decreases, the drop shadow fades.
• **Blur** — determines the blur of the shadow
• **Color** — lets you choose the color of the drop shadow. You can click the color box to choose a color from the Color dialog box, or right-click the color box to choose a color from the Recent Colors dialog box.
• **Shadow on new layer** — places the drop shadow on a separate raster layer

You can apply an effect similar to the Drop Shadow effect by choosing the **Border with drop shadow** script from the **Script** drop-list on the **Script** toolbar.

### Inner Bevel

**Edit tab**

You can apply the Inner Bevel effect to give a 3D appearance to the inside edges of a selection, or to an object surrounded by a transparency. This effect does not increase the size of the object. When you use the Inner Bevel effect, you can set the options yourself, use one of the preset effects included with the program, or start with a preset effect and then modify its settings.

The Inner Bevel command is available when an image has a transparent background, has a colored background that contains a selection, or has a colored background and a layer. If a layer does not contain a selection or transparent area, the effect is applied to the edges of the layer. You can promote a selection, paste a selection as a new layer, or use the Eraser Tool to create a layer with transparency. You can access the Inner Bevel dialog box by choosing **Effects** ➔ **3D Effects** ➔ **Inner Bevel**.

The Inner Bevel dialog box contains the following controls:

• **Bevel** — specifies the bevel shape
• **Width** — specifies the width in pixels
• **Smoothness** — controls the slope (sharpness) and thickness of the edge. As this value increases, the edges become more rounded. As it decreases, the edges appear thinner and steeper.
• **Depth** — controls the height of the edge. As this value increases, the edge becomes more pronounced.
• **Ambience** — adjusts the overall brightness of the image
• **Shininess** — determines how reflective the surface appears. A higher value produces a glossy image and makes the highlights more evident. A lower value makes the highlights diminish.
• **Color** — determines the color of the light shining on the image. To change the light color, you can click a color in the image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle. To set the value, you can click in the circle, drag the needle, or set or type a number in the control.
• **Intensity** — adjusts the brightness of the directional light. Note that the Ambience value determines the brightness of the entire image before the Intensity value is applied.
• **Elevation** — shows the angle of elevation of the light source above the image. At a setting of 90 degrees, the light source is positioned directly overhead. As you lower the value, the light source moves closer to the image, producing longer shadows.

### Outer Bevel

**Edit tab**

The Outer Bevel effect gives a selection a three-dimensional look by creating the appearance of raised edges. It expands the size of the selection by the width of the bevel.

You must first make a selection in the image before choosing the Outer Bevel command from the Effects menu. You can access the Outer Bevel effect dialog box by clicking **Effects** ➔ **3D Effects** ➔ **Outer Bevel**.

The Outer Bevel dialog box contains the following controls:

• **Bevel** — specifies the bevel shape
• **Width** — specifies the width of the beveled edge in pixels
• **Smoothness** — controls the slope (sharpness) and thickness of the edge. As this value increases, the edges become more rounded. As it decreases, the edges appear thinner and steeper.
• **Depth** — controls the height of the edge. As this value increases, the edge becomes more pronounced.
• **Ambience** — adjusts the overall brightness of the image
• **Shininess** — determines how reflective the surface appears. A higher value produces a glossy image and makes the highlights more evident. A lower value makes the highlights diminish.
• **Color** — determines the color of the light shining on the image. To change the light color, you can click a color in the image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
Applying Art Media effects

You can apply Art Media effects to make an image look painted or drawn. You can simulate the use of traditional art media, including with pencil, charcoal, and chalk.

Black Pencil
Edit tab

The Black Pencil effect is similar to the Charcoal effect, but it uses thinner strokes and produces a more detailed image. You can access the Black Pencil dialog box by choosing Effects ▶ Art Media Effects ▶ Black Pencil.

Brush Strokes
Edit tab

The Brush Strokes effect makes your image look like an oil or watercolor painting. You can access the Brush Strokes dialog box by choosing Effects ▶ Art Media Effects ▶ Brush Strokes.

The Brush Stroke dialog box contains the following controls:
• **Softness** — determines the amount of blur in the image
• **Bristles** — specifies the number of bristles in the brush
• **Width** — controls the width of the brush
• **Opacity** — determines the strength of the effect
• **Length** — specifies the length of the brushstrokes
• **Density** — specifies the number of strokes in the image
• **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle. To set the value, you can click in the circle, drag the needle, or set or type a number in the control.
• **Color** — lets you choose a color for the light shining on the edges of the forms. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
Charcoal
Edit tab

The Charcoal effect is similar to the Black Pencil effect, but the thicker strokes produce an image containing less detail. You can access the Charcoal dialog box by choosing Effects ▶ Art Media Effects ▶ Charcoal.

The Charcoal effect dialog box contains the following controls:
- **Detail** — controls the number and darkness of the strokes
- **Opacity** — controls the strength of the effect. As the Opacity value increases, the image displays more of the effect and less of its original appearance.

Colored Chalk
Edit tab

The Colored Chalk effect uses the colors in the image to make the image appear drawn in colored chalk. Wider strokes appear with this effect than with the Colored Pencil effect.

You can access the Colored Chalk dialog box by choosing Effects ▶ Art Media Effects ▶ Colored Chalk.

The Colored Chalk dialog box contains the following controls:
- **Detail** — controls the number and darkness of the strokes
- **Opacity** — controls the strength of the effect. As the Opacity value increases, the image displays more of the effect and less of its original appearance.

You can produce an effect similar to the Colored Chalk effect by using the Chalk tool found on the Tools toolbar.

Colored Pencil
Edit tab

The Colored Pencil effect uses the colors in the image to make it appear drawn in colored pencil. The effect is similar to the Colored Chalk effect, but it uses thinner strokes. You can access the Colored Pencil dialog box by choosing Effects ▶ Art Media Effects ▶ Colored Pencil.
The Colored Pencil dialog box contains the following controls:

- **Detail** — controls the number and darkness of the strokes
- **Opacity** — controls the strength of the effect. As the Opacity value increases, the image displays more of the effect and less of its original appearance.

**Pencil**

**Edit tab**

The Pencil effect enhances and colors the edges in the image to make the image look like a pencil drawing. You can access the Pencil dialog box by choosing **Effects** ➤ **Art Media Effects** ➤ **Pencil**.

The Pencil dialog box contains the following controls:

- **Luminance** — adjusts the overall brightness of the image
- **Blur** — determines the softness of the image. As you increase the value, the image becomes less sharp.
- **Color** — lets you choose a color for the background, or non-edge area, of the image. To change the light color, you can click a color in the image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Intensity** — controls the contrast between the background and the edges. As you increase the contrast, more detail appears.

**Applying Artistic effects**

You can apply Artistic effects to age a photograph or to create a variety of artistic results. Balls and Bubbles, Colored Foil, and Solarize are among the effects included in this group.

**Aged Newspaper**

**Edit tab**

The Aged Newspaper effect applies a warm brown tone and blurs the image so that it resembles a newspaper that has yellowed with age. This effect works best with images that contain text.

For best results, you should convert your image into grayscale and then increase the color depth to 16 million colors before applying this effect. You can access the Aged Newspaper dialog box by clicking **Effects** ➤ **Artistic Effects** ➤ **Aged Newspaper**.

The Aged Newspaper dialog box contains the following control:

- **Amount to age** — lets you select the intensity of the effect by dragging the slider or typing a number in the box.

**Balls and Bubbles**

**Edit tab**

The Balls and Bubbles effect lets you create sophisticated multilayered spherical objects. You can use environment maps and bump maps with this effect. For more information, see “Applying environment maps and bump maps” on page 287.
You can access the Balls and Bubbles dialog box by choosing Effects » Artistic Effects » Balls and Bubbles.

The Balls and Bubbles dialog box has four tabs: Shape, Surface, Maps, and Illumination.

The Shape page contains the following controls:

- **Automatic multiple balls or bubbles** — applies an assortment of bubbles to your image. This option also lets you specify the coverage, average size, size variation, and type of the bubbles.
- **Coverage** — determines how much of the canvas is filled with bubbles or balls
- **Average size** — sets a standard size for the bubbles or balls
- **Size variation** — determines how dissimilar in size the largest and smallest bubbles can be. A value of 0 forces all the bubbles to be uniform. A value of 100 allows the bubbles be as random as possible.
- **Balls or Bubbles type** — lets you choose nonintersecting, intersecting, or overlapping balls and bubbles
- **Randomize** — randomly sets the size and placement of the bubbles
- **Seed** — determines the strength of the effect
- **Single ball or bubble** — applies a single ball or bubble instead of multiple ones
- **Maximum possible size** — makes a single ball or bubble the largest possible size. You can choose another size by dragging a bounding box in the Before pane.

The Surface page contains the following controls:

- **Material** — lets you choose the color, gradient, and pattern for the surface material of the balls and bubbles. You can combine each of these elements with choices from the Textures panel of the Material Properties dialog box. Note that when you select the Textures option, the material becomes semitransparent.
- **Opacity** — sets the maximum opacity for the object. The default is 15% for bubbles. A solid object would have a setting of 100%.
- **Shininess** — determines how the light is absorbed or reflected from the surface. This control interacts with the setting for the Gloss control.
- **Gloss** — determines how the light is absorbed or reflected from the surface. This control interacts with the setting for the Shininess control.

The Maps page contains the following controls:

- **Bump map** — lets you add surface texture to your balls and bubbles by activating the bump map controls
- **Smoothness** — determines the smoothness of the effect
- **Depth** — determines the depth of the effect. The greater the value, the more recessed the black areas on the map appear and the more raised the white areas appear. Negative values reverse this effect.
- **Fit bump map** — automatically resizes the map to wrap around the sphere. You can unmark the check box to change the size of the map.
- **Size** — lets you set the size of the map when the Fit bump map check box is unmarked.
- **Environment map** check box — lets you add surface details to your balls and bubbles by activating the environment map controls
- **Opacity** — controls the strength of the effect. As the opacity increases, the image displays more of the effect and less of its original appearance.
- **Environment map** option and swatch — let you choose an image from the Environment Maps folders or the current image
- **Current Image** — wraps the current image around the spherical objects
- **Diffraction map** — wraps a rainbow-style light pattern around the spherical objects. To change the pattern, adjust the Fringe spacing and Type settings.
- **Type** — sets randomness of the origins, direction, and paths of the bands

The Illumination page contains the following controls:

- **Maximum** — sets the maximum value for the overall lighting of the object
- **Minimum** — sets the minimum value for the overall lighting of the object
- **Add** and **Remove** buttons and Lights menu — let you add or remove individual lights. By default, a single light with a highlight appears just above and to the left of the center.
• **Position** — lets you move the focus of the light by clicking on the highlight and dragging it to a new location
• **Back light** — redirects the light so that it comes from behind the object. You can drag back lights, but they are visible only around the perimeter of the sphere.
• **Bubble light** — scatters the illumination as though it were passing through a semitransparent object. This option is available only when the Opacity setting is less than 100%.
• **Color** — lets you choose the color for each light. The default color is white.
• **Highlight size** — lets you control the size of each highlight

**Chrome**

Edit tab

The Chrome effect gives an image a metallic look. It works best with images that have distinct areas of contrast. You can access the Chrome dialog box by choosing Effects ➤ Artistic Effects ➤ Chrome.

![Chrome example image](image1)

The Chrome dialog box contains the following controls:
• **Flaws** — sets the number of creases, or folds. Each fold is a transition between light and dark areas.
• **Brightness** — sets the brightness of the chrome
• **Use original color** — applies the image’s color for the chrome
• **Color** — makes the chrome a uniform color. You can choose a color by unmarking the Use original color check box, and then clicking the color box to access the Color dialog box. You can also right-click the color box to access the Recent Colors dialog box. The default color is white.

**Colored Edges**

Edit tab

The Colored Edges effect makes an image look retouched by enhancing and coloring its edges. You can access the Colored Edges dialog box by choosing Effects ➤ Artistic Effects ➤ Colored Edges.

![Colored Edges example image](image2)

The Colored Edges dialog box contains the following controls:
• **Luminance** — adjusts the overall brightness of the image
• **Blur** — determines the softness of the image. As you increase the value, the image becomes less sharp.
• **Color** — lets you choose a color for the edges. To change the edge color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• **Intensity** — controls the intensity of the effect. As you increase the value, more edges are colored, and more color is applied to the edges.
Colored Foil
Edit tab

The Colored Foil effect adds a sculpted look to the edges and applies several colors to an image. You can access the Colored Foil dialog box by choosing Effects ▶ Artistic Effects ▶ Colored Foil.

The Colored Foil dialog box contains the following controls:

- **Blur** — determines the softness of the image. As you increase the value, the image becomes less sharp.
- **Detail** — controls the amount of the effect applied. As you increase the value, color is applied to more areas of contrast.
- **Color** — lets you choose a color for the light shining on the image. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle. To set the value, you can click in the circle, drag the needle, or set or type a number in the control.

Contours
Edit tab

The Contours effect reproduces the look of a topographical map by covering the image with contour lines. You can access the Contours dialog box by choosing Effects ▶ Artistic Effects ▶ Contours.

The Contours dialog box contains the following controls:

- **Luminance** — adjusts the overall brightness of the image
- **Blur** — determines the softness of the image. As you increase the value, the image becomes less sharp.
- **Detail** — controls where the color is applied. As you increase the value, the color is applied to more areas of contrast.
- **Intensity** — controls the amount of color applied to each area. As you increase the value, more color is applied.
- **Color** — lets you choose a color for the contour lines. To change the color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.

Enamel
Edit tab

The Enamel effect applies the look of a shiny, hard surface to the image. You can access the Enamel dialog box by clicking Effects ▶ Artistic Effects ▶ Enamel.
The Enamel dialog box contains the following controls:

- **Blur** — determines the softness of the image. As you increase the value, the image becomes less sharp.
- **Detail** — controls the scale of the relief. Low values produce fewer levels of relief and a softer, less defined effect.
- **Density** — controls the number of areas of relief. Low values produce fewer larger areas and a softer look. Higher values add relief to smaller areas, producing a denser effect.
- **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle. To set the value, you can click in the circle, drag the needle, or set or type a number in the control.
- **Color** — lets you choose a color for the light shining on the edges of the forms. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to open the Recent Colors dialog box.

**Glowing Edges**

The Glowing Edges effect makes the image appear to have been created from neon tubes. The edges in an image become brightly colored, while the remaining portions turn black. You can access the Glowing Edges dialog box by choosing **Effects > Artistic Effects > Glowing Edges**.

The Glowing Edges dialog box contains the following controls:

- **Intensity** — sets the brightness of the edges. As you increase the value, more edges are displayed, and they become brighter.
- **Sharpness** — controls the tightness of the edges. As you increase the value, the edges narrow and become more defined.

**Halftone**

The Halftone effect applies a series of dots to the image, rather than a continuous tone. Halftone images can be printed easily and are therefore typically used in newspapers and magazines. You can choose different sizes, colors, and shapes for the Halftone effect. Larger dots produce darker, more dense areas of the image, whereas smaller dots produce lighter areas. You can access the Halftone dialog box by choosing **Effects > Artistic Effects > Halftone**.

The Halftone dialog box contains the following controls:

- **Halftone pattern** — lets you choose a line, round, or square pattern
- **Size** — lets you choose a size for the pattern cell
• **Screen angles** — lets you choose the angles for the screen. In the case of a grayscale image, you can choose only one angle. For an RGB image, you can choose an angle for each color channel.
• **Use as overlay** — lets you adjust the strength of the effect and apply blending
• **Blend mode** — lets you choose from a wide variety of blending effects
• **Opacity** — controls the strength of the effect. As the opacity increases, the image displays more of the effect and less of its original appearance.
• **RGB** — processes the red, green, and blue channels independently
• **Greyscale** — lets you choose pattern and background colors
• **Ink** — lets you choose the color for the pattern
• **Background** — lets you choose the color of the background
• **Transparent** — makes the original image visible in the effect background. Unmark this check box if you want to choose a color for the background.

**Hot Wax Coating**

*Edit tab*

The Hot Wax Coating effect makes the image appear coated in a layer of hot wax. The current Foreground/Stroke color is used for the wax. You can apply the Hot Wax Coating effect by choosing **Effects** ➤ **Artistic Effects** ➤ **Hot Wax Coating**.

**Magnifying Lens**

*Edit tab*

The Magnifying Lens effect lets you bring attention to a portion of your image by placing a magnifying lens over it. You can use environment maps and bump maps with this effect. For more information, see “Applying environment maps and bump maps” on page 287.

The Magnifying Lens dialog box has four tabs: Shape, Properties, Illumination, and Frame. You can access the Magnifying Lens dialog box by clicking **Effects** ➤ **Artistic Effects** ➤ **Magnifying Lens**.

The **Shape** page contains the following controls:
• **Magnification** — sets the strength of the magnification
• **Refraction** — controls the degree of refractive distortion
• **Defocus** — blurs the magnified image
• **Darkness** — sets the darkness of the image surrounding the magnified frame
• **Spherical** — uses a round magnifying lens
• **Cylindrical vertical** — uses a cylindrical lens to produce a magnified image that is wider than it is long
• **Cylindrical horizontal** — uses a cylindrical lens to produce a magnified image that is longer than it is wide

The **Properties** page contains the following controls:
• **Material** swatch — lets you choose the colors, gradients, and patterns for the surface material of the magnified image. You can combine each of these elements with choices from the Textures panel of the Material Properties dialog box. Note that when you select the Textures option, the material becomes semitransparent.
• **Opacity** box in the Material panel — sets the maximum opacity for the surface material. At higher values, you can see more of the material and less of the original image.

• **Shininess** — determines how the light is absorbed or reflected from the surface. This control interacts with the setting for the Gloss control.

• **Gloss** — determines how the light is absorbed or reflected from the surface. This control interacts with the setting for the Shininess control.

• **Environment map** check box — lets you add surface details to your magnified image by activating the Environment map controls

• **Opacity** box in the Environment Map panel — sets the opacity of the environment map that covers the magnified image. Higher values let you see more of the environment map.

• **Current image** — uses the current image as an environment map

• **Environment map** option and swatch — let you choose an image from the Environment Maps folders

The **Illumination** page contains the following controls:

• **Maximum** — sets the maximum value for the overall lighting of the object

• **Minimum** — sets the minimum value for the overall lighting of the object

• **Add** and **remove** buttons and **Lights** menu — let you add or remove individual lights. By default, a single light with a highlight appears just above and to the left of the center.

• **Position** — lets you move the focus of the light by clicking on the highlight and dragging it to a new location

• **Back light** — redirects the light so that it comes from behind the object. You can drag back lights, but they are visible only around the perimeter of the sphere.

• **Color** — lets you choose the color for each light. The default color is white.

• **Highlight size** — lets you control the size of each highlight

The **Frame** page contains the following controls:

• **Circular** — provides a curved frame edge

• **Rounded square** — provides a rounded square frame edge

• **Thickness** — specifies the thickness of the frame

• **Material** — lets you choose the material for the frame

• **Color** — lets you choose the color for the frame

**Neon Glow**

*Edit tab*

The Neon Glow effect gives an image a three-dimensional appearance by applying a neon effect and heightening the contrast of the edges. You can access the Neon Glow dialog box by choosing **Effects** ➤ **Artistic Effects** ➤ **Neon Glow**.

The Neon Glow dialog box contains the following controls:

• **Detail** — controls the number of colors and the brightness of colors. Increasing the detail level increases the number of strokes and the strength of the contrast between light and dark areas.

• **Opacity** — controls the strength of the effect. As the opacity increases, the image displays more of the effect and less of its original appearance.

**Posterize**

*Edit tab*

The Posterize effect reduces the number of bits for each color channel, which decreases the number of colors and levels of lightness in the image or selection. The result is a flatter-looking image that has bands of color rather than smooth gradients. You can access the Posterize dialog box by choosing **Effects** ➤ **Artistic Effects** ➤ **Posterize**.
The Posterize dialog box has the following control:
• **Levels** — divides the range of lightness levels (from 2 to 255) into a chosen number of equal increments. As the number of levels decreases, the image or selection appears flatter.

**Solarize**
Edit tab

The Solarize effect lets you convert all colors in an image or selection above a specific lightness value into their inverse on the scale from 1 to 254. The threshold level is the lightness value above which all colors are inverted. You can access the Solarize dialog box by choosing **Effects > Artistic Effects > Solarize**.

The Solarize dialog box contains the following control:
• **Threshold** — sets the threshold level. As the level increases, increasingly lighter colors are inverted.

**Topography**
Edit tab

The Topography effect gives an image a three-dimensional look so that the image appears to have been created from a system of terraces. You can access the Topography dialog box by choosing **Effects > Artistic Effects > Topography**.

The Topography dialog box contains the following controls:
• **Width** — controls the size of each terrace or layer
• **Density** — sets the number of terraces
• **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle. To set the value, you can click in the circle, drag the needle, or set or type a number in the control.
• **Color** — lets you choose a color for the light shining on the sides of the terraces. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
Applying environment maps and bump maps

When using the Balls and Bubbles effect or the Magnifying Lens effect, you can apply optional environment maps or bump maps. An environment map lets you add reflections, surface detail, and nuances. A bump map treats the source image like a three-dimensional surface, in which pixel luminance values determine height.

To apply an environment map

Edit tab
1. Choose Effects ▶ Artistic Effects, and select one of the following effects:
   - Balls and Bubbles
   - Magnifying Lens
2. Do one of the following:
   - In the Balls and Bubbles Effect dialog box, click the Maps tab.
   - In the Magnifying Lens Effect dialog box, click the Properties tab.
3. Mark the Environment map check box.

To apply a bump map

Edit tab
1. Choose Effects ▶ Artistic Effects ▶ Balls and Bubbles.
   The Balls and Bubbles Effect dialog box appears.
2. Click the Maps tab.
3. Mark the Bump map check box.

Applying Distortion effects

You can apply Distortion effects to an image and produce interesting results. Curlicues, Pixelate, and Warp are examples of effects that let you distort your image.

Curlicues

Edit tab

The Curlicues effect turns an image into a series of rows and columns composed of curls. You can access the Curlicues dialog box by choosing Effects ▶ Distortion Effects ▶ Curlicues.

The Curlicues dialog box contains the following controls:

- **Number of columns** — sets the number of curls in each row
- **Number of rows** — sets the number of curls in each column. If the number of columns is set at 5 and the number of rows is set at 4, then each of the four rows will have five curls.
- **Symmetric** — links the Rows and Columns values so that changing one changes the other. Mark this check box if you want an equal number of rows and columns.
- **Radius** — sets the radius of the curls. This value is a percentage of the smallest dimension — either the column width or the row height.
- **Strength** — controls the amount of rotation of each curl
- **Clockwise** — sets the direction of the curls
Displacement Map

You can warp, or displace, one image based on the contents of another image. For information about using the Displacement Map effect, see “Using the Displacement Map effect” on page 292.

Lens Distortion

Edit tab

The Lens Distortion effect simulates barrel, fisheye, or pincushion distortion in an image. You can access the Lens Distortion dialog box by choosing Effects ➤ Distortion Effects ➤ Lens Distortion.

The Lens Distortion dialog box contains the following controls:

- **Horizontal** — positions the center of the distortion horizontally in the image. Increasing the value moves the center of the distortion to the right. Decreasing the value moves the center of the distortion to the left.
- **Vertical** — positions the center of the distortion vertically in the image. Increasing the value moves the center of the distortion toward the bottom. Decreasing the value moves the center of the distortion toward the top.
- **Distortion type** — lets you specify whether to choose Barrel, Fisheye, Fisheye (Spherical), or Pincushion distortion
- **Strength** — determines the strength of the Barrel or Pincushion effects
- **Field of view** — determines the strength of the Fisheye or Fisheye (Spherical) effect
- **Wrap** — makes the image appear as though it were a tile repeating in each direction
- **Repeat** — finds the edge pixel of each side and repeats it outward infinitely
- **Color** — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Transparent** — makes out-of-bounds pixels transparent (available only with layered images).

Pinch

Edit tab

The Pinch effect is a deformation that makes the image or selection appear pinched by pushing the contents in toward the center. You can access the Pinch dialog box by choosing Effects ➤ Distortion Effects ➤ Pinch.

The Pinch dialog box contains the following control:

- **Strength** — determines how much of the image is pushed toward the center
**Pixelate**

*Edit tab*

The Pixelate effect divides an image into rectangles or squares of a specified size. You can access the Pixelate dialog box by choosing **Effects ➤ Distortion Effects ➤ Pixelate**.

![Pixelate Effect Example](image)

The Pixelate effect dialog box contains the following controls:

- **Block width** — sets the width of the blocks in pixels
- **Block height** — sets the height of the blocks in pixels
- **Symmetric** — creates square blocks. You can create rectangular blocks by clearing the check box.

**Polar Coordinates**

*Edit tab*

The Polar Coordinates effect changes pixels by mapping them from Cartesian to polar coordinates, or from polar to Cartesian coordinates. You can access the Polar Coordinates dialog box by choosing **Effects ➤ Distortion Effects ➤ Polar Coordinates**.

![Polar Coordinates Effect Example](image)

The Polar Coordinates dialog box contains the following controls:

- **Rectangular to polar** — maps pixels from Cartesian to polar coordinates
- **Polar to rectangular** — maps pixels from polar to Cartesian coordinates
- **Wrap** — makes the image appear as though it were a tile repeating in each direction
- **Repeat** — finds the edge pixel of each side and repeats it outward infinitely
- **Color** — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Transparent** — makes out-of-bounds pixels transparent.

**Punch**

*Edit tab*

The Punch effect is a deformation that makes an image or selection appear punched out from behind so that the contents in the center expand toward the outer edges. You can access the Punch dialog box by choosing **Effects ➤ Distortion Effects ➤ Punch**.

![Punch Effect Example](image)

The Punch dialog box contains the following control:
• **Strength** — determines how much of the image is pushed out toward the edges

### Ripple

**Edit tab**

The Ripple effect is a deformation that creates concentric rings similar to those produced by dropping a pebble in water. You can access the Ripple dialog box by choosing **Effects ➤ Distortion Effects ➤ Ripple**.

The Ripple dialog box contains the following controls:
- **Horizontal** — moves the central point of the ripples. The value is a percentage of the width of the image or selection. The default position, 50, corresponds to the center of the image or selection.
- **Vertical** — moves the central point of the ripples. The value is a percentage of the height of the image or selection. The default position, 50, corresponds to the center of the image or selection.
- **Amplitude** — controls the amplitude of each ripple, or the distance from the trough to the crest
- **Wavelength** — controls the distance from the crest of one ripple to the crest of the next
- **Color** — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Transparent** — makes out-of-bounds pixels transparent (available only with layered images)

### Spiky Halo

**Edit tab**

The Spiky Halo effect is a deformation that you can use to create a radical pattern of waves or ripples. You can access the Spiky Halo dialog box by choosing **Effects ➤ Distortion Effects ➤ Spiky Halo**.

The Spiky Halo dialog box contains the following controls:
- **Horizontal** — moves the central point of the ripples. The value is a percentage of the width of the image or selection. Negative values move the halo to the left, and positive values move the halo to the right.
- **Vertical** — moves the central point of the ripples. The value is a percentage of the height of the image or selection. Negative values move the halo up, and positive values move the halo down.
- **Amplitude** — sets the apparent height of the waves. Lower values produce smoother ripples.
- **Frequency** — sets the number of rays for each quarter-circle
- **Radius** — sets the distance of the waves from the center. Lower numbers cause the waves to begin closer to the center.
- **Color** — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Transparent** — makes out-of-bounds pixels transparent (available only with layered images)
Twirl  
Edit tab

The Twirl effect distorts an image by twisting or whirling it around its center. You can twirl an image up to two rotations in either direction. You can access the Twirl dialog box by choosing Effects » Distortion Effects » Twirl.

The Twirl dialog box has the following control:

• **Degrees** — sets the direction and amount of twirl. Positive values create a clockwise twirl; negative values create a counter-clockwise twirl.

Warp  
Edit tab

The Warp effect makes a circular area of the image appear at a higher or lower zoom level. The area is distorted as if viewed through a convex or concave lens. You can access the Warp dialog box by choosing Effects » Distortion Effects » Warp.

The Warp dialog box has the following controls:

• **Horizontal** — moves the central point of the warp horizontally. The value is a percentage of the width of the image or selection. Negative values move the center to the left, and positive values move the center to the right.

• **Vertical** — moves the central point of the warp vertically. The value is a percentage of the height of the image or selection. Negative values move the center up, and positive values move the center down.

• **Size** — sets how far the effect continues from the center. The value is a percentage of the image size. As you lower the number, less of the image appears distorted.

• **Strength** — sets the level of the distortion. Positive values make the distorted image area appear closer, and negative values make it appear farther away.

Wave  
Edit tab

The Wave effect distorts an image by creating undulating lines. You can determine the amount of distortion by setting the size of the wave. You can access the Wave dialog box by choosing Effects » Distortion Effects » Wave.

The Wave dialog box contains the following controls:
• **Amplitude** (in the Horizontal displacement group box) — sets the distance from the trough to the crest for horizontal ripples
• **Amplitude** (in the Vertical displacement group box) — sets the distance from the trough to the crest for vertical ripples
• **Wavelength** (in the Horizontal displacement group box) — sets the distance from the crest of one horizontal ripple to the crest of the next
• **Wavelength** (in the Vertical displacement group box) — sets the distance from the crest of one vertical ripple to the crest of the next
• **Color** — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• **Transparent** — makes out-of-bounds pixels transparent (available only with layered images)

**Wind**

Edit tab

The Wind effect blurs an image to make it look as though it has been blown by wind coming from either the left or the right. You can access the Wind dialog box by choosing Effects ➤ Distortion Effects ➤ Wind.

The Wind dialog box contains the following controls:
• **Wind direction** group box — lets you choose From left or From right for the wind direction
• **Wind strength** — controls the strength of the deformation. Increasing the strength increases the blurriness of the image.

**Using the Displacement Map effect**

You can warp, or displace, one image (the displacement map) based on the contents of another image (the source image). For example, you can apply text to an image that depicts something with an uneven surface, making it look like the text was there all along.

To apply a displacement map

Edit tab

1. Open the images you want to use as the displacement map and the source image.
2. Make the source image the active image.
4. In the Displacement map group box, click the image drop-list, and choose an image to use as the displacement map.
   If the displacement map and the source image don’t have the same dimensions, choose either the Stretch map to fit image option, or the Tile map to cover image option.
5. Type or set a value in the **Blur** control to set the amount of blur to apply to the displacement map.
   Lower values produce jittery, pointillistic effects; higher values produce smoother warping effects.
6. In the Displacement properties group box, choose one of the following options:
   • **2D offsets** — uses the red and green channels to displace the image
   • **3D surface** — treats the source image as though it were a 3D surface in which pixel luminance values determine height
7. Type or set a value in the **Intensity** control to set the amount of displacement.
   Lower values result in less change to the image; higher values yield greater deformation.
8. Type or set a value in the **Rotation** control to determine the rotation of the displacement data.
9. In the Edge mode group box, choose one of the following options to determine how to handle out-of-bounds displacement:
   • **Wrap** — treats the image as though it were a tile repeating in each direction
   • **Repeat** — finds the edge pixel of each side and repeats it outward infinitely
   • **Color** — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• **Transparent** — makes out-of-bounds pixels transparent (available only with layered images)

### Applying Edge effects

Edge effects are applied to the edges in an image or selection. You can dilate, enhance, erode, find, and trace the edges in an image to create interesting results.

**Important!** These effects work on grayscale and 16 million–color (24-bit) images only. For more information about increasing the color depth of an image, see "Increasing the color depth of an image" on page 382.

#### Dilate

Edit tab

The Dilate effect enhances the light areas of an image or selection. You can apply the Dilate effect by choosing **Effects > Edge Effects > Dilate**.

![Dilate Example](image)

#### Enhance

Edit tab

The Enhance effect increases the contrast along the edges in an image. You can apply the Enhance effect by choosing **Effects > Edge Effects > Enhance**.

![Enhance Example](image)

#### Enhance More

Edit tab

The Enhance More effect applies a stronger contrast to the edges in an image than the Enhance effect does. You can apply the Enhance More effect by choosing **Effects > Edge Effects > Enhance More**.

![Enhance More Example](image)

#### Erode

Edit tab

The Erode effect enhances the dark areas in an image. You can apply the Erode effect by choosing **Effects > Edge Effects > Erode**.

![Erode Example](image)
Find All
Edit tab

The Find All effect enhances the contrast between light and dark in an image by darkening the image and then highlighting the edges. You can apply the Find All Edges effect by choosing Effects ➤ Edge Effects ➤ Find All.

Find Horizontal
Edit tab

The Find Horizontal effect enhances the contrast between light and dark in an image by darkening the image and then highlighting the horizontal edges. You can apply the Find Horizontal edges by choosing Effects ➤ Edge Effects ➤ Find Horizontal.

Find Vertical
Edit tab

The Find Vertical effect enhances the contrast between light and dark in an image by darkening the image and then highlighting the vertical edges. You can apply the Find Vertical edges effect by choosing Effects ➤ Edge Effects ➤ Find Vertical.

High Pass
Edit tab

The High Pass effect emphasizes color transitions between highlight and shadow colors. You can use it with other imaging operations to create or enhance special effects such as embossing or line-drawing effects. The High Pass effect preserves the contrast of edges and areas of high detail while leaving the rest of the image a neutral gray. You can access the High Pass dialog box by choosing Effects ➤ Edge Effects ➤ High Pass.
The High Pass dialog box contains the following controls:

- **Radius** — sets the radius of the blur effect as a percentage
- **Desaturate** — removes all color, leaving a gray result. The results of the High Pass effect are close to monochrome, even when this check box is unmarked. You can mark this check box, however, to prevent subtle color shifts that can occur when sharpening is applied to an image. This option works by removing any color artifacts that remain after sharpening.

**Trace Contour**

The Trace Contour effect traces a series of single-pixel lines around areas of contrast and turns the remaining pixels white. You can apply the Trace Contour effect by choosing **Effects > Edge Effects > Trace Contour**.

**Applying Geometric effects**

You can change the shape or perspective of an image by applying Geometric effects. For example, you can turn an image into a sphere or cylinder, skew it, or change its vertical or horizontal perspective.

**Circle**

The Circle effect deforms your image or selection by turning it into a sphere. You can access the Circle dialog box by choosing **Effects > Geometric Effects > Circle**.

The Circle dialog box contains the following controls:

- **Wrap** — treats the image as though it were a tile repeating in each direction
- **Repeat** — finds the edge pixel of each side and repeats it outward infinitely
- **Color** — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Transparent** — makes out-of-bounds pixels transparent (available only with layered images)

**Cylinder–Horizontal**

The Cylinder–Horizontal effect stretches the image or selection as though wrapping it around a horizontal cylinder. You can access the Cylinder–Horizontal dialog box by choosing **Effects > Geometric Effects > Cylinder–Horizontal**.

The Cylinder–Horizontal dialog box has the following control:

- **Strength** — determines how much of the image appears wrapped
Cylinder–Vertical

Edit tab

The Cylinder–Vertical effect is a deformation that stretches the image or selection as though wrapping it around a vertical cylinder. You can access the Cylinder–Vertical dialog box by choosing Effects ▶ Geometric Effects ▶ Cylinder–Vertical.

The Cylinder–Vertical dialog box has the following control:
• Strength — determines how much of the image appears wrapped

Pentagon

Edit tab

The Pentagon effect deforms your image or selection by turning it into a pentagon. You can access the Pentagon dialog box by choosing Effects ▶ Geometric Effects ▶ Pentagon.

The Pentagon dialog box contains the following controls:
• Wrap — treats the image as though it were a tile repeating in each direction
• Repeat — finds the edge pixel of each side and repeats it outward infinitely
• Color — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• Transparent — makes out-of-bounds pixels transparent (available only with layered images)

Perspective–Horizontal

Edit tab

The Perspective–Horizontal effect creates a perspective along the horizontal axis by narrowing the left or right side of the image or selection. You can access the Perspective–Horizontal dialog box by choosing Effects ▶ Geometric Effects ▶ Perspective–Horizontal.

The Perspective–Horizontal dialog box contains the following controls:
• Distortion — sets the length of the shortened edge to the unchanged edge. Moving the slider to the left or typing a negative number reduces the length of the left side of the image. Moving the slider to the right or typing a positive number reduces the length of the right side of the image.
• Wrap — treats the image as though it were a tile repeating in each direction
• Repeat — finds the edge pixel of each side and repeats it outward infinitely
• Color — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• Transparent — makes out-of-bounds pixels transparent (available only with layered images)

Perspective–Vertical

Edit tab

The Perspective–Vertical effect creates a perspective along the vertical axis by narrowing the top or bottom of the image or selection. You can access the Perspective–Vertical dialog box by choosing Effects ▶ Geometric Effects ▶ Perspective–Vertical.

The Perspective–Vertical dialog box contains the following controls:
• Distortion — sets the length of the shortened edge to the unchanged edge. Moving the slider to the left or typing a negative number reduces the length of the upper side of the image. Moving the slider to the right or typing a positive number reduces the length of the bottom side of the image.
• Wrap — treats the image as though it were a tile repeating in each direction
• Repeat — finds the edge pixel of each side and repeats it outward infinitely
• Color — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• Transparent — makes out-of-bounds pixels transparent (available only with layered images)
Skew
Edit tab

The Skew effect tilts an image or selection along its horizontal or vertical axis up to 45 degrees in either direction. You can access the Skew dialog box by choosing Effects ➤ Geometric Effects ➤ Skew.

The Skew dialog box contains the following controls:
• Horizontal — tilts the image to the left or right, depending on the Skew Angle setting
• Vertical — tilts the image up or down, depending on the Skew Angle setting
• Skew angle — sets the tilt angle. When the Horizontal option is selected, positive numbers tilt the image to the right, and negative numbers tilt it to the left. When the Vertical option is selected, positive numbers lower the left side and raise the right side, and negative numbers raise the left side and lower the right side.
• Wrap — treats the image as though it were a tile repeating in each direction
• Repeat — finds the edge pixel of each side and repeats it outward infinitely
• Color — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• Transparent — makes out-of-bounds pixels transparent (available only with layered images)

Spherize
Edit tab

The Spherize effect wraps a selection or layer around a sphere. You can access the Spherize dialog box by choosing Effects ➤ Geometric Effects ➤ Spherize.

The Spherize dialog box contains the following controls:
• Strength — determines the strength of the effect
• Circle — wraps the selection or layer around a circular sphere
• Ellipse — wraps the selection or layer around an elliptical sphere

Applying Illumination effects

You can use an illumination effect to apply a sunburst or spotlights to images.

Important! These effects work on grayscale and 16 million–color (24-bit) images only. For more information about increasing the color depth of an image, see “Increasing the color depth of an image” on page 382.

Lights
Edit tab

The Lights effect uses up to five spotlights to apply lighting to an image. You can set the intensity, direction, color, and origin of the light source. You can access the Lights dialog box by choosing Effects ➤ Illumination Effects ➤ Lights.

The Lights dialog box contains the following controls:
• Darkness — determines the darkness of the non-illuminated areas of the image
• Light source buttons — lets you choose the spotlights you want to apply. You can also click the light dots on the image in the Before pane.
• On — lets you turn individual spotlights on or off. To turn a spotlight off, you can click the light source button (or the spotlight in the Before pane) and then unmark the On check box.
• Color — lets you choose a color for the spotlight. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• Intensity — sets the brightness of the spotlight
• Direction — sets the lighting direction. The needle points to the direction of the light source, measured in degrees of rotation around the circle. To set the value, you can drag the needle, click in the circle, set or type a number in the control, or click the spotlight in the Before pane and drag its center arm.
• Horizontal — positions the light source horizontally. For each light, a value of 0 indicates the center of the image. Positive values produce movement to the right, and negative values produce movement to the left.
• **Vertical** — positions the light source vertically. For each light, a value of 0 indicates the center of the image. Positive values produce upward movement, and negative values produce downward movement.

• **Scale** — controls the size of the image area that is covered by light

• **Smoothness** — determines the smoothness of the transition from the light area to the dark area at the edge of the cone. At lower settings, the edge is sharp. Increasing the value produces a more gradual transition.

• **Cone size** — sets the width of the light, or cone size. As you increase the size to 89, the cone widens. You can also alter the width by dragging either handle of the light source in the Before pane.

• **Asymmetry** — lengthens or shortens the asymmetry

### Sunburst

*Edit tab*

The Sunburst effect simulates the appearance of an image and light source viewed through a camera lens. You can adjust the light origin, the amount of radiating light, and the brightness of the halos, or glare spots. You can access the Sunburst dialog box by choosing **Effects** » **Illumination Effects** » **Sunburst**.

The Sunburst dialog box contains the following controls:

• **Color** — lets you choose a color for the effect. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.

• **Brightness** in the **Light spot** group box — controls the strength of the light source

• **Horizontal** — indicates the horizontal location of the light origin. A value of 0 corresponds to the far left side of the image, and a value of 100 corresponds to the far right side of the image. You can also set this value by dragging the crosshairs in the Before pane.

• **Vertical** — indicates the vertical location of the light origin. You can also set this value by dragging the crosshairs in the Before pane.

• **Density** — determines how many rays of light radiate from the light source

• **Brightness** in the **Rays** group box — controls the lightness of the light rays

• **Brightness** in the **Circles** group box — controls the visibility of the halos, or glare spots

### Applying Image effects

You can apply an Image effect to your image. This group of effects lets you offset an image, curl the corners of an image, or tile an image.

### Offset

*Edit tab*

The Offset effect shifts the image on the canvas so that pixels are wrapped around to the opposite edge as they move off the canvas. You can access the Offset dialog box by choosing **Effects** » **Image Effects** » **Offset**.

The Offset dialog box has the following controls:

• **Horizontal offset** — lets you move the image horizontally on the page when the Custom option is selected

• **Vertical offset** — lets you move the image vertically on the page when the Custom option is selected

• **Center** — positions the image so that one corner is exactly in the middle of the page

• **Custom** — lets you adjust the position of the image horizontally and vertically on the page

• **Wrap** — treats the image as if it were a tile repeating in each direction

• **Repeat** — finds the edge pixel of each side and repeats it outward infinitely

• **Color** — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.

• **Transparent** — makes out-of-bounds pixels transparent (available only with layered images).

### Page Curl

*Edit tab*

The Page Curl effect makes the image appear as though a corner of it has been rolled up. You can access the Page Curl dialog box by choosing **Effects** » **Image Effects** » **Page Curl**.

The Page Curl dialog box contains the following controls:

• **Color** in the **Curl settings** group box — lets you select a color for the curled-back corner of the image page. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• **Radius** — determines the amount of the curl. As you increase the value, the curl loosens.
• **Corner** buttons — let you select which corners to curl
• **Width** — determines the width of the curl. You can also specify the desired width by dragging the arm in the Before pane.
• **Height** — determines the height of the curl. You can also specify the desired height by dragging the arm in the Before pane.
• **Color** in the Edge mode group box — lets you select a color for the background underneath the curled area of the page. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• **Transparent** — makes out-of-bounds pixels transparent (available only with layered images)

**Seamless Tiling**
*Edit tab*

The Seamless Tiling effect helps you convert a selection into a seamless custom pattern, which you can use for painting, adding text, or creating Web page backgrounds. You can access the Seamless Tiling dialog box by choosing Effects ➤ Image Effects ➤ Seamless Tiling. The Seamless Tiling dialog box contains the following controls:
• **Show tiling preview** — opens a preview area that displays the tile you are designing
• **Edge** — blends the edges of the image
• **Corner** — blends the image at the corners
• **Mirror** — mirrors the edges of the image
• **Horizontal** — places the tiles horizontally on the image
• **Vertical** — places the tiles vertically on the image
• **Bidirectional** — places the tiles both horizontally and vertically on the image. If you choose Bidirectional, you must choose a setting from the Corner style group box.
• **Horizontal offset** — positions the center of the tiling effect horizontally in the image. The position is a percentage of the width of the image. At 50, the tiling starts at the center of the image. You can increase the value to move the center to the right and decrease the value to move the center to the left.
• **Vertical offset** — positions the center of the tiling effect vertically in the image. The position is a percentage of the height of the image. At 50, the tiling starts at the center of the image. You can increase the value to move the center toward the bottom and decrease the value to move the center toward the top.
• **Width** — sets the width of the tile
• **Transition** — lets you determine the degree of blending when the Edge option is selected
• **Linear** — lets you choose a linear corner when the Corner option is selected
• **Curved** — lets you choose a curved corner when the Corner option is selected

**Applying Photo effects**

You can apply different Photo effects to your images to simulate some traditional photo techniques and processes.

**Time Machine**

The Time Machine lets you recreate some popular photographic styles from the past. It lets you choose from seven styles, which range from the year 1839 to the 1980s. For information about the Time Machine, see “Creating vintage-style photos with the Time Machine” on page 305.

**Film and Filters**

PaintShop Pro lets you experiment with effects that are inspired by different types of camera film and filters. For information about applying film and filter effects, see “Applying film and filter effects to photos” on page 307.

**Black and White Film**

You can simulate taking a photo with black-and-white film. To modify the effect, you can apply a wide range of RGB values as well as adjust image brightness and clarity.
Filter color adjustments in the Black and White Film dialog box can create very different results from the original photo (left-most image in top row).

Infrared Film

You can simulate the look created when you take a photo with black-and-white infrared film and an infrared pass lens filter on the camera. To enhance the effect, you can adjust settings for film grain and flare.

Original photo (left) and the same photo with the Infrared Film effect applied (right)

Sepia Toning

You can simulate the look created when you take a photo with sepia film. Sepia-toned images are similar to black-and-white photos (also known as grayscale photos), except the tones are brown instead of gray.

Selective Focus

You can create a quick miniature effect (also known as a tilt-shift effect) so that the scene in a photo resembles a miniature model or toy. The illusion is created by adjusting the depth of field, usually across a specified horizon line, and increasing the saturation of the photo.

An urban scene (left) appears to be transformed into a miniature model (right).
You can also use Selective Focus to apply a quick depth of field effect to any photo. For general information about depth of field, see “Controlling depth of field” on page 144.

**Photo tip:** Photos taken from high vantage points usually make the best candidates for a miniature effect.

**Vignette**

You can fade the edges of a photo to create a vignette effect. You can control the appearance of the edges by choosing a shape and color (light or dark), and adjusting the amount of blur, glow, and feathering.

![Vignette Effect Example](image)

**Retro Lab**

Inspired by photos taken spontaneously with a vintage-style pocket camera, such as LOMO, Diana, or Holga, the Retro Lab lets you apply a fun retro effect. For more information, see “Using Retro Lab” on page 303.

**Graduated Filter**

You can apply a color gradient to your photos to simulate the effect achieved by using a graduated filter on your camera lens. For more information, see “Applying a gradient with the Graduated Filter effect” on page 304.

**To apply the Black and White Film effect**

*Edit tab*

1. Choose **Effects** ➤ **Photo Effects** ➤ **Black and White Film**.

   The Black and White Film dialog box appears.

2. Modify the settings you want and click **OK**.

**You can also**

- **Adjust the RGB filter color**
  
  In the **Filter Color** group box, click or drag inside the color spectrum to set the RGB filter color.

  The **Red**, **Green**, and **Blue** values and the **After** pane are updated.

- **Simulate shooting the photo without a filter**
  
  In the **Filter Color** group box, place the filter toward the middle of the color spectrum, or click the **Reset to Default** button below the **After** pane.

- **Use an automatic filter setting**
  
  In the **Filter Color** group box, click **Suggest Color**

- **Adjust overall brightness**
  
  In the Adjustments group box, drag the **Brightness** slider, or type
You can also or set a value in the control.

Adjust overall clarity In the Adjustments group box, drag the Clarify slider, or type or set a value in the control.

To apply the Infrared Film effect

Edit tab

1. Choose Effects Photo Effects Infrared Film.
   The Infrared Film dialog box appears.
2. Type or set a value in the Strength control to determine the overall strength of the Infrared effect. Higher settings make greens appear brighter and blues appear darker. Setting the value to 0 creates a grayscale image.
3. Type or set a value in the Flare control to apply a halo effect to lighter areas in the photo. Higher settings intensify the halation effect, producing soft edges throughout the photo. Lower settings minimize the halation effect.
4. Type or set a value greater than 0 in the Grain control to add a more realistic infrared graininess to the photo.
5. Click OK.

To apply the Sepia Toning effect

Edit tab

1. Choose Effects Photo Effects Sepia Toning.
   The Sepia Toning dialog box appears.
2. Type or set a value in the Amount to age control to determine the strength of the effect. Higher settings increase the effect by increasing the amount of brown in the image.

To apply a miniature effect by using Selective Focus

Edit tab

1. Choose Effects Photo Effects Selective Focus.
   The Selective Focus dialog box appears. You can maximize the dialog box to increase the size of the Before and After panes of the preview area.
2. In the Area of focus, click one of the following tools:
   - Planar Selection Tool — the default tool for setting a linear area of focus. It is effective at setting an area of focus along a road, bridge, or other linear element that isn’t along the edge of your photo.
   - Half Planar Selection Tool — lets you set a linear area of focus along the edge of a photo
   - Radial Selection Tool — lets you set a circular area of focus
3. In the Before pane of the preview area, when your pointer displays the move cursor, drag the area of focus to the position you want.
4. Drag the rotation handle (the box at the end of the short line) to rotate the area of focus.
5. Drag a sizing handle (on the solid lines) to set the edges for the area of focus.
6. Fine-tune the results by dragging any of the following sliders:
   - Blur amount — determines the amount of blur outside the area of focus
   - Feather edge — determines the softness of the transition between the area in focus and the blurred areas. You can also adjust feathering interactively by dragging a feathering handle (on the dotted lines) in the Before pane.
   - Saturation — determines the intensity of the colors in the photo. Increasing saturation can help simulate the vivid paint colors used for models and toys.
Interactive elements in the Before pane: (1) Center line (for Planar Selection Tool), (2) Rotation handle, (3) Sizing handle, (4) Feathering handle

You can use the Selective Focus effect to apply a quick depth of field effect. Adjust the settings to achieve a natural look.

To apply a Vignette effect

Edit tab

1. Click Effects ➤ Photo Effects ➤ Vignette.
2. In the Area of focus, choose a selection tool and drag in the Before pane to set the edge for the effect.
3. Drag the Dark/Light slider to set an edge color.
4. Fine-tune the results by dragging any of the following sliders:
   - **Blur** — determines the amount of blur outside the area of focus
   - **Diffuse glow** — adds a luminescent brightening effect and softens details in the entire photo
   - **Feather edge** — determines the softness of the transition between the area in focus and the edge effect

Using Retro Lab

Inspired by photos taken spontaneously with a vintage-style pocket camera, such as LOMO, Diana, or Holga, the Retro Lab lets you apply a fun retro effect. Sometimes referred to as a “toy camera” effect, this photo style is often characterized by colors and contrast that are pushed beyond their natural appearance with blurred or vignette edges.

For a quick effect, apply a preset. Want to dig deep? You can access a complete set of controls that let you create and save your own presets.
To use Retro Lab to create a toy camera effect

1. Click Effects ➔ Photo Effects ➔ Retro Lab.
   If you want to apply a preset, click a preset in the Settings drop-list. Click OK to apply and exit the dialog box, or continue to the next step to create a custom effect.

2. To create a custom effect, do any of the following:
   • In the Range area, click an Area of focus tool and drag in the Before pane of the Preview area to select an area of focus.
   • Adjust the settings in the Range area to adjust the vignette effect. For information about individual controls, see “To apply a Vignette effect” on page 303.
   • In the Color Adjust area, drag the sliders to get the color effect you want.
   • In the Curves area, click and drag the diagonal line to adjust the tone or choose a color from the Channel drop-list and drag the diagonal line to adjust individual color channels. For more information about Curves, see “To change color channel brightness” on page 132.

   If you want to save your settings, click the Save Preset button, type a name in the Preset name box, and click OK.

Applying a gradient with the Graduated Filter effect

You can apply a color gradient to your photos to simulate the effect achieved by using a graduated filter on your camera lens. Graduated filters often consist of a single color that fades to transparent. This lets you adjust the color in a specific area of the photo. For example, in a photo where you want an otherwise too bright sky to have more blue, you can use a blue graduated filter to increase the blue of the sky without affecting the lower part of the photo. If you want to push your creativity, the Graduated Filter effect lets you choose from different gradient shapes and dual-color options.
The Graduated Filter effect was applied to the original photo (left) to create a sunset effect and to intensify the blue of the water.

To apply a gradient with the Graduated Filter effect
1. Click Effects ➤ Photo Effects ➤ Graduated Filter.
   The Graduated Filter dialog box appears.
2. Click a Style button to determine the shape of the gradient.
   The default option, Linear Graduated Filter, best simulates traditional graduated filters.
3. Drag in the Before pane to set the size and direction of the gradient. A line displays as you drag.
4. In the Preset drop-list, choose a type of blend.
5. In the Color area, click a color swatch to set a color.
   If you want to change the direction of the color or transparency, click the Swap Colors button.
6. In the Settings area, adjust any of the following sliders:
   - Opacity — specifies the transparency of the colors. Lower values are more transparent.
   - Blend — specifies how gradual the color transition is. Higher values produce a softer blend.
   - Rotate — specifies the angle of the gradient in degrees.

If you want to fine-tune specific areas of your photo, you can paste your finished version as a layer over the original version. You can then use the Eraser tool to reveal original colors and detail.

Creating vintage-style photos with the Time Machine

The Time Machine lets you recreate some vintage photographic styles. It lets you choose from seven styles, which range from the year 1839 to the 1980s.

The table below describes each style.

<table>
<thead>
<tr>
<th>Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Daguerreotype</td>
<td>Widely used from 1839 to 1855, the daguerreotype was the first popular form of photography. Images were captured directly on a thin piece of silver-plated copper. Because no negative was produced, copies could not be made, so each image was unique. Daguerreotypes are often characterized by their reflective quality, a darkening at the edges, and a dark blue-gray or brown-black color.</td>
</tr>
</tbody>
</table>
**Albumen** — Widely used from 1855 to the 1890s, this inexpensive photographic method produced paper-based photos. Negatives were captured on glass, and the print was then created on paper that used albumen from egg whites to bind the light-sensitive chemicals to the paper. Albumen photos are often characterized by their glossy finish, and soft, warm, brown tones.

**Cyanotype** — Invented in 1841, this simple, inexpensive photographic method became popular from the late 19th century to the early 20th century. The images are created when ultraviolet light converts the light-sensitive chemicals on the paper to Prussian blue. Cyanotypes are characterized by their brilliant blue color. Although this process did not lend itself to portrait photography, the permanence of the images made them popular for scientific and engineering purposes. For example, this method was used for creating blueprints.

**Platinum** — Popular from 1873 to 1920, this photographic method used platinum-based developing materials and placed the paper in direct contact with the negative. Although the resulting high-quality prints remained stable over time, the high price of platinum made this method expensive. Platinum prints are often characterized by their wide tonal range and silvery-black colors. This method was revived by artists in the 1960s.

**Early Color** — Autochrome was a popular method of producing early color photographs. This method was developed by the Lumière brothers (Auguste and Louis Lumière) in 1904. It used potato starch granules, dyed red, green, and blue, to create colored images on glass, similar to a slide. Autochromes are often characterized by softer colors and a slightly grainy quality.

**Box camera** — The box camera was popular from 1900 to the 1960s. The simplicity and portability of the camera meant that anyone could take photos. Photos taken with box cameras have different characteristics, which reflect the
The age of the camera, the type of film, and the skill of the photographer.

**Cross Process** — Cross-processing is a modern photography technique that creates unique color effects by mismatching the film and the chemicals used to develop the film. For example, you can achieve this effect by processing slide film in chemicals designed for color negative film. Cross-processed photos are often characterized by skewed colors, high saturation, and extreme highlights.

**Time Machine settings**

The Time Machine dialog box includes thumbnails that let you preview each effect on your photo. It also contains an information box that gives you a brief description of the effect.

*The photo on the left is the original photo, and the photo on the right has the Time Machine’s Daguerreotype style applied to it.*

You can adjust each effect by using the Intensity slider in the Time Machine dialog box. The Intensity slider changes the appearance of the effect in different ways, depending on the effect you choose. For example, the Intensity slider may adjust the color, brightness, or contrast.

You can apply edges to your photos that simulate the look of the edge of the paper on vintage-style photos. For example, the Photo Edges feature can simulate the dark edges of daguerreotypes, the uneven blue edges of cyanotypes, and the decorative edges that were popular during the box camera era. Photo Edges are added to the outside edge of a photo.

You can also apply edge and frame effects by using the Picture Frame dialog box. For more information, see "Adding picture frames to images" on page 318.

**To create vintage-style photos with the Time Machine**

1. Choose **Effects** \> **Photo Effects** \> **Time Machine**.
2. Click one of the thumbnails above the timeline to choose an effect.
3. Move the **Intensity** slider to adjust the appearance of the effect.

You can add or remove edge effects for photos. Unmark the **Photo Edges** check box below the Intensity slider to remove the edges, or mark the check box to apply the edges.

**Applying film and filter effects to photos**

Whether you are a novice or an experienced photographer, you can experiment in PaintShop Pro with effects that are inspired by different types of camera film and filters. You can choose from a list of preset film effects, called Film Looks, or you can choose from a list of preset filter effects, called Creative Filters. You can also combine a film effect with a filter effect to create a unique style.
Film Looks

Film Looks are inspired by the effects achieved when you use different types of film in a traditional camera. Film Looks are described by the type of effect they achieve, rather than a film name, which makes them easier to identify. You can experiment with them even if you’ve never worked with different types of film. Unlike the Creative Filters, which apply a color to the entire photo, Film Looks can change what is emphasized in a photo by making some colors more dramatic or more subtle. Some Film Looks also change the contrast or softness of photos.

The Vibrant Foliage Film Look enhances blues and greens.

The following Film Looks are available:

<table>
<thead>
<tr>
<th>Film Look</th>
<th>Purpose</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vivid</td>
<td>General purpose</td>
<td>Increases the saturation and contrast in a photo to make the colors more vivid</td>
</tr>
<tr>
<td>Vivid skin tones</td>
<td>Portraits</td>
<td>Enhances skin tones</td>
</tr>
<tr>
<td>Muted reds</td>
<td>General purpose, changes emphasis</td>
<td>Makes reds more subtle</td>
</tr>
<tr>
<td>Enhanced reds</td>
<td>General purpose, changes emphasis</td>
<td>Emphasizes reds</td>
</tr>
<tr>
<td>Vibrant foliage</td>
<td>Landscapes</td>
<td>Enhances blues and greens</td>
</tr>
<tr>
<td>Warm earth tones</td>
<td>Landscapes</td>
<td>Enhances reds, oranges, and yellows</td>
</tr>
<tr>
<td>Glamour</td>
<td>Portraits</td>
<td>Creates a soft glow</td>
</tr>
</tbody>
</table>

You can also apply the following film effects:
• Black-and-white — For more information, see “To apply the Black and White Film effect” on page 301.
• Sepia toning — For more information, see “To apply the Sepia Toning effect” on page 302.
• Infrared — For more information, see “To apply the Infrared Film effect” on page 302.

Creative Filters

Creative Filters simulate the effect achieved when you use color filters on the lens of your camera. Although the color is applied across the entire photo, PaintShop Pro maintains the luminance of the image, to achieve a color toning effect. You can use a preset color or choose a custom color.
The Sunset filter adds a warm orange tone to your photos.

The following Creative Filters are available:

<table>
<thead>
<tr>
<th>Creative Filter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Night effect</td>
<td>Applies a dark blue filter to make a photo look like it was taken at dusk or in moonlight</td>
</tr>
<tr>
<td>Cooling</td>
<td>Cools image colors</td>
</tr>
<tr>
<td>Warming</td>
<td>Applies a subtle warming effect</td>
</tr>
<tr>
<td>Orange</td>
<td>Warms colors to intensify photos with fall colors or other warm tones</td>
</tr>
<tr>
<td>Champagne</td>
<td>Applies a subtle warming effect that works well with portraits, especially when combined with the Glamour Film Look.</td>
</tr>
<tr>
<td>Sunset</td>
<td>Simulates the orange-red lighting conditions that occur at sunset</td>
</tr>
<tr>
<td>Custom</td>
<td>Lets you choose a filter color</td>
</tr>
</tbody>
</table>

To apply film and filter effects to a photo

Edit tab

1. Choose Effects ➤ Photo Effects ➤ Film and Filters.
2. In the Film and Filters dialog box, perform one or more tasks from the following table, and click OK.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply a Film Look</td>
<td>Choose a style from the Film looks drop-list.</td>
</tr>
<tr>
<td>Apply a filter</td>
<td>Choose a filter from the Creative filters drop-list.</td>
</tr>
<tr>
<td>Choose a custom filter color</td>
<td>Click the Filter color swatch, and choose a color from the Color dialog box.</td>
</tr>
<tr>
<td>Change the amount of color applied by a filter</td>
<td>Type a value in the Density box. Higher numbers increase the amount of color; lower numbers decrease the amount of color.</td>
</tr>
</tbody>
</table>
Applying Reflection effects

The reflection effects include such effects as a kaleidoscope or an intricate pattern.

Feedback
Edit tab

The Feedback effect makes the image appear reflected in concentric squares or circles. You can access the Feedback dialog box by choosing Effects ➤ Reflection Effects ➤ Feedback.

The Feedback dialog box contains the following controls:

• **Opacity** — controls the strength of the effect. As the Opacity increases, the image displays more of the effect and less of its original appearance.
• **Intensity** — sets the number of image repetitions
• **Horizontal offset** — positions the center of the feedback effect horizontally in the image. The position is a percentage of the width of the image. At 50, the feedback effect starts at the center of the image. Increasing the value moves the center to the right. Decreasing the value moves the center to the left.
• **Vertical offset** — positions the center of the feedback effect vertically in the image. The position is a percentage of the height of the image. At 50, the feedback effect starts at the center of the image. Increasing the value moves the center toward the bottom. Decreasing the value moves the center toward the top.
• **Elliptical** — makes the feedback elliptical (oval). You can unmark the check box to return to the rectangular (default) shape of the feedback.

Kaleidoscope
Edit tab

The Kaleidoscope effect turns a pie-shaped area of an image or selection into a circular pattern. The result is similar to the pattern seen in a kaleidoscope. You can access the Kaleidoscope dialog box by choosing Effects ➤ Reflection Effects ➤ Kaleidoscope.

The Kaleidoscope dialog box contains the following controls:

• **Horizontal offset** — determines the horizontal origin of the effect. Negative values move the pie origin to the left. Positive values move the pie origin to the right. The values are a percentage of the width of the range.
• **Vertical offset** — determines the vertical origin of the effect. Negative values move the pie origin up. Positive values move the pie origin down. The values are a percentage of the height of the image.
• **Rotation angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle.
• **Scale factor** — controls how much of the pie-shaped area is enlarged or reduced when you create the kaleidoscope pattern. As you decrease the scale, the pattern repeats itself more frequently.
• **Number of petals** — determines the repetitions of the pattern. The number of repetitions controls the width of the pie. When you enter a lower value, the arc is repeated fewer times.
• **Number of orbits** — sets the number of times the circles of the pattern repeat
• **Radial suction** — controls where in the pie the image information is used to create the pattern. As you increase the value, this area is pushed toward the outer edge of the pie.
• **Wrap** — treats the image as though it were a tile repeating in each direction
• **Repeat** — finds the edge pixel of each side and repeats it outward infinitely
• **Color** — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• **Reflect** — reflects the edge pixel on each side

Pattern
Edit tab

The Pattern effect turns any image or selection into an intricate geometric pattern. You can use these patterns to create seamless tiles for the background of your Web page. You can access the Pattern dialog box by choosing Effects ➤ Reflection Effects ➤ Pattern.

The Pattern dialog box contains the following controls:
Applying effects

- **Horizontal offset** — determines the horizontal origin of the effect. Negative values move the origin to the left. Positive values move the origin to the right. The values are a percentage of the width of the range.
- **Vertical offset** — determines the vertical origin of the effect. Negative values move the origin up. Positive values move the origin down. The values are a percentage of the height of the image.
- **Rotation angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle.
- **Scale factor** — controls the size of the pattern. The default of 0 uses the original scale of the image. As you decrease the scale, the pattern repeats itself more frequently.
- **Number of columns** — sets the number of times the pattern is repeated from the left side to the right side of the image at a scale factor of 0.
- **Number of rows** — sets the number of times the pattern is repeated from the top to the bottom of the image at a scale factor of 0.
- **Horizontal shift** — moves the pattern with the image window. You can place a specific section of the pattern at the center. You can use this box along with the Scale factor box to create a seamless pattern.
- **Vertical shift** — moves the pattern with the image window. You can place a specific section of the pattern at the center. You can use this box along with the Scale factor box to create a seamless pattern.

**Rotating Mirror**

The Rotating Mirror effect reflects an image or selection along a radial angle. You can access the Rotating Mirror dialog box by choosing Effects ➤ Reflection Effects ➤ Rotating Mirror.

The Rotating Mirror dialog box contains the following controls:
- **Horizontal offset** — moves the center point of the reflection line away from the image center. The value is a percentage of the width of the image. Negative horizontal values move the reflection line to the left, while positive values move it to the right. The horizontal offset does not affect horizontal lines.
- **Vertical offset** — moves the center point of the reflection line away from the image center. The value is a percentage of the height of the image. Negative values raise the reflection line, and positive values lower it. The vertical offset does not affect vertical lines.
- **Rotation angle** — sets the angle of the rotation line. The angle corresponds to the degrees of a circle, so entering 0 and 180 creates reflection along a vertical line. Entering 90 and 270 creates reflection along a horizontal line. You can create diagonal lines between the corners by entering 45, 135, 225, and 315.
- **Wrap** — treats the image as though it were a tile repeating in each direction
- **Repeat** — finds the edge pixel of each side and repeats it outward infinitely
- **Color** — lets you choose a color to represent out-of-bounds pixels. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Reflect** — reflects the edge pixel on each side

**Applying Texture effects**

You can apply the Texture effects to your images. These effects make the surfaces of your images resemble those of various materials, such as leather, mosaic tiles, and polished stone.

**Blinds**

The Blinds effect makes the image appear to be drawn on vertical or horizontal window blinds. You can access the Blinds dialog box by choosing Effects ➤ Texture Effects ➤ Blinds.

The Blinds dialog box contains the following controls:
- **Width** — sets the width of the blinds
• **Opacity** — controls the strength of the effect. As the Opacity increases, the image displays more of the effect and less of its original appearance.
• **Color** — lets you choose a color other than the default of black. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• **Horizontal** — makes the blinds horizontal. You can unmark the check box to return the blinds to the default, vertical orientation.
• **Light from left/top** — lets you reverse the direction of light from the default setting, which is from the right side for a vertical orientation or the bottom for a horizontal orientation. The hard edge of the blinds is opposite to the light direction.

**Emboss**

*Edit tab*

The Emboss effect converts the image into a bas-relief. The effect highlights the areas of contrast with black or white pixels, and it colors the low-contrast areas a medium gray. Color appears in areas of higher contrast. You can apply the Emboss effect by choosing **Effects > Texture Effects > Emboss**.

![Emboss Effect Example](image)

**Fine Leather**

*Edit tab*

The Fine Leather effect makes the image appear embossed on fine-grained leather. You can access the Fine Leather dialog box by choosing **Effects > Texture Effects > Fine Leather**.

![Fine Leather Effect Example](image)

The Fine Leather dialog box contains the following controls:
• **Color** — lets you choose a color for the light shining on the image. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle. To set the value, you can click in the circle, drag the needle, or set or type a number in the control.
• **Blur** — determines the softness of the image. As you increase the value, the image becomes less sharp.
• **Transparency** — controls how much of the original image is visible. As you increase the value, more of the image shows through the furrows.
• **Number of furrows** — controls how many leather furrows, or lines, are applied
• **Length of furrows** — controls the length of the furrows, or lines

**Fur**

*Edit tab*

The Fur effect gives the image the appearance of being covered in fur or bristles. You can access the Fur dialog box by choosing **Effects > Texture Effects > Fur**.

![Fur Effect Example](image)
The Fur dialog box contains the following controls:

- **Blur** — determines the softness of the image. As you increase the value, the image becomes less sharp.
- **Density** — controls the strength of the effect. Increasing the value adds more fur to the image.
- **Length** — sets the length of the individual strands of fur.
- **Transparency** — controls how much of the image is visible. As you increase the value, the fur effect becomes more transparent, letting more of the image show through.

**Mosaic–Antique**

Edit tab

The Mosaic–Antique effect makes an image appear to be created from antique tiles. You can access the Mosaic–Antique dialog box by choosing **Effects → Texture Effects → Mosaic–Antique**.

The Mosaic–Antique dialog box contains the following controls:

- **Number of columns** — sets the number of columns of tiles. As you increase the number, you reduce the size of the tiles.
- **Number of rows** — sets the number of rows of tiles. As you increase the number, you reduce the size of the tiles.
- **Symmetric** — links the values for the numbers of rows and columns so that changing one value changes the other value. You can unmark this check box to have an unequal number of rows and columns.
- **Tile diffusion** — sets how much of the original image shows through the tiles. Increasing the opacity blurs the tiles.
- **Grout width** — sets the number of pixels between the tiles
- **Grout diffusion** — sets the opacity of the pixels between the tiles
- **Locked transparency fill color** — sets the fill color for the transparency

**Mosaic–Glass**

Edit tab

The Mosaic–Glass effect makes the image appear to be created from glass tiles. You can access the Mosaic–Glass dialog box by choosing **Effects → Texture Effects → Mosaic–Glass**.

The Mosaic–Glass dialog box contains the following controls:

- **Number of columns** — sets the number of columns of tiles. As you increase the number, the tiles become smaller.
- **Number of rows** — sets the number of rows of tiles. As you increase the number, the tiles become smaller.
- **Symmetric** — links the values for the numbers of rows and columns so that changing one value changes the other value. You can unmark this check box to have an unequal number of rows and columns.
• **Glass curvature** — sets the distortion of the tiles and the width and opacity of the area between them. As you increase the value, each tile displays a larger area of the image. The effect is similar to that produced by using the zoom-out setting of a camera lens.
• **Edge curvature** — sets the distortion of the area around the edges of the tiles. Larger values produce rounder edges and increase the zoom-out effect.
• **Grout width** — sets the number of pixels between the tiles
• **Grout diffusion** — sets the opacity of the pixels between the tiles
• **Lock transparency fill color** — sets the fill color for the transparency

**Polished Stone**

Edit tab

The Polished Stone effect makes the image appear carved on a hard, shiny surface. You can access the Polished Stone dialog box by choosing **Effects   Texture Effects   Polished Stone.**

The Polished Stone dialog box contains the following controls:
• **Blur** — determines the softness of the image. As you increase the value, the image becomes less sharp.
• **Detail** — controls the scale of the relief. As you increase the value, smaller areas of contrast are shown in relief.
• **Polishing** — controls the size of the polished area. As you increase the value, the roughness decreases and the surface appears smoother.
• **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle.
• **Color** — lets you choose a color for the light shining on the edges of the forms. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.

**Rough Leather**

Edit tab

The Rough Leather effect makes the image appear embossed on leather with a coarse grain. You can access the Rough Leather dialog box by choosing **Effects   Texture Effects   Rough Leather.**

The Rough Leather dialog box contains the following controls:
• **Light color** — lets you choose a color for the light shining on the leather surface. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• **Leather color** — lets you choose a color for the leather background. To change the leather color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle.
• **Luminance** — adjusts the overall brightness of the image
• **Contrast** — controls the roughness of the leather and the colors
• **Sharpness** — controls the sharpness of the edges in the image
• **Blur** — determines the blur of the original image
Sandstone
Edit tab

The Sandstone effect makes the image appear as though it is carved from sandstone. You can access the Sandstone dialog box by choosing Effects ▶ Texture Effects ▶ Sandstone.

The Sandstone dialog box contains the following controls:
- **Blur** — determines the softness of the original image
- **Detail** — controls the scale of the relief. As you increase the setting, the smaller areas of the contrast are shown in relief.
- **Luminance** — adjusts the overall brightness of the image
- **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle.
- **Color** — lets you choose a color for the light shining on the edges of the forms. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.

Sculpture
Edit tab

The Sculpture effect accentuates the edges of the image so that they appear embossed or sculpted and overlays the result with a colored pattern. The patterns are 24-bit RGB images stored in the Patterns folder. You can access the Sculpture dialog box by choosing Effects ▶ Texture Effects ▶ Sculpture.

The Sculpture dialog box contains the following controls:
- **Pattern** — lets you select the pattern. The image’s color is the result of the pattern color combined with the light color.
- **Size** — resizes the pattern to a percentage of its original dimensions. You can decrease the value to make the pattern tiling more pronounced and increase the value to enlarge the pattern.
- **Smoothness** — controls the slope (sharpness) and thickness of the edges
- **Depth** — controls the height of the sculpting
- **Ambience** — adjusts the overall brightness of the image
- **Shininess** — determines how reflective the surface appears
- **Color** — lets you choose the color of the light shining on the image. The pattern color and saturation affect the light color. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle.
- **Intensity** — adjusts the brightness of the directional light. Note that the Ambience value determines the brightness of the entire image before the intensity is applied.
- **Elevation** — shows the angle of elevation of the light source above the image. At a setting of 90 degrees, the light source is positioned directly overhead. As you lower the value, the light source moves closer to the image, producing longer shadows.
Soft Plastic
Edit tab

The Soft Plastic effect makes the image look as though it were molded from plastic. You can access the Soft Plastic dialog box by choosing **Effects ➤ Texture Effects ➤ Soft Plastic.**

The Soft Plastic dialog box contains the following controls:

- **Blur** — determines the softness of the original image
- **Detail** — controls the scale of the relief
- **Density** — controls the number of areas of relief. Lower values produce fewer larger areas and a softer look. Higher values add relief to smaller areas, producing a denser effect.
- **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle.
- **Color** — lets you choose a color for the light shining on the edges of the forms. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.

Straw Wall
Edit tab

The Straw Wall effect makes the image look like it is covered in straw. You can access the Straw Wall dialog box by choosing **Effects ➤ Texture Effects ➤ Straw Wall.**

The Straw Wall dialog box contains the following controls:

- **Blur** — determines the softness of the original image
- **Density** — controls the number of straws covering the image
- **Length** — determines the length of the straws
- **Width** — determines the width of the straws
- **Transparency** — controls how much of the image is visible
- **Color** — lets you choose a color for the light shining on the edges of the forms. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle.

Texture
Edit tab

The Texture effect makes the image appear three-dimensional, as though it had a textured surface. You create the textures by using seamless tiles of 8-bit grayscale images that are stored in the Textures folder. You can access the Texture dialog box by choosing **Effects ➤ Texture Effects ➤ Texture.**
The Texture dialog box contains the following controls:

- **Texture swatch** — lets you choose the texture
- **Size** — resizes the texture to a percentage of its original dimensions. You can decrease the scale to make the tiling more pronounced and increase the scale to enlarge the texture.
- **Smoothness** — controls the slope (sharpness) and thickness of the edges
- **Depth** — controls the height of the edges
- **Ambience** — adjusts the overall brightness of the image
- **Shininess** — determines how reflective the surface appears
- **Color** — lets you choose a color for the light shining on the image. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle.
- **Intensity** — adjusts the brightness of the directional light. Note that the Ambience value determines the brightness of the entire image before the Intensity effect is applied.
- **Elevation** — shows the angle of elevation of the light source above the image. At a setting of 90 degrees, the light source is positioned directly overhead. As you lower the value, the light source moves closer to the image, producing longer shadows.

Tiles
Edit tab

The Tiles effect makes the image appear to be created from tiles. The tiles can be of varying shape, depth, and shininess. You can access the Tiles dialog box by choosing Effects ➤ Texture Effects ➤ Tiles.

The Tiles dialog box contains the following controls:

- **Tile Shape** — lets you select a triangular, square, or hexagonal tile
- **Tile Angularity** — reshapes the tiles. As you increase the value, the original tile shape changes to multiple shapes that align more closely with the edges of the image.
- **Tile Size** — lets you increase or decrease the size of the tiles
- **Border Size** — controls the grout, which is the width of the space between tiles. Note that the grout is always black.
- **Smoothness** — controls the slope (sharpness) and thickness of the edges
- **Depth** — controls the height of the edges
- **Ambience** — adjusts the overall brightness of the image
- **Shininess** — determines how reflective the surface appears
- **Color** — lets you choose a color for the light shining on the image. To change the light color, you can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
- **Angle** — affects which edges appear light and shadowed. The needle points to the direction of the light source, measured in degrees of rotation around the circle.
- **Intensity** — adjusts the brightness of the directional light. Note that the Ambience value determines the brightness of the entire image before the Intensity effect is applied.
- **Elevation** — shows the angle of elevation of the light source above the image. At a setting of 90 degrees, the light source is positioned directly overhead. As you lower the value, the light source moves closer to the image, producing longer shadows.
Weave
Edit tab

The Weave effect makes an image appear to be created with a woven pattern. You can weave the strands loosely or tightly. You can also fill the gaps between strands with any color. You can access the Weave dialog box by choosing Effects ➤ Texture Effects ➤ Weave.

The Weave dialog box contains the following controls:
• Gap size — sets the pixel size of the area between the woven strands
• Width — sets the pixel width of the woven strands
• Opacity — controls the strength of the effect
• Weave color — lets you choose a weave color. You can click a color in the original image, click the color box to access the Color dialog box, or right-click the color box to access the Recent Colors dialog box.
• Gap color — lets you choose a gap color. You can click the color box to access the Color dialog box, or right-click the color box to access the Recent Color dialog box.
• Fill gaps — fills the area that appears between the strands with a color. You can unmark the check box to fill the gap area with the image.

Adding picture frames to images

You can add picture frames to your images to provide an eye-catching final touch. You can choose square or oval frames, modern or classic frames, mats or photo edges, or a variety of other styles. The frame is applied on a separate layer, which can be edited like any other layer.

To add a picture frame to an image
Edit tab

1. Choose Image ➤ Picture Frame.
   The Picture Frame dialog box appears.
2. In the Picture Frame group box, choose a frame from the drop-list.
3. In the Orientation group box, choose one of the following options:
   • Frame canvas — sizes the frame to the canvas. The frame layer is named “Picture Frame” on the Layers palette. Successive frames reside on layers named “Picture Frame 1,” “Picture Frame 2,” and so on.
• **Frame current layer** — sizes the frame to the current layer (which may have a different size than the canvas). For example, if you are creating a collage of photos for a scrapbook and each photo is on a separate layer, you can frame each photo by choosing this option. The frame layer is named after the original layer with the words “Picture Frame” appended to the name.

4 Choose one of the following options:

• **Frame inside of the image** — resizes the frame to fit within the image canvas

• **Frame outside of the image** — increases the canvas size to accommodate the frame. The added canvas uses the current background color if the frame is applied to the Background layer. If the frame is applied to any other layer, the extra canvas is transparent.

5 Mark any of the following check boxes:

• **Flip frame** — reverses the frame along its horizontal axis

• **Mirror frame** — reverses the frame along its vertical axis

• **Rotate frame right** — lets you rotate the frame clockwise when the image is taller than it is wide

6 Click **OK**.

If the width and height differ by a considerable amount, the frame appears thicker along the shorter sides.

If you select a frame in step 2 that contains transparent areas, you can choose to keep these frame area transparent, or you can substitute a color. To maintain frame transparency, mark the **Keep transparent** check box. To substitute a color, unmark the check box, and choose a color from the color box.

### Creating your own effects

You can create your own effects (or filters), which you can save and reuse.

**To create your own effects**


   The User Defined Filter dialog box appears.

2. In the **Load Preset** drop-list, select a filter to use as a starting point.

3. In the **Filter matrix** group box, type or set values in the controls to modify the coefficients that process pixels to create the effect.

4. Click **OK**.

   PaintShop Pro applies the effect to the image.

You can also

- Use random values to create an effect
  
  Click the **Randomize Parameters** button to automatically adjust the coefficients.

- Save a user-defined effect
  
  Click the **Save Preset** button, type a name in the **Save Preset** dialog box, and click **OK**.

- Reuse a user-defined effect
  
  In the **Load Preset** drop-list, select the user-defined effect.

### Combining images

PaintShop Pro lets you combine two images into a third image. The new image is the product of the color data from the two source images combined on a pixel-by-pixel basis according to the arithmetical function you select, such as Add, Subtract, Multiply, or Difference.
If you want to combine images without these functions, you can simply use layers to paste a second image over a background image, and use masking to adjust the transparency. For information about copying and pasting images as layers, see “Cutting, copying, and pasting” on page 68. For information about masking, see “Working with masks” on page 245.

To combine images by using the Arithmetic command

1. Open the two images you want to combine.
2. Choose Image ➤ Arithmetic.
   The Image Arithmetic dialog box appears.
3. In the Image #1 and Image #2 drop-lists, select the images to combine.
   **Note:** The size of the image you choose in the Image #1 drop-list determines the size of the new image.
4. In the Function group box, choose one of the following options for combining the images:
   - **Add** — Image 1 Value + Image 2 Value
   - **Subtract** — Image 1 Value – Image 2 Value
   - **AND** — Binary And
   - **Average** — (Image 1 value + Image 2 Value) / 2
   - **Multiply** — Image 1 Value x Image 2 Value
   - **Difference** — Absolute Value of (Image 1 Value – Image 2 Value)
   - **OR** — Binary Or
   - **Darkest** — Minimum of (Image 1 Value, Image 2 Value)
   - **Lightest** — Maximum of (Image 1 Value, Image 2 Value)
   - **XOR** — Exclusive Or
   The color data from the two images is combined on a pixel-by-pixel basis according to the function you choose.
5. From the Channel group box, do one of the following:
   - To produce a 24-bit image, mark the All channels check box to use all the color channels in both images to produce a 24-bit image
   - To produce a grayscale image, choose a color channel option for each image. In the Modifiers group box, type or set values in the following controls:
     - **Divisor** — divides the color values by the value you specify. This value can reduce the effects of the other selections.
     - **Bias** — shifts each color value by amount you specify.
     These modifiers are applied to the color values produced by the Formula and the Channel selections.
6. Mark or unmark the Clip color values check box to determine how PaintShop Pro handles final color values that are greater than 255 and less than 0.
   When the Clip color values check box is marked, color values less than 0 become 0, and color values greater than 0 become 255.
   When the Clip color values check box is unmarked, color values less than 0 are calculated as 256 plus the value, and color values greater than 0 are calculated as 256 minus the value.
7. Click OK.

Using the Picture Tube tool

You can use the Picture Tube tool to paint with a collection of objects. For example, you can add butterflies and beetles to a picnic setting or frame a picture with flowers. You can use one of the picture tubes included with PaintShop Pro or create your own.
The Picture Tube tool lets you apply various preset images to your photos to create unique effects.

Picture tubes are PspTube files. Each picture tube file is made up of a series of images arranged in rows and columns, called cells. Picture tubes may have any number of cells. As you paint with the Picture Tube tool, PaintShop Pro paints one image from the picture tube after another. Many picture tubes create discrete images (such as zoo animals), and others create the effect of a continuous image (such as grass).

Each picture tube file contains a series of images.

To make picture tube elements easier to edit, it is helpful to paint them on a separate layer. For example, you can apply adjustment or effect filters to layers with picture tubes so that they blend in better with the background image.

**Important!** You cannot use the Picture Tube tool on vector layers.

Where can I get more picture tubes?

You can create your own picture tubes. You can use picture tubes from a previous version of the application. For more information, see "To use picture tubes from previous versions of the application" on page 323.

You can also download free picture tubes from the Web by checking the Corel website (www.corel.com) or by using the keyword phrase “free picture tubes” in an online search engine.

**Important!** This tool works only on raster layers in grayscale and 16 million–color images. Using this tool on a 256-color or lower raster image automatically promotes the image to the appropriate color depth. To convert a vector layer to a raster layer, choose **Layers ➤ Convert to Raster Layer**. For more information about increasing the color depth of an image, see “Increasing the color depth of an image” on page 382.

**Picture Tube settings**

When you click the **Settings** button on the Tool Options palette, the Picture Tube Settings dialog box appears. You can use this dialog box to update the current Tool Options palette settings and to modify the look of the current picture tube. However, you can also make the settings permanent by marking the **Save as default for this Picture Tube** option.

- **Current Picture Tube name and path** — The name and path of the picture tube appear at the top of this dialog box.
- **Cell arrangement** — The **Cells across** and **Cells down** fields display the current cell layout of the tube. The ranges for these values depend on how the tube was created. The **Total cells** field shows the product of multiplying the **Cells across** value by the **Cells down** value.
- **Placement options** — Modifying any of these settings updates the corresponding setting on the Tool Options palette. Note that the Scale setting is only available for some picture tubes.
• **Save as default for this Picture Tube** — Mark this check box if you want to save any modifications made in the Picture Tube Settings dialog box. If you do not mark this check box, the changes affect only the current use of the picture tube.

**To paint with a picture tube**

*Edit tab*

1. On the Tools toolbar, choose the Picture Tube tool.

2. On the Tool Options palette, select a picture tube from the Picture Tube drop-list.
   
   **Note:** Most picture tube previews show the first image rather than all images in the picture tube. To view all images, select the desired picture tube and then paint with it, or open the .PspTube file in PaintShop Pro.

3. If necessary, adjust the following:
   - **Scale** — determines the percentage (10% to 250%) for reducing or enlarging each image in the picture tube and scaling the step
   - **Step** — determines the distance in pixels (1 to 500) between the centers of each picture tube cell that you paint
   - **Placement mode** — determines how the images are placed. Choose Continuous to space the images evenly by step size, or choose Random to randomly space the images, with intervals ranging from 1 pixel to the step size.
   - **Selection mode** — determines how PaintShop Pro selects images from the cells within the picture tube file. Angular selects images based on the direction you drag; Incremental selects images one by one from top left to bottom right; Pressure selects images based on the pressure you apply on a pressure-sensitive tablet; Random selects images randomly; and Velocity selects images based on the speed with which you drag.
   - **Create as a new raster layer** — creates a layer for each click or brushstroke. This is very helpful when you want to move or adjust individual elements with the Pick Tool later.

4. In the image window, click to paint with one picture tube image, or drag to paint with multiple picture tube images.

   You can make further changes to the behavior of the current picture tube by clicking the Settings button on the Tool Options palette and adjusting settings in the Picture Tube Settings dialog box.

**To create a picture tube**

*Edit tab*


2. Click the Grid tab.

3. In the Current image settings group box, type or set the Horizontal grids and Vertical grids, and click OK.
   
   **Note:** Values for the grid positions are the values in pixels for the width and height of the cells. Images must be no larger than this cell size.

   
   The New Image dialog box appears.

5. Set the following options:
   - **Image Dimensions** — sets a width and height (in pixels) that are multiples of the horizontal and vertical grid spacing. The width and height of the image determine the total number of cells in the image. For example, if the grid spacing is 100 pixels, you can create an image that is 400 pixels wide by 300 pixels high. These dimensions would produce 12 cells (four across and three down).
   - **Image Characteristics** — Choose Raster Background as the layer type, 8 bits/channel or 16 bits/channel as the Color depth, and mark the Transparent check box.

6. Click OK.
   
   If the grid is not visible, choose View  Grid.

7. Create one image in each grid square. These squares are the picture tube cells.
   
   To change the size of cells, change the grid size, and then use the Canvas Size command.

   
   The Export Picture Tube dialog box appears.

9. Set the following options:
• **Cell arrangement** — Enter the number of cells across and down. Set these fields to match your arrangement of images in step 7. The **Total cells** field should match the number of images you placed in the tube file.

• **Placement options** — Choose the default options for this picture tube. You can change these options when you apply the picture tube.

• **Tube name** — Enter the filename of the tube. The extension **.PspTube** is automatically added to the filename.

10 Click **OK**.

You can make further changes to the behavior of the current picture tube by clicking the **Settings** button on the Tool Options palette and adjusting settings in the Picture Tube Settings dialog box.

If you want to use one image as a paint brush, export the image as a picture tube. Use a cell arrangement of one cell across by one cell down. The image must contain one raster layer that is not the background. To promote the background to a layer, choose **Layers** > **Promote Background Layer**. Choose the Picture Tube tool, and select the new picture tube you created.

### To use picture tubes from previous versions of the application

**Edit tab**

1 Choose the **Picture Tube** tool from the Tools toolbar.

2 On the Tool Options palette, click the **Presets** drop-list, and click the **File Locations** button.

3 In the File Locations dialog box, choose **Picture Tubes** from the **File types** list.

4 Click the **Add** button.

   The Browse for Folder dialog box appears.

5 Choose the folder where the previous versions of the picture tubes are stored, and click **OK**.

   The folder path is added to the Picture Tube folders list.

6 Click **OK**.

### Warping images

You can distort image areas by using the warp brushes on image pixels to produce a warping effect. You can twirl areas of images, contract or expand parts of images, and create many interesting effects. The effect of the Warp Brush is often time-dependent, which means that the longer you hold the brush over an area, the more the brush produces the effect.

![The Warp Brush tool can be used to create caricatures.](image)

You can also warp images by using a grid. When you use the Mesh Warp tool, a grid or mesh is placed on the image. The grid intersections have mesh points, or nodes, that you drag to create deformations.

For more information about warping by using a grid, see “To warp image areas by using a grid” on page 324.
To warp image areas by using a brush

**Edit tab**

1. On the Tools toolbar, choose the **Warp Brush** tool 🖌.

2. On the Tool Options palette, choose the type of warp in the **Warp Modes** group box:
   - **Push** — pushes pixels in the direction of the stroke for an effect similar to smearing paint. This warp mode is time-independent.
   - **Expand** — pushes pixels away from the center of the brush
   - **Contract** — pulls pixels into the center of the brush
   - **Right Twirl** — rotates pixels clockwise around the center of the brush
   - **Left Twirl** — rotates pixels counterclockwise around the center of the brush
   - **Noise** — causes random movements of pixels under the brush
   - **Iron Out** — removes unapplied warps. This warp mode is time-independent.
   - **Unwarp** — removes unapplied warps

3. Specify the brush options, such as size and hardness.
   - **Note:** Unlike other brushes, the size of the Warp Brush tool can be adjusted only by using the control on the Tool Options palette, not by using the keyboard.

4. Type or set a value in the **Strength** control to determine the strength of the warping effect.
   - Full strength is 100%; minimum strength is 1%.

5. Choose settings for the **Edge mode**, **Draft quality**, and **Final apply** controls.

6. Drag in the image.

   For more information about setting brush options, see “Choosing brush options” on page 366.

   For the time-dependent warp modes, you can also place the pointer at one position (instead of dragging) and hold down the mouse button to repeat the effect in one area.

   To unwarp an area, click the **Iron Out** button or **Unwarp** button on the Tools Options palette, and click over the area that you want to restore.

To warp image areas by using a grid

**Edit tab**

1. On the Tools toolbar, select the **Mesh Warp Tool** 🖌.

2. Drag the nodes in one of the following ways to deform the image:
   - Drag a node to move it.
   - Press **Shift** while dragging a node to move the entire row or column.
   - Press **Ctrl** while dragging a node to deform the row or column into a smooth curve.

3. Choose settings from the Tool Options palette:
   - **Mesh horizontal** and **Mesh vertical** — specifies the number of mesh lines within the frame. The border lines are not counted. You can change the grid size as you work. Entering new Mesh values reconfigures the grid and returns it to the original position. The image retains any deformations you have made.
   - **Symmetric** — creates a grid that evenly covers the image. If your image is not square, there will be different values for Mesh horizontal and Mesh vertical. Unmark this check box to adjust the **Mesh horizontal** and **Mesh vertical** settings independently.
   - **Show mesh** — hides and shows the mesh warp grid.
• Draft Quality — specifies the quality of the preview that appears while you edit the mesh nodes. Increasing the quality can slow the warping process in large images.

• Final Apply — determines the quality of the applied effect. Unmark the Best Quality check box to create a finished mesh warp at the lower quality of the mesh preview.

4. Click Apply on the Tool Options palette.

You can save the position of the mesh nodes (the deformation map) to apply the deformation to other images. For information about saving and loading deformation maps, see “Working with deformation maps” on page 325.

You can also double-click the image to apply the effect.

Choose Edit ➤ Undo to undo changes to the mesh as you edit. To cancel the mesh warp before it is applied, click Cancel.

Working with deformation maps

You can save the deformations you create with the Mesh Warp tool to warp other images. PaintShop Pro creates a deformation map file that contains the positions of the nodes and the number of mesh lines. You can save the mesh during the warping process or after you have applied the deformation. After you save a deformation map, you can load it into other images.

To save a deformation map

Edit tab
1. On the Tools toolbar, choose the Warp Brush tool.

2. Drag the cursor across the image.

3. On the Tool Options palette, in the Deformation map group box, click the Save deformation map button.

   The Save Deformation Map dialog box appears.

4. In the New deformation map group box, type a name for the map file.

5. In the Deformation map group box, choose a deformation map style from the drop-list.

6. In the Checkerboard size drop-list, choose a checkerboard size to help you to preview the deformation effect.

   Note: This information is not saved with the map file.

7. Click Save.

   The file is added to the default Deformation Maps folder.

To load a deformation map

Edit tab
1. On the Tools toolbar, choose the Warp Brush tool.

2. On the Tool Options palette, choose one of the following options from the Edge mode drop-list:

   • Background — fills areas between the edge of the image and the edge of the warp with the current background color
   • Fixed — fills areas between the edge of the image and the edge of the warp with replicated edge pixels
   • Wraparound — fills areas between the edge of the image and the edge of the warp with material from the opposite side of the image

3. On the Tool Options palette, click the Open deformation map button.

   The Load Deformation Map dialog box appears.

4. In the Deformation map group box, choose a deformation map style from the drop-list.

5. In the Operation group box, choose one of the following options:

   • Replace current map — replaces the existing mesh nodes with the new map. Any adjustments you have made but not applied are lost.
• **Add to current map** — adds the settings from the new deformation map to the mesh nodes. Any adjustments you have made are retained.

6 In the **Mapping** group box, choose one of the following options:
   • **Fit to canvas** — adjusts to fit the image canvas
   • **Fit to layer** — adjusts to fit the current layer
   • **Current size centered on** — retains original map size and positions it in the center of the canvas or layer

7 In the **Preview** group box, choose a checkerboard size from the drop-list to obtain the best preview of the deformation.

8 Click **Load**.
Working with text

PaintShop Pro lets you add text to images and create interesting text effects.

This section presents the following topics:
- “Applying text” (page 327)
- “Formatting text” (page 329)
- “Saving text presets” (page 332)
- “Fitting text to a path” (page 333)
- “Wrapping text within a selection or shape” (page 334)
- “Pasting and fitting text to a shape” (page 335)
- “Moving text” (page 336)
- “Applying effects to text” (page 336)
- “Converting text to curves” (page 337)
- “Creating a text cutout filled with an image” (page 337)
- “Filling text with image patterns” (page 338)
- “Sizing and transforming text” (page 339)
- “Displaying captions and info text on images” (page 340)

Applying text

PaintShop Pro lets you apply different types of text to your images. You can apply vector text, raster text, and text as a selection. The type of text you apply depends on the effect you want to create.

Vector text

Vector text, which is used in most instances, is the most versatile type of text because you can edit the text characters at any time. For example, you can change the words, font type, style, and alignment. Unlike raster text, vector text retains its crisp, sharp edges when you resize it. For more information about vector objects, see “Drawing and editing vector objects” on page 341.
You can add text to your photos.

When you use raster-only tools, such as the Mesh Warp tool, or apply raster-only commands, such as an effect, the vector text is converted to a raster layer, and it can no longer be edited as text.

Raster text

You cannot edit raster text after you apply it. Therefore, you should not apply it unless you know you won’t need to change the words and formatting. You create raster text as a floating selection on a new raster layer, so you can easily move and transform it before you apply it to your image. When you defloat raster text, the text is merged with the underlying raster layer. If a vector layer is active when you defloat the raster text, PaintShop Pro creates a new raster layer.

Text selection

You can create a selection in the shape of text and edit it as you would any other selection. You can use a text selection to create special effects; for example, you can fill the characters in a text selection with an image. You can also fill text with an image by using the Text Cutter. For more information, see "Creating a text cutout filled with an image" on page 337. As with raster text, you cannot edit selection-based text. For more information about selections, see "Working with selections" on page 197.

Text formatting options

When you create text, you can specify formatting options such as font, font size, and alignment, as well as character and line spacing. For more information about text formatting options see "Formatting text" on page 329.

You can delete vector, raster, or selection-based text at any time.

To create text

Edit tab

1. On the Tools toolbar, choose the Text tool T.

2. On the Tool Options palette, choose a font, font size, units, font style, font color and stroke width and color. Note: The Units drop-list offers two options — Points (for print output) and Pixels (for Web output).

3. On the Tool Options palette, choose one of the following text types from the Create As drop-list:
   - Vector — creates fully editable text that resides on a vector layer. This text type is the default and is used in most instances.
   - Selection — creates a selection marquee in the shape of the text characters. The marquee is filled with the underlying layer.
   - Floating — creates raster text as a floating selection. The selection can be moved, but the text characters cannot be edited.

4. In the image window, click where you want the text to appear, type the text, and click the Apply button on the Tool Options palette.

A bounding box appears around the text.

5. Do any of the following to adjust the text position:
   - Position the pointer in the centre of the bounding box until the pointer changes its shape to a four-way arrow, and drag the text to the desired location.
   - Position the pointer over a corner of the bounding box until the pointer changes its shape to a two-way arrow, and drag up and down to rotate the text.
For information about using the Materials palette to choose colors for the text outline and fill, see “Using the Materials palette” on page 253.

With the Text tool selected, you can also set the font size by clicking and dragging in the image window to create a text object of the desired size. A tooltip displays the font size as you drag.

You can also apply the text after you have typed it by double-clicking the area outside the text object.

To delete text
Edit tab
1 On the Tools toolbar, choose the Pick tool .
2 Click the vector text you want to delete to select it.
3 Press Delete.

You can also use the following text selection methods: double-click a word to select it, triple-click a line to select it, and quadruple-click in the text or press Ctrl + A to select the entire text.

Formatting text

The text formatting options in PaintShop Pro let you control the appearance of text. You can set these options when you create vector, raster, or selection text. If you create vector text, you can reformat the text at any time by changing your text formatting settings. You cannot change the characters or formatting of raster text. You can modify raster text only by using the Pick tool.

You can use the following text options to format your text:
- Font, Size, Units, Font Style, and Text options — let you choose a typeface, type size, units based on intended output (print or Web), type style (bold, italic, underline, or strikethrough), and text options (Superscript, Subscript)
- Font color — lets you set the font fill color
- Stroke width and Stroke color — lets you set a font outline width and the color of the outline
- Alignment — lets you center multiple lines of text or align them on a left or right margin and apply justification
- Direction — lets you set the horizontal or vertical direction of the text
- Kerning — lets you change the space between characters
- Leading — lets you change the line spacing
- Tracking — lets you set equal spacing between characters
- Anti-alias — lets you smooth the edges of text characters

You can customize which controls display on the Tool Options palette and which controls are hidden in the More Options drop-list.

For information about using the Materials palette to choose colors for the text outline and fill, see “Using the Materials palette” on page 253.

How can you identify vector text?

Vector text, like other vector objects, can be identified by the vector icon  that appears next to the text in the Layers palette.

To change font attributes
Edit tab
1 On the Tools toolbar, choose the Text tool .
2 Select the vector text characters you want to change by dragging over them.
Note: You can also select the entire text by pressing Ctrl + A.

3 On the Tool Options palette, perform a task from the following table, and click the Apply changes button.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the font</td>
<td>Choose an option from the Font drop-list.</td>
</tr>
<tr>
<td>Change the font size</td>
<td>Choose an option from the Size drop-list.</td>
</tr>
<tr>
<td>Change the units of measurement for the font</td>
<td>From the Units drop-list, choose Points for print output or Pixels for Web output.</td>
</tr>
<tr>
<td>Apply bold formatting to text</td>
<td>Click the Bold button.</td>
</tr>
<tr>
<td>Apply italic formatting to text</td>
<td>Click the Italic button.</td>
</tr>
<tr>
<td>Underline the text</td>
<td>Click the Underline button.</td>
</tr>
<tr>
<td>Apply a line through text</td>
<td>Click the Strikethrough button.</td>
</tr>
<tr>
<td>Apply superscript or subscript</td>
<td>In the Text options area, click the Superscript or Subscript button.</td>
</tr>
<tr>
<td>Set the font fill color</td>
<td>Click the Font color swatch and choose a color.</td>
</tr>
<tr>
<td>Set font outline width</td>
<td>In the Stroke width box, type a value for the font outline. Type 0 for no outline.</td>
</tr>
<tr>
<td>Set the font outline color</td>
<td>Click the Stroke color swatch and choose a color.</td>
</tr>
</tbody>
</table>

To change text alignment

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit tab</td>
<td></td>
</tr>
<tr>
<td>1 On the Tools toolbar, choose the Text tool</td>
<td></td>
</tr>
<tr>
<td>2 Select the text object you want to align by dragging over it.</td>
<td></td>
</tr>
<tr>
<td>Note: You can also select the entire text by pressing Ctrl + A.</td>
<td></td>
</tr>
<tr>
<td>3 On the Tool Options palette, choose one of the following buttons:</td>
<td></td>
</tr>
<tr>
<td>• — aligns the left edge of each text line to the initial cursor position</td>
<td></td>
</tr>
<tr>
<td>• — centers each text line on the initial cursor position</td>
<td></td>
</tr>
<tr>
<td>• — aligns the right edge of each text line to the initial cursor position</td>
<td></td>
</tr>
<tr>
<td>• — Justify extends the text to the edges of the text, without changing inter-character spacing</td>
<td></td>
</tr>
<tr>
<td>• — Force Justify extends the text to the edges of the text box, including the last line by adjusting inter-character spacing if required.</td>
<td></td>
</tr>
</tbody>
</table>

330 | Corel PaintShop Pro User Guide
To set text direction

1. On the Tools toolbar, choose the Text tool.
2. Select the text object you want to reposition by dragging over it.
   Note: You can also select the entire block of text by pressing Ctrl + A.
3. On the Tool Options palette, choose one of the following options from the Direction drop-list:
   - Horizontal and Down — positions text horizontally, with subsequent lines below the top line
   - Vertical and Left — positions each character vertically, with subsequent lines to the left of the top line
   - Vertical and Right — positions each character vertically, with subsequent lines to the right of the top line
4. On the Tool Options palette, click the Apply button.

To change horizontal spacing between characters

1. On the Tools toolbar, choose the Text tool.
2. Select the text characters whose spacing you want to change by dragging over them.
   Note: You can also select the entire text by pressing Ctrl + A.
3. On the Tool Options palette, type or set a value in the Kerning control.
   Note: If you don’t see the control on the palette, click More Options.
   Positive values increase the spacing; negative values decrease the spacing.
4. On the Tool Options palette, click the Apply button.

Kerning values are expressed as 1 being equal to one em space — the width of capital letter M for a given font and font size.

You can use the built-in kerning values for the current font by marking the Auto Kern check box.

To change vertical spacing between lines of text

1. On the Tools toolbar, choose the Text tool.
2. Select the text lines whose spacing you want to adjust by dragging over them.
   Note: You can also select the entire block of text by pressing Ctrl + A.
3. On the Tool Options palette, type or set a value in the Leading control.
   Note: If you don’t see the control on the palette, click More Options.
   Positive values increase the spacing; negative values decrease the spacing.
4. On the Tool Options palette, click the Apply button.

To set equal spacing between characters

1. On the Tools toolbar, choose the Text tool.
2. Select the text characters whose spacing you want to adjust by dragging over them.
   Note: You can also select the entire text by pressing Ctrl + A.
3 On the Tool Options palette, type or set a value in the Tracking control.
   Note: If you don’t see the control on the palette, click More Options.
4 On the Tool Options palette, click the Apply button.

To smooth jagged edges in text
Edit tab
1 On the Tools toolbar, choose the Text tool.
2 Select the text object whose edges you want to adjust by dragging over it.
   Note: You can also select the entire text by pressing Ctrl + A.
3 On the Tool Options palette, choose an option from the Anti-alias drop-list:
   • Off — applies no anti-aliasing (edges appear jagged)
   • Sharp — applies a slight degree of edge smoothing
   • Smooth — applies a stronger degree of edge smoothing
4 On the Tool Options palette, click the Apply button.

Anti-aliasing may increase the number of colors in an image, which may cause stray colors to appear along the edges of text. Anti-aliasing may also make it difficult to reduce the file size and to maintain image quality.

To customize the Text Tool Options palette
1 On the Tools toolbar, choose the Text tool.
2 On the Tool Options palette, click More Options.
3 Click Customize, and in the Show/Hide Options dialog box, mark the check boxes for the controls that you want to see on the palette. Unmark the check boxes for the controls that you want to display only in the More Options drop-list.
4 Click Close.

Saving text presets
You can save formatted text as text presets. For example, if you annotate screenshots in PaintShop Pro regularly, you can create an annotation text style that includes your preferred font, text size, color, and other settings, and save it as a preset for quick access. Likewise if you create collage pages or flyers and use the same text styles each time—presets help you keep the pages consistent.
To save a text style as a preset

Edit tab

1. Create and select the formatted text that you want to save as a preset.
2. On the Tool Options palette, click the Presets drop-list, and click the Save preset button to display the Save Preset dialog box.
3. Type a name for the preset.
   Note: You cannot use “Default” or “Last Used” as the name for a preset.
   If you want to enter additional preset information or customize which settings are included, click Options.
4. Click OK.

You can delete, rename, copy, or move a preset text style by clicking the Resource Manager button in the Presets drop-list, clicking a text style in the list, and clicking the corresponding button for the action that you want to perform. For more general information about presets, see “Using and creating presets” on page 437.

To apply a preset text style

Edit tab

1. With the Text tool, select the text that you want to format.
2. On the Tool Options palette, click the Presets drop-list, and hover over the text styles to see a live preview of the style on your text.
3. Click the text style that you want to apply.

Fitting text to a path

Every vector object has a path that defines its shape. You can fit vector text to a path to create fun and interesting effects.

PaintShop Pro aligns the text along the path, starting from the spot where you click to insert it. You can also set the alignment style for the text: left-aligned text starts where you click; centered text is centered on the spot where you click; and right-aligned text ends where you click. When you fit your text to a path, you can adjust the distance between the text and the path.

Text is displayed differently on open and closed paths. Open paths are lines on which the start and end nodes do not meet; closed paths are shapes such as circles, squares, and rectangles. On open paths, text that is longer than the path hangs from the end. The angle of the last line segment determines the direction in which the text hangs. On closed paths, text that is longer than the path wraps around itself. For more information about lines and shapes, see “Editing shapes” on page 347.

To fit text to a path

Edit tab

1. Create a vector line or shape.
2. Click the Text tool.
3. On the Tool Options palette, choose Vector from the Create As drop-list, and set the other text controls.
   If the Materials palette is not displayed, choose View > Palettes > Materials.
4. On the Materials palette, click the Foreground and Stroke properties box, and choose a color for the text outline.
5. Click the Background and Fill properties area, and choose a color for the text fill.
6. Click the line or shape.
   Note: To position the text on a vector object or path without attaching it to the object or path, hold down Alt and click the path or shape.
7. Click on the image where you want the test to appear, and type the text.
8. On the Tool Options palette, click the Apply button.
If you want to warp the text around the curved section of a path, mark the **Warp text** check box on the Tool Options palette. If the path is not curved, the effect is not apparent. Warping is set on a per-character basis, so you can warp specific characters in a text block.

**To attach an unattached text object to a path**  
*Edit tab*  
1. Choose the **Pick** tool.
2. Select the vector object.
3. Hold down **Shift**, and select the vector text.  
   Both the text and the vector object are selected.
4. Choose **Objects** ➤ **Fit Text to Path**.

   After you align text to a vector object, you can make the object invisible. On the Layers palette, click the **Visibility Toggle** button next to the object.

**To detach text from its associated path**  
*Edit tab*  
1. Choose the **Pick** tool.
2. Select the text.
3. Choose **Objects** ➤ **Detach Object from Path**.  
   **Note:** The **Detach Object from Path** command is available only if you have selected a text object that is fitted to a path.

**To adjust the position of text fitted to a path**  
*Edit tab*  
1. On the Tools toolbar, choose the **Text** tool.
2. Select the text whose position you want to adjust by dragging over it.  
   **Note:** You can also select the entire text by pressing **Ctrl + A**.
3. On the Tool Options palette, set a value in the **Offset** control.  
   Positive values position the text above the path; negative values position the text below the path.
4. On the Tool Options palette, click the **Apply** button.

**Wrapping text within a selection or shape**  
You can wrap text inside a selection or a vector shape. For example, you can draw a closed shape with the **Freehand Selection** tool by tracing along a silhouette in a photo and fill the selection with text or you can draw a heart with the **Preset Shape Tool** and fill the shape with text.
To wrap text inside a selection or a vector shape

1. In the Tools toolbar, click a selection tool or a vector shape tool, and in the image window, drag to create a selection or vector shape.
   
   **Note:** If you are drawing a selection, ensure that it is a closed selection.

2. Click the **Text Tool** and in the image window, click inside the selection or vector shape, at the start position for your text.

3. Type your text.
   
   The text automatically wraps to stay within the shape or selection, unless there is too much text for the space. Extra text appears outside the shape or selection.

Pasting and fitting text to a shape

The **Paste-to-Fit** command lets you automatically fit Clipboard text to a shape in a PaintShop Pro project. The text can be copied from a Web page or other document, and expands to fit the vector shape, such as a shape created with the Preset Shape, Rectangle, Ellipse, or Symmetric Shape tools.

To fit Clipboard text to a shape

1. From your browser or another program, copy your source text to the Clipboard.

2. In PaintShop Pro, choose an existing vector shape, or create a vector shape.

3. Choose the **Text tool** and click inside the vector shape.

4. Right-click and choose **Paste-to-Fit** from the context menu.
   
   The text will automatically adjust to fit the shape. Note that simple shapes work best.
Moving text

You can move vector and raster text anywhere in an image. You can move the text after it is fitted to the path by selecting it and dragging it along the path. PaintShop Pro aligns text based on the nearest point where the text meets the path.

Important! To move raster text that is on a layer with other raster information, such as raster shapes or brushstrokes, you must isolate the text. You can use a selection tool, such as the Magic Wand tool, to select and move the text. For more information about making selections, see “Creating selections” on page 197.

To move text

Edit tab

1. On the Tools toolbar, choose the Pick tool .
2. Click the text you want to move.
   A bounding box surrounds the text.
3. Position your cursor over the selected text, until it changes its shape to a four-way arrow , and drag the text anywhere in the image.

You can also move text to another layer by cutting and pasting it onto another layer.

To move text along a path

Edit tab

1. Choose the Pick tool .
2. Click the text you want to move.
   A bounding box appears around the text.
3. Position your cursor over the selected text, until it changes its shape to a four-way arrow , and drag the text to the desired location.

   Note: As you drag the text, a small, square icon moves with it. This icon indicates one of the following:
   • the start of the text if the text was left-aligned
   • the midpoint of the text if the text was centered
   • the end of the text if the text was right-aligned

Applying effects to text

You can use raster text to create an unlimited variety of text effects. For example, you can apply a drop shadow or a beveled edge, transform text into brushstrokes, or apply a colored-chalk effect. To apply an effect to vector text, you must first convert the vector text to raster text.

To apply effects to raster text

Edit tab

1. Apply raster text to a transparent layer on an image.
2. On the Tools toolbar, choose the Magic Wand tool .
3. Select the text.
4. Choose the Effects menu, and select an effect.

For information about layers, see “Working with layers” on page 219. For information about applying text to images, see “Applying text” on page 327.
To apply effects to vector text
Edit tab
1 On the Tools toolbar, choose the Pick tool.
2 Select the text.
3 Choose Selections ➔ From Vector Object.
4 Choose Edit ➔ Paste As New Layer.
5 On the Tool Options palette, choose the Magic Wand tool.
6 Select the text.
7 Choose the Effects menu, and select an effect.

Converting text to curves
You can edit vector text by converting it to curves and then adding, deleting, and moving nodes. Nodes are the tiny squares that appear along the object’s outline.

You can convert letters to individual curve objects, or you can convert the entire string of text into one curve object, with each letter as a separate contour within the object path.

To convert vector text to curves
Edit tab
1 On the Tools toolbar, choose the Pick tool.
2 Select the text.
3 Do one of the following:
   • To convert the entire text object into one vector object, choose Objects ➔ Convert Text to Curves ➔ As Single Shape. This command produces one path containing a contour for each letter.
   • To convert each letter to a separate vector object with its own path, choose Objects ➔ Convert Text to Curves ➔ As Character Shapes. A vector layer is created for each letter, and the layers are grouped in the Layers palette.

If you convert each letter to a separate vector object, you must select the letters individually in order to edit the nodes.

You can edit a curve object by using the Pen tool in Edit mode. For more information, see “Adding and closing contours” on page 356.

Creating a text cutout filled with an image
You can use the Text Cutter option to create a text cutout that is filled with the underlying photo or imagery. The effect is similar to using a clipping mask, except the cutout object is created as a new file with a transparent background—perfect for collage, scrapbook, or other creative photo projects.
To create a text cutout

1. From the Edit tab, open an image that you want to use as a fill.
2. On the Tools toolbar, click the Text tool.
3. On the Tool Options palette, set the text options.
4. In the image window, click where you want to position the text, and type the text.
   - If you resize or reposition the text with the Pick Tool, reactivate text mode by clicking the Text Tool and clicking inside the text.
5. On the Tool Options palette, click the Cutter Preview button.
   - A semi-transparent mode is activated that lets you preview the cutout. You can now adjust the position, size, or rotation of the proposed cutout using the control handles for the object.
6. On the Tool Options palette, click the Text Cutter button.
   - The text cutout is filled with the underlying imagery and is created as a new file with a transparent background. A layer and mask is also created on the current image.

Filling text with image patterns

You can fill text with one image or you can fill it with repeated images to create a pattern.

To fill text with one image

Edit tab

1. Open a copy of the image.
2. On the Tools toolbar, choose the Text tool.
3. On the Tool Options palette, choose Selection from the Create As drop-list, and set the other text controls.
4. In the image window, click where you want to create the text selection, and type the text.
5. On the Tool Options palette, click the Apply changes button.
6. Copy the text selection to a new image.

For information about applying text, see “Applying text” on page 327.

To fill text with a repeated image

Edit tab

1. Open the image you want to use to fill the text.
2. On the Materials palette, click the Background and Fill properties box.
3. In the Material properties dialog box, click the Pattern tab.
Choose the image from the drop-list.

Apply text to the image.

For information about applying text, see “Applying text” on page 327.

Sizing and transforming text

You can transform raster and vector text interactively. For example, you can resize, rotate, shear, distort, or apply perspective to text.

You can also resize and reshape vector text by editing its nodes and contours. For more information, see “Working with nodes” on page 348.

1. Open a copy of the image.
2. On the Tools toolbar, choose the Text tool.
3. On the Tool Options palette, choose Selection from the Create As drop-list, and set the other text controls.
4. In the image window, click where you want to create the text selection, and type the text.
5. On the Tool Options palette, click the Apply changes button.
6. Copy the text selection to a new image.

To resize and transform text

1. On the Layers palette, choose a layer.
2. On the Tools toolbar, choose the Pick tool, and select the text.
   A bounding box with handles appears on the selection or the layer.
3. Drag a corner handle to resize the text.
   If you want to change the current proportions, right-click and drag a handle.
4. Perform any of the actions in the following table to transform the text.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the entire text block</td>
<td>Drag the bounding box.</td>
</tr>
<tr>
<td>Change the center of rotation</td>
<td>Drag the rotation pivot point.</td>
</tr>
<tr>
<td>Rotate the text</td>
<td>Drag the rotation handle.</td>
</tr>
<tr>
<td></td>
<td>You can set a specific angle of rotation in</td>
</tr>
<tr>
<td></td>
<td>the Angle box on the Tools Options palette.</td>
</tr>
<tr>
<td>Change the perspective symmetrically</td>
<td>Hold down Ctrl and drag a corner handle</td>
</tr>
<tr>
<td></td>
<td>horizontally or vertically.</td>
</tr>
<tr>
<td>Change the perspective asymmetrically</td>
<td>Hold down Shift and drag a corner handle.</td>
</tr>
<tr>
<td>To shear text</td>
<td>Hold down Shift while dragging a side handle.</td>
</tr>
<tr>
<td>To distort text</td>
<td>Hold down Ctrl and Shift while dragging a</td>
</tr>
<tr>
<td></td>
<td>handle.</td>
</tr>
</tbody>
</table>
To make the deform handles on a layer easier to see, drag the corner of the image window to make it larger than the image.

Displaying captions and info text on images

You can display text on your images based on captions and EXIF data, such as the date the photo was captured, the camera used, or the camera settings. When you use the Add Info dialog box, the text is added to your images as a separate layer. You can access Add Info from the File menu or you can applying the settings to multiple photos by accessing it in the Batch Process wizard. For more information about batch processing, see “Processing files in batches” on page 439. You can format the text, add a drop shadow for better visibility, and set the position for the text.

To add info text to an image

Edit tab

1. Click File ➤ Add Info.
   If you want to see more controls, click the Maximize button in the upper right corner of the dialog box.
2. In the Caption box, type any text you want to add.
3. In the Add EXIF info to caption box, select any EXIF info that you want to display and click the Add button (plus sign). You can add spacing or other characters between EXIF data tags in the Caption box.
4. In the Font Properties area, set the font, style, size, and color for your text.
5. Set the Opacity for the text.
6. If you want to add a drop shadow to the text (for better visibility), enable the Drop Shadow check box and set the properties for the drop shadow. For more information about drop shadow settings see “To apply a Drop Shadow layer style” on page 242.
7. In the Position area, click a check box to indicate where you want the text to display. You can fine-tune the position by dragging the Horizontal and Vertical sliders in the Offset X | Offset Y area.

When you save to a file format that doesn’t support layers, the info text is merged with the image.
Drawing and editing vector objects

You can use PaintShop Pro drawing tools to create any type of object — from simple lines and shapes to complex illustrations.

This section presents the following topics:

• “Understanding raster and vector objects” (page 341)
• “Selecting vector objects” (page 342)
• “Drawing rectangles and squares” (page 343)
• “Drawing circles and ellipses” (page 344)
• “Drawing symmetric shapes” (page 345)
• “Creating preset shapes” (page 345)
• “Filling cutout shapes with images” (page 346)
• “Editing shapes” (page 347)
• “Saving shapes as presets” (page 348)
• “Working with nodes” (page 348)
• “Sizing, shaping, and rotating vector objects” (page 352)
• “Aligning, distributing, and arranging vector objects” (page 353)
• “Grouping and ungrouping vector objects” (page 355)
• “Converting objects to paths” (page 356)
• “Adding and closing contours” (page 356)
• “Editing contours and paths” (page 357)
• “Drawing lines” (page 359)
• “Saving custom line styles” (page 360)
• “Drawing curves” (page 361)
• “Modifying lines and curves” (page 363)
• “Copying and moving vector objects” (page 364)

Understanding raster and vector objects

When you draw raster objects, you are really painting on a raster layer. Even though you create a raster object in the same way as a vector object, the result is a pixel-based shape. You can edit the pixels with raster editing tools.

Important! You can only draw raster objects on raster layers. If you draw a raster object on a vector layer, PaintShop Pro creates a new raster layer for your object.

A vector object’s properties — such as its outline color, fill color, size, and location — can be easily changed. You can also edit the paths, contours, line segments, and nodes that make up vector objects.
Important! You can only draw vector objects on vector layers. If you try to draw a vector object on a raster layer, PaintShop Pro creates a new vector layer for the vector object.

For more information on vector and raster objects, see “Starting from a blank canvas” on page 60. For information about vector, floating, and selecting text, see “Working with text” on page 327.

The anatomy of a vector object

In order to understand vector objects, you must be familiar with the following terms.

- **Object** — anything you create with the Pen or Preset Shape tool. Each object is represented by its own bounding box. An object has properties you can control such as line style and fill color. Each object contains one path made up of contours and nodes. For more information, see “Aligning, distributing, and arranging vector objects” on page 353.

- **Path** — includes all of the contours in an object. The properties of the path are controlled by the object’s properties. A path’s direction flows from its start to its end point. Some paths are closed, in which their start and end points are the same.

- **Contour** — contains at least one line segment. A contour can be open or closed. Some of a contour’s properties are determined by the object’s properties, such as the line style, fill color, and anti-aliasing.

- **Node** — a point on a path or contour that lets you define its shape. For more information about nodes, see “Working with nodes” on page 348.

- **Line Segment** — the straight or curved line between two nodes. For more information, see “Drawing lines” on page 359.

Selecting vector objects

You must select a vector object in order to edit it. You can select one or more objects on the same layer, or you can select objects on different layers. You can select vector objects by using the Pick tool or by using the Layers palette. The Pick tool lets you select one or more vector objects quickly. The Layers palette lets you select vector objects regardless of whether they overlap or are currently showing in the image window. For more information about showing and hiding layers, see “Viewing layers” on page 229.
To select vector objects with the Pick tool

1. On the Tools toolbar, choose the Pick tool.
2. Click the object you want to select.

If you want to select multiple objects, hold down Shift, and click the objects.

To select vector objects from the Layer palette

1. On the Layers palette, click the plus sign (+) next to a layer to view all of its objects.
2. Click the layer name for the vector object.
   The layer name appears in bold type.

If you want to select multiple objects, hold down Shift and click each object name.

Drawing rectangles and squares

You can draw squares and rectangles.

To draw a rectangle or square

1. On the Tools toolbar, select the Rectangle tool.

   Note: If you want to place the rectangle or square on the current vector layer, mark the Create on Vector check box on the Tool Options palette. If no vector layer exists, marking this check box creates one for the rectangle or square. If this check box is unmarked, the rectangle or square is placed on a raster layer. Placing a rectangle or square on a vector layer makes it easier to edit.

2. On the Materials palette, click the Background and Fill properties box, and choose a fill color.
3. Click the Foreground and Stroke properties box, and choose an outline color.
4. On the Tool Options palette, click one of the following buttons:
   • Draw Rectangle
   • Draw Square
   If you want to display the shape’s nodes, mark the Show Nodes check box.
5. Drag to draw the shape.
6. Click the Apply button.

You can also

- Set the radii for the shape’s corners
- Choose a line style and width
- Smooth the shape’s edges
- Type or set values in the Horizontal Radius and Vertical Radius controls.
- Choose an option from the Line Style drop-list, and type or set a value in the Width control beside the drop-list.
- Mark the Anti-alias check box.
You can also

Change the way the line segments join
Choose an option from the Join drop-list. If you choose Miter join, you can also type or set a value in the Miter Limit control.

Size the shape
Mark the Show nodes check box. Type or set values in the Width and Height controls.

Move the shape
Mark the Show nodes check box. Type or set values in the Left and Top controls.

You can save your settings as a preset. For more information, see “Using and creating presets” on page 437.

Drawing circles and ellipses
You can draw circles and ellipses.

To draw a circle or ellipse
Edit tab
1 On the Tools toolbar, select the Ellipse tool.

Note: If you want to place the circle or ellipse on the current vector layer, mark the Create on Vector check box on the Tool Options palette. If no vector layer exists, marking this check box creates one for the circle or ellipse. If this check box is unmarked, the circle or ellipse is placed on a raster layer. Placing a circle or ellipse on a vector layer makes it easier to edit.

2 On the Materials palette, click the Background and Fill properties box, and choose a fill color.
3 Click the Foreground and Stroke properties box, and choose an outline color.
4 On the Tool Options palette, click one of the following buttons:
   • Draw Circle
   • Draw Ellipse

   If you want to display the shape’s nodes, mark the Show Nodes check box.

5 Drag to draw the shape.
6 Click the Apply button.

You can also

Set the radii
Mark the Show Nodes check box. Type or set values in the Radius X and Radius Y controls.

Set the center horizontal (center X) and vertical (center Y) position
Mark the Show Nodes check box. Type or set values in the Center X and Center Y controls.

You can save Tool Options palette settings as presets. For more information, see “Using and creating presets” on page 437.
If you have not displayed nodes in the shape, you can still set the radii and the center horizontal and vertical positions by clicking the Edit Mode button on the Tools Options palette.

Drawing symmetric shapes

You can draw polygons and stars.

To draw a symmetric shape

Edit tab

1. On the Tools toolbar, select the Symmetric Shape tool.

   Note: If you want to place the symmetric shape on the current vector layer, mark the Create on Vector check box on the Tool Options palette. If no vector layer exists, marking this check box creates one for the symmetric shape. If this check box is unmarked, the symmetric shape is placed on a raster layer. Placing a symmetric shape on a vector layer makes it easier to edit.

2. On the Materials palette, click the Background and Fill properties box, and choose a fill color.

3. Click the Foreground and Stroke properties box, and choose an outline color.

4. On the Tool Options palette, click one of the following buttons:
   - Draw Polygon
   - Draw Stellated

   If you want to display the shape’s nodes, mark the Show Nodes check box.

5. Type or set a value in the Number of sides control.

6. Drag to draw the shape.

7. Click the Apply button.

You can also

Apply rounded outer corners to the shape

Apply rounded inner corners to the stellated shape

Set the radius for the stellated shape

Mark the Rounded Outer check box.

Mark the Rounded Inner check box.

Type or set a value in the Radius control.

You can save Tool Options palette settings as presets. For more information, see “Using and creating presets” on page 437.

You can also choose line style options such as style, stroke width, and join and miter limit settings. For more information, see “Drawing lines” on page 359.

Creating preset shapes

You can draw preset shapes such as callouts, arrows, flowers, and gears.

To draw a preset shape

Edit tab

1. On the Tools toolbar, choose the Preset Shape tool.
Note: If you want to place the preset shape on the current vector layer, mark the Create on Vector check box on the Tool Options palette. If no vector layer exists, marking this check box creates one for the preset shape. If this check box is unmarked, the preset shape is placed on a raster layer. Placing a preset shape on a vector layer makes it easier to edit.

2 On the Tool Options palette, choose an option from the Shapes List drop-list. If you want to filter the options, choose a category from the Category drop-list.

3 Drag to create the shape. Note: If you want to apply a custom fill, unmark the Retain style check box. On the Materials palette, click the Background and Fill properties box, and choose a fill color. Click the Foreground and Stroke properties box, and choose an outline color. If you do not want the line segments to have a fill, click the Transparent button.

4 Drag to draw the shape.

You can also

Choose a line style Select an option from the Line Style drop-list.

Choose a stroke width (in pixels) Type or set a value in the Width control.

Smooth the appearance of a shape Mark the Anti-alias check box.

Apply a join style Choose an option from the Join drop-list. If you choose Miter Join, type or set a value in the Miter limit control to set the degree of pointedness. The higher the value, the more pointed the join is.

Create a shape with the same aspect ratio as the one in the Shapes list Hold down Shift while you drag.

Place the centerpoint of the shape where you click Right-click and drag.

You can save a Tool Options palette settings as presets. For more information, see “Using and creating presets” on page 437.

Filling cutout shapes with images

You can use vector shapes, such as Preset Shapes, to create cutouts that are filled with the background imagery. The effect is similar to using a clipping mask, except the cutout object is created as a new file with a transparent background—perfect for collage, scrapbook, or other creative photo projects.

To create a shape cutout
1 Open a copy of the image that you want to use as a fill.
2 On the Tools toolbar, choose one of the following tools:
   • Preset Shape
   • Rectangle
   • Ellipse
   • Symmetric Shape
3 On the Tool Options palette, set the options for your shape.
4 In the image window, drag where you want to create the shape.
5 On the Tool Options palette, click the Cutter Preview button.
   A semi-transparent mode is activated that lets you preview the cutout. You can now adjust the position, size, or rotation of the proposed cutout using the control handles for the object.
6 On the Tool Options palette, click the Shape Cutter button.
   The cutout is filled with the underlying imagery and is created as a new file with a transparent background. A layer and mask is also created on the current image.

To help determine the best size and position for the shape cutout, in the Layers palette, reduce the Opacity setting for the shape so that you can see the underlying image.

Editing shapes

You can edit the basic properties of vector objects, such as the line width, line style, and anti-aliasing. You can also rename an object in the Layers palette. You can also hide or display vector objects.

To modify vector object properties
   Edit tab
1 Select the vector object you want to edit.
   If you want to edit multiple objects, choose the Pick tool, hold down Shift, and marquee select the objects.
2 On the Tool Options palette, click the Properties button.
   The Vector Property dialog box appears.
3 Adjust any of the settings.
4 Click OK.

To edit a shape by using the Tool Options palette
   Edit tab
1 On the Tools toolbar, select the Pen tool.
2 On the Tool Options palette, click Edit Mode button.
3 Click the shape you want to edit.
4 Adjust any of the available settings on the Tool Options palette.

Edit mode lets you edit shapes in a variety of ways; however, you can also edit shapes by using the Pick tool to move, rotate, align, and stretch shapes.
Saving shapes as presets

You can also save any vector object as a preset. Preset shapes are stored in shape libraries, in the ...Documents/Corel PaintShop Pro/2023/Preset Shapes folder. You can also store shape libraries in a different folder. For more information, see “Setting file locations” on page 413.

To save a shape as a preset
Edit tab
1. On the Tools toolbar, choose the Pick tool.
2. Select the shape you want to save as a preset.
   If you want to save multiple shapes, marquee select the shapes.
3. Choose File ➤ Export ➤ Shape.
   The Export Shape Library dialog box appears.
4. Type a name for the library file, and click OK.
   The library file is saved in the default Preset Shapes folder.

To delete a shape library
Edit tab
1. Choose a library file from the Preset Shapes folder.
2. Press Delete.

Working with nodes

Nodes are square points on line and curve objects. You can change the shape of a line or curve object by dragging one or more of its nodes.

Nodes have zero, one, or two control arms. The length and direction of the control arms determine the shape of the contour at the node. The straight or curved line between two nodes is a line segment. There are four types of nodes: symmetrical, asymmetrical, cusp, and smooth.

You can use symmetrical nodes to create smooth, flowing curves on either side of a node. Any adjustments to one control arm are mirrored by the other.

You can use asymmetrical nodes to obtain a different amount of curve on each side of the node, but keep a smooth flow through the node. You can adjust the length of each control arm, but the not the direction.
You can use cusp nodes to create extreme changes in direction. You can adjust the length and direction of each control arm independently.

You can use smooth nodes to create a smooth transition between straight and curved line segments.

You can select a node to edit, or you can move it. Moving a node alters the shape of a vector object. If an object has more than one contour, you can move all of its nodes. You can also move the path to move the entire object. You can edit the contour of a vector object by adding, merging, or deleting nodes anywhere along a path.

You can merge nodes on a contour while retaining the line segments on each side. The line segments are combined into one line segment between remaining nodes. If the contour is curved at the node, PaintShop Pro attempts to retain the curve.

You can also delete a node to remove the node and the line segments on each side.

To select a node

1. On the Tools toolbar, select the Pen tool.
2. On the Tool Options palette, click Edit Mode button.
3. Click a vector object.
   The object’s nodes appear.
4. Click the node.
   The selected node appears with a solid gray fill.

You can also

Select multiple nodes
Hold down Shift, and click the nodes.

Select all nodes on a contour
Double-click one node. If the object has only one node, this selects all nodes in the path.

Select all nodes in a path (all nodes in the object)
Right-click a node, and choose Edit ▶ Select All.

Select the next or previous node on a contour
Hold down Shift, and press [ or ].

Deselect a selected node
Hold down Shift, and click the node.
To view the selected node more easily, click the Visibility icon on the Layers palette next to the vector object you are working on. This hides the fill and outline for the object. For more information about showing and hiding layers, see “Viewing layers” on page 229.

Start and end nodes are easy to find. The cursor displays “START” or “END” when you hold it over the node. If the shape is closed, the cursor displays “CLOSE.”

To move a node

**Edit tab**

1. On the Tools toolbar, select the **Pen** tool.
2. On the Tool Options palette, click **Edit Mode** button.
3. Select a node, and then drag it to a new position.

You can constrain a node’s line segments to 45-degree increments by holding down **Shift** as you drag.

To add a node on a contour

**Edit tab**

1. On the Tools toolbar, select the **Pen** tool.
2. On the Tool Options palette, click one of the following buttons:
   - **Edit Mode**
   - **Knife Mode**
3. Click the contour.
4. Hold down **Ctrl**, and click where you want to add a node.
   The cursor displays “+ADD.”

To add a new start or end node

**Edit tab**

1. On the Tools toolbar, select the **Pen** tool.
2. On the Tool Options palette, click the **Drawing Lines and Polylines** button.
3. Select the start or end node of the contour.
4. Click to add another node.
   The contour automatically connects to the new node.

To merge one or more nodes

**Edit tab**

1. On the Tools toolbar, select the **Pen** tool.
2. Select the node you want to merge.
   If you want to select multiple nodes, hold down **Shift** and click.
3. Right-click a node, and choose **Edit ➤ Merge**.
To transform nodes
Edit tab
1 On the Tools toolbar, select the Pen tool.
2 On the Tool Options palette, click the Edit Mode button.
   Note: If you cannot see all of the options on the Tool Options palette, click the More button.
3 Select one or more nodes.
4 Choose Objects | Transform Selected Nodes, and choose one of the following commands:
   • Flip — moves selected nodes along the vertical axis (those on top go the bottom and vice versa). On a single node, the command flips the node’s control arms.
   • Mirror — moves selected nodes along the horizontal axis (those on the left go to the right and vice versa). On a single node, the command mirrors the node’s control arms.
   • Rotate — rotates the selected nodes by the current rotation setting. Applied to a single node, the control arms (if any) will rotate.
   • Skew X — moves selected nodes to the left or right (along the horizontal axis) using the current skew setting
   • Skew Y — moves selected nodes to the left or right (along the vertical axis) using the current skew setting
   • Contract — moves the selected nodes closer to each other by the current contraction setting. This command cannot be applied to a single node.
   • Expand — moves the selected nodes away from each other by the current expansion setting. This command cannot be applied to a single node.
5 Where applicable, type a value for the selected transformation setting.
6 Click the Apply button.

To adjust a curve using a node’s control arms
Edit tab
1 Select a node to display its control arms.
   Note: Cusp nodes may have no control arms.
2 Move the cursor over a control handle until the cursor changes to two rotating arrows.
3 Drag the handle.
   To constrain the control arms to fixed angles (45-degree increments), hold down Shift as you drag.

To straighten a curve between two nodes
Edit tab
1 Select two consecutive nodes.
2 Right-click one node, and then choose Node Type | Convert to Line.

To delete a node
Edit tab
1 Select a node.
2 Press Delete.

If you delete a node in the middle of an open contour, the vector object becomes two separate contours. If you delete a node in a closed contour, the contour opens.
Sizing, shaping, and rotating vector objects

You can transform vector objects and vector text interactively. For example, you can drag the handles on a bounding box to size, shape, or rotate objects. You can also transform vector objects by editing their nodes. For more information, see “Working with nodes” on page 348.

You can also size vector object to make them the same width, height, or both.

To size and shape a vector object

**Edit tab**

1. On the Tools toolbar, choose the Pick tool  .
2. Select the object.
3. Perform any of the steps in the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size a vector object</td>
<td>Drag a corner or edge handle.</td>
</tr>
<tr>
<td></td>
<td>If you want to resize while changing the current proportions, right-click and drag a handle.</td>
</tr>
<tr>
<td>Change perspective symmetrically</td>
<td>Hold down <strong>Shift</strong>, and drag a corner handle.</td>
</tr>
<tr>
<td>Shear a vector object</td>
<td>Hold down <strong>Shift</strong>, and drag a side handle.</td>
</tr>
<tr>
<td>Distort a vector object</td>
<td>Hold down <strong>Ctrl</strong> + <strong>Shift</strong>, and drag a handle.</td>
</tr>
</tbody>
</table>

To rotate vector objects

**Edit tab**

1. On the Tools toolbar, choose the Pick tool  .
2. Select an object.
3. Drag the rotation handle.
   - You can set a specific angle of rotation in the **Angle** box on the Tools Options palette.

   ![Tip](Note: To change the center of rotation, hold down **Ctrl**, and drag the rotation pivot point to a new location.)

To make vector objects the same size

**Edit tab**

1. On the Tools toolbar, choose the Pick tool  .
2. Select the first vector object.
   - **Note:** The first object controls how all the other vector objects are resized.
3. Hold down **Shift**, and click the other objects you want to resize.
4. On the Tool Options palette, choose one of the following options from the Same Size group box:
   - **Make Same Height**
   - **Make Same Width**
• Make Same Width and Height

To change the object’s proportions while resizing, select the object with the Pick tool, and then right-click and drag a corner handle.

Aligning, distributing, and arranging vector objects

You can align, distribute, and arrange vector objects on the canvas. For example, you can align their edges, distribute them evenly, center them on the image canvas, or arrange their order (from top to bottom) on a layer. Each object you draw on a layer is stacked on top of the next.

When you move a vector object, you can snap it to another vector object.

To move a vector object

1. On the Tools toolbar, choose the Pick tool.
2. Select the object.
   - If you want to move multiple objects, hold down Shift and select the objects.
   - A bounding box surrounds the selected objects.
3. Drag the object or objects to a new position.

You can also

Move an object one pixel at a time: Press an arrow key.
Move an object 10 pixels at a time: Hold down Ctrl, and press an arrow key.
Move an object 50 pixels at a time: Hold down Shift, and press an arrow key.
Move an object 100 pixels at a time: Hold down Shift + Ctrl, and press an arrow key.

To align vector objects

1. On the Tools toolbar, choose the Pick tool.
2. Select the first vector object.
3. Hold down Shift, and select the other objects you want to align.
4. In the Tool Options palette, click one of the following buttons in the Object Alignment group box:
   - Align Top
   - Align Bottom
   - Align Left
   - Align Right
   - Align Vertical Center
To move an object, select it on the Layers palette, and drag it up or down in the list.

To evenly distribute objects

1. On the Tools toolbar, choose the Pick tool.
2. Hold down Shift, and marquee select the objects.

   **Note:** You must have three or more objects selected to distribute them in relation to each other.
3. In Tool Options palette, click one of the following buttons in the Object Distribution group box:
   - Distribute Vertical Top
   - Distribute Vertical Center
   - Distribute Vertical Bottom
   - Distribute Horizontal Right
   - Distribute Horizontal Center
   - Distribute Horizontal Left

To align vector objects to the canvas

1. On the Tools toolbar, choose the Pick tool.
2. Select an object.
   - If you want to align multiple objects, hold down Shift and marquee select the objects.
3. In the Tool Options palette, click one of the following buttons in the Position On Canvas group box:
   - Center in Canvas
   - Align Horizontally Center in Canvas
   - Align Vertically Center in Canvas

To distribute vector objects on the canvas

1. On the Tools toolbar, choose the Pick tool.
2. Select an object.
   - If you want to distribute multiple objects, marquee select the objects.
3. In the Tool Options palette, click one of the following buttons in the Position On Canvas group box:
   - Space Evenly Horizontal
   - Space Evenly Vertical

To arrange vector objects

1. On the Tools toolbar, choose the Pick tool.
2. Select an object.
3. Right-click the object, choose Arrange, and select one of the following options:
• **Bring to Top** — moves an object to the top
• **Send to Bottom** — moves an object to the bottom
• **Move Up** — moves an object up one position
• **Move Down** — moves an object down one position

You can also arrange vector objects by dragging them up or down in the Layer palette.

**To snap a vector object to another vector object**

1. On the Tools toolbar, choose the **Pick** tool.
2. Select a vector object.
3. Drag the selected object to the object to which you want it to snap.
4. Release the mouse button.

Object snapping is enabled by default. If object snapping is disabled, choose **View > Snap To Object**.

Object snapping is governed by the snap influence, which controls the distance, in pixels, that a vector object must be from another vector object in order to snap to it. You can change the snap influence by choosing **View > Change Grid, Guide, Object & Snap Properties**, clicking the **Object** tab, and setting a value in a **Snap influence** control. The **Default Settings** group box shows the default setting for object snapping. The **Current Image Settings** group box shows the setting for object snapping in the current image.

If other snapping options (**Snap To Grid** or **Snap To Guides**) are also enabled, a vector object will snap to the closest enabled snapping target. If the snapping targets are the same distance from the object, the object will snap to the grid or guide.

**Grouping and ungrouping vector objects**

You can group several objects or groups of objects to move, resize, reshape, and change their lines and materials.

When you group objects on different layers, PaintShop Pro automatically moves them to the layer of the first object you select. Each group is labeled on the Layers palette and the objects in the group are shown as components.

**To group or ungroup vector objects**

1. Group objects
   - Using the **Pick** tool, select the objects you want to group. On the Tool Options palette, click the **Group** button.
2. Ungroup objects
   - Using the **Pick** tool, select the group. On the Tool Options palette, click the **Ungroup** button.

**To group objects by using the Layers palette**

1. On the Layers palette, click the first object you want to group.
2. Hold down **Shift**, and click each object you want to add to the group.
3. Right-click, and choose **Group**.
If you group objects from several layers, PaintShop Pro moves them to the layer of the first object you selected.

Click the plus sign (+) next to the group name to show the group’s components.

To remove an object from a group

Edit tab

1. On the Layers palette, drag the object to another group or layer.

Converting objects to paths

You can convert any selected vector object, including text, to a fully editable path (as though it were created by the Pen tool). This allows you to use the Pen tool’s full complement of node-editing commands to modify the converted object.

To convert a vector object to an editable path

Edit tab

1. On the Tools toolbar, choose the Pick tool.
2. Select an object.
   - If you want to convert multiple objects to paths, marquee select the objects.
3. Right-click the objects, and choose Convert to Path.

Adding and closing contours

You can add new contours to any existing object. The new contour will have the same properties, including color, material, line style, and so on, as the selected object. You can also duplicate contours.

To add a contour to an object

Edit tab

1. On the Tools toolbar, click the Pen tool.
2. In the Tool Options palette, click the Edit Mode button.
3. Select an object.
4. Click one of the following buttons:
   - Draw Lines and Polylines
   - Draw Point-to-point Bézier Curves
• Draw Freehand

5 Drag on the object to create the contour.

To close a contour
Edit tab
1 On the Tools toolbar, select the Pen tool.
2 On the Tool Options palette, click the Edit Mode button.
3 Select a contour.
4 Click the Close selected open contours button.

When you close a contour, PaintShop Pro draws a segment from the contour’s start node to its end node.

Editing contours and paths

You can edit the contours and paths of vector objects. You can join contours by connecting their end points. You can also reverse the direction of paths and contours. The direction of a contour flows from the start node to the end node. When you place the cursor over the start node, a “START” message appears next to the cursor. When you place the cursor over the end node, an “END” message appears. If the object has a closed path, a “CLOSE” message appears.

You can duplicate contours.

For more information about the different types of nodes, see “Modifying lines and curves” on page 363.

To join two contours
Edit tab
1 On the Tools toolbar, select the Pen tool.
2 On the Tool Options palette, click the Edit Mode button.
3 Select one of the contours you want to join.
   All of the nodes in the object are displayed.
4 Select the start or end node of the first contour you want to join.
   Note: You can only join contours in the same object.
5 Hold down Shift, and select the start or end node of the second contour.
6 Right-click, and choose Edit  Join.

You can also join contours manually. Drag a node on the first contour over the second contour’s start or end node. When the cursor displays “JOIN,” release the mouse button.

To break a contour at a node
Edit tab
1 On the Tools toolbar, select the Pen tool.
2 On the Tool Options palette, click the Edit Mode button.
3 Select the node where you want to break the contour.
4 Right-click the node, and choose Edit  Break.
The path or contour breaks and a new node is added on top of the current node. The node square changes to a node-on-node indicator.

**To move a path**  
*Edit tab*  
1. On the Tools toolbar, select the **Pen** tool.  
2. On the Tool Options palette, click the **Edit Mode** button.  
3. Drag any contour in the path.

**To move a contour**  
*Edit tab*  
1. On the Tools toolbar, select the **Pen** tool.  
2. On the Tool Options palette, click the **Edit Mode** button.  
3. Hold down **Shift**, and move the cursor over the contour until the cursor displays "SUB."  
4. Drag the contour.

You can also move a contour by double-clicking a node to select all nodes, and then dragging one of the nodes.

**To reverse a path or contour**  
*Edit tab*  
1. On the Tools toolbar, select the **Pen** tool.  
2. On the Tool Options palette, click the **Edit Mode** button.  
3. Click on a contour or path.  
4. Select a node.  
   If you want to reverse multiple contours, select one node from each contour.  
5. Right-click the path or contour, choose **Edit**, and then choose one of the following:  
   - **Reverse Path**  
   - **Reverse Contour**

**To duplicate a contour**  
*Edit tab*  
1. On the Tools toolbar, select the **Pen** tool.  
2. On the Tool Options palette, click the **Edit Mode** button.  
3. Select one or more nodes.  
4. Choose **Objects** ➤ **Edit**, and select one of the following options:  
   - **Duplicate** — copies the selected contour and pastes it directly on top of the original contour  
   - **Duplicate & Offset** — copies the selected contour and pastes it at an offset from the original contour. The default offset is 10 pixels in the X and Y directions.
You can adjust the offset from the original contour by adjusting the settings in the *Duplication X* and *Duplication Y* controls on the Tool Options palette.

**To delete a contour**

**Edit tab**

1. On the Tools toolbar, select the *Pen* tool.
2. In the Tool Options palette, click the *Edit Mode* button.
3. Click on a contour.
4. Double-click one node to select all nodes.
5. Press *Delete*.

You cannot delete a path. A path is deleted with its object or when all of its contours are deleted.

**Drawing lines**

You can draw straight lines, freeform lines, and line segments. You can edit the nodes in a line to create curves.

You can also adjust the line options of existing vector objects.

**To draw a line segment**

**Edit tab**

1. On the Tools toolbar, choose the *Pen* tool.

   **Note:** If you want to place the line segment on the current vector layer, mark the *Create on Vector* check box on the Tool Options palette. If no vector layer exists, marking this check box creates one for the line segment. If this check box is unmarked, the line segment is placed on a raster layer. Placing a line segment on a vector layer makes it easier to edit.

2. On the Materials palette, click the *Foreground and Stroke properties* box, and choose a color for the outline.

3. If you are drawing connected line segments and you want to apply a fill, click the *Background and Fill properties* box, and choose a color for the text fill. If you do not want the line segments to have a fill, click the *Transparent* button.

   **Note:** If you are drawing a single, unconnected line segment, it is not necessary to choose settings from the *Background and Fill properties* box.

4. On the Tool Options palette, click the *Draw Lines and Polylines* button.

5. Choose a line style from the *Line Style* drop-list.

6. Type or set a line width (in pixels) value in the *Width* control.

7. Drag in the image window to create the line.

8. On the Tool Options palette, click the *Apply* button.

You can also:

- View the object’s nodes while drawing: Mark the *Show Nodes* check box.
- Smooth the appearance of the line: Mark the *Anti-alias* check box.
- Choose a join setting: Select an option from the *Join* drop-list. If you select *Miter Join*, you can type or set a value in the *Miter limit* control to set the
You can also

Create a vertical, horizontal, or 45-degree line

Hold down Shift while dragging.

Connect each line segment

Mark the Connect Segments check box.

You can save your settings in the Tool Options palette settings for subsequent use. For more information about saving settings as presets, see "Using and creating presets" on page 437.

To draw a curved or straight line

1 On the Tools toolbar, choose the Pen tool.
2 On the Tool Options palette, click the Draw Point to Point button.
3 Drag in the image window to create the line.
4 Do one of the following:
   • To create a straight line, click where you want the next node.
   • To create a curved line, click and drag. When the curve is the right shape, release the mouse button.
   If you want to draw lines at fixed angles (45 degree increments), hold down Shift as you drag.

To draw a free-form line

1 On the Tools toolbar, choose the Pen tool.
2 On the Tool Options palette, click the Draw Freehand button.
3 Drag in the image window to create the line.

To draw line segments

1 On the Tools toolbar, choose the Pen tool.
2 On the Tool Options palette, click the Draw Line and Polylines button.
3 Drag in the image window to create the line.

Saving custom line styles

You can design your own line styles and save them as presets.

To design and save a custom line style

1 On the Tools toolbar, choose one of the following tools:
   • Pen tool
   • Rectangle tool
   • Ellipse tool
• Symmetric Shape tool
• Preset Shape tool
• Text tool

2 On the Tool Options palette, click the **Line Style** drop-list, and click **Custom**.
   If you want to copy an existing line style, choose that style from the **Line Style** drop-list, and click **Custom**.

3 In the Styled Line Editor dialog box, choose settings from any of the following controls:
   • **First cap** — lets you pick a style for the first segment in the line
   • **Last cap** — lets you pick a style for the last segment in the line
   If you want to specify a size for the cap, click the **Size** button, and type or set a value in the **Width** and **Height** controls. To make the height and width equal, mark the **Link axes** check box.

4 Do one of the following:
   • If you are creating a new line, click **Save as New**. Type a name in the **Styled Line Name** field, and click **OK**.
   • If you are editing an existing line, click **Save**.

You can also

Undo the changes
   Click the **Undo** button.

Reset the line to the original style
   Click the **Reset** button.

Create separate end caps for the middle dashes in the line
   Mark the **Different segment caps** check box, and choose settings from the **Segment Start** and **Segment End** group boxes.

Add dashes or gaps
   Type or set a value in the **Length** control, and click **Add**.

Delete dashes or gaps
   Select a dash or gap, and click **Delete**.

Remove all dashes and gaps
   Click **Clear**.

The preview area at the bottom of the Styled Lines Editor dialog box displays the changes you make to the line. The edit area has a ruler you can use to size dashes and gaps (in pixels).

Saved styles appear in the **Line Style** drop-list on the Tool Options palette.

**Drawing curves**

You can draw Bézier and freehand curves.

To draw an object with Bézier curves

1 On the Tools toolbar, choose the **Pen** tool.
   **Note:** If you want to place the line segment on the current vector layer, mark the **Create on Vector** check box on the Tool Options palette. If no vector layer exists, marking this check box creates one for the line segment. If this check box is unmarked, the line segment is placed on a raster layer. Placing a line segment on a vector layer makes it easier to edit.

2 On the Materials palette, click the **Foreground and Stroke properties** box, and choose a color for the outline.
If you want to apply a fill to the curve, click the **Background and Fill properties** box, and choose a color. If you do not want to apply a fill to the curve, click the **Transparent** button.

3 In the Tool Options palette, click the **Draw Point to Point** button.

4 Mark the **Show Nodes** check box.

5 Click where you want to place the first node, and drag.
   As you drag, the arrow-end of the control arm handle points in the same direction. Release the mouse button when the first control arm reaches the desired length.

6 Click where you want to place the second node, and drag.
   As you drag, the curve segment appears on the image canvas.
   **Note:** If you marked the **Connect Segments** option, you can continue adding segments in this manner.

7 On the Tool Options palette, click one of the following buttons to complete the Bézier curve object:
   • **Start New Contour** button — creates an open shape where the first and last segments are not connected
   • **Close Selected Open Contours** button — creates a closed shape where the first and last segments are connected

8 Click the **Apply** button.

You can also

- Automatically connect each curve segment
- Choose a line style
- Set a line width
- Smooth the line’s edges

You can save Tool Options palette settings as presets. For more information, see "Using and creating presets" on page 437.

**To draw a freehand curve**

**Edit tab**

1 On the Tools toolbar, choose the **Pen** tool.
   **Note:** If you want to place the line segment on the current vector layer, mark the **Create on Vector** check box on the Tool Options palette. If no vector layer exists, marking this check box creates one for the line segment. If this check box is unmarked, the line segment is placed on a raster layer. Placing a line segment on a vector layer makes it easier to edit.

2 On the Materials palette, click the **Foreground and Stroke properties** box, and choose a color for the outline.
   If you want to apply a fill to the curve, click the **Background and Fill properties** box, and choose a color. If you do not want the curve to have a fill, click the **Transparent** button.

3 On the Tool Options palette, click the **Draw Freehand** button.
   If you want to display the curve’s nodes, mark the **Show Nodes** check box.

4 Type or set a value in the **Tracking** control to set the distance in pixels between nodes.
   Higher values create smoother, less precise lines with fewer nodes; lower values create more segmented, precise lines with more nodes.

5 Drag to create the curve.

6 Click the **Apply** button.
You can also

Connect multiple curve objects
Mark the Connect Segments check box.

Smooth the curve’s edges
Mark the Anti-alias check box.

Choose a join setting
Select an option from the Join drop-list. If you selected Miter Join, you can type or set a value in the Miter limit control to set the degree of pointedness.

Choose a line style
Choose an option from the Line style drop-list.

Set a line width
Type or set a value in the Width control.

Modifying lines and curves
You can edit the properties of lines and curves. You can reshape a curve by changing its nodes the shape of the contour at a node by changing the node type, by modifying its line segments on either side of a node, or by connecting line segments. You can also cut a line segment. When you cut a closed path or contour, you open it. When you cut an open path or contour, you create two separate contours.

To edit a line or curve
Edit tab
1 On the Tools toolbar, choose the Pen tool.
2 On the Tool Options palette, click the Edit Mode button.
3 Select the shape.
4 Modify any of the settings on the Tool Options palette.

You can also edit the curve by clicking the Pick tool, selecting the curve, and modifying any of the settings on the Tool Options palette.

To adjust a line segment by changing the nodes
Edit tab
1 On the Tools toolbar, choose the Pen tool.
2 On the Tool Options palette, click the Edit Mode button.
3 Right-click a node, choose Node Type, and select one of the following options:
   • Convert to Line — straightens the segment before and after the node
   • Line Before — straightens the segment before the node
   • Line After — straightens the segment after the node
   • Curve Before — curves the segment before the node
   • Curve After — curves the segment after the node

To connect multiple line segments
Edit tab
1 Create as many connected line segments as you want.
2 On the Tool Options palette, click one of the following buttons:
• Start New Contour — connects line segments in an open shape
• Close Selected Open Contours — connects line segments in a closed shape
3 Click the Apply button.

You can save a set of Tool Options palette settings as presets. For more information, see “Using and creating presets” on page 437.

To cut a line segment
Edit tab
1 From the Tools toolbar, choose the Pen tool.
2 On the Tool Options palette, click the Knife Mode button.
3 Drag across the contour where you want to cut it.

When you click the Knife Mode button, you can cut through all selected contours in an object.

Copying and moving vector objects
You can copy and move vector objects by using Cut, Copy, and Paste commands. For more information about moving objects precisely, see “To move a vector object” on page 353.

To copy or move a vector object
Edit tab
1 On the Tools toolbar, select the Pen tool.
2 On the Tool Options palette, click the Edit Mode button.
3 Click on a contour, and then double-click one node to select all nodes.
4 Choose Objects » Edit and select one of the following commands:
   • Copy — copies the selected contour to the Windows clipboard
   • Cut — removes the selected contour to the Windows clipboard. If the object has only one contour, the command removes the entire object.
5 Click where you want to copy or move the contour.
6 Choose Edit and choose one of the following options:
   • Paste As New Vector Selection — pastes vector objects within the same layer
   • Paste As New Layer — pastes vector objects as a new layer
   • Paste As New Image — pastes vector objects as a new image
Working with brushes

Brush tools offer countless ways to work creatively with your images. For example, you can apply soft- or hard-edged brushstrokes of any color or material, paint with another image as a source, retouch images to correct colors or contrast, replace colors, or paint with picture tubes. You can also erase pixels by making them transparent.

Brush tools work only on raster layers, and they produce the best results when applied to grayscale or 16 million–color images. They are less effective when applied to images of other color depths.

You can also work with painting tools within a selection so that only the selected pixels are affected. For more information about making selections, see “Working with selections” on page 197.

This section presents the following topics:
• “Choosing brushes” (page 365)
• “Choosing brush options” (page 366)
• “Using brushes” (page 366)
• “Customizing brush settings” (page 367)
• “Creating brush tips and presets” (page 368)
• “Importing and sharing brush tips” (page 370)

Choosing brushes

You can choose from the following brush tools:
• **Paint Brush** — creates strokes of color that simulate strokes from an artist’s paintbrush. Brushstrokes can have hard or soft edges. The Paint Brush is a multipurpose tool that can be used to edit an image by applying color to areas as small as a single pixel. This tool can be used to adjust transparency in specific areas or to create a selection. For more information, see “To create a selection by using a Painting tool” on page 202.
• **Airbrush** — simulates an airbrush or spray can. The longer you apply the brush to an area, the more pronounced the effect becomes.
• **Warp Brush** — produces a warping effect on image pixels. You can twirl areas of the image, contract or expand parts of the image, and create other interesting effects. For more information, see “Warping images” on page 323.
• **Picture Tube** — lets you paint with a collection of preset objects. For example, you can add butterflies and beetles to a picnic setting, fill an aquarium with fish, or frame a picture with holly. You can use the picture tubes included with PaintShop Pro or create your own. For more information, see “Using the Picture Tube tool” on page 320.
• **Eraser** — causes pixels to become transparent. For more information, see “Erasing image areas” on page 167.
• **Background Eraser** — erases pixels selectively. For more information, see “Erasing image areas” on page 167.
• **Clone Brush** — lets you edit your image by using parts of the image, or parts of another image, as a paint source. For more information, see “Removing flaws and objects with the Clone Brush or Object Remover” on page 161.
• **Color Replacer** — replaces a color in a selection or layer with another color. For more information, see “Replacing colors, gradients, or patterns” on page 178.
• **Retouch Brushes** — let you retouch images. Some retouch brushes mimic photographic effects. Others change pixels based on
lightness, saturation, hue, or color values. Some retouch brushes are similar to color correction commands in the effects they produce.

### Choosing brush options

The brush options help you create hundreds of different brushstrokes. You can experiment with the options until you achieve the effect you
want.

You can further customize the basic brush settings by specifying additional options on the Brush Variance palette. For more information
about using the Brush Variance palette, see “Customizing brush settings” on page 367.

The following options are available on the Tool Options palette for painting tools:

- **Shape** — specifies the shape of the brush tip. You can create a rectangular, elliptical, or angled brush tip by starting with the round or
  square shape and modifying it with the Thickness and Rotation options.
- **Last Used** — when you switch from one brush tip to another, **Last Used** lets you retain the last settings you used with a brush rather
  than apply the settings that are saved with the brush tip (such as **Size** and **Step** settings).
- **Size** — determines the size of the brush in pixels. You can adjust the **Size** value by using the keyboard as well as by setting the Size
  control in the Tool Options palette. For more information, see “To adjust the brush size by using the keyboard” on page 375.
- **Hardness** — determines the sharpness of the brush edges. A setting of 100 produces the sharpest edge; lower values produce an
  increasingly softer, fading edge.
- **Step** — determines the time interval that elapses between applications of paint, with each application defined as a single, continuous
  brushstroke. Lower values produce a smoother, more continuous appearance; higher values create a choppier appearance.
- **Density** — determines the evenness of coverage produced by the brushstroke (or for the Eraser tool, the evenness of the erasure). Higher
  values produce more even coverage; lower values produce spottier coverage, which resembles a spray-painted effect. When using the
  Airbrush tool, you should set Density to values lower than 100.
- **Thickness** — determines the width of the brushstroke. A setting of 100 produces a brush tip that is completely round or completely
  square, depending on the Shape setting. As the Thickness setting decreases, the brush becomes increasingly narrow.
- **Rotation** — applies rotation to a noncircular brush tip.
- **Opacity** — determines how well the paint covers the image surface. At 100% opacity, the painted brushstroke completely covers the
  surface beneath it. At 1% opacity, the paint stroke is almost completely transparent. For the Eraser tool, this setting determines the level
  of erasing, so that a setting of 100% produces the most transparent result.
- **Blend mode** — determines how painted pixels are blended with pixels on underlying layers. The blend modes are the same as layer
  blend modes. With the Paint Behind blend mode, for example, painting is done behind the image on the active layer. No paint is visible
  when the topmost layer and the active layer are both fully opaque. For more information about blend modes, see “Blending layers” on
  page 233.
- **Rate** — determines the rate at which the Airbrush tool applies paint (from 0 to 50). A value of 0 applies a consistent amount of paint
  even when the speed of the brushstroke varies. Higher values apply more paint when the brush slows down or pauses.
- **Stroke** — lets you build up paint on existing paint strokes that were applied with the Continuous check box marked. If the Continuous
  check box is not marked, or if the check box is marked but no strokes have been made, the Stroke button is grayed (unavailable).
- **Continuous** — specifies whether paint builds up when multiple brushstrokes are applied over the same area with opacity set at less than
  100%. If this check box is marked, painting produces a continuous color, and repainting an area has no effect. To repaint an area, you
  must click the Stroke button. If the Continuous check box is unmarked (the default), each brushstroke over the same area applies more
  paint; the color darkens until it reaches 100% opacity.
- **Wet Look Paint** — mimics wet paint, with soft color inside and a darker ring near the edge. The effect is more visible with lower values
  for the Hardness setting.
- **Smart Edge** — uses content-aware technology to sample the brush stroke area and apply a brush stroke only to areas that match the
  underlying pixels. This makes it easier to apply brush strokes to or around specific elements in your image. For example, you can use
  Smart Edge with retouch brushes, such as the Dodge, Burn, or Sharpen, to help you edit specific areas of the face, lips, or eyes. Note:
  Enabling Smart Edge can affect the brush speed.

### Using brushes

When you choose a brush, you can modify its settings to achieve the effect you want. You can also reset the brush to its default settings.

When applying paint, you can undo and redo multiple brushstrokes.
To use a brush

1. On the Tools toolbar, choose a brush tool.
2. On the Materials palette, choose the foreground and background colors and materials.
3. On the Tool Options palette, choose a tool from the Presets drop-list.
4. Choose a preset brush tip from the brush tip drop-list.
5. Specify the brush options, such as shape, size, opacity, hardness, thickness, and rotation.
6. Do one of the following:
   • To apply the foreground color or material, drag in the image.
   • To apply the background color or material, hold down the right mouse button, and drag in the image.

With the Airbrush tool, you can build up color in one area by clicking and holding the mouse at one position.

To paint a straight line, click once at the beginning point, press Shift, and then click the end point. To continue the straight line, move to the next point, press Shift, and then click again.

To reset a brush to its default settings

1. On the Tool Options palette, click the Presets drop-list.
2. Click the Reset to Default button.

To undo the most recent brushstroke

1. Click the Undo button on the Standard toolbar.

You can also press Ctrl + Z or use the History palette to undo the stroke.

To undo multiple brushstrokes

1. Click the Undo button on the Standard toolbar multiple times.

You can also press Ctrl + Z multiple times or use the History palette to undo multiple strokes.

You can redo strokes by clicking the Redo button on the Standard toolbar, by pressing Ctrl + Alt + Z, or by using the History palette.

Customizing brush settings

The Brush Variance palette lets you customize the settings in the Tool Options palette for particular brush options. You can also make random adjustments by increasing the Jitter percentage.

You may find the most benefit to using Brush Variance palette settings if you use a pen tablet or a 4D mouse.
To customize brush settings

1. Choose View ▶ Palettes ▶ Brush Variance.
2. On the Tools toolbar, choose a brush tool.
3. On the Tool Options palette, set the brush options.
4. On the Brush Variance palette, set the brush variance for each option (Color Blend, Hue, Saturation, Lightness, Size, Opacity, Thickness, Rotation, Density):
   - Normal — applies no variance
   - Pressure — applies variance to the selected brush attribute according to the pressure from a tablet stylus
   - Tilt Angle — applies variance based on the angle between the tablet stylus and the tablet
   - Tilt Direction — applies variance based on the rotation angle of the brush tip
   - Orientation — applies variance based on the rotation angle around the stylus (for 4D mouse only)
   - Fingerwheel — lets you control the variance in the brush attribute by using the wheel on an airbrush stylus
   - Z-Wheel — lets you control the brush attribute by using a 4D mouse wheel that is set to behave according to the current application
   - Direction — controls brush variation based on the angle between consecutive mouse points on a path
   - Fade In — fades the brush impression from small to large
   - Repeating Fade In — repeatedly fades the brush impression from small to large
   - Fade Out — fades the brush impression from large to small
   - Oscillating Fade — repeatedly fades the brush impression in and out by oscillating between small and large

   **Note:** Options marked with an asterisk (*) in the Brush Variance palette are available only to users with pressure-sensitive tablets. The options available depend on the type of tablet being used.

5. Type or set a value in the Fade rate (pixels) control to select a threshold for the number of pixels over which the fading in and fading out occurs.
   - Lower values produce faster fading; higher values produce slower fading.

6. Type or set a value in the Position Jitter (%) control to select a percentage for randomly adjusting the brush impression location, relative to the document size.
   - Mark the Scale check box if you want the jitter to scale proportionally when you change the brush size.

7. Type or set a value in the Impressions per step control to indicate how many brush impressions per step are made of the brushstroke

   
   To reset brush variance options to their default values, click the Reset Brush Variance palette button.

   If you have a variance loaded with a brush and then load another brush without loading its variance, the new brush can take on the variance settings from the previous brush. Click the Reset Brush Variance palette button to clear any leftover variance settings.

   You can save your modified brush as a brush tip or as a preset. For more information about saving brushes and presets, see “Creating brush tips and presets” on page 368.

Creating brush tips and presets

By modifying the brush options, you can create your own brush tips to use with the painting tools. When you create a brush tip, all options selected for the brush are saved, including the brush shape, step, density, thickness, size, hardness, and rotation settings. You can also include the variance settings in creating a brush tip. The settings that you save can be applied to any tool that has a brush tip control in the Tool Options palette.

You can also make a selection, and then use the selection to create a custom brush with a width and height of up to 999 x 999 pixels.

In addition to brush tips, you can create brush presets. When you create a preset, all settings specified for a particular tool are saved, including all of the parameters and variance settings. The tool preset is available only when you select that particular tool.
To create a brush tip

1. On the Tools toolbar, choose a painting tool.
2. On the Tool Options palette, modify the settings for the brush.
3. Click the brush tip drop-list to display current brush tips.

4. Click the Create Brush Tip button in the brush tip drop-list.

5. Complete the fields in the Create Brush Tip dialog box.
6. Click OK.

The new brush appears in the brush tip drop-list. You can use the new brush with any of the painting tools that display this drop-list.

You can also open the Create Brush Tip dialog box by choosing File ➤ Export ➤ Custom Brush.

To save the new brush in a folder other than the default Brushes folder, click Edit Paths in the Create Brush Tip dialog box. For more information on changing file locations, see “Setting file locations” on page 413.

To create a brush tip from a selection

1. Make a selection of the area you want to convert into a custom brush.
2. On the Tools toolbar, choose a painting tool.
3. On the Tool Options palette, click the brush tip drop-list to display current brush tips.

4. Click the Create Brush Tip from Selection button.

A preview of the new brush appears in the Create Brush Tip dialog box.

5. Enter a name for the brush in the Name box.
6. Select a step value.
7. Click OK.

The new brush appears in the brush tip drop-list. You can use the new brush with any of the painting tools that appear in the drop-list.

To save the new brush in a folder other than the default Brushes folder, click Edit Paths in the Create Brush Tip dialog box. For more information on changing file locations, see “Setting file locations” on page 413.

To create a brush preset

1. Choose a painting tool and modify any of the tool options.
2. On the Tool Options palette, click the Presets drop-list.
3. Click the Save preset button.

The Save Preset dialog box appears.

4. Type a name for the brush preset.
   Note: You cannot use the names “Default” or “Last Used.”
5. To enter additional preset information, click Options, and then enter information in the Author, Copyright, and Description fields.
6. Click OK.
You can exclude any of the current brush settings from the preset by clicking the Save icon associated with those settings in the Preset Includes list. A white “X” appears over the icon, indicating that this brush setting will not be saved with the preset.

**Importing and sharing brush tips**

You can import custom brushes or create your own. For information about creating custom brushes, see “Creating brush tips and presets” on page 368.

After you create a custom brush tip, you can share it with others by sending them the brush file. If the brush uses a custom shape, you must share both the brush file and the custom shape file for that brush.

### To import a custom brush

**Edit tab**

1. Choose File ➔ Import ➔ Custom Brush.
   The Import Custom Brush dialog box appears.
2. Click Open.
3. In the Open dialog box, navigate to the brush file that you want to import, and click Open.
4. In the Import Custom Brush dialog box, select the custom brushes that you want to import, and click Add.
   If you want to import multiple brushes, click Add All.
5. Click OK to import the custom brushes.

### To share brush tips

**Edit tab**

1. Navigate to ...Documents\Corel PaintShop Pro\2023\Brushes.
   Navigate to the folder in which you saved your custom brushes if it is different from the default Brushes folder.
2. Share the brush files (those with .PspBrush or .PspScript extensions) — for example, by attaching them to an e-mail message.
   The recipient should save the brush files to ...Documents\Corel PaintShop Pro\2023\Brushes, or to the folder that contains custom brushes.

If you are sharing brushes created from selections, you must share both the PspBrush file and the associated PspScript file.
Painting and drawing with the Art Media tools

The Art Media tools let you create digital artwork that closely mimics real-world media, pigments, paints, and artists' tools.

This section presents the following topics:
• “Working with Art Media layers” (page 371)
• “Working with the Mixer palette” (page 372)
• “Working with Art Media tools” (page 374)
• “Using the Oil Brush tool” (page 376)
• “Using the Chalk tool” (page 376)
• “Using the Pastel tool” (page 377)
• “Using the Crayon tool” (page 377)
• “Using the Colored Pencil tool” (page 378)
• “Using the Marker tool” (page 378)
• “Using the Watercolor Brush tool” (page 379)
• “Using the Palette Knife tool” (page 379)
• “Using the Smear tool” (page 380)
• “Using the Art Eraser tool” (page 380)

Working with Art Media layers

Art Media layers are automatically created when you use the Art Media tools. You can also convert Art Media layers to raster layers.

You can choose to create a new image with an Art Media layer. You can also choose a canvas texture on which to apply the Art Media pigment, and you can apply a fill color or a canvas color to the texture. To add to the effect, you can dry or wet an Art Media layer at any time.

To create an Art Media layer

Edit tab

Choose Layers ▶ New Art Media Layer.

A new Art Media layer 🎨 appears in the Layers palette.

You can also create a new Art Media layer by clicking the New Layer drop-list 🔄 on the toolbar of the Layers palette, and choosing New Art Media Layer.
To dry or wet an Art Media layer  
Edit tab  
• Choose Layers, and click one of the following options:  
  • Dry Art Media layer  
  • Wet Art Media layer  

The Dry Art Media layer command and the Wet Art Media layer command can be selectively undone in the History palette.

To modify Art Media layer properties  
Edit tab  
1 On the Layers palette, double-click the Art Media layer to display the Layer Properties dialog box.  
2 Click the Canvas Texture tab.  
3 Modify any of the layer’s properties.

Working with the Mixer palette  
You can use the Mixer palette to blend colors and create paint swatches similar to those you would create by using a traditional artist’s palette. Once you have created a color, you can use the Art Media brushes to apply it to the canvas.

If you blend colors too much, you can undo the 20 most recent Mixer Tube tool or Mixer Knife tool actions. You can also redo color mixing actions.

**Important!** The history of the actions in the Mixer palette is lost when you close the program; however, you can close the Mixer palette at any time while the program is open and not lose your changes.

By default, the Mixer pages you create are 500 × 500 pixels. However, you can also create larger, custom mixer pages. You can also save the Mixer area as a Mixer page, which you can reload and use in another PaintShop Pro session.

To mix colors  
Edit tab  
1 On the Materials palette, set the Foreground and Stroke Property box to Color, and choose a color from the Frame, Rainbow, or Swatch tab.  
   **Note:** When any Art Media tool is active, the mode buttons below the Foreground and Stroke Property and Background and Fill Property boxes are inactive.  
2 On the Mixer palette, select the Mixer Tube tool .  
3 In the Mixer area, drag to apply paint strokes.  
   If you want to change the width of the stroke, change the setting in the Size box.  
   **Note:** You can choose another color by repeating step 1.  
4 Choose the Mixer Knife tool , and drag in the Mixer area to smear colors together.

You can toggle between the Mixer Knife tool and the Mixer Tube tool by using the right-mouse button. For example, you can apply paint by holding down the left mouse button and dragging; and you can mix the paint by holding down the right mouse button and dragging.

To undo and redo color mixing  
Edit tab  
• On the Mixer palette, click one of the following buttons:  
  • Unmix — lets you undo a Mixer Tube tool or Mixer Knife tool action
To use Mixer palette colors

Edit tab

1. On the Mixer palette, choose the Mixer Dropper tool, and click a color in the Mixer area.

   Note: Dragging around the Mixer area on the Materials palette updates the Foreground and Stroke property box with the current sampling position.

2. On the Tools toolbar, choose an Art Media tool.


   Note: The strokes will be applied on an Art Media layer. If this layer type is not the active layer, one is created automatically once you begin using the Art Media tool.

4. To choose another color, use the Mixer Dropper tool to choose the desired color from the Mixer area.

You can also

Pan to other areas of the Mixer page Hold down the Navigate button to display the entire Mixer page. Drag to enclose the desired area of the page.

Clear the Mixer page On the Mixer palette, choose Clean Page.

The size of the Dropper tool is determined by the Size setting on the Tool Options palette.

You can dry the Art Media layer, or make it wet again by choosing Layers ▶ Dry Art Media layer or Layers ▶ Wet Art Media layer.

For more information on each Art Media tool, see “Working with Art Media tools” on page 374.

To create a custom Mixer page

Edit tab

1. Choose File ▶ New to display the New Image dialog box.

2. In the Image Dimensions group box, type values to set the dimensions for the Mixer page.

   Note: The width and height must be at least 500 pixels.

3. In the Image Characteristics group box, click the Art Media Background option.

4. Click the texture swatch in the Select canvas texture area, and choose a texture from the menu.

   Note: The texture acts like an invisible surface on which Art Media pigments are applied.

5. Click OK.

   Note: At this point you can apply Art Media pigment to the image.

6. On the Standard toolbar, click the Save button to display the Save As dialog box.

7. Navigate to X: Program Files\Corel\Corel PaintShop Pro 2023 (64-bit)\Corel_19, where “X” indicates the drive on which PaintShop Pro is installed.

8. Save the new image in the .pspimage file format.

You can also

Save the Mixer area as a page On the Mixer palette, choose Save Page or Save Page As, and type
You can also

a name for the page.

You can also access Mixer pages from your user folder, ...Documents\Corel PaintShop Pro\2023\Mixer Pages.

You can fill the Mixer page with a color by marking the **Enable fill color** check box in the New Image dialog box, clicking the **Color** box, and choosing a fill color. Be aware, however, that you cannot sample this color, nor will the Art Media tools affect the color.

**To load Mixer area pages**

*Edit tab*

1. Click the **Load Mixer Page** button.
2. Click the Mixer page you want, or navigate to the folder where the Mixer page is stored.

   **Note:** By default, Mixer pages are saved in ...Documents\Corel PaintShop Pro\2023\Mixer Pages.

You can also load a mixer page by clicking the **Mixer Menu** icon and choosing **Load Page**.

**Working with Art Media tools**

You can use the Art Media tools when working on Art Media layers. The Art Media tools let you simulate the rich, expressive results you get when working on physical pigment media such as paint, chalk, pastel, and pencil.

**Important!** Although the Art Media tools support Presets, they do not support custom brush tips like the Paint Brush tool and other raster painting tools.

**The wet pigment media tools**

The Oil Brush, Watercolor Brush, and Marker tools simulate the effect of painting with real wet pigment and tools. The Oil Brush even creates the effect of running out of paint at the end of a stroke. To get more paint, simply release the mouse button, and then drag more paint strokes.

The Oil Brush tool and the Palette Knife tool let you produce strokes with multiple colors on the brush head. This simulates the effect you can achieve by using a real painting palette and multiple wet pigments. Additionally, you can dry the wet strokes you have applied. For more information, see “To dry or wet an Art Media layer” on page 372.

**The dry pigment media tools**

The Chalk, Pastel, Crayon, and Colored Pencil tools let you create effects that simulate artwork that you create with dry pigment media. Unlike the Oil Brush tool, the dry tools don’t run out of pigment media. Furthermore, the pigment applied with these tools has less volume than that which is applied by using the Oil Brush tool.

**The Palette Knife, Smear, and Art Eraser tools**

You can use the Palette Knife to apply and smear art media pigments. You can also use the Smear tool blend pigments as though you are using a finger or a cloth.

You can use the Art Eraser tool to erase pigment. However, if you are using the Art Eraser tool to erase pigment created with multiple paint strokes (such as those applied by the Oil Brush tool), it may take multiple strokes to clean the area. If you are using the tool to erase pigment created with the Chalk tool or the Colored Pencil tool, you’ll achieve results with fewer strokes.
Creating artistic rendering of photos

You can give a photograph image the look of a painting or drawing. By dragging the Artistic Media tool over a color, you select the pigment or paint color by sampling the data below the center of the brush regardless of the layer type. When you hold down the mouse button to begin the stroke, note that a single sample is performed, and the resulting color is used for the duration of the stroke.

To use an Art Media tool

1. On the Tools palette, choose one of the following tools:
   - Oil Brush
   - Chalk
   - Pastel
   - Crayon
   - Colored Pencil
   - Marker
   - Watercolor Brush
   - Palette Knife
   - Smear
   - Art Eraser

2. On the Tool Options palette, click the Presets button and choose a preset brush.
   If you want to adjust the preset brush, change any of the settings on the Tool Options palette.

To adjust the brush size by using the keyboard

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Increase or decrease brush size interactively</td>
<td>Hold down Alt, and drag.</td>
</tr>
<tr>
<td>Increase brush size by 1 pixel</td>
<td>Hold down Alt, and press C.</td>
</tr>
<tr>
<td>Increase brush size by 20 pixels</td>
<td>Hold down Shift + Alt, and press C.</td>
</tr>
<tr>
<td>Decrease brush size by 1 pixel</td>
<td>Hold down Alt, and press X.</td>
</tr>
<tr>
<td>Decrease brush size by 20 pixels</td>
<td>Hold down Shift + Alt, and press X.</td>
</tr>
</tbody>
</table>

To create an artistic rendering of a photo

1. With the image open, choose an Art Media tool that applies paint or pigment.
2. Mark the Trace check box on the Tool Options palette.
3. Place the cursor over the image where you want to sample an underlying color and drag to apply a stroke using the sampled color. The resulting color is used for the duration of the stroke.

You can experiment with your results by adjusting the brush size and zoom level.

You can achieve accurate results by creating a color-based selection by using the Magic Wand tool, and applying the pigment or paint to the color sampled area.
Using the Oil Brush tool

You can use the Oil Brush tool to simulate a dense medium that blends color by mixing with a thick medium, rather than through an overlay function. You can load the Oil Brush tool with multiple colors. You can smear and blend colors by mixing them with oil that is already on the canvas.

There are a number of options for managing the reloading of the Oil Brush tool head between strokes. You can
• reload the brush with a solid color
• reload the brush by sampling from the Mixer page
• reload the brush with its current contents and optional amounts of color from the Mixer page
• leave the brush unloaded, and dip into the palettes or canvas after each stroke

Paint strokes applied by the Oil Brush tool are wet in terms of how strokes interact with other strokes by smearing or mixing together. For more information see “To dry or wet an Art Media layer” on page 372.

Oil Brush tool options

Edit tab

Oil Brush tool options include
• **Shape** — defines the shape of the brush tip
• **Size** — defines the size of the tool head in pixels
• **Thickness** — defines the aspect ratio of the tool head. This setting is active only when the Fixed angle Head Tracking option is chosen.
• **Rotation** — defines the angle of head rotation in degrees
• **Head Tracking** — determines whether the tool head bends around the path of the user’s stroke, or remains at a fixed angle
• **Head Loading** — defines the percentage of material on the brush at the start of the stroke
• **Viscosity** — defines the rate at which the material on the brush is applied, and thus the length of the stroke before your paint runs out
• **Firmness** — defines the amount of splay in the brush, how the rendered line gets wider with more pressure, and how well it penetrates the surface on to which it is painting
• **Bristle size** — affects the underlying noise function for texture and application of paint
• **Auto Clean** check box — cleans the brush and reloads it with fresh paint at the start of a new stroke
  
  **Note:** When unmarked, the brush head is not cleaned at the start of the stroke. Instead, the dirty head has a small amount of the current color added to whatever dirty head state exists from the previous stroke.
• **Clean** button — cleans the head and start the next stroke with fresh paint or pigment
• **Trace** check box — allows the current Art Media tool to select the pigment or paint color by sampling the data below the center of the brush regardless of the layer type.

**Important!** When you hold down the mouse button to begin the stroke, note that a single sample is performed and the resulting color is used for the duration of the stroke.

Using the Chalk tool

The Chalk tool lets you create consistent, dry media over the course of a stroke. The pigment penetrates the canvas texture according to the pressure setting you choose. The Chalk tool does not have a bristle component to the stroke; instead, it is applied with a flat or angled edge that is affected by the texture of the canvas.

Chalk tool options

Edit tab

Chalk tool options include
• **Shape** — defines the shape of the chalk tip
• **Size** — defines the size of the tool head in pixels
• **Thickness** — defines the aspect ratio of the tool head
• **Rotation** — defines the angle of head rotation in degrees
• **Head Tracking** — defines whether the tool head bends around the path of the stroke, or whether it remains at a fixed angle
• **Trace** check box — allows the Chalk tool to select the pigment color by sampling the data below the center of the tool regardless of the layer type. (This feature works much the same way as the Clone Brush’s Sample Merged tool option).

**Important!** When you hold down the mouse button to begin the stroke, note that a single sample is performed and the resulting color is used for the duration of the stroke.

### Using the Pastel tool

Pastel is a dry media, softer than chalk, but like chalk it has infinite brush loading. Applied with the Pastel tool, its dry pigment tends to penetrate the canvas texture proportional to the pressure with which you apply it. Pastel pigments have a fixed viscosity that is slightly less than chalk, meaning the strokes you apply leave some volume on the canvas as they break from the pigment stick. Pastels do not have a bristle component to the stroke, instead presenting a flat or angled surface of the stick. The stroke edges fall off and break up based on the texture of the canvas.

Pastel is slightly shiny, interacts with itself by smearing slightly, and dirtying the tool head slightly when applied with light pressure. It loads the canvas more than chalk, breaking up more when applied, and this gives the appearance of volume to the surface.

#### Pastel tool options

**Edit tab**

Pastel tool options include

- **Shape** — defines the shape of the pastel tip
- **Size** — defines the size of the tool head in pixels
- **Thickness** — defines the aspect ratio of the tool head
- **Rotation** — defines the angle of head rotation in degrees
- **Head Tracking** — determines whether the tool head bends around the path of the user’s stroke, or remains at a fixed angle
- **Trace** check box — allows the Pastel tool to select the pigment color by sampling the data below the center of the tool regardless of the layer type.

**Important!** When you hold down the mouse button to begin the stroke, note that a single sample is performed and the resulting color is used for the duration of the stroke.

### Using the Crayon tool

Crayon is a dry media similar to chalk but with a wetter feel that prevents powdering. The tool has infinite pigment loading. As applied by the Crayon tool, its dry pigment tends to penetrate the canvas texture proportional to the pressure with which you apply it. This is due to PaintShop Pro mimicking a solid tool head. The pigment leaves a slightly waxy volume that can smear for a short distance as it is painted over. Crayons do not have a bristle component to the stroke, instead presenting a flat or angled tool surface. The body of the stroke tends to have a fall-off and break up affected strongly by the canvas texture. However, crayon pigment is less transparent than chalk and does not powder.

Crayon is a little more shiny than pastel, smears itself slightly less, but does apply a tiny amount of matter to the canvas and can smooth over bumps if used repeatedly. This is because the volume that is laid down is viscous enough to fill dents but also dense enough to prevent large-range smearing.

#### Crayon tool options

**Edit tab**

Crayon tool options include

- **Shape** — defines the shape of the crayon tip
- **Size** — defines the size of the tool head in pixels
- **Thickness** — defines the aspect ratio of the tool head
- **Rotation** — defines the angle of head rotation in degrees
- **Head Tracking** — controls whether the tool head bends around the path of the user’s stroke, or remains at a fixed angle
- **Trace** check box — allows the Crayon tool to select the pigment color by sampling the data below the center of the tool regardless of the layer type.
Important! When you hold down the mouse button to begin the stroke, note that a single sample is performed and the resulting color is used for the duration of the stroke.

Using the Colored Pencil tool

The Colored Pencil tool lets you apply dry pencil strokes that blend when you apply light pressure, and overlay when you apply firm pressure. The Colored Pencil tool does not apply bump to a surface, and it will only smear when you apply pressure to the canvas. You can use the Smear tool to blend colored pencil strokes.

Colored Pencil tool options

Edit tab

Colored Pencil tool options include

- **Shape** — defines the shape of the pencil tip
- **Size** — defines the size of the tool head in pixels
- **Thickness** — defines the aspect ratio of the tool head
- **Rotation** — defines the angle of head rotation in degrees
- **Head Tracking** — controls whether the tool head bends around the path of the user’s stroke, or remains at a fixed angle
- **Style** — determines the behavior of the Colored Pencil tool tip when using a stylus
  - Choose **Tilt** to change the style through a linear progression based upon the stylus tilt. Choose **Tip** to mimic using the very tip of a pencil. Choose **Edge** to mimic using the pencil’s edge.
- **Softness** — defines the softness of the pencil lead, controlling how easily pressure or velocity break up the lead and cause it to powder into the canvas dents, or to smudge when applied
- **Trace** check box — allows the Colored Pencil tool to select the pigment color by sampling the data below the center of the tool

Important! When you hold down the mouse button to begin the stroke, note that a single sample is performed and the resulting color is used for the duration of the stroke.

Using the Marker tool

The Marker tool lets you apply pigment that resembles drawing with a marker on a canvas. Marker pens are a slightly wet medium, though generally not wet enough to interact with other wet media. The pigment goes on the canvas with a multiply function, simulating the interaction of using a pen repeatedly on the same spot. Pens generally have a very sharp fall-off at the stroke edge, and there is full canvas penetration even at light pressure.

Marker tool options

Edit tab

Marker tool options include

- **Shape** — defines the shape of the marker tip
- **Size** — defines the size of the tool head in pixels
- **Thickness** — defines the aspect ratio of the tool head
- **Rotation** — defines the angle of head rotation in degrees
- **Head Tracking** — controls whether the tool head bends around the path of the stroke, or whether it remains at a fixed angle
- **Trace** check box — allows the Marker tool to select the pigment color by sampling the data below the center of the tool, regardless of the layer type

Important! When you hold down the mouse button to begin the stroke, note that a single sample is performed and the resulting color is used for the duration of the stroke.
Using the Watercolor Brush tool

You can use the Watercolor Brush tool to simulate the transparent strokes of watercolor painting. Watercolor brushstrokes reveal the canvas texture and are wet in terms of how they interact with other strokes when you smear or mix them together. For more information see “To dry or wet an Art Media layer” on page 372.

To reload the Watercolor Brush tool with color, you can

• reload the brush with a solid color
• reload the brush by sampling from the Mixer page

Watercolor Brush tool options

Edit tab

Watercolor Brush tool options include

• **Shape** — defines the shape of the brush tip
• **Size** — defines the size of the tool head in pixels
• **Thickness** — defines the aspect ratio of the tool head. This setting is active only when the Fixed angle Head Tracking option is chosen.
• **Rotation** — defines the angle of head rotation in degrees
• **Head Tracking** — determines whether the tool head bends around the path of the user’s stroke, or remains at a fixed angle
• **Viscosity** — defines the rate at which the material on the brush is applied, and thus the length of the stroke before your paint runs out
• **Firmness** — defines the amount of splay in the brush, how the rendered line gets wider with more pressure, and how well it penetrates the surface on to which it is painting
• **Bristle size** — affects the underlying noise function for texture and application of paint
• **Auto Clean** check box — cleans the brush and reloads it with fresh paint at the start of a new stroke
  
  Note: When unmarked, the brush head is not cleaned at the start of the stroke. Instead, the dirty head has a small amount of the current color added to whatever dirty head state exists from the previous stroke.
• **Clean** button — cleans the head and start the next stroke with fresh paint or pigment
• **Trace** check box — allows the current Art Media tool to select the pigment or paint color by sampling the data below the center of the brush regardless of the layer type.

Using the Palette Knife tool

The Palette Knife tool interacts with the medium on the canvas. Generally, you use it with strokes placed by the Oil Brush tool as this is the only tool that applies large amounts of its medium. As the mass of the medium reduces in a spot, there is less to smear and using the Palette Knife tool has less effect. This means that the Crayon tool, which applies very little medium, is only slightly affected by the Palette Knife tool.

The method of loading or cleaning the Palette Knife tool is similar to the Oil Brush tool. You can clean it automatically after each stroke, retain the color picked up from the canvas, or allow manual cleaning. You can use the Palette Knife tool to apply pigment or smear it.

Paint strokes applied by the Palette Knife tool are wet in terms of how strokes interact with other strokes by smearing or mixing together. For more information, see “To dry or wet an Art Media layer” on page 372.

Palette Knife tool options

Edit tab

Palette Knife tool options include

• **Shape** — defines the shape of the knife tip
• **Size** — defines the size of the tool head in pixels
• **Thickness** — defines the aspect ratio of the tool head
  
  This setting is only active when the Fixed angle Head Tracking option is enabled.
• **Rotation** — defines the angle of head rotation
• **Head Tracking** — controls whether the tool head bends around the path of the user’s stroke, or remains at a fixed angle
• **Head Loading** — defines the percentage of material on the brush at the start of the stroke
• **Auto Clean** check box — cleans the tool and dips it into fresh paint at the start of a new stroke
• **Clean** button — cleans the head and start the next stroke with fresh paint or pigment.
  This button is only active when the **Auto Clean** check box is not marked.
• **Trace** check box — allows the Palette Knife tool to select the pigment or paint color by sampling the data below the center of the tool regardless of the layer type.

**Important!** When you hold down the mouse button to begin the stroke, note that a single sample is performed and the resulting color is used for the duration of the stroke.

### Using the Smear tool

The Smear tool lets you smear existing pigment, including pigment that has no volume on the canvas, such as pencil strokes. The tool simulates the effects of dragging a cloth or finger through chalk or pencil strokes on a canvas.

You can use the Smear tool to create a smudging effect on dry pigment, or to create a smearing effect on wet pigment.

**Smear tool options**

**Edit tab**

Smear tool options include
- **Shape** — defines the shape of the tool tip
- **Size** — defines the size of the tool head in pixels
- **Thickness** — defines the aspect ratio of the tool head
- **Rotation** — defines the angle of head rotation in degrees
- **Head Tracking** — controls whether the tool head bends around the path of the stroke, or whether it remains at a fixed angle

### Using the Art Eraser tool

The Art Eraser tool lets you erase art media from an image. While this tool is not strictly realistic, it does provide you with the flexibility to erase mistakes, rather than undoing entire strokes.

**Art Eraser tool options**

**Edit tab**

Art Eraser tool options include
- **Shape** — defines the shape of the eraser tip
- **Size** — defines the size of the tool head in pixels
- **Thickness** — defines the aspect ratio of the tool head
- **Rotation** — defines the angle of head rotation in degrees
- **Head Tracking** — controls whether the brush head bends around the path of the stroke, or whether it remains at a fixed angle
Working with advanced color

PaintShop Pro has many advanced color features that let you work with color in many ways. For example, you can change the color depth of your images to prepare them for printing or the Web. You can control how your monitor displays colors and manage colors for output. You can also split images into color channels.

This section presents the following topics:
• “Understanding color depth” (page 381)
• “Viewing color depth information” (page 382)
• “Increasing the color depth of an image” (page 382)
• “Decreasing the color depth of an image” (page 383)
• “Understanding color reduction methods” (page 386)
• “Understanding palette options” (page 386)
• “Working with image palettes” (page 386)
• “Understanding color and color models” (page 389)
• “Understanding how monitor colors and print colors differ” (page 390)
• “Calibrating your monitor” (page 391)
• “Working with color management” (page 391)
• “Using color channels” (page 392)

Understanding color depth

Color depth, also called bit depth, refers to the number of colors each pixel in an image can display. As the color depth increases, the number of colors an image can display increases. Each pixel’s color information is stored in a certain number of computer bits — from 1 bit to 48 bits. In a 1-bit image, each pixel can display only one of two colors — black or white. In images with greater bit depth, each pixel can display one of an increasingly large number of colors. High-end digital camera photos saved in the camera’s RAW format contain the most colors, but they also require more hard drive space, and more system memory to display and work on them.

In PaintShop Pro, you can use the following color depths:
• 2 colors
• 16 colors
• 256 colors
• 8-bit per channel RGB
• 8-bit per channel Grey
• 16-bit per channel RGB
• 16-bit per channel Grey

Before you change the color depth of your image, consider the following:
• Many effect and correction commands work on higher color depth images only. After you finish working on an image, you can decrease its color depth and save it in another format.
• Computer monitors also have a color depth that is determined by the monitor’s capabilities as well as the selected color setting. If you display an image with a higher color depth than the monitor can display, the image has some color distortion.
• Some file formats limit the number of supported colors so that images display correctly on a variety of monitor types. For example, GIF images, a popular format for the Web, contain up to 256 colors (8-bit depth).

### Viewing color depth information

You can use PaintShop Pro to view the color depth information for images. You can also check the color depth of a monitor to ensure it supports the color depth of the images with which you are working.

The number of colors actually used in an image is usually less than the color depth. For example, a 16 million-color image is capable of displaying that many colors, but may only use 50,000 colors. You can use PaintShop Pro to view the number of colors used in an image or layer.

#### To view the color depth of an image

**Edit tab**

1. Choose **Image > Image Information**.
   
   The Current Image Information dialog box appears. The color depth value for the image is displayed in the Pixel Depth/Color field in the Image group box.

   ![Image Information Dialog Box](image.png)

2. You can also view the color depth information on the Status bar. The color depth information appears after the two numbers that display the pixel dimensions of the image.

3. You can also view color depth information on Overview palette by pressing **F9**, clicking the **Info** tab, and viewing the Color Depth field.

#### To view the color depth of a monitor

**Edit tab**

1. Choose **Help > About PaintShop Pro**.
2. Click **System Info**.
3. Scroll down to the Video Driver Information section, and view the Number of Colors field.

#### To view the number of colors in an image

**Edit tab**

1. Choose **Image > Count Image Colors**.

#### To view the number of colors in a layer

**Edit tab**

1. On the Layers palette, click the layer that you want to check.
2. Choose **Layers > Count Layer Colors**.

### Increasing the color depth of an image

If an image has a color depth of less than 24-bit, you may want to increase the color depth so you can use a wider range of effect and correction commands, many of which only work on images with 16 million colors. Depending on the color depth of your image, you can also increase an image to 16 colors (4-bit) or 256 colors (8-bit).
To increase the color depth of an image

**Edit tab**

- Choose **Image > Increase Color Depth**, and choose one of the following:
  - 16 color palette
  - 256 color palette
  - RGB - 8 bits/channel
  - RGB - 16 bits/channel

Color depths not available for the active image are grayed out.

If your image has a palette, for example if you have a 256 color (8-bit) image, and you need to maintain the palette colors, you can save the palette before increasing the color depth. After editing the image, you can reload the palette. For more information, see “Working with image palettes” on page 386.

If you are increasing or decreasing several images to the same color depth, you can add a button to the toolbar that you can click to automatically set color depth. For more information, see “Customizing toolbars” on page 398.

Decreasing the color depth of an image

If you are creating an image for on-screen viewing, you can decrease the number of colors to reduce the file size and ensure the image displays properly.

Before decreasing the color depth, consider the following:

- Most PaintShop Pro effect and correction commands work on 16 million-color and grayscale images only.
- When you decrease the color depth, PaintShop Pro flattens the image, which merges the data on all layers. However, you can add vector layers to images of any color depth.

If you are creating images for the Web, we recommend that you work with 16 million color (24-bit) images in the PspImage file format. After editing the images, you can reduce the color depth of the images and prepare them for the Web by exporting the images using the GIF optimizer, JPEG optimizer, or PNG Optimizer.

Depending on the current color depth of your image, you can decrease its color depth to the color depths described below.

**2 colors (1-bit)**

You can create a black-and-white image by decreasing the color depth of an image to 2 colors. For example, if your image is already black-and-white, you can change the color depth to two colors to reduce the file size.

**16 Colors (4-Bit)**

When you have an image that has only a few colors, you can decrease the color depth of an image to 16 colors (4-bit). This color depth is useful for simple graphics on Web pages that you want to load quickly. The resulting image has an image palette that contains 16 specific colors. You can change any of those colors by editing the image palette. For information, see “Working with image palettes” on page 386.

**256 colors (8-Bit)**

When you decrease the color depth of an image to 256 colors (8-bit), you can choose a Web-safe palette to ensure your image displays as expected regardless of the Web browser or monitor used to view the image. You can only convert color images to 256 Colors (8-bit). For information about converting images to 8-bit grayscale, see “To create an 8-bit grayscale image” on page 385.

**Grayscale (8-bit)**

You can convert a color image to an 8-bit grayscale image that uses up to 256 shades of gray.
32K and 64K Colors (24-Bit)

You can reduce the number of colors used in a 24-bit image by decreasing the color depth to 32K (32,000) or 64K (64,000) colors. Displaying images with 32K or 64K colors on older monitors results in better refresh rates than displaying 24-bit images with 16 million colors.

Decreasing color depth to a selected number of colors

You can decrease the number of colors used in an image by specifying the number of colors that you want to use. When you specify the number of colors, PaintShop Pro converts the image to the appropriate color depth. For example, if you specify 16 or fewer colors, the image is saved as a 4-bit image. If you specify 17 to 256 colors, the image is saved as an 8-bit image. Specifying the number of colors is advantageous when saving to some file formats, such as GIF, because the file compression is sensitive to the number of colors in the image. For example, by using 100 colors instead of 256 colors, a smaller GIF file is created, even though both files are 8-bit images. Smaller files result in faster download times.

To decrease the color depth to 2 colors

Edit tab

1. Choose Image \ Decrease Color Depth \ 2 Color palette.
2. In the Palette Component group box, choose the color channel to use for the final image.
   Choosing the Grey values option produces the best results in most cases. However, if the image consists mainly of a single color, selecting that color channel may produce the best results.
3. In the Reduction Method group box, choose a color reduction method.
   For more information about color reduction, see “Understanding color reduction methods” on page 386.
4. In the Palette Weight group box, select an option:
   - Weighted — weighted palettes produce less dithering and sharper edges
   - Non-weighted — non-weighted palettes produce more dithering and softer edges
   Note: Dithering places pixels of different colors or gray levels next to each other to simulate missing colors or grays.
5. Click OK.

You can also create a black-and-white image by choosing Adjust \ Brightness and Contrast \ Threshold. With this command, the color depth does not change. For more information, see “To convert a photo’s pixels to black and white” on page 137.

To decrease the color depth to 16 colors

Edit tab

1. Choose Image \ Decrease Color Depth \ 16 Color palette.
2. In the Palette group box, choose a palette option.
   For more information about setting Palette options, see “Working with image palettes” on page 386.
3. In the Reduction Method group box, choose a color reduction method.
   For more information about color reduction, see “Understanding color reduction methods” on page 386.
   Note: The Ordered Dither option is available only for the Windows color palette.
4. In the Options group box, mark or unmark these check boxes:
   - Boost marked colors by — when you have a selection in your image, this option lets you make the colors in the selection more important by a factor of the value you enter
   - Reduce color bleeding — makes the left-to-right bleed effect of colors less noticeable when you choose the Optimized Median Cut or the Optimized Octree palette and the Error Diffusion reduction method
5. Click OK.
If you want to emphasize the importance of certain colors in the conversion, create a selection of the area that you want to use before you decrease the color depth.

To decrease the color depth to 256 colors
Edit tab
1. Choose Image ➤ Decrease Color Depth ➤ 256 Color palette.
2. In the Palette group box, choose a palette option. For more information about setting Palette options, see “Working with image palettes” on page 386.
3. In the Reduction Method group box, choose a color reduction method.
   For more information about reducing colors, see “Understanding color reduction methods” on page 386.
   Note: The Ordered Dither option is available only for the Standard/Web-safe color palette.
4. In the Options group box, choose any of the following options:
   • Boost marked colors by — when you have a selection in your image, this option lets you make the colors in the selection more important by a factor of the value you enter
   • Include Windows’ colors — lets you include the 16 standard Windows colors in the converted image palette when you choose the Optimized Median Cut or the Optimized Octree palette option
   • Reduce color bleeding — makes the left-to-right bleed effect of colors less noticeable when you chose the Optimized Median Cut or the Optimized Octree palette and the Error Diffusion reduction method
5. Click OK.

To create an 8-bit grayscale image
Edit tab
* Choose Image ➤ Greyscale.

To decrease the color depth to 32K or 64K colors
Edit tab
1. Choose Image ➤ Decrease Color Depth, and choose one of the following:
   • 32K Colors (8 bits/channel) — reduces the number of colors to 32,000
   • 64K Colors (8 bits/channel) — reduces the number of colors to 64,000
2. In the Reduction Method group box, select a color reduction method.
   For more information about reducing colors, see “Understanding color reduction methods” on page 386.
3. Click OK.

To decrease the color depth to a selected number of colors
Edit tab
2. Type or set the number of colors (from 2 to 256) in the Number of colors control.
3. In the Palette group box, select the palette options.
   For more information about setting Palette options, see “Working with image palettes” on page 386.
4. In the Reduction Method group box, choose a color reduction method.
   For more information about reducing colors, see “Understanding color reduction methods” on page 386.
5. In the Options group box, choose any of the following options:
• **Boost marked colors by** — when you have a selection in your image, this option lets you increase the colors in the selection by a factor of the value you enter

• **Include Windows’ colors** — lets you include the 16 standard Windows colors in the converted image palette when you choose the Optimized Median Cut or the Optimized Octree palette

• **Reduce color bleeding** — reduces the left-to-right bleed effect when you choose the Optimized Median Cut or the Optimized Octree palette and the Error Diffusion reduction method

6 Click OK.

If you want to emphasize the importance of certain colors in the conversion, create a selection of the area that you want to use before you decrease the color depth.

**Understanding color reduction methods**

When you decrease the color depth of an image, you must select a color reduction method. Depending on the color depth you select, two or three of these methods are available:

• **Nearest Color** — replaces the original color of a pixel with the color in the newly generated palette that is closest to the original RGB value. This method eliminates dithering and produces a high-contrast image. This method works well with most simple graphics.

• **Error Diffusion** — replaces the original color of a pixel with the most similar color in the palette, but spreads the discrepancy between the original and new colors to the surrounding pixels. As it replaces a color (working from the top left to the bottom right of the image), it adds the “error,” or discrepancy, to the next pixel, before selecting the most similar color. This method produces a natural-looking image and often works well for photos or complex graphics. With the Error Diffusion method, you select the Floyd-Steinberg, Burkes, or Stucki algorithm for the dithering pattern.

• **Ordered Dither** — adjusts adjacent pixels so that two colors give the illusion of a third color and intermingles pixels to produce patterns based on a known palette. You can use this method to give the image the appearance of containing more colors than it actually does. Images may appear to be composed of cross-hatches and dots and may have distinct light and dark areas.

When you decrease an image’s color depth, don’t be intimidated by the mathematical algorithms that make up the color reduction methods and the palette options. It’s recommended that you start with the default settings. If you like the result, try out several other combinations of settings. It take can take some experimentation to find the right options.

**Understanding palette options**

When you decrease the color depth of an image, you must select a palette option. Depending on the color depth you select, two or three of these methods are available:

**Optimized Median Cut** — measures and ranks each color by how frequently it occurs in the image, then uses the most frequently occurring colors to determine the new palette. Even if your image contains fewer colors than the palette that is generated, this method may not represent each color exactly. The method, therefore, is not as accurate as the Optimized Octree method, but it is better at weighting color importance.

**Optimized Octree** — creates an eight-level “tree” with eight branching nodes totaling 256 individual “leaves” or colors to determine the new palette. This method attempts to reproduce each color in the original image, so if your image contains fewer colors than the palette that is generated, every color in the image is represented. This method is faster and more accurate than Optimized Median Cut, but is not as good at weighting color importance.

**Windows** — changes each pixel’s color to the nearest color in the Windows palette

**Standard/Web-Safe Palette** — changes each pixel’s color to the nearest color in the standard Web-safe palette. You can use this method to create images for the Web that can be viewed without color distortion on most monitors.

**Working with image palettes**

An image palette is a collection of colors that an image uses — similar to a painter’s palette. An image palette is a subset of all the colors your monitor can display. Not all images have image palettes — only images with color depths between 16 and 256 colors have palettes that you can fine-tune and edit.
Images with a color depth of 16 million colors do not have an image palette because they can contain all the colors your computer can display. For these images, you can load an image palette to decrease the image’s color depth to 256 colors (8-bit). Loading a palette produces the same result as decreasing color depth, except that you are controlling which colors are used in the converted image. For more information about color depth, see “Understanding color depth” on page 381.

You can also create and save your own palettes. Preset palettes are located in the Palettes folder of the PaintShop Pro program folder. When you save a palette, you can load it into other images. This is a good way to maintain consistent colors across several images. Saving a palette is also useful if you are making many color changes and want to save a backup copy of the palette.

If you are using a palette with the current image only, you don’t need to save it as a separate file because the palette colors are saved with the image itself.

Editing the palette of a grayscale image

If you edit the color palette for a grayscale image, you are prompted to change the image to 8-bit indexed color. This allows you to add color to your grayscale image.

Using the Web-Safe color palette

PaintShop Pro includes a Web-safe, 256-color palette, the Safety palette. Images using this palette can be viewed without color distortion on most computer monitors. There are three ways to use this palette on an image:

- You can load the Safety palette into your image. For 16 million color (24-bit) images, this flattens the layers and reduces the image’s color depth to 256 colors (8-bit), which limits the available commands.
- You can decrease the image’s color depth to 256 colors and select the Standard/Web-Safe Palette option. Decreasing the color depth also flattens layers and makes some commands unavailable.
- You can edit the image in 16 million colors (saving it to the PspImage file format), then use the GIF Optimizer or PNG Optimizer to export a copy of the image. These optimizers use the Web-safe palette by default and decrease the color depth in the saved image. This is recommended because it does not change the color depth or flatten the layers of your original PspImage file. For more information about saving optimized images, see “Saving images for the Web” on page 455.

Making a palette color transparent

Paletted images (those with 256 or fewer colors) do not support transparent backgrounds, but you often need a way to make part of your image transparent when you are using an image on a Web page. For example, you may have a round logo and you want the background of the Web page to display around the logo.

Most Web browsers can choose not to display one color, effectively making it transparent. In PaintShop Pro, you have two ways to make a color transparent:

- You can make one color in an image palette transparent. The color can be the background color or any color from the image. To set a transparent color, the image must have only one layer and use an image palette, which means the image must have a color depth less than 16 million colors (24-bit).
- You can edit a 16 million-color image, save it to the PspImage file format, then use the GIF or PNG optimizer to export a copy of the image. With these optimizers you can set the transparency of the image. This is recommended because it does not change the color depth or flatten the layers of your original PspImage file. For more information saving optimized images, see “Saving images for the Web” on page 455.

To edit an image palette of 16 to 256 color images

Edit tab

1 Choose Image Palette Edit Palette. This command is not available for 16 million color images.

2 Perform one or more tasks from the following table, and click OK.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the sort order of the colors</td>
<td>Select an option from the Sort Order drop-list.</td>
</tr>
<tr>
<td>Replace a color</td>
<td>Double-click the color, choose a color from the Color page, and</td>
</tr>
</tbody>
</table>
To Do the following

click OK.

Reset the palette to the original colors

In the Edit Palette dialog box, click Revert.

To save an image palette

Edit tab

1 Choose Image ➤ Palette ➤ Save Palette.
The Save Palette dialog box appears.
2 Type a name for the palette in the Filename box.
3 Click Edit Paths.
The File Locations dialog box appears.
4 Choose the folder where you want to save the palette in the Palette Folder group box.
   If you save the palette in the Palettes folder of the PaintShop Pro program folder, you can access the palette as a preset.
5 Click OK.
6 In the Save palette as group box, select a palette format option:
PSP palette — the default palette format
Microsoft palette — palette format used for other applications
7 Click Save.
   PaintShop Pro automatically adds the .PspPalette filename extension when you save the file.

To load an image palette

Edit tab

1 Choose Image ➤ Palette ➤ Load Palette.
The Load Palette dialog box appears.
2 In the Palette drop-list, click the File Locations button.
The File Locations dialog box appears.
3 Choose the folder which contains the palette you want to load, and choose a palette.
Preset image palettes are stored in the Palettes folder of the PaintShop Pro program folder.
4 Click OK.
5 In the Apply Palette Using group box, select one of the following options:
   • Nearest color matching — changes each image color to the color in the palette that is the closest match
   • Error diffusion dithering — attempts to maintain the image appearance by dithering colors that are not in the palette. Dithering places pixels of different colors next to each other to simulate missing colors.
   • Maintain indexes — assigns each color in the palette a sequential index number and does the same for each color in the image. Each color in the image is then changed to the like-numbered color in the palette.
6 Click Load.
The palette is loaded and the image colors are updated.

If you load a palette and do not like the results, you can revert to the original image by pressing Ctrl + Z to undo the action.

To load the Web-safe color palette

Edit tab

1 Choose Image ➤ Palette ➤ Load Palette.
The Load Palette dialog box appears.
In the Palette drop-list, click the File Locations button. The File Locations dialog box appears.

Navigate to the Palettes folder in the PaintShop Pro program folder, and choose Safety.

In the Apply Palette Using group box, choose one of the following options:

• Nearest color matching — changes each image color to the color in the palette that is the closest match.

• Error diffusion dithering — attempts to maintain the image’s appearance by dithering colors that are not in the palette. Dithering places pixels of different colors next to each other to simulate missing colors.

• Maintain indexes — assigns each color in the palette a sequential index number and does the same for each color in the image, then changes each color in the image to the like-numbered color in the palette. This option is not available for 16 million-color images.

Click Load.

To make one image color transparent

1 Choose Image ➤ Palette ➤ Set Palette Transparency.

If you are prompted to reduce the color depth and number of layers, click Yes to continue and then choose the options for decreasing color depth.

2 On the Set Palette Transparency dialog box, choose one of the following options:

• Set the transparency value to the current background color — makes the background color transparent

• Set the transparency value to a palette entry — specifies a color to be transparent. Click the color in the image, or click the color box to select from the current color picker.

If you want to view the transparency, click Proof.

3 Click OK.

The color is now transparent; however, it may still be displayed until you hide it.

To view or hide the transparency of a color

• Choose Image ➤ Palette ➤ View Palette Transparency.

Understanding color and color models

We usually think of color as a quality inherent in an object — for example a red car or a green frog. But color is really what we see as a result of three factors interacting: light, the object, and the observer. As rays of light hit the object, the object absorbs some light and reflects some light. We see the reflected light and perceive it as color. Different colors reflect light of different wavelengths. Human eyes are able to perceive thousands of colors in the visible spectrum of light.

When you apply ink to paper, the colors we see result from the light that the ink reflects. Computer monitors use emitted light rather than reflected light. The colors we see result from light emitted from the screen.

To describe how color is produced or perceived, we use color models. Computer monitors display colors by producing varying amounts of red, green, and blue light — the RGB color model. Human eyes perceive color by its hue, saturation, and lightness levels — the HSL color model. With PaintShop Pro you can select colors using either the RGB or HSL color model. You can also output images using the CMYK (Cyan, Magenta, Yellow, Black) model, which is used for high-end printing applications.

RGB is the default color model in PaintShop Pro. For information about changing the default color model, see “To set Palettes preferences” on page 404. PaintShop Pro uses your preferred color model (RGB or HSL) whenever color values are displayed. When you select colors from the Color page, you are able to enter RGB or HSL values regardless of your preference setting. The color model used to display color values on-screen has no effect on how colors are printed.

RGB model

All colors on your computer screen are created by mixing red, green, and blue light in varying proportions and intensities. When these primary colors are mixed in equal proportions, they create yellow, cyan, and magenta. Adding all the colors together creates white.
Each primary color (red, green, and blue) is assigned a value from 0 (none of the color present) to 255 (the color at full strength). For example, pure red is produced by combining a red value of 255, a green value of 0, and a blue value of 0. Yellow is a combination of a red value of 255, a green value of 255, and a blue value of 0. Setting all three values to 255 produces white; setting all three values to 0 produces black. When all three colors are set to the same value, the result is gray.

**HSL model**

The HSL model is based on how the human eye perceives color using the characteristics of hue, saturation, and lightness. Each characteristic is assigned a value from 0 to 255. The three characteristics are described as follows:

- **Hue** — the color reflected from an object, such as red, yellow, or orange. Each hue value is assigned based on its position on the color wheel. On the Color page's Color wheel, colors are assigned counter-clockwise from the top. Red is at the top (value 0) and as you move around the wheel the colors go through orange, yellow, green, blue, purple, and back to red.
- **Saturation** — the purity or vividness of the color. Saturation represents the amount of gray in the color, from 0 (entirely gray) to 255 (fully saturated color).
- **Lightness** — the perceived amount or intensity of light in the color. Lightness ranges from 0 (no light, or black) to 255 (total lightness, or white). At 50 percent lightness, or a value of 128, a color is considered pure. For example, pure red has a hue of 255, a saturation of 255 (100 percent) and a lightness of 128 (50 percent). For pure blue, the hue is 170, saturation is 255 and lightness is 128.

**CMYK model**

The CMYK model is based on the fact that ink on paper both absorbs and reflects light. As white light strikes the ink, part of the color spectrum is absorbed and part is reflected back to your eyes (resulting in the color you see).

In this model, the primary colors cyan (C), magenta (M), and yellow (Y) combine in varying proportions to produce a variety of colors. When the three colors are combined, they produce black. Because impurities in the ink make it difficult to produce a true black, a fourth color, black (K), is added.

Combining inks in this way is called four-color process printing. It is used by printing services and high-end color printers.

Although you cannot create images in PaintShop Pro using the CMYK model, you can produce color separations that can be printed on CMYK printers. There are two ways to do this: You can split the images into CMYK channels, or you can print color separation pages.

CMYK channels are simply four separate grayscale images that represent the percentage and location of cyan, magenta, yellow, and black in the image. For more information about working with color channels, see "Using color channels" on page 392.

When you print CMYK separations, PaintShop Pro prints a separate grayscale page for each primary color. You can then use these pages as “color plates” when working with a printing service. For more information about CMYK color separations, see “Printing CMYK color separations” on page 450.

**Understanding how monitor colors and print colors differ**

Computer monitor colors and printed colors may often be quite different — which is a challenge when you are trying to match a certain color. Colors can also appear different from monitor to monitor.

Image colors on a monitor are influenced by a variety of factors:

- the color range, called the color gamut, of the input device (such as the scanner or camera)
- the manufacturer and age of the monitor
- the monitor’s brightness and contrast settings

When you print an image, you introduce other factors that influence color:

- the quality and absorption properties of the paper
- the color gamut of the printer
- the conversion of RGB values from the monitor to the CMYK values of the printer’s ink

This conversion is a challenge because of the different approaches to color between monitors and printers. Because monitors use light to display color, they use additive colors—when you add them together, they produce white. Conversely, when you remove all monitor colors you produce black. Because printers use ink to display color, they use subtractive colors—when you remove colors, you produce white, and when you add all printer colors you produce black. As a result, monitors and printers have different color gamuts. Although they share many
of the same colors, there are some colors a monitor can display that a printer can’t print and some colors a printer can print that a monitor can’t display.

Given all the factors that go into producing colors, how do you go about making colors accurate and consistent? Try these options:

• You can calibrate your monitor every few months.
• You can get to know the differences between your monitor’s colors and your printer’s colors so you can adjust your images as needed. You can do this by printing out several photos or other images and comparing them to the image on-screen. For example, your printer may always print colors darker than your monitor displays them. Knowing this, you can modify the lightness of your images accordingly.
• You can use Windows Color Management, which helps to improve color consistency across devices.

Calibrating your monitor

It is important that the colors represented on your monitor are reasonably accurate and meaningful. For example, red should really look red and not like a shade of orange or purple, and 50% gray shouldn’t look like light gray or dark gray.

In PaintShop Pro, you can use a wizard that walks you through the process of calibrating your monitor so it displays accurate colors. At the end of the process, you can save a color profile for your monitor and apply the adjustments.

To calibrate your monitor

Edit tab

1 Choose File ➤ Color Management ➤ Monitor Calibration.
   The Monitor Calibration wizard appears.

2 Click the Maximize button.
   Maximizing the dialog box eliminates distracting background colors.

3 Follow the instructions in the wizard, and click Finish to exit the wizard.

4 In the Save As dialog box, type a name for your monitor profile in the File Name box, and click Save.
   If you have Administrator privileges for your computer, the profile becomes the active monitor profile.
   If you do not have Administrator privileges for your computer, a message appears informing you to contact your System Administrator to install the profile.

You can also calibrate red, green, and blue tones for your monitor by marking the Advanced options check box when it appears on a wizard page.

You can clear the calibration settings for a wizard page by clicking Reset.

Working with color management

If you are preparing professional quality digital images, you can enable or disable color management settings. Additionally, every RGB image in PaintShop Pro has a profile associated with it. By default, these advanced color settings are enabled, allowing the application to make use of a consistent color working space. You can define advanced features for color working spaces and profiles. For example, you can set a CMYK profile that determines how CMYK images are processed when you split or combine CMYK channels, or when you output to a CMYK TIF file.

To set up profiles for color management

Edit tab

1 Close any open images.

2 Choose File ➤ Color Management ➤ Color Management.
   The Color Management dialog box appears.
   Note: The recommended working space for PaintShop Pro is sRGB.
   If necessary, mark the Enable Color Management check box to access the controls in this group box.

3 Choose the Basic color management option to access controls for your monitor and printer.

4 In the Monitor Profile drop-list, choose the monitor profile you want to use.
If you’re using multiple monitors with your computer, the profile you choose only applies to the primary display.

5 In the **Printer Profile** drop-list, choose the printer profile you want to use.

If you’re using multiple printers with your computer, the profile you choose only applies to the primary printer.

6 In the **Rendering Intent** drop-list, choose the setting that matches your intended output.

   This setting affects how the option you choose in the **Printer Profile** drop-list is used.

7 Click **OK**.

Only valid and correctly installed profiles appear in the profile lists.

If you have Administrator privileges for your computer, the profile you save becomes the active monitor profile. If you are a restricted user, you must contact your System Administrator to install the profile.

You can set your printer to simulate a printing press by choosing the **Proofing** option, choosing a device in the **Emulated Device Profile** drop-list, and choosing the appropriate option in the **Rendering Intent** drop-list.

---

**To define a color working space and CMYK profile**

**Edit tab**

1 Close any open images.

2 Choose **File ➤ Color Management ➤ Color Working Space**.

   The Color Working Space dialog box appears.

   **Note:** The recommended working space for PaintShop Pro is sRGB.

3 In the **Color Working Space** drop-list, choose a color space.

4 In the **CMYK Profile** drop-list, choose a profile to be used for the CMYK-related operations in the application.

   The drop-list includes the default CMYK profile and any profiles that you have added.

5 Click **OK**.

---

**Using color channels**

Image files store color information in channels, or planes, of colors. You can separate an image into RGB, HSL, or CMYK color channels. An RGB image has three channels: red, green, and blue. An HSL image has three channels: hue, saturation, and lightness. Although you cannot create or edit an image using the CMYK model, you can still split the image into four channels: cyan, magenta, yellow, and black.

You can create a new grayscale image for each color channel; the original image is not affected. For example, an HSL image is split into separate grayscale images named “Hue,” “Saturation,” and “Lightness.” Each grayscale image represents the percentage and location of a color (such as red) or a characteristic (such as lightness) within the image.

You can edit the grayscale images and use them to create interesting effects or masks. You can then combine them again. If you split an image into CMYK channels, you can then send the four grayscale images to a printing service. You can also print CMYK separations directly.

You can split images into RGB, HSL, or CMYK color channels regardless of the type of color model (RGB or HSL) you choose as a display preference.

Color channels give you increased image-editing options. You can create a color shift by splitting an image into HSL channels, modifying the Hue channel, then combining the channels. You can also use a channel grayscale to create a selection.

---

**To split an image into color channels**

**Edit tab**

• Choose **Image ➤ Split Channel**, and choose one of the following:

• Split to RGB

• Split to HSL
• Split to CMYK
A new grayscale image opens for each color channel.

To combine color channels
Edit tab
1. Open each color channel file.
2. Choose Image ➤ Combine Channel, and choose one of the following:
   • Combine from RGB
   • Combine from HSL
   • Combine from CMYK
3. For each Channel Source drop-list, select the name of the file that contains that channel. For example, in the Combine RGB dialog box, select the file Red1 as the red channel source.
   Note: If you are combining channels that you split with the Split Channel command, mark the Sync check box to have PaintShop Pro automatically fill in the Channel Source boxes with matching file names.
4. Click OK.
   A new file is created from the selected channels.
Customizing
In PaintShop Pro, you can customize workspaces, the menu system, toolbars, keyboard shortcuts, application preferences, file format preferences and associations, resources, and viewing options. You can even choose another language in which to use the application.

This section presents the following topics:
- “Viewing and hiding toolbars” (page 396)
- “Viewing and hiding tools” (page 396)
- “Using custom workspaces” (page 396)
- “Customizing the menu system” (page 398)
- “Customizing toolbars” (page 398)
- “Creating custom toolbars” (page 399)
- “Customizing keyboard shortcuts” (page 400)
- “Setting Undo preferences” (page 401)
- “Setting View preferences” (page 402)
- “Setting Display and Caching preferences” (page 402)
- “Setting Palettes preferences” (page 404)
- “Setting Units preferences” (page 405)
- “Setting Transparency and Shading preferences” (page 405)
- “Setting Warnings preferences” (page 406)
- “Setting Auto Action preferences” (page 406)
- “Setting Miscellaneous preferences” (page 407)
- “Setting Manage tab preferences” (page 409)
- “Setting Auto-Preserve preferences” (page 409)
- “Setting workspace tab preferences” (page 410)
- “Setting performance preferences” (page 410)
- “Setting file format preferences” (page 411)
- “Setting file format associations” (page 413)
- “Setting file locations” (page 413)
- “Managing resources” (page 415)
- “Setting plug-in preferences” (page 416)
- “Selecting Web browsers” (page 417)
- “Setting Autosave preferences” (page 418)
- “Resetting all preferences” (page 418)
- “Switching languages” (page 419)
- “Adjusting general viewing options” (page 419)
- “Accessing tools and commands from previous versions of PaintShop Pro” (page 421)
- “Protecting and restoring the PaintShop Pro database” (page 421)
Viewing and hiding toolbars

You can choose which toolbars are displayed.

To select which toolbars are displayed

**Edit tab**
1. Click View ➤ Customize to display the Customize dialog box.
2. Click the Toolbars tab.
3. Mark the check box next to the name of the toolbar you want to display.

You cannot hide the Menu bar.

You can also open the Customize dialog box by right-clicking the Menu bar, Tool palette, or Tool Options palette, and choosing Customize.

Viewing and hiding tools

You can choose which tools are displayed by using the Quick Customize button on the Tools toolbar.

To hide or show tools in the Tools toolbar

1. On the Tools toolbar, click the Quick Customize button.
2. Mark the check box beside the name of the tools you want to show; unmark the check box beside the name of the tools you want to hide.
   - If you want to reset the toolbar to its original settings, click the Reset Toolbar button.

Using custom workspaces

The PaintShop Pro workspaces consist of tabs, palettes, toolbars, and open images. You may find that the way you arrange the workspace while editing photos may differ from the arrangement while using the Web tools. Fortunately, PaintShop Pro lets you save and use any number of workspace arrangements.

**Important!** Workspace files do not include an actual copy of any open images. Workspace files only reference the name and location of an image. If you delete an image from your computer, the image will not appear in the workspace.

Saving custom workspaces

When you save a workspace, PaintShop Pro saves the information in a PSPWorkspace file. The following information is stored:
- ruler, grid, and guide information
- menu, palette, and toolbar settings, locations, and docking status
- full screen edit mode status
- open images, including zoom levels and scroll bar locations

Loading workspaces

You can load a custom workspace. Tool, menu, and palette positions change to reflect the workspace you are loading.

If you had two windows open for the same image when you saved the workspace, they both open again. If an image from the workspace is already open, PaintShop Pro applies the workspace settings to the open image.
Deleting saved workspaces

If you no longer want to use a saved workspace, you can delete it.

To save the current workspace

1. Choose File ➤ Workspace ➤ Save.
   The Save Workspace dialog box appears.
2. In the New Workspace Name field, type a name for the new workspace.
3. Click Save.

If your workspace contains any modified images that you have not saved, you are prompted to save the changes to your image. To save the image changes and the workspace, click Yes. To save the workspace, but not the image changes, click No. To cancel saving the workspace and the image changes, click Cancel.

You can open the Save Workspace dialog box by pressing Shift + Alt + S.

You can save the workspace in a folder other than the program default folder, by clicking the File Locations button in the Save Workspace dialog box. For more information about editing paths, see “Setting file locations” on page 413.

To load a workspace

   The Load Workspace dialog box appears.
2. Click one of the following:
   • Yes — saves the current workspace before loading another one
   • No — does not save the current workspace before loading another one
3. Select the workspace file you want to load.
4. Click Load.

You can open the Load Workspace dialog box by pressing Shift + Alt + L.

You can load the workspace from a folder other than the program default folder, by clicking the File Locations button in the Load Workspace dialog box. For more information about editing paths, see “Setting file locations” on page 413.

You can also load a recently used workspace by choosing it from the list of recent workspaces located at the bottom of the File ➤ Workspace menu.

To delete a saved workspace

1. Choose File ➤ Workspace ➤ Delete.
   The Delete Workspace dialog box appears.
2. Select the workspace file you want to delete.
3. Click Delete.
You can open the Delete Workspace dialog box by pressing \texttt{Shift + Alt + D}.

**Customizing the menu system**

When you display the Customize dialog box, the entire PaintShop Pro workspace transforms into customize mode. You can choose which menus are displayed and how a menu opens when you select it. You can also reset the menus to the default settings.

**To animate the menu system**

\texttt{Edit tab}

1. Choose \texttt{View \rightarrow Customize}. The Customize dialog box appears.
2. Click the \texttt{Menu} tab.
3. In the \texttt{Select context menu} drop-list, select the menu that you want to modify.
4. From the \texttt{Menu animations} drop-list, choose one of the following animation styles for menu opening:
   - \texttt{None} — applies no animation effect
   - \texttt{Unfold} — opens the menu starting from its top-right corner to its bottom-left corner
   - \texttt{Slide} — opens the menu from top to bottom
   - \texttt{Fade} — gradually opens the entire menu, from a faded look to fully visible
5. Click \texttt{Close}.

**To reset the menus**

\texttt{Edit tab}

1. Choose \texttt{View \rightarrow Customize}. The Customize dialog box appears.
2. Click the \texttt{Menu} tab.
3. In the Application Frame Menus group box, click \texttt{Reset}.

**Customizing toolbars**

When you display the Customize dialog box, the entire PaintShop Pro workspace transforms into customize mode. You can click and drag almost any menu command or tool to any other menu or toolbar. You can add or delete commands from the menus on the Menu bar.

**To move a toolbar button**

\texttt{Edit tab}

- With the Customize dialog box displayed, drag the item to another toolbar.

**To add a command button to a toolbar**

\texttt{Edit tab}

1. Choose \texttt{View \rightarrow Customize}. The Customize dialog box appears.
2. Click the \texttt{Commands} tab.
3. From the Categories list, select a category.
   \textbf{Note}: PaintShop Pro groups related commands into categories. For example, click the \texttt{File} category to display all File menu commands.
   To list all PaintShop Pro commands at once, choose \texttt{All Commands}.
4. From the \texttt{Commands} list, drag a command to a toolbar.
To remove a command button from a toolbar
Edit tab
1. With the Customize dialog box displayed, drag the item to an empty workspace area or an empty area outside a toolbar.
2. Release the mouse button when you see the cursor change to this shape.

To reset all toolbars
Edit tab
1. Choose View ➤ Customize.
   The Customize dialog box appears.
2. Click the Toolbars tab.
3. Click Reset All.
   All toolbars revert to the default settings.

   You can reset a specific toolbar to its default settings by choosing it from the Toolbars list and clicking Reset.

   You can also open the Customize dialog box by right-clicking the Menu bar, Tool palette, or Tool Options palette, and choosing Customize.

   You can rearrange a button in relation to the separator by dragging the button to the desired location.

   You can also open the Customize dialog box by right-clicking the Menu bar, Tool palette, or Tool Options palette, and choosing Customize.

Creating custom toolbars

You can create a custom tool bar with your favorite commands and tools.

To create a custom toolbar
Edit tab
1. Choose View ➤ Customize.
   The Customize dialog box appears.
2. Click the Toolbars tab.
3. Click New.
   The Toolbar Name dialog box appears.
4. Type a name for the new toolbar, and click OK.
   A small, empty toolbar appears, and the new toolbar is added to the Toolbar list.
   Note: Drag the new toolbar off to the side of the Customize dialog box so you can see it better.
5. Click the Commands tab.
6. In the Categories list, click a menu.
7. From the Commands list, drag command icons to the new toolbar.
8. When you are finished adding commands, click Close.
You can add separator bars, if necessary, to place commands into desired groups. For more information about customizing toolbars, see “Customizing toolbars” on page 398.

You can also open the Customize dialog box by right-clicking the Menu bar, Tool palette, or Tool Options palette, and choosing Customize.

To delete a custom toolbar

Edit tab

1. Choose View ➤ Customize.
   The Customize dialog box appears.
2. Click the Toolbars tab.
3. In the Toolbars list, select the name of the custom toolbar you want to delete.
4. Click Delete.
5. Click Close.

Customizing keyboard shortcuts

You can view existing keyboard shortcuts, assign a keyboard shortcut to menu commands, bound scripts, and tools, and even modify keyboard shortcuts.

To view the default keyboard shortcut

Edit tab

1. Choose Help ➤ Keyboard Map.
   The Help Keyboard dialog box appears.
2. In the Category drop-list, select a category.
   Note: PaintShop Pro groups related commands into categories. For example, if you pick the File category, all the commands in the file menu are displayed. To list all commands at once, choose All Commands.
   The commands and their shortcut keys are displayed in the list, sorted by command name. Click any column heading (Command, Keys, or Description) to sort alphabetically by that column.
   You can print the list of the current category of shortcut keys by clicking the Print button on the toolbar of the Keyboard Map dialog box. You can also copy information about commands to the Clipboard by selecting information on the Keyboard Map and then clicking the Copy button.

To assign a keyboard shortcut

Edit tab

1. Choose View ➤ Customize.
   The Customize dialog box appears.
2. Click the Keyboard tab.
3. In the Category drop-list, select a category.
   Note: PaintShop Pro groups related commands into categories. For example, if you pick the File category, all the commands in the file menu are displayed. To list all commands at once, choose All Commands.
4. In the Commands list, select a command name.
   The description of the command and any assigned shortcut keys are displayed.
5. Click in the Press New Shortcut Key field.
6. Press the new keyboard shortcut you want to assign to the command.
The shortcut appears in the Press New Shortcut Key field. If the shortcut is already assigned to another command, a message is displayed above the field.

7 Click Assign.

8 Assign more shortcut keys, or click Close.

To modify a keyboard shortcut

1 Choose View ➤ Customize.

The Customize dialog box appears.

2 Click the Keyboard tab.

3 In the Category drop-list, choose the menu associated with the command, script, or tool for which you want to modify the keyboard shortcut.

4 In the Commands list, click the item for which you want to modify the keyboard shortcut.

5 In the Current Keys field, click the shortcut.

6 Click Remove.

7 Click inside the Press New Shortcut Key field so the cursor is blinking, and press the keyboard keys you want to assign as the new shortcut.

If the keyboard combination you entered is already assigned, a message is displayed above this field. If the keyboard combination is not assigned, “Assigned to: [Unassigned]” is displayed above the field.

8 Click Assign.

9 Click Close.

Setting Undo preferences

The Undo settings control some behavior of the Undo and Redo commands, as well as one option for the History palette.

To set Undo and Redo preferences

1 Choose File ➤ Preferences ➤ General Program Preferences.

2 From the left pane, choose Undo.

3 To enable PaintShop Pro to undo actions, mark the Enable the undo system check box.

   This enables you to set all the items in this area of the Undo page.

4 Perform one or more of the following tasks and click OK.

To Do the following

Set the amount of disk space undo and redo steps can use Mark the Limit undo/redo disk usage to check box, and type or set a value in the control.

Set the number of undo and redo steps for each open image Mark the Limit undo/redo to check box, and type or set a value in the control.

The default is 250.

Make the redo process faster Mark the Enable fast redo check box. This may slightly slow down the undo process, so if you rarely perform a redo, but use undo frequently, you may want to unmark this check box.

Set the number of non-undoable steps retained after the last non- Type or set a value in the Non-undoable steps in History Palette
Setting View preferences

The View settings lets you control some image window behaviors. You can choose how the image window and magnification level behave when you resize an image.

To set View preferences
Edit tab
Manage tab
1. Choose File ➤ Preferences ➤ General Program Preferences.
2. From the left pane, choose View.
3. Perform one or more of the following tasks and click OK.

Do the following

- **Resize an image window when you zoom in**
  - In the Zooming group box, mark the **Fit image to window when zooming in** check box.
  - The image window resizes to include as much of the image as will fit.

- **Resize an image window when you zoom out**
  - In the Zooming group box, mark the **Fit image to window when zooming out** check box.
  - The image window resizes to include as much of the image as will fit.

- **Automatically reset the magnification level to display an entire image on opening**
  - In the New images group box, mark the **Auto size** check box.

- **Automatically resize the image window when you resize an image**
  - In the After changing size group box, mark the **Fit window to image** check box.

- **Automatically reset the magnification level to display an entire image after resizing**
  - In the After changing size group box, mark the **Auto size** check box.

Setting Display and Caching preferences

You can change the display options for certain parts of the program. For example, you can change the appearance of tool cursors, reset the scaling quality of the Zoom, and set thumbnail sizes for the Effects Browser. You can also specify preferences for saving an image cache and setting a scratch disk.

Scratch disks

Setting a scratch disk (sometimes called a “swap disk”) enables the application to distribute operations across your main disk and a secondary disk. This extends the memory available to the application when working on several large files at one time. Your best option is to choose a drive on a second internal hard disk (SCSI, SSD, IDE, SATA) that has more than 500 MB of free space. Avoid using the main drive where the application is installed if possible. Removable drives are not supported and the configuration of the drive determines if it is available as a scratch disk.
**Important!** If you set your main drive as a scratch disk, ensure that you have more than 2 GB of free disk space. On some systems, using the main drive for a scratch disk causes performance issues. Unmark the scratch disk check box if this occurs.

**Display settings in Windows**

The Display settings in Windows affect PaintShop Pro and other applications on your computer system. PaintShop Pro is optimized for the 100% display option in Windows. If you see text cut off or elements of the user interface cut off (truncated), please check your Display settings in Windows (Control Panel ➤ Appearance and Personalization ➤ Display).

**To set Display and Caching preferences**

1. Choose File ➤ Preferences ➤ General Program Preferences.
2. From the left pane, choose Display and Caching.
3. Perform one or more of the following tasks, and click OK.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically use the last file format used to save an image</td>
<td>In the Presentation group box, mark the Re-use last type in file save-as dialog check box.</td>
</tr>
<tr>
<td>Hide Dropper tool color information</td>
<td>In the Presentation group box, unmark the Display all color dropper tooltips check box.</td>
</tr>
<tr>
<td>Use a crosshair cursor for all tool cursors</td>
<td>In the Presentation group box, mark the Use precise cursors check box. A crosshair cursor is displayed instead of the tool button shape.</td>
</tr>
<tr>
<td>Make a brush tool cursor reflect its size and shape</td>
<td>In the Presentation group box, mark the Show brush outlines check box.</td>
</tr>
<tr>
<td>Determine the rescaling quality for the Zoom tool</td>
<td>Adjust the Zoom / Rescaling Quality slider.</td>
</tr>
<tr>
<td>Set thumbnail sizes for the Effect Browser</td>
<td>In the Effect browser thumbnails group box, set or type a value in the Size (Pixels) control.</td>
</tr>
<tr>
<td>Save an image cache of your entire merged image</td>
<td>In the Caching group box, mark the Merged Image check box.</td>
</tr>
<tr>
<td>Save an image cache of all the layers below the active one</td>
<td>In the Caching group box, mark the Merged Below Active Layer check box.</td>
</tr>
<tr>
<td>Save an image cache of the merged image for each group</td>
<td>In the Caching group box, mark the Merged Group check box.</td>
</tr>
<tr>
<td>Save an image cache of all the group layers below the active one</td>
<td>In the Caching group box, mark the Merged Below Active Layer check box.</td>
</tr>
<tr>
<td>Set a scratch disk</td>
<td>In the Scratch disk group box, mark the Enable scratch disk check box and choose a disk from the drop-list.</td>
</tr>
</tbody>
</table>
Setting Palettes preferences

You can control the behavior of palettes, such as how palettes dock, as well as some properties of the Materials and Layers palettes. For more information about Layers palette settings, see “To modify the look of the Layers palette” on page 225.

To set Palettes preferences
Edit tab
Manage tab
1 Choose File ▶ Preferences ▶ General Program Preferences.
2 From the left pane, choose Palettes.
3 Perform one or more of the following tasks, and click OK.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the color mode in which to display color information</td>
<td>In the Materials palette group box, choose either the Display colors in RGB format option or Display colors in HSL format option. This determines how color information is displayed in the Materials palette and Dropper tool.</td>
</tr>
<tr>
<td>Set how color values are displayed in ToolTips or in a Color dialog box</td>
<td>In the Materials palette group box, choose either the Decimal display option or the Hexadecimal display option.</td>
</tr>
<tr>
<td>Set how paletted images display available colors in the Rainbow tab or in a Color dialog box</td>
<td>In the Materials palette group box, choose either Show rainbow picker or Show document palette. Note that this option only applies to images with 256 or fewer colors.</td>
</tr>
<tr>
<td>Show 16-bit color values in ToolTips</td>
<td>Mark the Display 16-bit values check box. Note that this option only applies to 16-bit images.</td>
</tr>
<tr>
<td>Make palettes undockable</td>
<td>In the Allow docking of group box, unmark check boxes for the palettes you want to make undockable.</td>
</tr>
<tr>
<td>Set whether palettes appear automatically</td>
<td>In the Automatically show palettes group box, choose one of the following: • Always — displays palettes appropriate to the tools and commands you are using. For example, if you perform a layers-related action, the Layers palette is displayed. • Never — displays palettes only when you choose to open them • With Learning Center — displays palettes appropriate to the topics accessed in the Learning Center palette. This is the default setting.</td>
</tr>
<tr>
<td>Set display options for the Layers palette</td>
<td>In the Layers palette group box, choose any of the following: • Tooltip thumbnails — sets the size at which a layer’s thumbnail appears in the tooltip • Palette thumbnails — displays a layer’s thumbnail within the palette. Mark this check box, and then set the desired size. • Right pane — displays a layer’s settings on the right side of the palette</td>
</tr>
</tbody>
</table>
Setting Units preferences

You can set ruler options and the default resolutions for images that do not contain resolution information, such as scanned images. You can also set snapping for vector coordinates and enable document-aware tool sizing that lets you set the maximum tool size relative to the document size.

To set Units preferences
Edit tab
Manage tab
1. Choose File ➤ Preferences ➤ General Program Preferences.
2. From the left pane, choose Units.
3. Perform one or more of the following tasks, and click OK.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose a unit of measurement for the rulers</td>
<td>In the Rulers group box, choose a unit of measurement option from the Display units drop-list.</td>
</tr>
<tr>
<td>Display rulers in black and white</td>
<td>In the Rulers group box, choose the Black on White option.</td>
</tr>
<tr>
<td>Display rulers in color</td>
<td>In the Rulers group box, choose the Toolbar colors option. The ruler color matches the toolbar color.</td>
</tr>
<tr>
<td>Snap vector objects to the pixel’s center</td>
<td>In the Vector coordinates group box, mark the Snap to center of pixel while moving check box.</td>
</tr>
<tr>
<td>Set the default resolution for images that do not contain resolution information</td>
<td>In the Default Resolution group box, choose the unit of measure from the drop-list and enter a value in the control.</td>
</tr>
<tr>
<td>Adjust the maximum tool size relative to the document size.</td>
<td>In the Tool size area, mark the Enable relative tool size check box, and set a percentage to adjust the maximum tool size relative to the document.</td>
</tr>
</tbody>
</table>

Setting Transparency and Shading preferences

You can choose the grid size and color scheme. You can also choose a color and opacity for the shaded areas that falls outside of the selected area when using the Crop tool.

To set Transparency preferences
Edit tab
Manage tab
1. Choose File ➤ Preferences ➤ General Program Preferences.
2. From the left pane, choose Transparency and Shading.
3. Perform one or more of the following tasks, and click OK.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customize grid colors</td>
<td>In the Grid group box, choose a color scheme from the Scheme drop-list, and click the color boxes to set the grid colors.</td>
</tr>
</tbody>
</table>
To
Do the following

Set the grid size
In the Grid group box, choose a size option from the Grid size drop-list.

To set Crop tool and Shading options

Edit tab
Manage tab
1 Choose File ▶ Preferences ▶ General Program Preferences.
2 From the left pane, choose Transparency and Shading.
3 In the Shading group box, mark the Enable crop shade area check box to activate shading outside the crop rectangle.
4 Click the Color box, and choose a shading area color.
5 Type or set a value in the Opacity control to set how opaque the shading area color is.
6 If you want the crop rectangle to appear every time you use the tool, mark the Automatically display crop rectangle check box.
7 If you want the floating crop toolbar to appear every time you use the tool, mark the Enable floating crop toolbar check box.

Setting Warnings preferences

You can control how warning dialog boxes are displayed.

By default, PaintShop Pro displays a warning dialog box whenever you are about to perform an operation that will result in the loss of information or one that cannot be applied to the image in its current state.

To set Warnings preferences

Edit tab
Manage tab
1 Choose File ▶ Preferences ▶ General Program Preferences.
2 From the left pane, choose Warnings.
3 Perform one or more of the following tasks, and click OK.

To
Do the following

Prevent a specific warning from appearing
Unmark the check box beside the warning description.

Prevent all warnings from appearing
Click Disable All.

Setting Auto Action preferences

You can automate actions that must be performed in order to further edit an image.

For example, some commands can be performed only on images with a bit depth of at least 8 bits per pixel. When you choose a command for an image with a bit depth lower than 8 bits per pixel, the Auto Actions dialog box appears with the message that the image must be converted to a higher bit depth in order to proceed with the command.

To set Auto Action preferences

Edit tab
Manage tab
1 Choose File ▶ Preferences ▶ General Program Preferences.
2 From the left pane, choose Auto Action.
3 Select an action from the Auto Action Prompt list, and choose one of the following options:
   • Never — prevents the action from happening
Note: Choosing **Never** makes certain menu commands inactive if the action is required to complete the command. Some items in the list do not have this option available.

- **Always** — performs the action silently without prompting you
- **Prompt** — asks if you want to perform the action

4. Click **OK**.

You can set all actions in the list to a certain option by clicking **Always All**, **Prompt All**, or **Never All**.

You can reset all the actions in the list to the default settings by clicking **Reset**.

**Setting Miscellaneous preferences**

You can control a variety of preferences on the Miscellaneous page of the Preferences dialog box.

**To set the number of files that appear in the Recent Files list**

1. Choose **File** ➤ **Preferences** ➤ General Program Preferences.
2. From the left pane, choose **Miscellaneous**.
3. Type or set a value in the **Recently used file list** control.

You must restart PaintShop Pro before the new settings take effect.

You can view the list by choosing **File** ➤ **Recent Files**.

**To set tolerance to background color when pasting a transparent selection**

1. Choose **File** ➤ **Preferences** ➤ General Program Preferences.
2. From the left pane, choose **Miscellaneous**.
3. Type or set a value in the **Tolerance to background color when pasting a transparent selection** control.

When you paste data as a transparent selection, PaintShop Pro adds it to the current image, defines it as a selection, and deselects all the pixels that match the current background color. The tolerance value you enter determines how closely the background color must match the transparent color for it to become transparent. The tolerance scale is 0% (only image pixels with a perfect match to the current background color are made transparent) to 100% (all image pixels are made transparent).

**To set Clipboard data preferences**

1. Choose **File** ➤ **Preferences** ➤ General Program Preferences.
2. From the left pane, choose **Miscellaneous**.
3. From the **Clipboard data on Exit** list, choose an option to determine how any information on the Clipboard is handled when you exit the program:
   - **Ask** — asks what you want to do with the Clipboard data
   - **Delete** — deletes Clipboard data when you exit the program
• **Leave** — leaves data in the Clipboard when you exit the program

**To redraw when you move an object**

**Edit tab**

**Manage tab**

1. Choose **File » Preferences » General Program Preferences**.
2. From the left pane, choose **Miscellaneous**.
3. Mark the **Force full window redraw when positioning image elements** check box.

The information in the active window is redrawn whenever you move objects in the image.

**To hide the program splash screen on startup**

**Edit tab**

**Manage tab**

1. Choose **File » Preferences » General Program Preferences**.
2. From the left pane, choose **Miscellaneous**.
3. Unmark the **Show splash screen when application starts** check box.

**To disable pressure support for puck-type pointing devices**

**Edit tab**

**Manage tab**

1. Choose **File » Preferences » General Program Preferences**.
2. From the left pane, choose **Miscellaneous**.
3. Mark the **Disable pressure support for puck-type pointing devices** check box.

**To enable preservation of brightness in resized images**

**Edit tab**

**Manage tab**

1. Choose **File » Preferences » General Program Preferences**.
2. From the left pane, choose **Miscellaneous**.
3. Mark the **Preserve image brightness when resizing** check box.

When this option is enabled, a resized image retains its overall perceived brightness. In certain cases, however, unmarking this check box may produce better results — for example, when you are reducing the size of a computer-generated image, such as a scanned line drawing.

**To set pen tablet interface**

**Edit tab**

**Manage tab**

1. Choose **File » Preferences » General Program Preferences**.
2. From the left pane, choose **Miscellaneous**.
3. In the **Pen tablet interface** area, choose one of the following options:
   - **WinTab**
   - **Real-Time Style (RTS)**

**Note:** The options are available only if you have the corresponding tablet installed on your computer. The option lets you set your preference when you have more than one type installed.
Setting Manage tab preferences
You can set controls for how image thumbnails that you access from the Manage tab appear, and you can specify formats and folders to exclude from viewing.

To set Manage tab preferences
Edit tab
Manage tab
1 Choose File ➤ Preferences ➤ General Program Preferences.
2 Click Manage in the list of categories on the left.
3 Perform one or more of the following tasks and click OK.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show photo ratings on thumbnails</td>
<td>In the Thumbnail images group box, mark the Show ratings with thumbnail images check box.</td>
</tr>
<tr>
<td>Show the image filename on thumbnails</td>
<td>In the Thumbnail images group box, mark the Show file name with thumbnail images check box.</td>
</tr>
<tr>
<td>Exclude specific file formats from appearing in the Manage tab</td>
<td>In the Excluded items group box, click the File format exclusions button. From the left side of the File Format Exclusions dialog box, mark the check boxes of the file formats you want to exclude. To mark all formats simultaneously, click Select All. To remove the check marks from all selected formats, click Remove All.</td>
</tr>
<tr>
<td>Specify folders to exclude from cataloging</td>
<td>In the Excluded items group box, click the Uncataloged Folders button. The Uncataloged Folders dialog box lists the folders that are currently not cataloged in the Manage tab. To add a folder to this list, click Add, and then use the Browse for Folder dialog box to select the folder. To allow a currently ignored folder to be cataloged, select the folder from the list, and click Delete. To reset the list of ignored folders to the default list, click the Reset to Default button.</td>
</tr>
</tbody>
</table>

💡 You can also open the Preferences dialog box by right-clicking anywhere inside the Thumbnails panel, and choosing Preferences from the context menu.

Setting Auto-Preserve preferences
You can set the program to always save a copy of your original (unedited) images in a clearly labeled backup folder. This feature essentially creates “digital negatives,” which can be accessed whenever you want to work with images in their original state.

To set Auto-Preserve preferences
Edit tab
Manage tab
1 Choose File ➤ Preferences ➤ General Program Preferences.
2 From the left pane, choose Auto-Preserve.
3 Mark the Enable Auto-Preserve check box.
Click OK.

To Do the following

Create copies of original images automatically when you first save them
In the dialog box that appears after you click Save, choose Yes - Do this every time. The original (unedited) image is copied to a Corel Auto-Preserve subfolder, which is automatically created within the folder in which you are saving the image.

Reopen the original image
In the Open dialog box or the Navigation palette to browse to the Corel Auto-Preserve subfolder that contains a copy of the original image. The Corel Auto-Preserve subfolder resides within the same folder in which original image was first saved.

Avoid creating copies of original images
In the dialog box that appears after you click Save, choose No - Save my images without preserving the original.

Setting workspace tab preferences
You can hide or show optional tabs for the current workspace. You can also choose which tab is open by default when you launch the application. For example, you can choose to display the content on Welcome tab or the Edit tab when the application opens.

To hide or show tabs and set the default tab
Edit tab
Manage tab
1 Choose File ➤ Preferences ➤ General Program Preferences. The Preferences dialog box appears.
2 Click Tabs in the list of categories on the left.
3 In the Visible Tabs area, mark the check boxes for the optional tabs you want to show.
4 Choose one of the following default tab options, and click OK.
   • Set Welcome as default — displays the Welcome tab content when you launch the program
   • Set Manage as default — displays the Manage tab content when you launch the program
   • Set Adjust as default — displays the Adjust tab content when you launch the program
   • Set Edit as default — displays the Edit tab content when you launch the program
   • Keep Last View — displays the tab you used before you closed the program in your last PaintShop Pro session

Setting performance preferences
By default, hardware acceleration is disabled. You can enable hardware acceleration to improve the performance of the Refine Brush.

To enable hardware acceleration
Edit tab
Manage tab
1 Choose File ➤ Preferences ➤ General Program Preferences. The Preferences dialog box appears.
2 Click Performance in the list of categories on the left.
3 Unmark the Disable Hardware Acceleration check box.
Setting file format preferences

In the File Format Preferences dialog box you can specify how PaintShop Pro handles images in the following formats:

- **General** — this tab lets you choose whether or not to auto-rotate images based on EXIF information, and lets you set options for RAW camera images.
- **Windows Metafile** — WMF is the Microsoft Windows native vector format.
- **Portable Network Graphics** — PNG is used for Web graphics. You can set preferences for opening and saving PNG files.
- **PostScript** — PaintShop Pro can read PostScript files (including multi-page files) through level 2 and open them as raster images. When converting, PaintShop Pro can anti-alias objects and retain transparency information.
- **RAW Graphics** — PaintShop Pro can read and save RAW graphics image formats. This format (which is not to be confused with RAW Camera Data images) is commonly used in graphics images in the scientific and computer gaming industries.

For a full list of supported file formats, see “Files supported by PaintShop Pro” on page 74.

What’s the difference between RAW camera data images and RAW (Graphics) file format images?

RAW camera data images contain unprocessed sensor data captured by high-end digital cameras from Canon, Fuji, Kodak, Minolta, Nikon, Olympus, and Pentax. The data from these images in no way resembles or responds like RAW graphics image data.

RAW graphics images are basic raster data format images with no compression, and may include an optional non-standard header which is not supported by PaintShop Pro. These graphics images are used primarily by game developers and by the scientific community. Game developers use RAW graphics images for custom image texturing, bumpmapping, and shading. The scientific community uses these images for custom application-based image analysis.

PaintShop Pro can create and edit RAW graphics images as well as provide conversion from standard formats (such as TIF, JPEG, or TGA) into the RAW graphics format.

You can correct the tint, or color cast, certain types of lighting may cause. For example, if the photo was shot indoors in fluorescent lighting, and the camera was set for outdoor lighting conditions, the photo may have a green color cast. In this case, you can choose an option that applies correction for a photo taken in fluorescent light.

To set General image preferences

**Edit tab**

1. Choose File ➤ Preferences ➤ File Format Preferences.
   The File Format Preferences dialog box appears.
2. Click the **General** tab.
3. Mark or unmark any of the following check boxes:
   - **Rotate images automatically upon opening using EXIF data** — when marked, images are rotated automatically according to EXIF orientation data. If unmarked, you must rotate your images manually.
   - **Open RAW images with Camera RAW Lab** — when marked, the **Camera RAW Lab** opens when you choose a RAW image.

To set WMF image preferences

**Edit tab**

1. Choose File ➤ Preferences ➤ File Format Preferences.
   The File Format Preferences dialog box appears.
2. Click the **Metafile / Import** tab.
3. In the **Load options** group box, choose one of the following options:
   - **Prompt for size and options each time a file is opened** — prompts you to choose settings for each WMF image you open
   - **Use file header information when available** — uses the file header default size. If you open a file without a header, the size defaults to the values you type in the **Default size when file header is not available** group box.
4. Click OK.
You can also

Import WMF vector data as objects you can edit with vector tools

Mark the Import vector data check box.

Smooth curved polylines (vector data only)

Mark the Apply smoothing check box.

To set PNG preferences

Edit tab

Manage tab

1. Choose File ➤ Preferences ➤ File Format Preferences.
   The File Format Preferences dialog box appears.

2. Click the PNG tab.

3. Choose one of the following options:
   • Load and Save transparency to/from layer transparency
   • Load and Save transparency to/from alpha channel

To set PostScript file import preferences

Edit tab

Manage tab

1. Choose File ➤ Preferences ➤ File Format Preferences.
   The File Format Preferences dialog box appears.

2. Click the PostScript tab.

3. Unmark the Prompt for size and options each time a PostScript file is opened check box.

4. Set or type a value in the Resolution control.

5. Choose a page size option from the Page size drop-list.

6. Choose an image mode option from the Image mode drop-list.

7. Click OK.

You can also

Choose to be prompted to set options every time you open a PostScript file

Mark the Prompt for size and options each time a PostScript file is opened check box.

Switch the page orientation to landscape

Mark the Landscape check box.

Anti-alias PostScript objects as they are converted to raster images

Mark the Anti-aliasing check box.

Use a white background instead of the default transparent background

Mark the Render transparency check box.

By default, if a PostScript file has a bounding box, the program matches the canvas size to the bounding box.

To set RAW file preferences

Edit tab

Manage tab

1. Choose File ➤ Preferences ➤ File Format Preferences.
The File Format Preferences dialog box appears.

2 Click the **RAW (Graphics)** tab.

3 In the **Save options** group box, type or set a value in the **Header size** control to set the header size of the file.

4 In the **24 bit options** group box, choose one of the following color order options:
   - **RGB order**
   - **BGR order**

5 Choose one of the following color order options:
   - **Planar mode** — stores the color data in separate 8-bit planes
   - **Interleaved** — stores pixels contiguously

You can flip the image upside down by marking the **Flip top and bottom** check box.

### Setting file format associations

File format associations control how PaintShop Pro interacts with many types of file formats. For a full list of supported file formats, see “Files supported by PaintShop Pro” on page 74.

#### Adding and removing file format associations

You can have certain file formats automatically open in PaintShop Pro. For example, when you associate the JPEG file format with PaintShop Pro, all JPEG files open in PaintShop Pro when you double-click them from the Windows desktop. The associated JPEG files also display PaintShop Pro icons.

#### Changing file format extensions

File format extension changes do not take effect until the next time you start PaintShop Pro. File extensions that have been associated with PaintShop Pro will have an asterisk (*) after the name.

#### What if I want to open a file in another program?

When you associate a file format with PaintShop Pro, you can still open the file in other programs by using the Open command in the program of your choice.

**To associate a file format with PaintShop Pro**

1 Choose **File ➤ Preferences ➤ File Format Associations**.

   The Windows Set associations for a program page appears.

2 Mark the check boxes for the options you want.

3 Click **Save**.

### Setting file locations

PaintShop Pro resources include such items as scripts, picture tubes, patterns, gradients, displacement maps, and workspaces. The full listing of resources is displayed along the left side of the File Locations dialog box. PaintShop Pro saves and searches for resources in several default folders on your computer. By changing File Locations preferences, you can change where PaintShop Pro looks for and saves these resources. You can also control how plug-ins are used and which Web browsers are used to preview your images.

By default, all new files you create are saved in the appropriate subfolder in the ...Documents\Corel PaintShop Pro\2023 folder. Most default program resources are stored in the appropriate folder in the path X:\Program Files\Corel\Corel PaintShop Pro 2023 (64-bit), where “X” indicates the drive on which PaintShop Pro is installed.
You can add or delete folders for PaintShop Pro to store and retrieve the various resources. Deleting a folder means that PaintShop Pro no longer looks in the folder for any items. The folder, however, is not deleted from your computer.

You can also change the file location for specific resources.

**To change file locations for resources**

**Edit tab**

1. Choose **File ▶ Preferences ▶ File Locations**.
   
The File Locations dialog box appears.

2. From the file types list, select the resource that you want to change file locations for.
   
The default folders where the specified resource can be saved to are listed on the right side of the dialog box.

3. Click **Add**.
   
The Browse Folder dialog box appears.

4. Navigate to the folder you want to add, and click **OK**.

5. In the **Folder options** group box, mark the **Enable** check box.
   
   If you want to enable the folder’s subfolders, mark the **Use sub folders** check box.
   
   **Note:** When these check boxes are unmarked, PaintShop Pro cannot search for folders and their subfolders.

6. From the Save to drop-list, choose the folder in which you want the current resource saved.

7. Click **OK** to save your settings and return to PaintShop Pro.

---

**To add file locations for resources**

**Edit tab**

1. Choose **File ▶ Preferences ▶ File Locations**.
   
The File Locations dialog box appears.

2. From the **File types** list, select the resource file type for which you want to add locations.

3. Click **Add**.
   
The Browse for Folder dialog box appears.

4. Click the **Create a New Folder** button and then enter the name for the new folder.

5. Click **OK** to add the new folder to the list.

6. Click **OK** to close the File Locations dialog box.

---

The Cache and CMYK Profiles resource file types can have only one location. You can only change the file location from one folder to another. For more information on changing file locations, see “Setting file locations” on page 413.

---

You can open the File Locations dialog box by clicking the **File Locations** button which appears in many PaintShop Pro dialog boxes.
To delete file locations for resources

Edit tab
Manage tab

1 Choose File ➤ Preferences ➤ File Locations.
   The File Locations dialog box appears.
2 From the File types list, select the resource file type that you want to delete file locations for.
3 In the list of folders, select the folder you want to delete.
4 Click Remove.
5 Click OK.

You can open the File Locations dialog box by clicking the File Locations button, which appears in many PaintShop Pro dialog boxes, as well as in the Presets drop-list (located in the Tool Options palette) for tools.

Managing resources

PaintShop Pro resources include such items as scripts, picture tubes, patterns, gradients, displacement maps, and workspaces. The full listing of resources is displayed along the left side of the File Locations dialog box. Using a consistent method for managing these resources can make your workflow easier. This is where the Resource Manager dialog box comes in.

Wherever you find a Presets control, such as in the Tool Options palette, or in the Presets drop-list in an effects dialog box, you can access the Resource Manager dialog box.

You can delete, rename, copy, and move resources. You can also create your own resource categories.

To access the Resource Manager dialog box

Edit tab
- Click a Presets control, and click the Resource Manager button.

To delete a resource

Edit tab
1 Click a Presets control, and click the Resource Manager button.
2 If necessary, from the Category drop-list choose the category where the resource resides.
3 Click the resource from the list.
4 Click Delete.

To rename a resource

Edit tab
1 Click a Presets control, and click the Resource Manager button.
2 If necessary, from the Category drop-list choose the category where the resource resides.
3 Click the resource from the list.
4 Click Rename.
   The Rename Resource dialog box appears.
5 Type the new name for the resource, and click OK.

To copy a resource to another location

Edit tab
1 Click a Presets control, and click the Resource Manager button.
2 If necessary, from the Category drop-list choose the category where the resource resides.
3 Click the resource from the list.

4 Click **Copy**.
   
The Save As dialog box appears.
   
   **Note:** At this point, you can also rename the file by typing a new name in the **File Name** field.

5 Navigate to the folder where you want to move the resource and click **Save**.
   
   **Note:** You cannot copy a resource without renaming it to a folder currently being scanned using the File Locations dialog box.

### To move a resource to another location

**Edit tab**  

1 Click a Presets control, and click the **Resource Manager** button ➤.  
2 If necessary, from the **Category** drop-list choose the category where the resource resides.
3 Click the resource from the list.
4 Click **Move**.  
The Browse for Folder dialog box appears.

5 Navigate to the folder where you want to move the resource, and then click **OK**.
   
   **Note:** The folder to which you move the resource must be listed in the File Locations dialog box for the resource to appear in the visual resource drop-list and in the Resource Manager dialog box. For information about setting file locations, see “Setting file locations” on page 413.

### To create a resource category

**Edit tab**  

1 Choose **File ➤ Preferences ➤ File Locations**.
   
The File Locations dialog box appears.

   2 In the File types list on the left side of the dialog box, click the resource for which you want to create a new category folder.
   3 In the folders list, click the folder under which the custom category subfolder will reside.
   4 In the Folder Options group box, mark the **Enable** and **Use sub folders** check boxes.

5 Click **Create Sub Folder**.  
The Enter Name dialog box appears.

6 Type a name for the custom category subfolder, and click **OK** to close the Enter Name dialog box.

7 Click **OK**.

   To have the new category appear in the Categories drop-list, you must first save, copy, or move a resource to the folder you created.

### Setting plug-in preferences

With PaintShop Pro, you can use plug-ins that provide compatibility with Adobe Photoshop files. The most common plug-in filename extension is `.8B*`. You can choose to limit the use of plug-ins to those having the `.8B*` filename extension, or you can choose to use plug-ins having any filename extension.

### To enable plug-ins

**Edit tab**  

1 Choose **File ➤ Preferences ➤ File Locations**.
   
The File Locations dialog box appears.

   2 From the File types list, select **Plug-ins**.
   3 Mark the **Enable plug-ins** check box.
You can also

Load plug-ins with any extension

Open the file in the plug-in before it opens in PaintShop Pro

Unmark the Limit Loaded plug-in files to those with an .8B* extension check box.

Mark the Allow file format plug-ins to request pre-filtering of support file types check box.

To add plug-in locations

Edit tab
Manage tab
1 Choose File ➤ Preferences ➤ File Locations.
   The File Locations dialog box appears.
2 From the File types list, select Plug-ins.
3 Click Add.
   A new blank item appears in the folder list, and the Browse for Folder dialog box appears.
4 Navigate to the folder you want to add, and click OK to return to the File Locations dialog box.
5 In the Folder options dialog box, mark the Enable check box.
6 Click OK.

You can also add any subfolders stored in the plug-in folder you add by marking the Use sub folders check box.

Selecting Web browsers

PaintShop Pro lets you preview your images with Web browsers. You can add, change, or delete Web browsers.

To add Web browsers

Edit tab
Manage tab
1 Choose File ➤ Preferences ➤ File Locations.
   The File Locations dialog box appears.
2 From the File types list, select Web Browsers.
3 Click Add.
   The Browser Information dialog box appears.
4 Click Browse.
   The Web Browser Path dialog box appears.
5 Navigate to the folder containing the Web browser executable file (with the filename extension .exe), and click Open.
6 Click OK.

To change Web browsers

Edit tab
Manage tab
1 Choose File ➤ Preferences ➤ File Locations.
   The File Locations dialog box appears.
2 From the File types list, select Web Browsers.
3 Select a browser from the list.
4 Click Edit.
To delete Web browsers

Edit tab
Manage tab
   The File Locations dialog box appears.
2. From the File types list, select Web Browsers.
3. Select a browser from the list.
4. Click Delete to remove the browser from the list.
5. Click OK.

To set the autosave preferences

Edit tab
Manage tab
   The Autosave Settings dialog box appears.
2. Do any of the following:
   • Click the Adjust tab and mark the Save edits to the current image automatically when the next image is selected check box.
   • Click the Edit tab, mark the check box for Auto-Recover, and type or set a value in the minutes control.
3. Click OK.

To find out where PaintShop Pro saves the Auto-Recover files, choose File ➤ Preferences ➤ File Locations and select the Undo/Temporary Files folder from the File Type list.

Resetting all preferences

You can revert various program preferences back to their defaults.

To reset application preferences

Edit tab
Manage tab
1. Choose File ➤ Preferences ➤ Reset Preferences.
The Reset the Application dialog box appears.

2 Mark any of the following check boxes:
• Reset general preferences — resets all general program preference settings to the program defaults
• Reset file locations — resets all file location settings to the program defaults
• Reset workspace to default configuration — resets the current workspace to the program defaults
• Reset dialog box positions and last used settings — resets dialog boxes so they appear in their default positions and use default settings
• Delete all cache files — deletes all existing cache files
• Make all toolbars/palettes visible and on screen — makes all toolbars and palettes visible

3 Click OK.

You can reset the entire application to its default state by holding down Shift while launching the program. All customization is cleared when you reset the program.

Switching languages
You can change the language that is displayed in PaintShop Pro. This option can be helpful for international or multilingual users, or for users sharing a workstation in an international corporate environment.

To switch the application language
Edit tab
Manage tab
1 Choose File ▶ Preferences ▶ Switch Language.
   The Switch Language dialog box appears.
2 Select the desired language from the drop-list.
   Note: This feature does not support switching between languages with single-byte character sets (such as English, German, and French) and languages with double-byte character sets (such as Chinese Simplified, Chinese Traditional, and Japanese).
3 Click OK.
4 In the message box that notifies you to restart the application, click OK.
   The selected language is displayed after the application is restarted.

Adjusting general viewing options
You can customize how PaintShop Pro displays icons, screen tips, captions, scrollbars, nodes (sometimes called “handles”), and make it easier to see lines and bounding boxes that appear on screen when you are working with tools. You can also adjust the size of application text.

To quickly adjust user interface options
1 On the menu bar, click User Interface, and choose any of the following options:
   • Icon Size
   • Text Size
   • Scroll Bar Size
   • Node Size
2 Choose the setting you want from the submenu.

To set toolbar view options
Edit tab
1 Choose View ▶ Customize.
The Customize dialog box appears.

2 Click the Options tab.

3 In the Toolbar area, mark any of the following check boxes:
   • Show ScreenTips on toolbars — displays the screen tips that appear over tools and buttons
   • Show shortcut keys in ScreenTips — displays the shortcut keys (if available) that appear in screen tips

4 In the Icons area, mark any of the following check boxes:
   • Show color icons — mark to show color icons; unmark to show grayscale icons
   • Show small icons — mark to decrease the size of the icons; unmark to display the icons at the default size

5 In the Personalized Menus and Toolbars group box, mark any of the following check boxes:
   • Menus show recently used commands first — simplifies menus to show only recently used commands
   • Show full menus after a short delay — displays all menu items after a delay if the Menus show recently used commands first check box is marked

You can erase the memory of your recently used menu commands by clicking Reset my usage data.

To adjust the size of scroll bars

1 Choose View ➤ Customize.
   The Customize dialog box appears.

2 Click the Options tab.

3 In the Scroll Bars area, enable the Small, Medium, or Large option.
   If you want the scroll bar handle to increase in size when you position a pointer over it, mark the Auto enlarge on hover.

To adjust the size of nodes

1 Choose View ➤ Customize.
   The Customize dialog box appears.

2 Click the Options tab.

3 In the Node Size area, enable Small, Medium, or Large.

You can adjust the size of nodes (Small on left; Large on right). Nodes are used to adjust layers, vectors objects, Pen tool lines, and more.

To increase the visibility of lines and bounding boxes

1 Choose View ➤ Customize.
   The Customize dialog box appears.

2 Click the Options tab.

3 In the Lines and Bounding Boxes area (you might need to scroll down to view the area), mark the Increase visibility with pointer proximity check box.

4 In the Proximity (pixels) box, type a value to determine how close the pointer needs to be to a line or bounding box in order to activate the visibility enhancement.
Accessing tools and commands from previous versions of PaintShop Pro

You can access and restore tools and commands that have been removed from the workspace. These commands were removed to accommodate improved features and functionality.

To access tools and commands from previous versions of PaintShop Pro

**Edit tab**

1. Choose **View ➤ Customize**.
   The Customize dialog box appears.
2. In the **Commands** tab, perform a task from the following table and click **Close**.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add commands</td>
<td>In the Categories list, click <strong>Unused Commands</strong>, find the command you want, and drag it to a menu.</td>
</tr>
<tr>
<td>Add tools</td>
<td>In the Categories list, click <strong>Tools</strong>, choose the tool you want, and drag it to the Tools toolbar.</td>
</tr>
</tbody>
</table>

Protecting and restoring the PaintShop Pro database

The database for your application stores information about your photo library and makes it easier to search for photos. If the database is damaged, it can affect the performance of PaintShop Pro. Please note that your photos are safe, but a damaged database can result in the loss of customized photo data, such as ratings, tags, and caption text.

To protect your database, you can create a backup file. In the event the database is damaged, you can reset the database and import your backup file.

Please note, JPEG photo data from Corel PaintShop Photo Pro is imported into the 2023 database when you browse folders. For more information about browsing folders, see “Getting photos into PaintShop Pro” on page 53.

To backup the application database

1. Save your work.
2. Click **File ➤ Database Backup ➤ Export**.
   You will be prompted to close the application. A backup database file is created. Restart the application.

To reset the application database

1. Ensure that the application is closed.
2. From the Windows Start menu, choose **All Programs ➤ PaintShop Pro ➤ Restore Database**.

   If your version of the application does not include the **Restore Database** utility, you can reset your database manually by closing the application, and deleting the Database folder in the following location: C:\Users\[user name]\###\AppData\Local\Packages \CorelCorporation.[…your version of PaintShop Pro]\LocalCache\Local\Corel PaintShop Pro\version number\Database.

To import your application database backup

1. Save any open work.
2. Click **File ➤ Database Backup ➤ Import**.
   You will be prompted to close the application. The backup database file is imported when you restart the application.
Importing content and plugins from previous versions

You can import content that you’ve saved to the default locations for the last three versions of PaintShop Pro. For example, you can migrate plugins, scripts, brush tips, color palettes, gradients, patterns, textures, and effects that you’ve previously installed.

To import content and plugins from previous versions of PaintShop Pro

• Click File ➤ Import ➤ Content From Previous Versions.
PaintShop Pro lets you open and edit photos captured with a 360° camera. You can correct and adjust 360° photos before you upload them to a site that supports 360° viewing. You can also convert a 360° photo to a standard image and apply fun Planet Effects or create a panorama-style image.

This section presents the following topics:
- “What you need to know about 360° photos” (page 423)
- “Removing a tripod from a 360° photo” (page 423)
- “Straightening 360° photos” (page 424)
- “Correcting or applying effects to 360° photos” (page 425)
- “Applying Planet Effects to 360° photos” (page 425)
- “Creating a panorama-style image from 360° photos” (page 426)

What you need to know about 360° photos

What you need to know:
- The 360° Photo window is designed to work with photos captured with a 360° camera (not designed for 360° images constructed in other ways).
- There is no standard for the 360° metadata that 360° camera includes with your images. Google 360° metadata is the most commonly used by camera manufacturers and this is what PaintShop Pro uses to recognize 360° images.
- In PaintShop Pro, only the Adjust and Effects menu items are recommended for editing 360° photos. Even within these menus, any adjustments or effects that distort the image will affect the integrity of the final image.

Removing a tripod from a 360° photo

You can remove a tripod, hand, or other device used to hold your 360° camera, from your 360° photos. A content-aware fill feature, Magic Fill, is used to sample the background and make the selected area disappear.

Magic Fill is a content-aware feature that can make unwanted elements of your photos vanish.
The Freehand Selection tool was used to loosely enclose the area with the tripod. Magic Fill uses content-aware technology to remove the tripod from the photo.

To remove a tripod from a 360° photo
1. In PaintShop Pro, open a photo that was captured with a 360° camera.
   A message appears that lets you choose between editing in the 360° Photo window and the Adjust or Effect menu on the Edit tab.
2. Click Edit in 360° Photo.
3. In the 360° Photo window, click Remove Tripod.
4. In the Position area, an option.
5. In the Selections tools area, choose a selection tool.
6. Drag in the preview area to enclose the area that you want to remove. You don’t have to be very precise, you can include some surrounding area in the selection.
7. Set the Feather value to determine how the edges of the fill will blend with the background.
8. Click Magic Fill. If you need to fine-tune, you can repeat the selection and Magic Fill steps.
9. Click Save As, and save your file to a new file name and choose the original file format. Close the 360° Photo window to return to the main application window.

Straightening 360° photos
You can level a 360° photo in PaintShop Pro.

The onscreen straightening overlay consists of a central cross-hair, two leveling lines, and an interactive rotation circle.

To straighten a 360° photo
1. In PaintShop Pro, open a photo that was captured with a 360° camera.
   A message appears that lets you choose between editing in the 360° Photo window and the Adjust or Effect menu on the Edit tab.
2. Click Edit in 360° Photo.
3. In the 360° Photo window, click Straighten.
4. In the preview window, drag the image to center a reference point for your horizon line within the onscreen straightening overlay. Use the cross-hair as your centering point. You can also use any of the following controls:
   • Pan — Lets you move right and left along the x-axis
   • Tilt — Lets you move up and down along the y-axis
Field of view — Lets you adjust how close the camera appears from the scene (effect is similar to zoom)

5 To rotate the image, drag on the circular overlay or adjust the Rotate slider in the panel on the right.

6 Click Save As, and save your file to a new file name. Close the 360° Photo window to return to the main application window.

Correcting or applying effects to 360° photos

Important! It is recommended that you use correction or special effect filters from the Adjust and Effect menu only. Editing 360° photos outside these menus can effect the 360° data that your photo must retain if you want to share it on a 360° photo viewing site.

Photos captured with 360° cameras can often benefit from a number of common corrections to fix exposure, white balance, sharpness, purple fringe, contrast, and color.

You can also apply effects, such as popular Photo Effects filters: Black and White Film, Sepia Toning, and Retro Lab.

Several color, noise, and exposure filters from the Adjust menu were used to improve the 360° photo.

To apply a correction or effect filter to a 360° photo

1 In PaintShop Pro, open a photo that was captured with a 360° camera.

   A message appears that lets you choose between editing in the 360° Photo window and the Adjust or Effect menu on the Edit tab.

2 Click the Adjust/Effects button.

3 From the main Edit tab, choose the filter you want from the Adjust or Effect menu.

4 When you are finished editing the image, it is recommended that you save to a new file name.

Applying Planet Effects to 360° photos

You can transform your 360° photos into tiny planet-style images or rabbit hole-style images by applying Planet Effects. Sometimes referred to as spherical panorama, these effects essentially wrap the bottom edge (to create a tiny planet) or top edge (to create a rabbit hole tunnel) of a 360° image into a spherical shape.

Important! Applying Planet Effects removes the 360° metadata from images, so it is important to save your new image to a new file name to preserve the original photo.
To apply a planet effect to a 360° photo

1. In PaintShop Pro, open a photo that was captured with a 360° camera.
   A message appears that lets you choose between editing in the 360° Photo window and the Adjust or Effect menu on the Edit tab.
2. Click Edit in 360° Photo.
3. In the 360° Photo window, click Planet Effects.
4. In the Effects area, choose one of the following:
   • Tiny planet: Uses the bottom edge of the image as the center of the sphere
   • Rabbit hole: Uses the top edge of the image as the center of the sphere
5. Adjust the Rotate slider to determine the rotation of the sphere.
6. Adjust the Field of View slider to set the camera position for the scene (similar to zoom).
7. Choose an Aspect ratio setting for the image.
8. Click Save As, and save your file to a new file name. Close the 360° Photo window to return to the main application window.

Creating a panorama-style image from 360° photos

You can create panorama-style images from 360° photos by applying the 360°-to-Panorama effect. The effect works by projecting the 360° photo to a flat surface using popular mapping projections: Equirectangular and Mercator.

Important! Applying 360°-to-Panorama removes the 360° metadata from images, so it is important to save your new image to a new file name to preserve the original photo.
To create a panorama-style image from a 360° photo

1. In PaintShop Pro, open a photo that was captured with a 360° camera.
   A message appears that lets you choose between editing in the 360° Photo window and the Adjust or Effect menu on the Edit tab.
2. Click Edit in 360° Photo.
3. In the 360° Photo window, click 360°-to-Panorama.
4. In the Projection area, choose Equirectangular or Mercator. Experiment to see which one provides the results you like best.
5. Ensure the Crop check box is enabled, and drag in the preview area to set the crop box.
6. Adjust the Horizontal Shift slider to display the area of the image that you want to capture.
7. Click Save As, and save your file to a new file name. Close the 360° Photo window to return to the main application window.
Automating tasks

PaintShop Pro has many time-saving automation features. You can use scripts to automate an action or set of actions, and presets to save dialog box or tool settings for later use. You can also perform the same action to a number of images at the same time.

This section presents the following topics:
- “Scripting basics” (page 429)
- “Working with scripting tools and features” (page 430)
- “Recording and saving a script” (page 431)
- “Running saved scripts” (page 433)
- “Stopping or undoing a script” (page 434)
- “Editing scripts in Corel PaintShop Pro” (page 435)
- “Editing scripts using a text-editing application” (page 436)
- “Troubleshooting a script” (page 436)
- “Assigning icons to scripts” (page 437)
- “Using and creating presets” (page 437)
- “Processing files in batches” (page 439)
- “Renaming files in batches” (page 440)

Scripting basics

Scripts are a series of commands that you record and play back. This can be a great time-saver, because instead of having to make the changes to each image, you simply have to play back the script. The commands you recorded in the script are performed on the image.

PaintShop Pro has a full-featured scripting engine based on the Python programming language. You can get more information on this language at [www.python.org](http://www.python.org). Although you can write your own scripts using Python syntax, PaintShop Pro has a built-in script recorder that can do this work for you, allowing you to script almost any action within the application.

If, however, you choose to write a script in the Python language, note that Python uses indentation to determine scoping, so you must be very careful about mixing spaces and tabs. We recommend that you use a Python-aware editor such as PythonWin or Idle if you choose to write your own scripts.

Scripting resources

PaintShop Pro provides the following scripting resources:
- **Command API** — an HTML-based resource that helps you add PaintShop Pro commands and parameters to the scripts that you write.
- **Scripting Guide** — a PDF guide that provides information about scripting for PaintShop Pro. Definitions, example scripts, and command and parameter information helps you become familiar with scripting.
• **Sample scripts** — referenced in the Scripting Guide, the sample scripts are provided to give you some examples that you can learn from and build on.

## Working with scripting tools and features

You can find most scripting commands both in the **File ➤ Script** submenu and on the **Script** toolbar. You’ll find it much easier and faster working with scripts using the Script toolbar. Some commands, however, are accessible only using the menu.

The following table describes the buttons on the Script toolbar.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="Select Script drop-list" /></td>
<td>The <strong>Select Script</strong> drop-list lets you choose the scripts saved in the <strong>Scripts-Trusted</strong> and <strong>Scripts-Restricted</strong> folders.</td>
</tr>
<tr>
<td><img src="Image" alt="Run Selected Script button" /></td>
<td>The <strong>Run Selected Script</strong> button lets you run the script displayed in the <strong>Select Script</strong> drop-list.</td>
</tr>
<tr>
<td><img src="Image" alt="Run Multiple Scripts button" /></td>
<td>The <strong>Run Multiple Scripts</strong> button opens the Run Multiple Scripts dialog box so you can choose scripts from a list and run them in sequence.</td>
</tr>
<tr>
<td><img src="Image" alt="Edit Selected Script button" /></td>
<td>The <strong>Edit Selected Script</strong> button opens the Script Editor so you can edit the script displayed in the <strong>Select Script</strong> drop-list.</td>
</tr>
<tr>
<td><img src="Image" alt="Toggle Execution Mode button" /></td>
<td>The <strong>Toggle Execution Mode</strong> button lets you switch between Silent and Interactive mode when running scripts. When the button shows a border, it is set to Interactive mode.</td>
</tr>
<tr>
<td><img src="Image" alt="Run Script button" /></td>
<td>The <strong>Run Script</strong> button lets you navigate to and select the script you want to load.</td>
</tr>
<tr>
<td><img src="Image" alt="Stop Script button" /></td>
<td>The <strong>Stop Script</strong> button lets you stop the running script.</td>
</tr>
<tr>
<td><img src="Image" alt="Start Script Recording button" /></td>
<td>The <strong>Start Script Recording</strong> button lets you begin recording actions that will comprise a script.</td>
</tr>
<tr>
<td><img src="Image" alt="Pause Script Recording button" /></td>
<td>The <strong>Pause Script Recording</strong> button lets you pause the recording of a script. You can click it again to resume recording.</td>
</tr>
<tr>
<td><img src="Image" alt="Cancel Script Recording button" /></td>
<td>The <strong>Cancel Script Recording</strong> button lets you cancel script recording.</td>
</tr>
<tr>
<td><img src="Image" alt="Save Script Recording button" /></td>
<td>The <strong>Save Script Recording</strong> button lets you stop recording a script and prompts you to save it.</td>
</tr>
</tbody>
</table>

To display the Script toolbar

**Edit tab**

• Choose **View ➤ Toolbars ➤ Script**.
To access a script command from a menu
Edit tab
• Choose File ➤ Script, and choose a script command.

You can only choose the Clear Output Window and Single Step commands from the menu. You can, however, add those commands to the Script toolbar. For more information, see “Customizing toolbars” on page 398.

To display the Script Output palette
Edit tab
• Choose View ➤ Palettes ➤ Script Output.

The Script Output palette displays information such as previously-used commands, Python syntax errors, or runtime errors.

To clear the Script Output palette
Edit tab
• Choose File ➤ Script ➤ Clear Output Window.

You can also clear a script by right-clicking the Script Output palette, and choosing Clear from the context menu.

Recording and saving a script

Scripts are particularly useful for tasks with many steps. Most actions you can perform in PaintShop Pro are scriptable; however, be aware of the following guidelines:
• You cannot script user interface customizations, CMYK profile creation or editing, operations outside the Edit tab, operations inside of Print Layout, or gradient creation.
• You cannot script the floating, docking, or arranging of toolbars, palettes, and windows.
• You can script Materials palette and Mixer palette operations, as well as Tool Options palette selections, but you cannot record them. To script these actions, you must use a text editor application.
• Only plug-ins that support scripting are scriptable.
• Outside of the above restrictions, most actions you perform in PaintShop Pro are scriptable.

Before you start recording a script, it’s a good idea to write down the specific actions you want to record. Ideally, your actions should be as efficient as possible.

Restricted and trusted scripts

The scripts in PaintShop Pro are created in the Python programming language, which can unfortunately also be used to create and execute malicious scripts. Because of this potential danger, PaintShop Pro includes two folders, automatically created in two locations during installation, each folder containing script files of distinct modes. These folders are
• Scripts-Restricted — contains scripts that do not reside in a trusted folder
• Scripts-Trusted — contains any trusted scripts

These folders reside inside the following paths:
• %Program Files%\Corel\Corel PaintShop Pro 2023 (64-bit)\Languages\[language code]
• In your user folder, ...\Documents\Corel PaintShop Pro\2023

When you create and save a script for the first time, you’re directed to save the script in the appropriate path in ...\Documents\Corel PaintShop Pro\2023. After that, you’ll be directed to save to the most recently used folder.
When the application searches for scripts, restricted scripts are searched before trusted scripts.

Here are some considerations about restricted scripts:
- If a script is run from an unconfigured path, it is treated as restricted.
- If a path appears in both the restricted and trusted lists, it is treated as restricted.
-Presets, Material palette swatches, and Print Layout templates (which are essentially scripts) are treated as restricted.

**Commands that cannot be used in a restricted script**

Some commands cannot be run from a script stored in the Scripts-Restricted folder. The table below lists a number of these commands. If you want to run a script that contains any of these commands, you must move it to the Scripts-Trusted folder.

<table>
<thead>
<tr>
<th>Command</th>
<th>Menu location</th>
</tr>
</thead>
<tbody>
<tr>
<td>FileSave</td>
<td>File ▶ Save</td>
</tr>
<tr>
<td>FileSaveAs</td>
<td>File ▶ Save As</td>
</tr>
<tr>
<td>FileSaveCopyAs</td>
<td>File ▶ Save Copy As</td>
</tr>
<tr>
<td>GIFExport</td>
<td>File ▶ Export ▶ GIF Optimizer</td>
</tr>
<tr>
<td>PNGExport</td>
<td>File ▶ Export ▶ PNG Optimizer</td>
</tr>
<tr>
<td>JPEGExport</td>
<td>File ▶ Export ▶ JPEG Optimizer</td>
</tr>
<tr>
<td>FileLocations</td>
<td>File ▶ Preferences ▶ File Locations</td>
</tr>
<tr>
<td>FileClose</td>
<td>File ▶ Close</td>
</tr>
<tr>
<td>FileCloseAll</td>
<td>File ▶ Close All</td>
</tr>
<tr>
<td>FileSend</td>
<td>File ▶ Send</td>
</tr>
<tr>
<td>BatchConvert</td>
<td>File ▶ Batch ▶ Process</td>
</tr>
<tr>
<td>BatchRename</td>
<td>File ▶ Batch ▶ Rename</td>
</tr>
<tr>
<td>Mapper</td>
<td>File ▶ Export ▶ Image Mapper</td>
</tr>
<tr>
<td>Slicer</td>
<td>File ▶ Export ▶ Image Slicer</td>
</tr>
<tr>
<td>FileExit</td>
<td>File ▶ Exit</td>
</tr>
</tbody>
</table>

**To record and save a script**

1. Click the **Start Script Recording** button  
2. Perform the actions that comprise the script.
3 Click the **Save Script Recording** button.
   The Save As dialog box appears.
4 Choose the folder where you want to store the script.
5 Type a name for the script, and click **Save**.

You can also

- **Remove any undone commands from a script**
  In the Save As dialog box, mark the **Remove Undone Commands** check box.

- **Save Materials palette settings used by actions with a tool in a script**
  In the Save As dialog box, mark the **Save Materials** check box. If this check box is cleared, the current material is used with the given tool when the script is run, rather than the material that was used when the script was recorded. This option only applies to recorded actions with a tool, not with a material setting in a dialog box.

- **Display interactive dialog boxes in their position during recording**
  In the Save As dialog box, mark the **Save Dialog Positions** check box. You may not want to use this option if you intend to share the script with others. Enabling this check box not only records the dialog position, but whether the Before/After preview area is displayed, whether the dialog is maximized, and whether the **Preview on Image** check box is marked. You can leave these preferences up to other users of your script.

- **Add descriptive information to a script**
  In the Save As dialog box, click **Description**, and type information in the **Author**, **Copyright**, and **Description** boxes. The information you enter is displayed when you edit the script.

### Running saved scripts

You can run a saved script by selecting the script from the **Select Script** drop-list, or by navigating to the folder where the script is located. You can also add folders containing scripts to the **Select Script** drop-list.

You can also run multiple scripts in a sequence. If you have a single script with too many operations, you may want to spread the tasks into several scripts that you can run in a specific order. This modularity makes it easier for you to maintain scripts and allows you to work around memory limitations.

When you have scripted actions that involve dialog boxes, you can choose to run the script in Silent mode, so the dialog boxes do not appear as the script runs. Conversely, you can choose to run the script in Interactive mode, so that dialog boxes appear for user interaction. For more information, see “To set a playback mode for a script action or command” on page 435.

To run a script listed in the **Select Script** drop-list

**Edit tab**

1 On the Script toolbar, click the **Select Script** drop-list to display the scripts.
2 Click the script that you want to run.
3 Click the **Run Selected Script** button.

Automating tasks | 433
You can add any folder to the list of folders that the Select Script drop-list displays by clicking the drop-list and clicking the File Locations button 📮. In the File Locations dialog box, click Add and navigate to the folder that contains the scripts.

To run a script not listed in the Select Script drop-list
Edit tab
1 On the Script toolbar, click the Run Script button 📏 to open the Run Script dialog box.
2 Choose the folder that contains the script you want to run.
3 Select the script.
4 Click Open.

To run multiple scripts
Edit tab
1 Click an open image to make it active.
2 On the Script toolbar, click the Run Multiple Scripts button 📏 to open the Run Multiple Scripts dialog box.
3 From the left pane, double-click the scripts that you want to run
4 Click Run.

To run scripts on all open images
Edit tab
1 Run a script or multiple scripts on an image.
2 Open the History palette by pressing F3.
3 Right-click the scripts in the History palette and choose Apply to other open documents.

You can also run scripts on another open image by dragging the actions from the History palette and dropping them onto the image. To run the last executed script or multiple scripts on another open image, click the image to make it active, and then press Ctrl + Y.

To toggle between Interactive and Silent script playback mode
Edit tab
• Click the Toggle Execution Mode button 📏 on the Script toolbar.

When the button has a border around it, it is in Interactive mode.

If you’ve edited the script and set part or all of it to run in either Silent or Interactive mode, clicking the Toggle Execution Mode button 📏 will not override that setting. If a script is set to Default mode, the state of this button will override the Toggle Execution Mode setting. The Toggle Execution Mode setting affects only those steps and commands set to Default mode within the script.

Stopping or undoing a script
You can stop a script while it is running. You can also undo a script after you’ve run it.

To stop a running script
Edit tab
• Click the Stop Script button 📏.
The Stop Script button is only active while the script is running. Depending on the script, this may only be a few seconds.

To undo an applied script
Edit tab
• Click the Undo button on the Standard toolbar.

Editing scripts in Corel PaintShop Pro
You can edit scripts using the PaintShop Pro user interface, or by editing the script’s Python code in a text editor application. For more information about editing scripts, see “Editing scripts using a text-editing application” on page 436.

To edit the currently selected script
Edit tab
1 Click the Edit Selected Script button to display the Script Editor dialog box.

The commands and actions that comprise the script appear in the Script Commands group box.
2 Make changes to the script.
Specific editing actions can be found in the table below.
Note: Command names shown in italics with the words “NOT editable” cannot be selected for editing.
3 Click Save.
4 Click Close.

You can also

Disable a script action or command
Unmark the check box beside the action or command.

Remove a script action or command
Click the action or command, and click Delete.

View or edit the Python code associated with the script
Click Text Editor. The text editor assigned in the File Locations dialog box opens the script. Unless you specify another application, the default editor is Notepad.

If the script format is unreadable, or if the script was created and edited manually in a text editor, the PaintShop Pro Script Editor cannot open the script. Instead, the script opens in the default text editor that is specified in the File Locations dialog box. For more information, see “Editing scripts using a text-editing application” on page 436.

If the script you want to edit is not in the Select Script drop-list, choose File ➤ Script ➤ Edit and choose the folder where the script is saved. When you open the script, its information appears in the Script Editor dialog box.

To set a playback mode for a script action or command
Edit tab
1 Click the Edit Selected Script button to display the Script Editor dialog box.

2 In the Scripts Commands group box, choose one of the following options from the Mode drop-list:
• Default — uses whatever mode was specified in the Run Script command.
• **Silent** — skips all dialog boxes associated with that command or action when you run the script. Use this mode when you feel it’s best to avoid interacting with a dialog in the script.
• **Interactive** — allows for user interaction with dialog boxes and other settings

**Editing scripts using a text-editing application**

You can edit the Python code in the text editor of your choice. The editor application designated for script editing will open.

**To edit Python code**

Edit tab

1. Click the **Edit Selected Script** button to display the Script Editor dialog box.
2. Click **Text Editor**.
   
   The text editor assigned in the File Locations dialog box opens the script.

   Until you specify another application, the default editor is Notepad.

**To change text-editing applications**

Edit tab

1. Choose **File** ➤ **Preferences** ➤ **File Locations** to display the File Locations dialog box.
2. In the File Types list, choose **Python Source Editor**.
3. Click **Browse**, and choose a text-editing application.
   
   The Python Source Editor Path dialog box appears.
4. Click **Open**.
5. Click **OK**.

You can also click the **File Locations** button in the **Select Script** drop-list to open the File Locations dialog box.

**Troubleshooting a script**

To selectively apply actions to the current image and identify any scripting problems, you can run a script step-by-step.

**To step through a script**

Edit tab

1. Choose **File** ➤ **Script** ➤ **Single Step**.
   
   PaintShop Pro is in Script Single Step mode.
2. Run the desired script.
   
   The Step Script dialog box appears, listing the script’s name and first action.
3. Click any of the following as you step through the script’s commands and actions:
   • **Continue** — applies the command to the image and moves on to the next command in the script
   • **Skip Command** — does not apply the command to the image and moves on to the next command in the script
   • **Stop Scripts** — cancels this operation and closes the Step Script dialog box

   **Note:** PaintShop Pro remains in Script Single Step mode until you toggle off this command by choosing **File** ➤ **Script** ➤ **Single Step** again.
When using this feature, it’s helpful to display the Script toolbar by choosing View ➤ Toolbars ➤ Script.

Assigning icons to scripts

You can assign any of 50 icons to a script, and then drag the icon to a custom or existing toolbar, or to a menu. By dragging the icon onto a toolbar or menu you can have easier, quicker access to your favorite scripts, and can execute them with a single click.

You can use an icon for any number of scripts. For example, you could assign a red light bulb icon to a script and drag it to the Photo toolbar. You could then assign the same icon to a different script and drag it to the Adjust menu.

The process of assigning an icon to a script is called “binding”. After the script is bound, you can assign a keyboard shortcut to it as another way to execute the script. For more information about using shortcuts, see “Customizing keyboard shortcuts” on page 400.

To assign an icon to a script

Edit tab

1. Choose View ➤ Customize to display the Customize dialog box.
2. Click the Scripts tab.
3. Choose the script from the drop-list.
4. Choose an icon, and then click Bind.
   The icon and its associated script appear in the list in the Bound Scripts group box.
5. From the Bound Script group box, drag the icon or script into a menu or toolbar.

When you position the cursor over the toolbar’s script icon, you’ll see the path name and file name associated with the script. If you drag the script icon into a menu, the menu displays the script’s name, and the script’s path appears in the status bar.

To unbind a script from an icon

Edit tab

1. Choose View ➤ Customize to display the Customize dialog box.
2. Click the Scripts tab.
3. In the Bound Script group box, choose the icon or script name.
4. Click Remove.

When you unbind a script from an icon, you also remove it from the user interface and from any keyboard shortcut assigned to it.

To remove a bound script icon from a menu or toolbar

Edit tab

1. Choose View ➤ Customize to display the Customize dialog box.
2. Drag the script’s icon into the PaintShop Pro workspace.

Using and creating presets

Presets are scripts that define the behavior, properties, or settings of a dialog box or tool. Many dialog boxes and tools come with predefined, ready-to-use presets; however, you can also design and save your own presets. This is useful if you frequently use the same settings in a dialog box or with a tool. By using presets, you can save the settings and they’ll appear in the Presets drop-list associated with that dialog box or tool.
To choose a preset
Edit tab
• In the **Presets** drop-list, select the desired preset from the list.

![Presets drop-list button in the Tool Options palette](image1)

*On the left is the Pan tool’s Presets drop-list button in the Tool Options palette, and on the right the Presets drop-list in a dialog box.*

To reset values to default settings
Edit tab
• In the **Presets** drop-list, click the **Reset to default** button ∇.

![Reset to default button](image2)

To reset a dialog box to the settings that displayed when you opened the dialog box, hold down **Shift** and click the **Reset to default** button.

To save settings as a preset
Edit tab
1 Modify the settings in the dialog box or the Tool Options palette.
2 Click the **Save preset** button 📝 to display the Save Preset dialog box.
3 Type a name for the preset.
   **Note:** You cannot use “Default” or “Last Used” as the name for a preset.
   If you want to enter additional preset information, click **Options**, and type text in the **Author**, **Copyright**, and **Description** fields.
4 Click **OK**.

The **Preset includes** group box shows the data saved with a preset.

To edit a preset
Edit tab
1 Modify the settings in the dialog box or the Tool Options palette.
2 Click the **Save Preset** button 📝.
3 Type the same preset name in the preset name box.
4 Click **Options**.
   If you want to omit any data from the **Preset includes** group box, click the **Include/Exclude** button 📝 associated with the data.
   A white “X” appears over the button associated with the item.
5 Click **OK**.
To delete a preset

Edit tab

1. In the Presets drop-list, click the Resource Manager button.

2. In the Resource Manager dialog box, select the preset you want to delete.

3. Click Delete.

Processing files in batches

You can save time by processing multiple files with the Batch Process feature. You can use batch processing to perform common tasks or specific actions. For example, you can:

- Copy files
- Rename files
- Convert the file format
- Add or remove metadata, including location information or other EXIF data
- Add watermarks
- Resize
- Apply scripts to multiple files
- Add a Picture Frame
- Apply Smart Photo Fix

The Batch Process dialog box steps you through three pages: Add Photos, Batch Actions, Output Settings. Batch Actions are optional, but you should review the Output Settings before running your batch.

To batch process files


2. In the Batch Process dialog box, on the Add Photos page, click Add and choose the files that you want to process.

3. Click Next.

4. On the Batch Actions page, choose any of the following actions:
   - Add Info — For information about displaying caption and EXIF info on your images, see “Displaying captions and info text on images” on page 340.
   - Watermark — For information about adding watermarks, see “Adding visible watermarks” on page 470.
   - Resize — For information on resizing, see “Resizing images” on page 150.
   - Script — Enable the check boxes for one or more scripts. Enable Silent Mode to avoid displaying dialog boxes associated with scripts (interrupts batch to request user input). For more information, see “Working with scripting tools and features” on page 430.
   - Picture Frame — For information about picture frames, see “Adding picture frames to images” on page 318.
   - Smart Photo Fix — For information about Smart Photo Fix, see “Making basic photo corrections automatically” on page 119.

   Note: To edit the settings for an action (scripts are the only actions that can’t be edited from the page), hover over an item you have added to the Add Batch Actions list, and click the Edit this action button that appears.

5. Click Next.

6. On the Output Settings page, modify any of the following settings:
   - Destination folder — Enable New and navigate to a folder location or enable Original to save back to the source folder
   - Filename — To rename the files, enable Rename, click Modify, and choose an option from the Rename Options list, and click Add.
     You can rename the file with info such as current date or custom text. Note: If you are renaming files, adding the Sequence option ensures that each file will have a unique name and you won’t have naming conflicts.
   - Naming conflicts — Enable the option that you want to apply in the event that two files have the same name.
   - File Format — Choose a file format. Click Options if you want to modify the settings for the file format.
   - Security features — Enable Delete EXIF information to remove all EXIF metadata from the processed files or enable Delete location information to remove any GPS coordinates. To add a Digimarc watermark, enable Embed Watermark.

7. Click Start to run the batch process.
You can also

Save your batch settings

On the Batch Actions page, click Save Batch, navigate to the folder where you want to store your batch file (.pba), and type a file name.

Use previously saved batch settings (.pba file)

On the Batch Actions page, click Load Batch, navigate to your batch settings file.

Renaming files in batches

You can rename multiple files at the same time.

To rename files in a batch

Edit tab

1. Choose File ▶ Batch Rename to open the Batch Rename dialog box.
2. Click Browse.
3. Choose the folder that contains the source files.
4. Do one of the following:
   • To select adjacent files, hold down Shift, and click the files.
   • To select non-adjacent files, hold down Ctrl, and click the files.
5. Click Select.
   The files appear in the Files to rename list in the Batch Rename dialog box.
6. Click Modify to open the Modify Filename Format dialog box.
7. Choose any of the following renaming options from the Rename Options list:
   • Camera Brand — camera used to take the photo, as indicated by EXIF data
   • Camera Model — camera model used to take the photo, as indicated by EXIF data
   • Custom Text — to add text to the converted files
   • Date — to add the current date to the file name
   • Document Name — to add the original file name to the new file name, and to change the case
   • Lens — lens used to take the photo, as indicated by EXIF data
   • Location — GPS coordinates if available in EXIF data
   • Sequence — to add the numerical position of a file in the renaming process
   • Time — to add the current time to the file name
8. Click Add for each option you want to move into the Included list.
   The file naming scheme appears at the bottom of the dialog box.
9. Click OK.
   If you want to stop the renaming process when PaintShop Pro encounters an error, mark the Stop on error check box in the Batch Rename dialog box.
10. Click Start.

You can use click the Move Up ▲ and Move Down ▼ buttons in the Modify Filename Format dialog box to rearrange the order of options you choose from the Rename Options list.
Printing

PaintShop Pro provides extensive options for printing your work.

This section presents the following topics:
- “Printing images” (page 441)
- “Creating layouts” (page 444)
- “Editing templates” (page 446)
- “Editing and saving layouts” (page 448)
- “Printing CMYK color separations” (page 450)
- “Understanding printing” (page 450)

Printing images

PaintShop Pro offers many ways to print images. You can use a template, or use a custom layout to meet specific size and layout requirements.

Templates help you simplify image placement and sizing. You can use templates to lay out and print images in standard sizes, including 4 x 6 inches, 5 x 7 inches, and 10 x 15 centimeters. You can use a PaintShop Pro template, or you can create your own custom template from a page layout that you create.

Creating your own layouts gives you the flexibility to print images to any size and lets you create a custom page for projects such as collages and scrapbooks. For more information about creating layouts, see “Creating layouts” on page 444.
If you are preparing images for professional output, you can print an image to a file, which lets a service bureau send the file directly to an output device. If you are unsure about which settings to choose, consult the service bureau. You can also print crop and registration marks. Crop marks represent the size of the paper and print at the corners of the page. You can print crop marks to use as guides to trim the paper. Registration marks are required to line up film for proofing or printing plates on a color press. They print on each sheet of a color separation.

To print the active image
Edit tab
1 Choose File ➤ Print.
2 In the Printer group box, click Printer.
   The Print dialog box appears.
3 Choose a printer from the Name drop-list, and click OK.
4 Click the Placement tab, and type or set a value in the Number of copies control.
5 In the Orientation group box, choose one of the following options:
   • Portrait
   • Landscape
6 In the Size and Position group box, set any of the following controls:
   • Width and Height — lets you specify width and height values to set the image size
   • Scale — lets you resize the image by entering a percentage
   • Fit to page — fits the image to the printed page
   • Center on page — centers the image on the printed page
   • Upper left of page — positions the image in the upper-left corner of the printed page
   • Custom offset — lets you enter values in the Left offset and Top offset boxes
7 Click the Options tab.
8 In the Print Output group box, choose one of the following options:
   • Color
   • Greyscale
   • CMYK separations
     If you choose the CMYK separations option, you can print CMYK labels on each color plate or page by marking the CMYK plate labels check box in the Print Marks group box.
9 Click Print.

You can also

Print the filename below the image
Mark the Image Name check box in the Print Marks group box.

Print a negative of the image
Mark the Negative check box in the Color Options group box.

Print a color background around the image
Mark the Background check box, click the color box, and choose a color from the color palette.

You can script most print options; however, because of variations in printer drivers, not all printer settings are scriptable. For more information about scripting, see “Scripting basics” on page 429.

For more information about printing options, see “Creating layouts” on page 444.
To print a contact sheet
Manage tab
1. In the Organizer palette, select the files that you want to print.
2. On the Organizer toolbar, click the Organizer menu button and choose Print Contact Sheet.
3. Specify the settings you want in the Print Contact Sheet dialog box.
4. Click Print.

For more information about printing options, see “Understanding printing” on page 450.

To print to a file
Edit tab
1. Choose File ➤ Print.
2. Mark the Print to File check box.
3. Click Print.
4. Type a name in the Output File Name box.

To print images by using a template
1. Select thumbnails in the Organizer palette.
2. Choose File ➤ Print Layout.
   The Print Layout window appears.
3. Click File ➤ Open Template.
   The Templates dialog box appears.
4. In the Category group box, choose a category from the list.
   Thumbnails of the templates in each category appear in the window on the right. Custom templates that you saved appear under the User Defined category. If the custom template was saved with images, the cells are filled with color.
5. Select a template, and click OK.
   Note: If you previously saved images with the template, the images appear in the template cells and in the thumbnail list. Cells are grayed in the template thumbnail for templates with missing images.
6. Drag images into the template cells.
   If you want to fill the template with copies of the same image, click a thumbnail and click the Fill Template with Image button.
7. Click File ➤ Print.

For information about saving templates with links to images, see “Setting file locations” on page 413.

You can remove an image from a template by selecting the image and pressing Delete.

You can also open images by choosing File ➤ Open Image.

To print crop and registration marks
Edit tab
1. Choose File ➤ Print.
2. In the Printer group box, click Printer.
   The Print dialog box appears.
3 Choose a printer from the **Name** list box, and click **OK**.
4 Click the **Options** tab.
5 In the **Print Marks** group box, mark one or more of the following check boxes:
   - **Corner Crop Marks** — prints crop marks at the corners of the image
   - **Center Crop Marks** — prints crop marks at the center of the image edges
   - **Registration Marks** — prints registration marks at the corners of the image

### Creating layouts

You can create a print layout and position images individually, or you can apply the same settings to all of the images.

By rotating and zooming, you can change the print layout of your images. Images are displayed at 100% magnification by default. You can zoom in to get a closer look at image detail, or zoom out to view a larger portion of the image.

When you use a print layout, you can add descriptive text captions, undo or redo the changes you make, and save the layout for future use as a template.

#### To add images to a layout

**Edit tab**

1 Open the image that you want to print.
   - If you want to select more than one file, hold down **Ctrl**, and click the files. If the files are in sequential order, click the first file, and then press **Shift** and click the last file.
2 Choose **File** ➤ **Print Layout** to open the Print Layout window.
   - Thumbnails of the selected images appear on the left side of the window; the page layout appears in the preview area.
   - If you want to add additional images to the Print Layout window, choose **File** ➤ **Open Image**, and choose the images.
3 Drag the thumbnails into a template cell or onto the custom layout page.

#### You can also

Print the page with the current settings

Click the **Print** button.

Change the print setup options

Choose **File** ➤ **Print Setup**. In the Print Setup dialog box, make changes to any of the settings.

Close the Print Layout window

Click the **Close Print Layout** button.

#### To position images in a layout

**Edit tab**

1 In the Print Layout window, choose a cell.
2 Click one of the following buttons:
   - **Fill Template with Image** — fills the template with the image
   - **Free Format** — lets you manually resize and position the image in the cell
   - **Size and Center** — retains the image size and centers it in the cell
   - **Fill Cell with Image** — centers the image and scales it to fill the cell. The aspect ratio is maintained, but parts of the image may not be visible.
   - **Fit and Center** — centers the image and scales the image to fit entirely inside the cell. The image aspect ratio is maintained.
• **Make Cell Elliptical** — creates an elliptical cell shape
• **Make Cell Rectangular** — creates a rectangular cell shape

You can display the grid if you want to position images with precision.

**To rotate an image in a layout**

Edit tab

1. In the Print Layout window, select an image.
   - If you want to rotate multiple images, hold down **Shift**, and select the images.
2. On the toolbar, click one of the following buttons:
   • **Rotate Right**
   • **Rotate Left**

**To zoom**

Edit tab

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Click the <strong>Zoom In 10%</strong> button</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Click the <strong>Zoom Out 10%</strong> button</td>
</tr>
<tr>
<td>Zoom in on a specific area</td>
<td>Click the <strong>Zoom Rectangle</strong> button. Drag in the page layout to choose an area to zoom in on.</td>
</tr>
<tr>
<td>Zoom to the fill the preview area with the layout</td>
<td>Click the <strong>Zoom to Page</strong> button</td>
</tr>
</tbody>
</table>

**To create a caption**

Edit tab

1. Choose **File ▶ Print Layout** to open the Print Layout window.
   - Thumbnails of the open images appear on the left side of the window; the page layout appears in the print layout preview area.
2. Drag the thumbnails into a template cell or onto the custom layout page.
3. Click the **Create a Text Field** button.
4. Drag to create the text box.
5. In the Text Field dialog box, type the text that you want to appear on the printed page.
6. Set the font, font attribute, and alignment controls.
   - **Note:** To continue to use these settings, mark the **Retain text settings** check box.
7. Click **OK**.

**You can also**

- Move the text box in the image
- Drag the text box.
You can also

Size the text box
Drag the corner handles in or out.

Rotate the text
Right-click the text box, and choose Rotate Right or Rotate Left.

To undo or redo a change to a layout
Edit tab
• Choose Edit  Undo to undo a change to a layout, or Edit  Redo to redo a change to a layout.

To change the Print Layout view
Edit tab
1 In the Print Layout window, choose View  Options. The Print Layout Options dialog box appears.
2 Choose a unit of measurement from the Units drop-list.
3 In the Auto Arrange group box, mark one or both of the following check boxes:
   • Use borders — creates a border around all images. This option requires you to set values in the Horizontal border size and Vertical border size controls.
   • Stretch to fit — automatically enlarges images to fit, while maintaining their aspect ratios
4 In the Template options group box, do one or both of the following:
   • To apply the new default placement option to all cells of the current template, mark the Apply to current template check box.
   • To specify the default placement of images in template cells, choose an option from the Default Placement drop-list.
5 In the Grid Settings group box, mark any of the following check boxes:
   • Show Grid — displays the grid
   • Snap-to-Grid — snaps images to the gridlines where you position them
   If you marked the Show Grid check box, you can also mark the Dot Grid check box to use a dotted-line grid. Clear the check box to use a solid-line grid.
6 Click OK.

You can also

Change the grid color
Click the Grid color area, and choose a color from the color palette.

Change the horizontal and vertical spacing
Set values in the Horizontal Spacing and Vertical Spacing controls.

Editing templates

In Print Layout mode, you can make changes to multiple cells at the same time. However, the position and size of a cell are locked when the layout is saved as a template, so template cells cannot be moved or resized. You can add descriptive text to a template, which can be helpful for future browsing.

If a print layout contains images that you want to print repeatedly, you can save the layout as a template with links to the images. Whenever you open the template, it displays the images in the layout.

If you no longer need a print template that was saved, you can easily delete it.
Important! When you print a template on thick paper, such as glossy photo paper, the images in the printed template may not fit perfectly inside the cell borders. You can correct this by adjusting the position of the template layout in PaintShop Pro.

To edit template cells
Edit tab
1 Click the cell you want to edit.
   If you want to edit multiple cells, hold down Ctrl while clicking the cells.
2 Choose Edit, and then choose the commands you want to apply to the template cells.

To enter descriptive text for a template
Edit tab
1 Load a template, or create a new template.
2 On the Print Layout toolbar, click the Save Template button
   The Save dialog box appears.
   If you want to create a specific name for the template, enter it in the Name field.
3 In the Description field, enter the information you want.
   If you want to save the template with the images it contains, mark the Save with images check box.
4 Click OK.
   If you did not change the template name, you are prompted to overwrite the template or cancel the action.

To move the template position
Edit tab

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the template 1/20th of an inch (1.25 mm)</td>
<td>Hold down Ctrl, and press the arrow keys.</td>
</tr>
<tr>
<td>Move the template 1/10th of an inch (2.5 mm)</td>
<td>Hold down Ctrl and Shift, and press the arrow keys.</td>
</tr>
</tbody>
</table>

💡 If your printer consistently misprints the same way, adjust the template position, and save it with a name that specifies its use with that printer.

To revert a template with images to a layout
Edit tab
1 Open the template you want to edit.
2 Click the New Template button
   A dialog box appears, asking whether to keep the current images in the new template.
3 Click Yes.

To save a template with images
Edit tab
1 Click the Save Template button
   The Save dialog box appears.
2 Enter a name for the new template in the Name field.
3 Mark the Save with Images check box.
4 Click OK.
To delete a template
Edit tab
1. Choose File ➤ Print Layout.
2. In the Print Layout window, click Open Template.
   The Templates dialog box appears.
3. Choose a category from the Select A Category list.
4. Select the thumbnail of the template you want to delete.
5. Click Delete.

Editing and saving layouts

PaintShop Pro includes many templates with different layouts that you can use to print your images. The layouts you create can be saved as templates.

You can arrange images in a layout automatically or manually. Before you arrange images automatically, you must choose whether to include borders. If you do not use borders, PaintShop Pro may arrange the images with touching edges. You must also choose whether to size the images to fit the layout. If you do not choose this option, PaintShop Pro keeps them the same size or, if necessary, makes them smaller to fit the layout. PaintShop Pro divides the page into sections of equal size and places each image in a section. Only images on the page or in the window are used.

Horizontal and vertical gridlines help you position items evenly on a page. You can display or hide grids and set preferences for grid spacing and appearance. When you display grids, they appear in any image window that is open.

You can snap images to the nearest gridline on the layout.

To resize an image in print layout
Edit tab
1. Click the Resize button on the toolbar.
2. Choose one of the following options:
   • Percent of original — resizes an image by a percentage you specify in the Width or Height boxes
   • Actual / Print size — resizes an image by the dimensions you specify in the Width or Height boxes without changing its aspect ratio

   Resizing an image for printing can result in poor image quality. When you enlarge an image, it loses detail and sharpness. As a general rule, it is best to avoid enlarging or reducing an image by more than 25 percent.

   You can also resize an image manually by dragging a corner handle.

To use borders in a print layout
Edit tab
1. Choose View ➤ Options.
2. Mark the Use Borders check box, and type or set values in the Horizontal border size and Vertical border size controls.
   The default border width is 0.5 inches (1.27 centimeters).
3. Click OK.
If you want to resize images to fit in their cells, mark the **Stretch to fit** check box. As you decide where to move images, you can place them temporarily in the area around the page. You can also arrange images manually by dragging the image to a new position on the page.

**To display the grid**

*Choose View ➤ Show Grid.*

**To snap images to the layout grid**

*Choose View ➤ Snap to Grid.*

**To change layout grid settings**

1. Choose View ➤ Options.
   
   The Print Layout Options dialog box appears.

2. In the **Grid Settings** group box, mark any of the following check boxes:
   - **Show Grid** — displays the grid
   - **Snap-to-Grid** — snaps images to the gridlines when you position them

   **Note:** If you mark the **Show Grid** check box, you can mark the **Dot Grid** check box to use a dotted-line grid instead of a solid-line grid.

You can also

- **Change the grid color**
  
  Click the **Grid color** area, and choose a color from the color palette.

- **Change the horizontal and vertical spacing**
  
  Set values in the **Horizontal Spacing** and **Vertical Spacing** boxes.

**To save a custom layout as a template**

1. Click the **Save Template** button.

   The Save dialog box appears.

2. Enter a name for the new template in the **Name** field.
   
   If you want to save the image links with the template, mark the **Save with Images** check box.

3. Click **OK**.

**To rotate an image in a layout**

1. Select the image.

2. Choose **Image**, and then choose one of the following commands:
   - **Rotate Right**
   - **Rotate Left**
To position an image in a layout
Edit tab
• Drag the image to a new position on the page.

Printing CMYK color separations

PaintShop Pro converts images for color printing by replacing the RGB (Red, Green, and Blue) colors you see on the monitor with the CMYK (Cyan, Magenta, Yellow, and Black) colors used in printing. You can then print a separate page for each CMYK color, which is useful if your work will be handled by a prepress service provider or a high-quality printer.

Printing CMYK color separations differs from splitting color channels. When you split color channels, PaintShop Pro treats white as having full color and black as having no color. When you print CMYK separations, PaintShop Pro treats black as having full color and white as having no color.

To print CMYK color separations
Edit tab
1. Choose File ▶ Print.
   The Print dialog box appears.
2. Click the Options tab.
3. In the Print Output group box, choose CMYK Separations.
4. Click Print.

You can also choose other print options. For more information, see “Printing images” on page 441.

Understanding printing

Whether you are new to printing or would like a quick review, this reference section can help you understand some of the factors that affect the printing of your images.

Image and printer resolution

Laser and ink-jet printers work by applying dots of black or colored ink to paper. Whereas image resolution is measured in pixels per inch (ppi), printer resolution is measured in dots per inch (dpi). The printed image size is expressed in inches and is calculated as the image size in pixels divided by pixels per inch. For information about viewing image information, see “Viewing images and image information” on page 63.

Images with higher dpi values have more data and result in higher print quality. You can resize images, to create a larger print size, but the print quality can decrease due to the reduced print resolution (ppi). For information about resizing images, see “Resizing images” on page 150.

It is best to consider the resolution of the printer when you choose a resolution for the image you are creating. You can use the following guidelines to determine the image size for printing:
• For a 300-dpi printer, use an image that is 72 to 120 ppi.
• For a 600-dpi printer, use an image that is 125 to 170 ppi.
• For a 1200-dpi printer, use an image that is 150 to 200 ppi.

Image color and lightness

Computer monitors display color by combining red, green, and blue light on the screen. Color printers, however, use a combination of cyan, magenta, yellow, and black inks. The differences between these two color modes can cause images to appear darker on paper than on the screen. As you become familiar with how your printer handles color, you can adjust your images to compensate for these differences. If the printed image appears too dark, you can adjust the brightness or contrast.
Paper quality

The texture and color of the paper used for printing affect the quality of the printed image. For example, porous paper can cause colors to bleed into each other, colored paper can alter the image colors, and off-white paper can reduce the contrast and vibrancy of the image colors. For recommendations on which paper to use for printing, refer to the documentation supplied with your printer.

File formats

Saving your image in the PspImage format provides the most flexibility if you plan to print your image on a personal printer. PaintShop Pro prints all layers in an image, so you do not need to flatten the image by merging the layers. If you are using a black-and-white printer, you can print your images in grayscale.

If you are sending the image to a printing service, you need to flatten the image — that is, merge the layers — before you save the image. The program automatically flattens an image when you save it in most formats other than PspImage. It is best to consult with your printing service about file format, resolution, and color depth requirements.
Sharing photos

PaintShop Pro gives you options for e-mailing your photos or sharing them on a sharing site.

This section presents the following topics:
• “E-mailing photos” (page 453)

E-mailing photos

You can e-mail items in the following ways.
• Embedded photos — You can embed photos so they are displayed in the body of your e-mail message. This means that the person who receives your e-mail can see the photos as soon as the e-mail is open. Embedded photos only appear in e-mail that uses the HTML message format. This is a standard message format, but if you know your recipient uses plain text or Rich Text Format (RTF), use the Attachments option.
• Attachments — You can send photos as file attachments. Each item is attached as an individual file, the original file format is preserved, and the e-mail recipient can choose how to view the photos.

Choosing a size for your photos

You can resize your photos to reduce their dimensions or to reduce the overall size of the e-mail. For example, you may want to reduce the size of a photo so you can send it to a mobile device. The Maximum Photo Size setting lets you choose the maximum width of the photos in pixels without affecting the proportions of the image. For example, if your photo is 2048 pixels x 536 pixels, and you choose a maximum photo size of 640 pixels, then your image is resized to 640 pixels x 480 pixels. The dimension information for each image is displayed above the preview thumbnail in the E-mail dialog box and the total e-mail size estimate is displayed beside the preview thumbnail.

E-mail application

To send items using e-mail, you must connect to the Internet and your computer must have a default e-mail application that supports the MAPI Standard (such as Microsoft Outlook) and be configured to use the MAPI e-mail client.

To e-mail photos

1. Choose File ➔ E-mail, and choose one of the following options:
   • Active image — lets you send the photo that is currently active in the image window
   • All open images — lets you send all the photos that are open in the image window
   • All selected items — lets you send all the photos that you currently have selected
2. In the E-mail dialog box, choose one of the following options:
   • Embedded photos — displays photos in the body of your e-mail message
   • Attachments (original file format) — sends photos as individual file attachments. This option preserves the original file formats.
3 Choose a size setting from the **Maximum photo size** drop-list.

The total size of your e-mail is displayed beside the preview.

Some e-mail providers limit the size of e-mails, which could prevent large e-mails from being sent or received. You can reduce the size of the e-mail by choosing a smaller **Maximum photo size** setting or by selecting fewer photos.

The Embedded photos option is available only for e-mail clients that support extended MAPI, such as Outlook.

You can review the items you are sending by clicking the playback arrows that appear under the Preview thumbnail.
Creating images for the Web

Creating images for the Web

You can save and optimize images for the Web to reduce the image file size and make images load more quickly. Using the Web tools, you can create backgrounds for your Web pages, and map and slice images to create hotspots or rollovers. You can also protect your images by adding watermarks with creator and copyright information.

This section presents the following topics:

• “Saving images for the Web” (page 455)
• “Working with GIF files” (page 456)
• “Working with JPEG files” (page 459)
• “Working with PNG files” (page 460)
• “Previewing images in Web browsers” (page 461)
• “Slicing images” (page 462)
• “Mapping images” (page 465)
• “Creating image rollovers” (page 467)
• “Using digital watermarks” (page 468)
• “Adding visible watermarks” (page 470)

Saving images for the Web

Because the majority of Web browsers recognize GIF and JPEG images, these two formats are used most often for saving Web images. Newer versions of the Web browsers can also recognize the more recent PNG format, and many Web browsers also support Wireless Bitmap (WBMP) and i-mode formats, which are popular formats for wireless devices.

When you save images for the Web, there are three major considerations: layers, color depth, and file size.

Layers

Because none of the current Web browsers can display layered images, you need to flatten an image before saving it for the Web.

Color depth

Some computers can display no more than 256 colors. If an image on a Web page contains more colors, the Web browser uses its own dithering method to display the image. This can produce color distortion. If you reduce the color depth of the image to 8 bits (256 colors) before placing it on your Web page, its appearance will be more consistent. For more information about color depth, see “Working with advanced color” on page 381.
Web file formats and file sizes

File size affects the majority of users accessing a Web page. As the size of an image file increases, it takes more time to download, so viewers have a longer wait. You should use a file format that reduces the image size while keeping the quality as high as possible.

Choose from the following file formats when saving images for use on the Web:

- **GIF** — this format compresses line art and images with areas of similar colors. It supports 8-bit (256) color. There are two versions of GIF: 89a, which can save transparency and information, and 87a, which cannot. Both are recognized by most browsers and use lossless compression.
- **JPEG** — this format efficiently compresses photographic images. It supports 24-bit (16.7 million) color, uses lossy compression, and is recognized by most browsers.
- **PNG** — this increasingly popular format efficiently compresses images. It supports up to 24-bit (16.7 million) color and uses lossless compression. It is not as widely used as JPEG, so some features of this format are not available for older browsers.
- **Wireless Bitmap (WBMP)** — this format is used with many wireless devices. The images are black and white and have lossless compression.

What’s the difference between lossy and lossless compression?

Lossy compression is a compression method that eliminates data to reduce the file size. Lossless compression retains all of the original image data and reduces the file size by storing patterns of pixels in the image.

To flatten an image

**Edit tab**

- Choose **Layers ➤ Merge ➤ Merge All (Flatten)**.

Working with GIF files

PaintShop Pro lets you optimize GIF files to maximize quality while minimizing file size. You can save images with or without transparency, depending on how you want to display them on your Web pages.

Paletted images (those with 256 or fewer colors, such as GIF or PNG files) do not support transparent backgrounds, but you often need to make part of your image transparent for a Web page. For example, you may have a round logo and want to display the background of the Web page around the logo. In this case, you can choose not to display one color. Most Web browsers support this option, effectively making that color transparent.

The GIF Optimizer dialog box contains four tabbed areas in which to configure the transparency, color, and format options of the file. The fifth tabbed area displays estimated download times of the image at various modem speeds.

**GIF Optimizer Transparency**

You can choose to base transparency on existing image or layer transparency, or you can sample a color in the image that you want to make transparent. If you have a selection in your image, you can base the transparency on the selection.

**GIF Optimizer Partial Transparency**

A GIF file cannot contain partially transparent pixels. All pixels must be either transparent or opaque (visible). Original images may contain partially transparent pixels if the image does not have a background layer, and you have reduced the opacity of a layer, added a mask, feathered a selection, or used a brush at a reduced opacity setting. You can determine whether the partially transparent pixels become transparent or opaque, and whether they are blended with another color.

**Important! If you mark the None option under the Transparency tab, the options in this area are unavailable.**

**GIF Optimizer Colors**

GIF images have an 8-bit color depth, which means they can display up to 256 colors. Because these colors are stored in a palette, an image containing 256 or fewer colors is called a paletted image. To reduce file size, you can have fewer than 256 colors. You can use the options under this tab to select the number of colors and the type of palette used.
GIF Optimizer Format

GIF images can be interlaced or non-interlaced, which affects how the image is displayed on a computer with a slow Internet connection. You can also save the image to an older version of the GIF format to enhance compatibility with older applications.

GIF Optimizer Download Times

The Download Times tabbed area in the GIF Optimizer dialog box displays the size of the compressed file and estimated download times for four different Internet speeds. If the file size is too large, you can decrease it by reducing the number of colors.

Using the Transparent GIF wizard

You can open the Transparent GIF wizard from the GIF Optimizer dialog box. This wizard guides you through the steps of optimizing a GIF file.

What is interlacing?

Interlacing is a method that lets you display a Web-based image on the screen at a low, blocky resolution. As the image data loads, the image quality improves.

To optimize and save a GIF file

Edit tab

1 Choose File ➤ Export ➤ GIF Optimizer.

The GIF Optimizer dialog box appears, and the preview areas show the current image on the left and the resulting GIF file on the right.

2 Click the Transparency tab, and choose one of the following options:
   - None — produces a GIF file that does not use a transparency setting
   - Existing image or layer transparency — uses the current transparency information from the image
   - Inside the current selection — for images with a selection, makes everything within the selection transparent
   - Outside the current selection — for images with a selection, makes everything outside the selection transparent
   - Areas that match this color — bases the transparency on a color you select. Click the color box to select a color or choose a color from the image by moving the cursor over the image, and clicking a color. Then set or type a tolerance factor in the Tolerance control to determine how closely colors must match the selected color before they become transparent.

3 Click the Partial Transparency tab and choose one of the following options:
   - Use full transparency for pixels below x% opacity — determines the opacity value at which pixels become transparent. Pixels below the opacity value you set become transparent. As you lower the value, you reduce the number of transparent pixels.
   - Use a 50% dither pattern — makes partially transparent pixels opaque using either the color chosen for blending or the image color (depending on the blending option), then applies a 50% dither pattern to make colors look more natural
   - Use error diffusion dither — makes partially transparent pixels opaque using either the color chosen for blending or the image color (depending on the blending option), then applies an error diffusion dither to make colors look more natural

4 Choose one of the following options to determine how partially transparent pixels are blended:
   - Yes — blends the partially transparent pixels with the color in the Blend color box. To choose a new color, click the color box, and choose a color from the Color dialog box. Partially transparent pixels below the value you set above are blended with this color.
   - No — uses the existing image color at 100% opacity

5 Click the Colors tab, and type or set a value in the How many colors do you want? control to determine the number of colors you want in the image.

Note: As you remove colors, the size of the file decreases, but so does the quality of the image. Use the preview areas to help you determine the best balance between file size and image quality.

6 Type or set a value in the How much dithering do you want? control.

The range is 16 to 256 colors. This determines the way PaintShop Pro arranges pixels in an image to compensate for missing colors in the adjacent pixels.

7 Choose one of the following options to determine the image palette:
   - Existing Palette — lets you use an existing image palette
• **Standard/Web-safe** — lets you use the Web-safe palette for images that you want to use on the Web.

• **Optimized Median Cut** — lets you reduce the image to only a few colors. If you choose this option, you can mark the **Boost selected colors** check box to give the colors more weight by a factor of the value you set. The selected colors stand out from the rest of the image. To boost colors, make a selection of an area that contains these colors and then mark this check box.

• **Optimized Octree** — lets you optimize an image that contains only a few colors.

*Note:* Depending on your needs, you may want to try both the Optimized Median Cut and the Optimized Octree options and choose the one that gives you the best results.

8 In the Options group box, mark the **Include Windows colors** check box to include the 16 standard Windows colors in the palette. If the image will be used on the Web, mark the check box.

9 Click the **Format** tab, and choose one of the following options:

• **Non-interlaced** — produces an image that downloads one line at a time, starting from the top.

• **Interlaced** — produces an image that is displayed incrementally in several passes, and detail is added each time.

*Note:* Choose the Interlaced option with larger images so that the viewer can get an idea of how the image looks while waiting for it to download.

10 Choose one of the following options:

• **Version 89a** — lets you save transparency information. It is selected automatically if the image contains transparent pixels.

• **Version 87a** — lets you save an image that does not contain a transparency setting.

11 Click **OK** to open the Save As dialog box, and navigate to the folder in which you want to save the new image and type a name for the file.

12 Click **Save**.

**To use the Transparent GIF wizard**

**Edit tab**

1 Choose **File** ➤ **Export** ➤ **GIF Optimizer**.

   The GIF Optimizer dialog box appears.

2 Click **Use wizard**, and follow the instructions.

3 Click **Finish** to close the wizard and open the **Save As** dialog box, where you type a name and select a location for saving the GIF file.

You can also

Choose a color within the image

On page 1 or 2 of the wizard, move the cursor over the image, and click a color. The color swatch displays the color you clicked.

Choose a color using the Color dialog box

On page 1 or 2 of the wizard, click the color swatch to open the Color dialog box. For more information about the controls in the Color dialog box, see “To choose a color from a dialog box” on page 42.

Change a setting

On page 5 of the wizard, click **Back** to return to the previous pages, change the settings you want, and return to page 5 to view the results.

*Note:* A GIF image cannot contain partially transparent pixels. If the image contains them, the Transparent GIF wizard blends them with the color you choose. Reducing layer opacity, adding a mask, feathering a selection, and using a brush set at reduced opacity are some of the actions that can produce partially transparent pixels.
You can click the Download Times tab to preview the file size of the compressed file and view an estimate of the download time at four modem speeds.

Working with JPEG files

PaintShop Pro lets you optimize JPEG files to maximize image quality and minimize file size.

**Important!** Each time you open and save a JPEG file, image data is discarded. It is a good idea to keep a copy of the original image.

**JPEG Optimizer Quality**

You can use compression to reduce the size of the JPEG file. When you compress a JPEG image, you delete image information. As you increase the compression, you lower the quality of the image. You can use the image preview area to help you find the best balance between file size and image quality.

You can also reduce the file size with chroma subsampling, which averages the color information for every $2 \times 2$ square of pixels. You can change this setting to have a larger area of color information averaged.

**JPEG Optimizer Background Color**

The Background Color tabbed area in the JPEG Optimizer dialog box is available if an image has transparent areas. You can determine how transparent pixels in your image are blended with a background by choosing a background color. For example, if you are placing an image on a Web background, you can select the same background color in the JPEG Optimizer to ensure the image blends seamlessly with the Web page.

**JPEG Optimizer Format**

You can determine how an image appears as it is being loaded. You can optimize the JPEG so that the image downloads one line at a time, starting from the top.

You can choose to have large images displayed incrementally in several passes; detail is added with each pass. This option allows the viewer to see the image as it is being downloaded.

**JPEG Optimizer Download Times**

You can view the size of the compressed file and estimated download times for four modem speeds.

**Using the JPEG wizard**

You can open the JPEG wizard from the JPEG Optimizer dialog box. This wizard guides you through the steps of optimizing a JPEG file.

**To optimize and save a JPEG file**

**Edit tab**

1. Choose **File**, **Export**, **JPEG Optimizer**.
   The JPEG Optimizer dialog box appears. The preview areas show the current image on the left and the resulting JPEG file on the right.
2. Click the **Quality** tab, and set or type a value in the **Set compression value to** control.
3. Choose a color sampling method from the **Chroma Subsampling** drop-list if you want to change the default setting.
4. Click the **Format** tab and choose one of the following options:
   - **Standard** — downloads one line at a time, starting from the top
   - **Progressive** — displays the image incrementally in several passes, and detail is added each time
5. Click **OK** to open the Save As dialog box, navigate to the folder in which you want to save the new image, and type a name for the file.
6. Click **Save**.
You can click the **Download Times** tab to preview the file size of the compressed file and view an estimate of the download time at four modem speeds.

### To use the JPEG wizard

**Edit tab**

1. Choose **File > Export > JPEG Optimizer**.
   
   The JPEG Optimizer dialog box appears.

2. Click **Use wizard** and follow the instructions.

### Working with PNG files

PaintShop Pro lets you optimize PNG files to maximize quality and minimize file size. The PNG Optimizer dialog box contains three tabbed areas where you can configure the color, transparency, and format options of the file. The fourth page displays estimated download times of the image at various modem speeds.

#### PNG Optimizer Colors

You can choose the color depth for the PNG file — the greater the color depth, the longer it takes to download the image. The controls under the Colors tab of the PNG Optimizer dialog box let you select a color depth for your PNG image. For paletted images, you can select the method of color reduction, number of colors, and amount of dithering.

#### PNG Optimizer Gamma

PNG images contain a gamma chunk, which controls gamma levels of an image. The gamma setting helps the image appear consistent across multiple display devices. If in doubt, you should use the default PC value.

#### PNG Optimizer Transparency

You can choose to base transparency on existing image or layer transparency, or you can sample the color in the image that you want to make transparent. If you have a selection in your image, you can base the transparency on the selection. You can also base transparency on the alpha channel.

#### PNG Optimizer Format

PNG images can be interlaced or non-interlaced, which affects how the image is displayed on a computer with a slow Internet connection.

#### PNG Optimizer Download Times

The size of the compressed file and an estimate of the download time at four modem speeds are displayed under the Download Times tab of the PNG Optimizer dialog box.

### Using the PNG wizard

You can open the PNG wizard from the PNG Optimizer dialog box. The wizard guides you through the steps of optimizing a PNG file.

### To optimize and save a PNG file

**Edit tab**

1. Choose **File > Export > PNG Optimizer**.
   
   The PNG Optimizer dialog box appears. The preview areas show the current image on the left and the resulting PNG file on the right.

2. Click the **Colors** tab, and choose one of the following image type options:
   - **Palette-Based** — for images with 256 colors or less
   - **Grayscale (8-bit)**
   - **16.7 million color (24-bit)**
If you choose the Palette-Based method, you can choose the number of colors in the image and the amount of dithering applied.

3 Click the **Transparency** tab, and choose one of the following transparency types:
   - **No transparency** — saves the image without transparency
   - **Single color transparency** — lets you make one color transparent by clicking a color swatch or clicking a color in the image, and entering a value in the **Tolerance** control.
   - **Alpha channel transparency** — uses the current selection or alpha channel transparency of the image. You can choose which part of the image will be transparent by choosing **Existing image or layer transparency**, **Existing alpha channel transparency**, **Inside the current selection**, or **Outside the current selection** option.

4 Click the **Gamma** tab, and set or type a value in the **Gamma** control if you want to change the default value.

5 Click the **Format** tab, choose one of the following options:
   - **Non-interlaced** — the image downloads one line at a time, starting from the top
   - **Interlaced** — the image is displayed incrementally in several passes; detail is added with each pass. Use this option with larger images so that the viewer can get an idea of how the image looks while waiting for it to download

6 Click **OK** to open the **Save As** dialog box, navigate to the folder in which you want to save the new image, type a name for the file, and click **Save**.

You can click the **Download Times** tab to preview the file size of the compressed file and an estimate of the download time at four modem speeds.

To use the PNG wizard

**Edit tab**

1 Choose **File**  **Export**  **PNG Optimizer**.
   The PNG Optimizer dialog box appears.
2 Click **Use wizard** and follow the instructions.
3 Click **Finish** to close the wizard and open the **Save As** dialog box, where you type a name and select a location for saving the GIF file.

To **Choose a color within the image**

Do the following

On page 2 or 3 of the wizard, move the cursor over the image, and click a color. The color swatch displays the color you clicked.

**Choose a color using the Color dialog box.**

On page 2 or 3 of the wizard, click the color swatch to open the Color dialog box.

**Change a setting**

On page 6 of the wizard, click **Back** to return to the previous pages. Then, change the settings you want, and return to page 6 to view the results.

**Previewing images in Web browsers**

You can use your Web browser to see how your active image will look on the Web. PaintShop Pro creates an HTML page that displays your image in Windows Bitmap, GIF, JPEG, or PNG format. You can select up to three browsers. For information about adding, changing, or deleting Web browsers that you use for previewing, see “**Selecting Web browsers**” on page 417.

To preview image files in Web browsers

**Edit tab**

1 Choose **View**  **Preview in Web Browser**.
   The Preview in Web Browser dialog box opens.
2 In the Select Image Formats list, click each format in which you want to preview your image.
3 Do one of the following to select a background color for the Web page:
   • Click the **Background color** box, and choose a color from the Color dialog box.
   • Right-click the **Background color** box, and choose a recently used color.

4 In the Image Size group box, do one of the following:
   • Mark the **Use default** check box to keep the original image dimensions.
   • Unmark the **Use default** check box and type or set new image dimensions (in pixels) in the **Width** and **Height** controls.

5 Click **Preview**.
   If you choose only **Windows Bitmap** in the Select Image Formats list, the program opens the Web Browser and displays the image.
   If you selected any other format, the program opens the appropriate optimization dialog box. Select your choices for optimizing the image, and click **OK**.

For each format, the browser displays the file size, color depth, and approximate download times at the bottom of the image.

### Slicing images

When you slice an image, you divide it into several smaller images that you can save in different formats or at different levels of optimization. Because these optimized images can take less time to download than one large image, your Web pages may load more quickly.

Slicing an image also can reduce the number of graphics you need to save. If your website displays the same logo or other graphic in more than one image, you only need to save that section once if you slice the images; you reload the same logo or graphic section into all the images.

Using the Image Slicer, you can create a table from the image, saving the location of each sliced section as a region in the table, and generating the HTML code for the column and cells. Then, you copy this code into your source files so that the image can be reassembled when the user downloads the Web page.

You can also create rollovers, which are areas that display secondary images when the user clicks or moves a mouse over them.

### Creating and editing cells

When slicing an image, you divide it into cells and edit the cell boundaries. You do this with the tools in the Tools groups box of the Imager Slicer dialog box.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Arrow" /></td>
<td>The <strong>Arrow</strong> tool lets you make a cell active or move its borders.</td>
</tr>
<tr>
<td><img src="image" alt="Grid" /></td>
<td>The <strong>Grid</strong> tool lets you create a grid of evenly spaced cells, either over the entire image or within another cell.</td>
</tr>
<tr>
<td><img src="image" alt="Slicer" /></td>
<td>The <strong>Slicer</strong> tool lets you create a horizontal or vertical line.</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>The <strong>Delete</strong> tool lets you delete slice lines.</td>
</tr>
<tr>
<td><img src="image" alt="Pan" /></td>
<td>The <strong>Pan</strong> tool lets you drag the image in the preview to view hidden areas of the image.</td>
</tr>
</tbody>
</table>
Assigning sliced cell properties

After you have created sliced cells, you can assign URLs, alternate text, and targets to each cell. You also have the option to have the cell appear in the downloaded image. By omitting cells, you can add cells from other images (such as logos or text) and create images in nonrectangular shapes.

When you assign alternative text, the text is displayed while the image is loading. The text is also displayed if the image cannot be downloaded, or if the user has images disabled in the Web browser. In some versions of Internet Explorer, this text also appears as a tooltip.

Setting slice preferences

You can select colors for the border lines of the active and inactive areas.

Saving and loading slice settings

When you save the slice settings, you save the cell arrangement and the information you typed in the Image Slicer dialog box. You can then reload them into the same image or use them with a different image.

Saving slices

You can save slices to a folder on your hard drive so that you can reuse or edit them.

To slice an image into cells

Edit tab

   The Image Slicer dialog box appears.

2. Choose the Slice tool and click in the image where you want create a slice line.
   Note: To create a vertical line, drag vertically; to create a horizontal line, drag horizontally.

3. Choose the Arrow tool and click inside the cell to make it active.
   The cell boundary information is displayed in the lower portion of the Cell Properties group box.

4. In the URL drop-list, type the address of the Web page where you want the cell to appear.
   If you want to select addresses already used in the image, select the address you want from the URL drop-list.

5. In the Alt text box, type text that the browser can display while the cell is downloading.

6. Choose one of the following target frames or window options from the Target drop-list:
   • _blank — loads the linked page in a new browser window
   • _parent — loads the linked page in the parent window or frameset of the link. If the link is not in a nested frame, the image loads in the full browser window.
   • _self — loads the linked page in the same window or frame as the link
   • _top — loads the linked page in the full browser window and removes all frames

7. Click Save.
   The HTML Save As dialog box appears.

8. Navigate to the folder where you want to save the HTML code and click Save.

You can also

Create cells with consistent spacing and size.

Click the Grid tool. Click in the preview area to open the Grid Size dialog box, and type or set values in the Rows and Columns controls.

Move a slice line or border

Click the Arrow tool, and move the cursor over a line.
You can also

- the cursor changes to the double-sided arrow, drag the line to a new position. To move only the segment within the current cell, hold down Shift while clicking the line.

Delete a line or border

- Click the Delete tool 🗑️, and move the cursor over the line. When the cursor changes to an eraser-shape, click to delete the line. If deleting the line would create an invalid area, PaintShop Pro displays an icon 🗑️ to indicate that you cannot erase the line.

Omit a cell from the downloaded image

- Click the cell with the Arrow tool, and unmark the Include cell in table check box.

Save slice settings to the Clipboard so you can paste them into the HTML code

- Click Save to Clipboard to open the HTML Destination Folder dialog box, navigate to the folder where the HTML file is saved, and click OK to save the slice settings.

- Open the HTML file, place the cursor where you want to insert the HTML slice code, and press Ctrl + P.

Create a rollover for a cell

- Click Rollover Creator. For more information about creating image rollovers, see “Creating image rollovers” on page 467.

You can move lines up, but not across, adjacent parallel lines. You can move individual lines and lines that are part of a grid. As you drag a line, PaintShop Pro moves the longest segment that can be repositioned without creating a non-rectangular cell.

To set slice preferences

**Edit tab**

1. In the Image Slicer dialog box, click Preferences.

2. Click the Active tile border color color box, and choose a color.

3. Click the Inactive tile border color color box, and choose a color.

4. In the Maximum history list size control, type or set the number of entries listed in the URL and Alt text drop-lists in the Cell Properties group box in the Image Slicer dialog box.

5. Click OK.

- If you want to be prompted for a file location and name for your slices when you save the HTML code, mark the Prompt for image folder on Save or Save As check box.

To save slice settings

**Edit tab**

1. In the Image Slicer dialog box, click Save Settings.

   The Save Slice Settings dialog box appears.

2. Navigate to the folder in which you want to save the settings file.

3. Type a name for the file and click Save.

   The file is saved in the JSD format.
To load slice settings

1. In the Image Slicer dialog box, click Load Settings.
   - The Load Slice Settings dialog box appears.
2. Select the JSD file you want to load, and click Open.

If you are loading a grid to a different image, PaintShop Pro automatically adjusts the grid size if the dimensions of the image are not the same.

Mapping images

An image map is a graphic that contains a mapped area (called a region or hotspot), that links to a URL. The cell can be a circle, rectangle, or irregular shape. When you move the mouse over the cell, the cursor changes to a hand indicating that you can click that area to jump to another Web page.

Creating map areas

You create and edit image map areas with the tools in the Tools group box of the Image Mapper dialog box.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Arrow symbol" /></td>
<td>The Arrow tool lets you modify a hotspot area.</td>
</tr>
<tr>
<td><img src="image" alt="Mover symbol" /></td>
<td>The Mover tool lets you move a hotspot area.</td>
</tr>
<tr>
<td><img src="image" alt="Polygon symbol" /></td>
<td>The Polygon tool lets you create an irregular-shaped hotspot area.</td>
</tr>
<tr>
<td><img src="image" alt="Rectangle symbol" /></td>
<td>The Rectangle tool lets you create a square or rectangular hotspot area.</td>
</tr>
<tr>
<td><img src="image" alt="Circle symbol" /></td>
<td>The Circle tool lets you create a circular or elliptical hotspot area.</td>
</tr>
<tr>
<td><img src="image" alt="Delete symbol" /></td>
<td>The Delete tool lets you delete a hotspot area.</td>
</tr>
<tr>
<td><img src="image" alt="Pan symbol" /></td>
<td>The Pan tool lets you drag the image in the preview to view hidden areas of the image.</td>
</tr>
</tbody>
</table>

Assigning map area properties

After you have created the map areas (or regions), you can assign URLs, alternate text, and targets.

Saving image maps

You can save image maps to a folder on your hard drive so you can use or edit them. You can also save map settings to the Clipboard and then paste them into the HTML code. When you save the map settings, you save the map area arrangement and the information you typed in the Image Mapper dialog box. You can then reload them into the same image, or use the settings with a different image.

Setting map preferences

After you have created the map areas (or regions), you can assign URLs, alternate text, and targets.
To create and save a map area

Edit tab

   The Image Mapper dialog box appears.

2. Choose one of the following tools and draw in the preview area to create a hotspot:
   • Rectangle tool □ — drag the cursor to enclose a square or rectangular-shaped hotspot area
   • Circle tool ○ — drag the cursor to enclose a circular or elliptical hotspot area
   • Polygon tool □ — click to set the starting point and continue moving the cursor and clicking to enclose an irregular-shaped hotspot area. Double-click to complete the polygon.

3. In the URL drop-list, type the address of the Web page to which you want to link.
   If you want to select addresses already used in the image, click the arrow in the box and select the address you want from the URL drop-list.
   If you do not want to link to a Web page, type #.

4. In the Alt text box, type the text that appears if the image does not load or if the user has images disabled in the Web browser.

5. Choose one of the following target frame options from the Target drop-list:
   • _blank — loads the linked page in a new browser window
   • _parent — loads the linked page in the parent frameset of the link. If the link is not in a nested frame, the image loads in the full browser window.
   • _self — loads the linked page in the same frame as the link
   • _top — loads the linked page in the full browser window and removes all frames

6. Click Save.
   The HTML Save As dialog box appears.

7. Navigate to the folder where you want to save the HTML code, and click Save.
   The Image Map Save As dialog box appears.

8. Navigate to the folder where you want to save the image and click Save.

You can also

Select an existing map area
Click the Arrow tool □, and click a map area.

Change the shape or size of a map area
Click the Arrow tool, click the shape to select it, and hover over one of the green points that appear until the cursor changes to a four-point arrow. Drag the point to a new position.

Move the map area
Click the Move tool □, click inside the map area, and then drag it to a new position.

Erase a map area
Click the Delete tool □ and then click inside the map area.

Remove all map areas
Click Clear.

Preview the image map in a Web browser
Click the Preview in browser button □ and test the map area in the Web browser.

Save map area information to the Clipboard so that you can paste it into the HTML code
Click Save to Clipboard to open the HTML Destination Folder dialog box, navigate to the folder where the HTML file is saved, and click OK to save the slice settings. Then, open the HTML file, place
You can also

Create a rollover for a map area

Click Rollover Creator. For more information about creating image rollovers, see “Creating image rollovers” on page 467.

To set map preferences
Edit tab
1 In the Image Mapper dialog box, click Preferences.
   The Map Preferences dialog box appears.
2 Click the Active tile border color box, and choose a color.
3 Click the Inactive tile border color box, and choose a color.
4 In the Maximum history list size control, set or type the number of entries listed in the URL and Alt text drop-lists in the Cell Properties group box in the Image Mapper dialog box.
5 Click OK.

To save map settings
Edit tab
1 Click Save Settings.
   The Save Map Settings dialog box appears.
2 Navigate to the folder in which you want to save the settings file.
3 Type a name for the file and click Save.
   The file is saved in the JMD format.

To load map settings
Edit tab
1 Open the image in which you want to load map settings.
2 Choose File ➤ Export ➤ Image Mapper.
   The Image Mapper dialog box appears.
3 Click Load Settings.
   The Load Map Settings dialog box appears.
4 Navigate to and select the JMD file you want to load.
5 Click Open.

Creating image rollovers

A rollover is an image or section of an image that changes appearance when the user activates it. Web designers frequently create rollovers for the buttons of a navigation bar. When a user clicks a button, the browser displays the linked Web page (or file), and the rollover area displays a different button.

You can assign a rollover to an image that is sliced and mapped by choosing an image file that will appear when the user performs a specific mouse action.

To create image rollovers
Edit tab
1 Create the image to be used as the rollover image. Often this second image is a duplicate of the original, but modified to appear differently when the mouse rolls over the original image.
2 Do one of the following:
• Choose File ▶ Export ▶ Image Mapper.
• Choose File ▶ Export ▶ Image Slicer.

Note: If necessary, navigate to an image region, and use the appropriate tool (for example, the Polygon, Rectangle, or Circle tool) to specify the region where you want to add a rollover.

3 Click Rollover Creator.

The Rollover Creator dialog box appears.

4 Mark any of the following check boxes to determine which actions activate the rollover:
   • Mouse over
   • Mouse out
   • Mouse click
   • Mouse double-click
   • Mouse up
   • Mouse down

5 Click the Open button.

The Select Rollover dialog box appears.

6 Navigate to and select the graphics file you want to use.
   If you do not select a file, then the original file is used.

7 Click Open.

In the Rollover Creator dialog box, the file path appears in the box beside the check box.

8 Click Cancel to return to the Image Mapper or Image Slicer dialog box.

You can view your work in a Web browser window by clicking the Preview in browser button.

Using digital watermarks

A digital watermark is a permanent proof of authenticity for an image. While a computer can detect it, it is invisible to the viewer. A watermark contains information about the creator, the copyright, and the image. When a viewer chooses to see this information, the program opens a dialog box that contains a link to the Digimarc web page.

Reading a digital watermark

Whenever PaintShop Pro opens an image, it automatically checks for a digital watermark. If one is detected, the program displays a copyright symbol in front of the filename on the title bar, and the Watermark Information dialog box appears. If PaintShop Pro does not detect a watermark, it displays a message stating that no watermark was found. You can also view the Digimarc database page to get information about the creator.

Embedding a digital watermark

A digital watermark can only be embedded on a layer once since this prevents its quality from being degraded by further changes to the layer. If you try to embed a watermark in a layered image, PaintShop Pro displays a message recommending that you flatten the image before proceeding.

When you embed a watermark, you can select the following options:
   • creator ID
   • image copyright dates
   • image attributes
   • restrictions on use
   • watermark durability

You only need to configure the creator ID the first time you embed a watermark. You can change the copyright date, image attributes, and durability each time you embed a watermark.
Setting the watermark durability

The watermark durability indicates how visible watermarks are on the image. For images to be printed, use stronger watermarks. For images to be displayed on a monitor, use weaker watermarks because they are not as visible. While stronger watermarks are easier to detect, and harder to remove, they are also more visible in the image. You can make two copies of the image and apply a stronger watermark to the copy you are printing and a weaker one to the copy you are displaying electronically.

Personalizing the Creator ID

Customizing the watermark with your own identification number requires the following two steps:
• Register with Digimarc to obtain your own ID number.
• Type the information in the Personalize Creator ID dialog box.

To read a digital watermark

Edit tab
• Choose Image ➤ Watermarking ➤ Read Watermark.

You can view the Digimarc database page to get information about the watermark creator by clicking Web Lookup in the Watermark Information dialog box.

To embed a watermark

Edit tab
1 Choose Image ➤ Watermarking ➤ Embed Watermark.
   The Embed Watermark dialog box appears.
2 In the Image Attributes group box, mark any of the following check boxes to determine the restrictions shown when the program displays the watermark information:
   • Restricted use
   • Do not copy
   • Adult content
3 In the Copyright Information group box, type either one or two years in the Copyright year(s) boxes.
   Digimarc accepts years from 1922 to the present.
4 Click OK.

A layer can contain only one watermark. You cannot embed a new watermark in a layer that already contains one.

To set the watermark durability

Edit tab
1 Choose Image ➤ Watermarking ➤ Embed Watermark.
   The Embed Watermark dialog box appears.
2 From the Target Output drop-list, choose the medium in which the image is to be displayed:
   • Monitor
   • Print
   If you select Print for an image with a resolution under 300 dpi, PaintShop Pro displays a message recommending that you increase the image resolution before embedding the watermark.
3 To set the watermark strength, type a number from 1 to 16, or use the default values in the Watermark durability control.
   The default for the Monitor option is 8 and for the Print option is 12.
4 To verify that the watermark information is embedded correctly, mark the Verify check mark.
   The program checks that the watermark has been applied and displays its attributes and durability.
To personalize the Creator ID

   The Embed Watermark dialog box appears.
2. Click Personalize.
   The Personalize Creator ID dialog box appears.
3. To register with Digimarc, click Register.
   Your Web browser opens and navigates to the Digimarc Web page. Follow the on-screen instructions to receive a Creator ID number, a PIN number, and a password. You should write them down for later use. Close the browser to return to the Personalize Creator ID dialog box.
4. Type the PIN and Creator ID numbers in the appropriate boxes.
5. Click OK.
   The Embed Watermark dialog box appears.
6. Click OK.
   If the Verify check box is marked, the Embed Watermark: Verify dialog box appears. It lets you know that the watermark has been embedded and displays the creator, copyright, image attribute, and durability information from the Embed Watermark dialog box.

   If your computer does not have Web access, phone Digimarc using the toll-free number to register and receive your Creator ID number, a PIN number, and a password.

Adding visible watermarks

You can place a visible watermark consisting of text and/or a graphic on any raster image. Whether you take professional photos or just share photos on public websites, adding a discrete mark to your photos reminds viewers who took the shot. This feature simplifies the task of adding a logo or other graphic, and you can choose from professional effects like embossing to give it a subtle look.

You may find that the watermark graphic looks better when you create it with a transparent background. If so, you’ll need to save the graphic in a file format that supports transparency (such as PspImage, TIF, or PNG). You can use images that do not have a transparent background, but be aware that the watermark will display a rectangle around it, although you can adjust the opacity of the overall graphic.

To add a visible watermark

   The Visible Watermark dialog box appears.
2. In the Watermark Source group box, click the Browse button. Use the Open dialog box to navigate to the folder containing the graphic you want to use for the watermark.
   The graphic appears in the preview area of the Watermark Source group box.
3. In the Placement group box, choose a placement option:
   • Tile — places the graphic in rows and columns that cover the image
   • Center — places the graphic in the center of the image
   • Corner — lets you choose the image corner in which the graphic is placed
4. In the Style group box, adjust the overall appearance of the graphic:
   • Size — lets you adjust the size of the graphic
   • Opacity — lets you adjust the graphic’s opacity. Increasing the Opacity setting allows more of the underlying image to be seen through the graphic.
   • Emboss — applies a raised appearance to the graphic
5. Click OK.
Legal Notice

Corel® PaintShop® Pro 2023 User Guide

© 2023 Corel Corporation

Corel, the Corel logo, PaintShop, the PaintShop P Logo, AfterShot, CorelDRAW, Essentials, MindManager, Painter, PhotoMirage, Pinnacle, Sea-to-Sky, Smart Carver, and WinZip are trademarks or registered trademarks of Corel Corporation in Canada, the U.S., and/or elsewhere. ClearSlide is a trademark or registered trademark of ClearSlide Inc. in Canada, the U.S., and/or elsewhere. Parallels is a trademark or registered trademark of Parallels International GmbH in Canada, the U.S., and/or elsewhere.

This product and packaging includes intellectual property (including trademarks) owned, registered, and/or licensed by third parties not affiliated with Corel and used with permission. The inclusion thereof does not constitute or imply any endorsement of, or by, such third parties, or any warranty by Corel of the quality, merchantability, or fitness of any third-party products or services. Use of this product is subject to acceptance of the license agreements included in this software. This product as well as certain products and materials referenced herein are protected by, or otherwise contain or practice all elements of, issued patents which Corel Corporation [and one or more of its affiliates] owns in the United States and elsewhere. A non-exhaustive list of those issued patents is available at www.corel.com/patents

INFORMATION PROVIDED HEREIN BY COREL IS SUBJECT TO CHANGE WITHOUT NOTICE PROVIDED “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS, WRITTEN OR ORAL, EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, ANY WARRANTY AS TO THE VALIDITY OF ANY PATENTS, WARRANTIES OF TITLE, WARRANTIES OF NON-INFRINGEMENT (INCLUDING BUT NOT LIMITED TO NON-INFRINGEMENT OF ANY INTELLECTUAL PROPERTY RIGHTS, PERSONALITY RIGHTS, DATA AND/OR PRIVACY RIGHTS OF THIRD PARTIES), ANY WARRANTY OF CONFORMITY TO MODELS OR SAMPLES OF MATERIALS, OR THOSE WARRANTIES ARISING BY FACT, LAW, STATUTE, USAGE OF TRADE, COURSE OF DEALING OR OTHERWISE AND THEIR EQUIVALENTS UNDER THE LAWS OF ANY JURISDICTION. THE ENTIRE RISK AS TO THE RESULTS OF THE INFORMATION PROVIDED OR ITS USE IS ASSUMED BY YOU. COREL CORPORATION, ITS AFFILIATES AND SUBSIDIARIES SHALL HAVE NO LIABILITY TO YOU OR ANY OTHER PERSON OR ENTITY FOR ANY [DIRECT] INDIRECT, INCIDENTAL, SPECIAL, OR CONSEQUENTIAL LOSS OR DAMAGES WHATSOEVER, INCLUDING, BUT NOT LIMITED TO, LOSS OF REVENUE OR PROFIT, LOST OR DAMAGED DATA OR OTHER COMMERCIAL OR ECONOMIC LOSS, ARISING FROM YOUR USE OF OR YOUR INABILITY TO USE THE INFORMATON PROVIDED AND/OR ITS RESULTS EVEN IF COREL HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES OR THEY ARE FORESEEABLE. COREL IS ALSO NOT LIABLE FOR ANY CLAIMS MADE BY ANY THIRD PARTY. COREL'S MAXIMUM AGGREGATE LIABILITY TO YOU SHALL NOT EXCEED THE COSTS PAID BY YOU TO PURCHASE THE MATERIALS. SOME STATES/COUNTRIES DO NOT ALLOW EXCLUSIONS OR LIMITATIONS OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, SO THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU. BY PURCHASING THE MATERIALS YOU ACKNOWLEDGE THAT YOU HAVE READ, FULLY UNDERSTOOD AND AGREED TO THIS FOREGOING DISCLAIMER.